D5438: rust-cpython: implementing Graph using C parents function

2018-12-23 Thread gracinet (Georges Racinet)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG4c25038c112c: rust-cpython: implement Graph using C parents function (authored by gracinet, committed by ). CHANGED PRIOR TO COMMIT https://phab.mercurial-scm.org/D5438?vs=12949=12967#toc REPOSITORY

D5440: rust: core implementation for lazyancestors

2018-12-23 Thread gracinet (Georges Racinet)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGef54bd33b476: rust: core implementation for lazyancestors (authored by gracinet, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE

D5439: rust-cpython: binding for AncestorsIterator

2018-12-23 Thread gracinet (Georges Racinet)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGd9f439fcdb4c: rust-cpython: binding for AncestorsIterator (authored by gracinet, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE

D5441: rust-cpython: binding for LazyAncestors

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added a comment. > +/// The purpose of this module is to hide identifiers from other Rust users > +/// > +/// Some of the identifiers we are defining are meant for consumption > +/// from Python with other naming conventions. For instance, `py_class!` > +/// does not let us

Re: D5441: rust-cpython: binding for LazyAncestors

2018-12-23 Thread Yuya Nishihara
> +/// The purpose of this module is to hide identifiers from other Rust users > +/// > +/// Some of the identifiers we are defining are meant for consumption > +/// from Python with other naming conventions. For instance, `py_class!` > +/// does not let us make a distinction between the Python

D5442: rust-cpython: using the new bindings from Python

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added a comment. > +try: > +from . import rustext Touch e.g. rustext.__doc__ here to get around the lazy importer. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D5442 To: gracinet, indygreg, #hg-reviewers Cc: yuja, mercurial-devel

Re: D5442: rust-cpython: using the new bindings from Python

2018-12-23 Thread Yuya Nishihara
> +try: > +from . import rustext Touch e.g. rustext.__doc__ here to get around the lazy importer. ___ Mercurial-devel mailing list Mercurial-devel@mercurial-scm.org https://www.mercurial-scm.org/mailman/listinfo/mercurial-devel

Re: D5473: config: register evolution.stackaliases as a config option

2018-12-23 Thread Sushil Khanchi
Oh, yes. It is extension specific configuration. Abandoning this one. On Mon, Dec 24, 2018 at 8:41 AM yuja (Yuya Nishihara) < phabrica...@mercurial-scm.org> wrote: > yuja added a comment. > > > > +coreconfigitem('experimental', 'evolution.stackaliases', > > +default=True, > > +) > >

D5449: pull: fix inconsistent view of bookmarks during pull (issue4700)

2018-12-23 Thread valentin.gatienbaron (Valentin Gatien-Baron)
valentin.gatienbaron added a comment. Thanks! > IIRC, listkeys is a newer command than lookup. If the peer doesn't support listkeys, I suspect this batch query would fail. In that case, maybe listkeys has to be skipped if the peer doesn't support it and if --bookmark is not specified.

D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added a comment. > Thanks for the info @yuja. I'm thinking to move --rev/-r to branches command and replacing --show/-s that I've made to --rev/-r in the branch command itself. I'm not sure if I get it, but my idea is to add `hg branches -r/--rev` that selects branches to be

Re: D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread Yuya Nishihara
> Thanks for the info @yuja. I'm thinking to move --rev/-r to branches > command and replacing --show/-s that I've made to --rev/-r in the branch > command itself. I'm not sure if I get it, but my idea is to add `hg branches -r/--rev` that selects branches to be listed by revisions. So, `hg

D5449: pull: fix inconsistent view of bookmarks during pull (issue4700)

2018-12-23 Thread valentin.gatienbaron (Valentin Gatien-Baron)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGbad05a6afdc8: pull: fix inconsistent view of bookmarks during pull (issue4700) (authored by valentin.gatienbaron, committed by ). CHANGED PRIOR TO COMMIT

D5476: merge: modify the logical statement

2018-12-23 Thread khanchi97 (Sushil khanchi)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG6faaf3a1c6ec: merge: modify the logical statement (authored by khanchi97, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D5476?vs=12963=12964

D5449: pull: fix inconsistent view of bookmarks during pull (issue4700)

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added a comment. Queued, thanks. I have a concern about compatibility with ancient Mercurial. Can you check it and send a follow-up as needed? > I had to change the handling of the case where the server doesn't > support the lookup query, because if it fails, it would

Re: D5449: pull: fix inconsistent view of bookmarks during pull (issue4700)

2018-12-23 Thread Yuya Nishihara
Queued, thanks. I have a concern about compatibility with ancient Mercurial. Can you check it and send a follow-up as needed? > I had to change the handling of the case where the server doesn't > support the lookup query, because if it fails, it would otherwise make >

D5473: config: register evolution.stackaliases as a config option

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added a comment. > +coreconfigitem('experimental', 'evolution.stackaliases', > +default=True, > +) No `stackaliases` found in core. Maybe it's an extension-specific config? REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D5473 To: khanchi97,

Re: D5473: config: register evolution.stackaliases as a config option

2018-12-23 Thread Yuya Nishihara
> +coreconfigitem('experimental', 'evolution.stackaliases', > +default=True, > +) No `stackaliases` found in core. Maybe it's an extension-specific config? ___ Mercurial-devel mailing list Mercurial-devel@mercurial-scm.org

Re: [PATCH 1 of 6 V2] extensions: import the exthelper class from evolve 980565468003 (API)

2018-12-23 Thread Matt Harbison
On Sun, 23 Dec 2018 08:27:42 -0500, Yuya Nishihara wrote: On Sun, 23 Dec 2018 01:15:46 -0500, Matt Harbison wrote: # HG changeset patch # User Matt Harbison # Date 1545530784 18000 # Sat Dec 22 21:06:24 2018 -0500 # Node ID ffab2010329f111c2237ebbb64be650a1b0301d8 # Parent

D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh added a comment. Thanks for the info @yuja. I'm thinking to move --rev/-r to branches command and replacing --show/-s that I've made to --rev/-r in the branch command itself. How's that sound to you guys, @pulkit @yuja ? REPOSITORY rHG Mercurial REVISION DETAIL

D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread pulkit (Pulkit Goyal)
pulkit added a comment. In https://phab.mercurial-scm.org/D5475#81060, @yuja wrote: > > _('set branch name even if it shadows an existing branch')), > > ('C', 'clean', None, _('reset branch name to parent branch name')), > > ('r', 'rev', [], _('change branches of the given revs

D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread yuja (Yuya Nishihara)
yuja added subscribers: pulkit, yuja. yuja added a comment. > _('set branch name even if it shadows an existing branch')), > ('C', 'clean', None, _('reset branch name to parent branch name')), > ('r', 'rev', [], _('change branches of the given revs (EXPERIMENTAL)')), > > +

Re: D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread Yuya Nishihara
> _('set branch name even if it shadows an existing branch')), > ('C', 'clean', None, _('reset branch name to parent branch name')), > ('r', 'rev', [], _('change branches of the given revs (EXPERIMENTAL)')), > + ('s', 'show', None, _('show branch name of the given rev')) >

Re: [PATCH 1 of 6 V2] extensions: import the exthelper class from evolve 980565468003 (API)

2018-12-23 Thread Yuya Nishihara
On Sun, 23 Dec 2018 01:15:46 -0500, Matt Harbison wrote: > # HG changeset patch > # User Matt Harbison > # Date 1545530784 18000 > # Sat Dec 22 21:06:24 2018 -0500 > # Node ID ffab2010329f111c2237ebbb64be650a1b0301d8 > # Parent e9c606fef203621755d75b0434574a8a60ffd0ff > extensions: import

D5476: merge: modify the logical statement

2018-12-23 Thread khanchi97 (Sushil khanchi)
khanchi97 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D5476 AFFECTED FILES mercurial/merge.py CHANGE DETAILS diff --git a/mercurial/merge.py

D5474: obsutil: fix the issue5686

2018-12-23 Thread khanchi97 (Sushil khanchi)
khanchi97 updated this revision to Diff 12962. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D5474?vs=12956=12962 REVISION DETAIL https://phab.mercurial-scm.org/D5474 AFFECTED FILES mercurial/obsutil.py tests/test-obsmarker-template.t

D5474: obsutil: fix the issue5686

2018-12-23 Thread khanchi97 (Sushil khanchi)
khanchi97 added a comment. @av6 Thanks for the review. I will update it. INLINE COMMENTS > av6 wrote in test-obsmarker-template.t:2511 > The new output looks somewhat more correct, but not quite. This changeset > definitely wasn't just pruned, but it also wasn't rewritten either: it was >

D5475: branch:Added option to show branch name of a given rev (Issue5948)

2018-12-23 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D5475 AFFECTED FILES mercurial/commands.py CHANGE DETAILS diff --git a/mercurial/commands.py