[Mesa-dev] [PATCH] glsl: add new variable declaration in function body in lower_output_read

2012-11-23 Thread Vincent Lejeune
--- src/glsl/lower_output_reads.cpp | 1 + 1 file changed, 1 insertion(+) diff --git a/src/glsl/lower_output_reads.cpp b/src/glsl/lower_output_reads.cpp index 90d71b0..a6192a5 100644 --- a/src/glsl/lower_output_reads.cpp +++ b/src/glsl/lower_output_reads.cpp @@ -97,6 +97,7 @@ output_read_remover:

[Mesa-dev] [PATCH] radeon/llvm: do not use magic number for resourceId

2012-11-23 Thread Vincent Lejeune
--- lib/Target/AMDGPU/AMDGPUIntrinsics.td | 16 - .../AMDGPU/MCTargetDesc/R600MCCodeEmitter.cpp | 7 ++-- lib/Target/AMDGPU/R600ISelLowering.cpp | 14 +--- lib/Target/AMDGPU/R600Instructions.td | 40 +++--- 4 files changed, 42

[Mesa-dev] [PATCH] r600g: separate resource_id and sampler_id tex info in tgsi-to-llvm

2012-11-23 Thread Vincent Lejeune
--- src/gallium/drivers/r600/r600_llvm.c | 5 + 1 file changed, 5 insertions(+) diff --git a/src/gallium/drivers/r600/r600_llvm.c b/src/gallium/drivers/r600/r600_llvm.c index b3d4e6b..2f243a2 100644 --- a/src/gallium/drivers/r600/r600_llvm.c +++ b/src/gallium/drivers/r600/r600_llvm.c @@ -11,

[Mesa-dev] Please test the automake-gallium4 branch

2012-11-23 Thread Andreas Boll
Hi mesa-list, I'm happy to announce that I've finished Matt's automake-gallium branch [0]. Some of the independent patches are already in the master branch. I've fixed the missing symbols in vdpau and xvmc and installed lots of compatibility links to provide the same behaviour as the old build sys

[Mesa-dev] [PATCH 4/4] st/dri: implement new driver hook flush_with_flags

2012-11-23 Thread Marek Olšák
--- .../state_trackers/dri/common/dri_drawable.c | 105 +--- .../state_trackers/dri/common/dri_drawable.h |6 ++ src/gallium/state_trackers/dri/common/dri_screen.h |1 + src/gallium/state_trackers/dri/drm/dri2.c | 28 ++ 4 files changed, 84 inser

[Mesa-dev] [PATCH 3/4] st/mesa: make st_flush do what glFlush does

2012-11-23 Thread Marek Olšák
--- src/mesa/state_tracker/st_cb_flush.c |1 + 1 file changed, 1 insertion(+) diff --git a/src/mesa/state_tracker/st_cb_flush.c b/src/mesa/state_tracker/st_cb_flush.c index b4372ae..7c9f91f 100644 --- a/src/mesa/state_tracker/st_cb_flush.c +++ b/src/mesa/state_tracker/st_cb_flush.c @@ -79,6

[Mesa-dev] [PATCH 2/4] glx/dri2: add and use new driver hook flush_with_flags

2012-11-23 Thread Marek Olšák
--- include/GL/internal/dri_interface.h | 29 - src/glx/dri2_glx.c| 144 - src/mesa/drivers/dri/intel/intel_screen.c |2 +- src/mesa/drivers/dri/nouveau/nouveau_screen.c |2 +- src/mesa/drivers/dri/radeon/radeon_scree

[Mesa-dev] [PATCH 1/4] glx: move the glFlush call one layer down

2012-11-23 Thread Marek Olšák
--- src/glx/dri2_glx.c | 18 +- src/glx/dri_glx.c | 12 ++-- src/glx/drisw_glx.c |7 ++- src/glx/glxclient.h |4 ++-- src/glx/glxcmds.c | 11 --- 5 files changed, 35 insertions(+), 17 deletions(-) diff --git a/src/glx/dri2_glx.c b/src/glx/dri

[Mesa-dev] [PATCH 0/4] DRI2: Fixing the triple-flush for Gallium v2

2012-11-23 Thread Marek Olšák
This series consolidates the 3 gallium context flushes done by libGL in SwapBuffers and CopySubBuffer, because we only need one context flush there. This is a cleanup. Please review. Marek ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org http:

Re: [Mesa-dev] Proposal: allow hidden security bugs on Mesa's Bugzilla

2012-11-23 Thread Benoit Jacob
On 12-11-21 12:48 PM, Chad Versace wrote: > On 11/20/2012 09:29 AM, Benoit Jacob wrote: > >> Any questions? >> Do you support or oppose me asking FD.o admins to allow hidden bugs on >> Mesa's bugzilla? >> >> Benoit > I support this. It seems a sensible proposal for addressing security bugs. > Thank

Re: [Mesa-dev] [PATCH 3/6] radeonsi: Flesh out support for depth/stencil exports from the pixel shader.

2012-11-23 Thread Christian König
On 23.11.2012 10:25, Michel Dänzer wrote: On Fre, 2012-11-23 at 09:43 +0100, Christian König wrote: On 22.11.2012 18:57, Michel Dänzer wrote: + if (si_shader_ctx->type == TGSI_PROCESSOR_VERTEX) { + case TGSI_SEMANTIC_PSIZE: +

Re: [Mesa-dev] [PATCH 3/6] radeonsi: Flesh out support for depth/stencil exports from the pixel shader.

2012-11-23 Thread Michel Dänzer
On Fre, 2012-11-23 at 09:43 +0100, Christian König wrote: > On 22.11.2012 18:57, Michel Dänzer wrote: > > + if (si_shader_ctx->type == > > TGSI_PROCESSOR_VERTEX) { > > + case TGSI_SEMANTIC_PSIZE: > > + target = V_008DFC

Re: [Mesa-dev] [PATCH 3/6] radeonsi: Flesh out support for depth/stencil exports from the pixel shader.

2012-11-23 Thread Christian König
On 22.11.2012 18:57, Michel Dänzer wrote: + if (si_shader_ctx->type == TGSI_PROCESSOR_VERTEX) { + case TGSI_SEMANTIC_PSIZE: + target = V_008DFC_SQ_EXP_POS; + } else { +

[Mesa-dev] [PATCH] mesa: Return 0 for XFB_VARYING_MAX_LENGTH if no varyings

2012-11-23 Thread Matt Turner
We add one for the null terminator, but if we don't have any varyings, it doesn't make sense to have a null terminator. Fixes part of es3conform's transform_feedback_init_defaults test. --- src/mesa/main/shaderapi.c |7 +-- 1 files changed, 5 insertions(+), 2 deletions(-) diff --git a/sr