Re: [Mesa-dev] [PATCH] mesa/shaderobj: Fix races on refcounts

2016-12-27 Thread Tapani Pälli
Reviewed-by: Tapani Pälli On 12/28/2016 12:45 AM, Chad Versace wrote: Use atomic ops when updating gl_shader::RefCount. Fixes intermittent failures and crashes in 'dEQP-EGL.functional.sharing.gles2.multithread.*'. All tests in that group now pass except

Re: [Mesa-dev] [PATCH v3 4/4] nir: Rewrite lower_regs_to_ssa to use the phi builder

2016-12-27 Thread Connor Abbott
Nice reduction in code size! The whole series is Reviewed-by: Connor Abbott For the last patch I looked at the 'review/regs-to-ssa' branch on cgit which seems like an earlier version of the branch, although AFAIK the last patch there is the same as this patch. On Fri, Dec

Re: [Mesa-dev] [PATCH v3 3/4] nir/phi-builder: Set the value in the block when creating a phi

2016-12-27 Thread Connor Abbott
On Fri, Dec 16, 2016 at 3:00 PM, Jason Ekstrand wrote: > Ken, Eric, > > Any thoughts on whether or not this should go to stable? It does fix a real > bug but the result of the bug is that we end up generating a bunch of > duplicate phi nodes instead of just one for the

Re: [Mesa-dev] [PATCH 1/2] spirv: add interface for drivers to define support extensions.

2016-12-27 Thread Edward O'Callaghan
I like it, Reviewed-by: Edward O'Callaghan On 12/28/2016 10:30 AM, Dave Airlie wrote: > From: Dave Airlie > > I expect over time the struct contents will change as all > drivers support stuff etc, but for now this should be a good > starting

[Mesa-dev] [Bug 99010] --disable-gallium-llvm no longer recognized

2016-12-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=99010 --- Comment #18 from Rhys Kidd --- (In reply to Tobias Droste from comment #17) > (In reply to Tobias Droste from comment #11) > > Ok, I take a look at this tomorrow (it's late here). > > Sorry for the problems. > > > > For

[Mesa-dev] [Bug 99010] --disable-gallium-llvm no longer recognized

2016-12-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=99010 --- Comment #17 from Tobias Droste --- (In reply to Tobias Droste from comment #11) > Ok, I take a look at this tomorrow (it's late here). > Sorry for the problems. > > For a quick workaround: > Set the env variable LLVM_CONFIG

[Mesa-dev] [Bug 99010] --disable-gallium-llvm no longer recognized

2016-12-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=99010 --- Comment #16 from Tobias Droste --- (In reply to Rhys Kidd from comment #15) > Tobias, > > Any update for your patch series on the mailing list? Looks like there's a > few comments for other developers requiring you to respin

[Mesa-dev] [Bug 99010] --disable-gallium-llvm no longer recognized

2016-12-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=99010 Rhys Kidd changed: What|Removed |Added CC||rhysk...@gmail.com ---

[Mesa-dev] [PATCH 1/2] spirv: add interface for drivers to define support extensions.

2016-12-27 Thread Dave Airlie
From: Dave Airlie I expect over time the struct contents will change as all drivers support stuff etc, but for now this should be a good starting point. Signed-off-by: Dave Airlie --- src/compiler/spirv/nir_spirv.h| 6 ++

[Mesa-dev] [PATCH 2/2] radv: denote support for extended storage image formats.

2016-12-27 Thread Dave Airlie
From: Dave Airlie I'm sure anv has support for these as well, but this is just a first use of the interface to allow different supported spir-v features. Signed-off-by: Dave Airlie --- src/amd/vulkan/radv_pipeline.c | 6 -- 1 file changed, 4

Re: [Mesa-dev] [PATCH] mesa/shaderobj: Fix races on refcounts

2016-12-27 Thread Timothy Arceri
On Tue, 2016-12-27 at 14:45 -0800, Chad Versace wrote: > Use atomic ops when updating gl_shader::RefCount. > > Fixes intermittent failures and crashes in > 'dEQP-EGL.functional.sharing.gles2.multithread.*'. > All tests in that group now pass except > 'dEQP- >

[Mesa-dev] [PATCH] mesa/shaderobj: Fix races on refcounts

2016-12-27 Thread Chad Versace
Use atomic ops when updating gl_shader::RefCount. Fixes intermittent failures and crashes in 'dEQP-EGL.functional.sharing.gles2.multithread.*'. All tests in that group now pass except

Re: [Mesa-dev] [PATCH] anv: Handle vkGetPhysicalDeviceQueueFamilyProperties with count == 0

2016-12-27 Thread Anuj Phogat
On Tue, Dec 27, 2016 at 10:30 AM, Chad Versace wrote: > > The spec implicitly allows the incoming count to be 0. From the Vulkan > 1.0.38 spec, Section 4.1 Physical Devices: > > If the value referenced by pQueueFamilyPropertyCount is not 0 [then > do stuff]. > >

Re: [Mesa-dev] [PATCH 0/8] nir: A few allocation cleanups

2016-12-27 Thread Jason Ekstrand
On Dec 27, 2016 11:04 AM, "Jordan Justen" wrote: Series Reviewed-by: Jordan Justen Thanks! On 2016-12-26 09:13:27, Jason Ekstrand wrote: > The first patch in this series is a change I've been meaning to make for > some time. I've been

Re: [Mesa-dev] [PATCH] anv: return count of queue families written

2016-12-27 Thread Jason Ekstrand
+stable On Dec 27, 2016 12:20 PM, "Chad Versace" wrote: > On Sun 25 Dec 2016, Damien Grassart wrote: > > The Vulkan spec indicates that > > vkGetPhysicalDeviceQueueFamilyProperties() should overwrite > > pQueueFamilyPropertyCount with the number of structures actually

[Mesa-dev] [PATCH] anv: Handle vkGetPhysicalDeviceQueueFamilyProperties with count == 0

2016-12-27 Thread Chad Versace
The spec implicitly allows the incoming count to be 0. From the Vulkan 1.0.38 spec, Section 4.1 Physical Devices: If the value referenced by pQueueFamilyPropertyCount is not 0 [then do stuff]. Cc: Damien Grassart --- src/intel/vulkan/anv_device.c | 9 - 1

Re: [Mesa-dev] [PATCH] anv: return count of queue families written

2016-12-27 Thread Chad Versace
On Sun 25 Dec 2016, Damien Grassart wrote: > The Vulkan spec indicates that > vkGetPhysicalDeviceQueueFamilyProperties() should overwrite > pQueueFamilyPropertyCount with the number of structures actually > written to pQueueFamilyProperties. > > Signed-off-by: Damien Grassart

Re: [Mesa-dev] [PATCH 12/70] mesa/glsl/i965: remove Driver.NewShader()

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > After removing brw_shader in the previous commit this is no longer > needed. Nice! 9-12 are: Reviewed-by: Eric Anholt signature.asc Description: PGP signature ___ mesa-dev

Re: [Mesa-dev] [PATCH 08/70] mesa/glsl: move LinkedTransformFeedback from gl_shader_program to gl_program

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > This will help allow us to store gl_program in the CurrentProgram array rather > than gl_shader_program which will allow a bunch of simplifications. > > Note that we make LinkedTransformFeedback a pointer so we don't waste > memory creating

Re: [Mesa-dev] [PATCH 07/70] i965: get LinkedTransformFeedback from gl_transform_feedback_object

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > We have already set the gl_shader_program pointer to the correct > shader program in _mesa_BeginTransformFeedback() so use it. > > This is more consistent with how we do it for gen7. > --- > src/mesa/drivers/dri/i965/gen6_sol.c | 27

Re: [Mesa-dev] [PATCH 06/70] mesa: move _Used to gl_program

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > We no longer need to initialise it because gl_program is never reused. Patches 3-6 are: Reviewed-by: Eric Anholt signature.asc Description: PGP signature ___ mesa-dev mailing

Re: [Mesa-dev] [PATCH 02/70] mesa/glsl: move subroutine metadata to gl_program

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > This will allow us to store gl_program rather than gl_shader_program > as the current program perstage which allows us to simplify code > that makes use of the CurrentProgram list. > --- > diff --git a/src/mesa/main/shaderapi.c

Re: [Mesa-dev] [PATCH] editorconfig: Fix up the tab rendering width.

2016-12-27 Thread Ilia Mirkin
Reviewed-by: Ilia Mirkin On Tue, Dec 27, 2016 at 12:04 PM, Eric Anholt wrote: > Our editorconfig file looked sensible, saying that we wanted to indent > with spaces and use 3/4/whatever space indentation. However, the spec has > this little surprise: > >

Re: [Mesa-dev] [PATCH 01/70] mesa/compiler: add stage to shader_info

2016-12-27 Thread Eric Anholt
Timothy Arceri writes: > This will allow us to simplify the current program logic for SSO. > > Also since we aim to detach shader_info from nir_shader this will come > in handy avoiding passing nir_shader around just to keep track of > the stage we are dealing with.

[Mesa-dev] [PATCH] editorconfig: Fix up the tab rendering width.

2016-12-27 Thread Eric Anholt
Our editorconfig file looked sensible, saying that we wanted to indent with spaces and use 3/4/whatever space indentation. However, the spec has this little surprise: "tab_width: a whole number defining the number of columns used to represent a tab character. This defaults to the value

Re: [Mesa-dev] [PATCH 0/8] nir: A few allocation cleanups

2016-12-27 Thread Jordan Justen
Series Reviewed-by: Jordan Justen On 2016-12-26 09:13:27, Jason Ekstrand wrote: > The first patch in this series is a change I've been meaning to make for > some time. I've been running into name collisions with nir_copy_deref and > the nir_builder nir_copy_deref_var

Re: [Mesa-dev] [PATCH 1/8] nir: Make nir_copy_deref follow the "clone" pattern

2016-12-27 Thread Jason Ekstrand
On Dec 27, 2016 8:35 AM, "Jason Ekstrand" wrote: On Dec 27, 2016 7:05 AM, "Eduardo Lima Mitev" wrote: On 12/26/2016 06:13 PM, Jason Ekstrand wrote: > We rename it to nir_deref_clone, re-order the sources to match the other > clone functions, and expose

Re: [Mesa-dev] [PATCH 1/8] nir: Make nir_copy_deref follow the "clone" pattern

2016-12-27 Thread Jason Ekstrand
On Dec 27, 2016 7:05 AM, "Eduardo Lima Mitev" wrote: On 12/26/2016 06:13 PM, Jason Ekstrand wrote: > We rename it to nir_deref_clone, re-order the sources to match the other > clone functions, and expose nir_deref_var_clone. This past part, in > particular, lets us get rid of

Re: [Mesa-dev] [PATCH 0/8] nir: A few allocation cleanups

2016-12-27 Thread Eduardo Lima Mitev
On 12/26/2016 06:13 PM, Jason Ekstrand wrote: > The first patch in this series is a change I've been meaning to make for > some time. I've been running into name collisions with nir_copy_deref and > the nir_builder nir_copy_deref_var helper. Also, now that we have lots of > other "clone" stuff,

Re: [Mesa-dev] [PATCH 1/8] nir: Make nir_copy_deref follow the "clone" pattern

2016-12-27 Thread Eduardo Lima Mitev
On 12/26/2016 06:13 PM, Jason Ekstrand wrote: > We rename it to nir_deref_clone, re-order the sources to match the other > clone functions, and expose nir_deref_var_clone. This past part, in > particular, lets us get rid of quite a few lines since we no longer have > to call nir_copy_deref and

Re: [Mesa-dev] [RFC] loader: Automatic PRIME detection

2016-12-27 Thread Axel Davy
Hi Thierry, Could you explain why in this situation default_fd would be a non-renderable device node ? In my understanding, for X11 DRI3 the Xserver is supposed to give you a renderable device node, and for Wayland, the device path advertised is the one used by the server for compositing.

Re: [Mesa-dev] [PATCH 8/8] i965/peephole_ffma: Use nir_builder

2016-12-27 Thread Eduardo Lima Mitev
Nice! Patch 8 is: Reviewed-by: Eduardo Lima Mitev On 12/26/2016 06:13 PM, Jason Ekstrand wrote: > --- > .../drivers/dri/i965/brw_nir_opt_peephole_ffma.c | 43 > +++--- > 1 file changed, 14 insertions(+), 29 deletions(-) > > diff --git