Re: [Mesa-dev] [PATCH] mesa: add missing error check in _mesa_CallLists()

2016-02-08 Thread Brian Paul
On 02/08/2016 05:07 PM, Ian Romanick wrote: On 02/08/2016 02:31 PM, Brian Paul wrote: Generate GL_INVALID_VALUE if n < 0. Return early if n==0. --- src/mesa/main/dlist.c | 9 + 1 file changed, 9 insertions(+) diff --git a/src/mesa/main/dlist.c b/src/mesa/main/dlist.c index

Re: [Mesa-dev] [PATCH 2/5] st/mesa: handle indirect samplers in arrays/structs properly (v4)

2016-02-08 Thread Timothy Arceri
On Mon, 2016-02-08 at 13:45 +1000, Dave Airlie wrote: > From: Dave Airlie > > The state tracker never handled this properly, and it finally > annoyed me for the second time so I decided to fix it properly. > > This is inspired by the NIR sampler lowering code and I only

Re: [Mesa-dev] [PATCH 1/2] mesa: compute sampler index in ir_to_mesa rather than using UniformHash

2016-02-08 Thread Dave Airlie
On 6 February 2016 at 22:30, Timothy Arceri wrote: > The aim of this is to work towards removing UniformHash from the program > struct so that we don't need to hold onto it in memory and pass it around > outside the linker. These look good to me, once they rebase on

Re: [Mesa-dev] [PATCH] radeonsi: enable denorms for 64-bit and 16-bit floats

2016-02-08 Thread Marek Olšák
FWIW, D3D requires round-toward-zero for conversion to FP16 colorbuffers. radeonsi does the same: round-toward-zero for colorbuffers and round-to-nearest-even for the GLSL packing functions. This looks like an inconsistency that may cause issues though. Marek On Tue, Feb 9, 2016 at 1:12 AM,

Re: [Mesa-dev] [PATCH 2/5] st/mesa: handle indirect samplers in arrays/structs properly (v4)

2016-02-08 Thread Dave Airlie
>> + >> + assert(var); >> + location = var->data.location; >> + calc_deref_offsets(ir, ir, array_size, base, index, reladdr, >> ); >> + >> + if (location != 0x) { > > This could just be an assert right? It shouldn't ever be -1 for a > sampler unless something went wrong in the

Re: [Mesa-dev] [PATCH] radeonsi: enable denorms for 64-bit and 16-bit floats

2016-02-08 Thread Ian Romanick
On 02/08/2016 12:38 PM, Marek Olšák wrote: > On Mon, Feb 8, 2016 at 5:08 PM, Tom Stellard wrote: >> On Sat, Feb 06, 2016 at 01:15:42PM +0100, Marek Olšák wrote: >>> From: Marek Olšák >>> >>> This fixes FP16 conversion instructions for VI, which has 16-bit

Re: [Mesa-dev] [PATCH v2 2/8] nir: Separate texture from sampler in nir_tex_instr

2016-02-08 Thread Kenneth Graunke
On Saturday, February 6, 2016 10:19:46 AM PST Jason Ekstrand wrote: > This commit adds the capability to NIR to support separate textures and > samplers. As it currently stands, glsl_to_nir only sets the texture deref > and leaves the sampler deref alone as it did before and nir_lower_samplers >

Re: [Mesa-dev] [PATCH v2 3/8] i965/fs: Add an enum for keeping track of texture instruciton sources

2016-02-08 Thread Kenneth Graunke
On Saturday, February 6, 2016 10:19:47 AM PST Jason Ekstrand wrote: > These logical texture instructions can have a *lot* of sources. It's much > safer if we have symbolic names for them. > --- > src/mesa/drivers/dri/i965/brw_fs.cpp | 46 > +++- >

Re: [Mesa-dev] [Mesa-stable] [PATCH 1/4] mesa/image: Make _mesa_clip_readpixels() work with renderbuffers

2016-02-08 Thread Brian Paul
Looks good to me too. Reviewed-by: Brian Paul On 02/08/2016 04:36 PM, Ian Romanick wrote: Series is Reviewed-by: Ian Romanick Might wait 24 hours or so to see if anyone responsible for a non-Intel driver has commentary... since this is shared

Re: [Mesa-dev] [PATCH 0/2] Simple Klocwork patches

2016-02-08 Thread Ian Romanick
On 02/07/2016 02:07 PM, Matt Turner wrote: > On Sun, Feb 7, 2016 at 1:37 PM, Juha-Pekka Heikkilä > wrote: >> Hi Iago, >> >> I know there are lot of places where there is malloc unchecked still >> -- and then there is ralloc which is a story of its own. Reason why I

Re: [Mesa-dev] [PATCH 4/5] nir: Handle large unsigned values in opt_algebraic.

2016-02-08 Thread Ian Romanick
On 02/08/2016 01:59 PM, Kenneth Graunke wrote: > On Thursday, February 4, 2016 5:48:00 PM PST Matt Turner wrote: >> The next patch adds an algebraic rule that uses the constant 0xff00ff00. >> >> Without this change, the build fails with >> >>return hex(struct.unpack('I', struct.pack('i',

Re: [Mesa-dev] [PATCH v2 5/8] i965/fs: Plumb separate surfaces and samplers through from NIR

2016-02-08 Thread Kenneth Graunke
On Saturday, February 6, 2016 10:19:49 AM PST Jason Ekstrand wrote: > --- > src/mesa/drivers/dri/i965/brw_blorp_blit_eu.cpp | 2 +- > src/mesa/drivers/dri/i965/brw_fs.cpp| 29 > - > src/mesa/drivers/dri/i965/brw_fs.h | 3 +++ >

[Mesa-dev] [Bug 94050] test_vec4_register_coalesce regression

2016-02-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=94050 Matt Turner changed: What|Removed |Added Assignee|mesa-dev@lists.freedesktop. |matts...@gmail.com

[Mesa-dev] [Bug 94050] test_vec4_register_coalesce regression

2016-02-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=94050 Matt Turner changed: What|Removed |Added Status|NEW |RESOLVED

Re: [Mesa-dev] [PATCH] radeonsi: enable denorms for 64-bit and 16-bit floats

2016-02-08 Thread Roland Scheidegger
Am 09.02.2016 um 00:02 schrieb Ian Romanick: > On 02/08/2016 12:38 PM, Marek Olšák wrote: >> On Mon, Feb 8, 2016 at 5:08 PM, Tom Stellard wrote: >>> On Sat, Feb 06, 2016 at 01:15:42PM +0100, Marek Olšák wrote: From: Marek Olšák This fixes

Re: [Mesa-dev] [PATCH 5/5] nir: Recognize open-coded bitfield_reverse.

2016-02-08 Thread Matt Turner
On Mon, Feb 8, 2016 at 12:04 PM, Jason Ekstrand wrote: > On Thu, Feb 4, 2016 at 5:48 PM, Matt Turner wrote: >> >> Helps 11 shaders in UnrealEngine4 demos. >> >> I seriously hope they would have given us bitfieldReverse() if we >> exposed GL 4.0 (but we

Re: [Mesa-dev] [PATCH 1/4] mesa/image: Make _mesa_clip_readpixels() work with renderbuffers

2016-02-08 Thread Ian Romanick
Series is Reviewed-by: Ian Romanick Might wait 24 hours or so to see if anyone responsible for a non-Intel driver has commentary... since this is shared code. On 02/08/2016 02:38 PM, Nanley Chery wrote: > From: Nanley Chery > > v2: Use

Re: [Mesa-dev] [Mesa-stable] [PATCH 1/4] mesa/image: Make _mesa_clip_readpixels() work with renderbuffers

2016-02-08 Thread Brian Paul
BTW, maybe the same thing could be done for _mesa_DrawPixels and _mesa_clip_drawpixels(), though I don't have time to look into it myself right now. -Brian On 02/08/2016 04:40 PM, Brian Paul wrote: Looks good to me too. Reviewed-by: Brian Paul On 02/08/2016 04:36 PM,

Re: [Mesa-dev] [PATCH 5/5] nir: Recognize open-coded bitfield_reverse.

2016-02-08 Thread Jason Ekstrand
On Mon, Feb 8, 2016 at 3:36 PM, Matt Turner wrote: > On Mon, Feb 8, 2016 at 12:04 PM, Jason Ekstrand > wrote: > > On Thu, Feb 4, 2016 at 5:48 PM, Matt Turner wrote: > >> > >> Helps 11 shaders in UnrealEngine4 demos. > >> > >> I

Re: [Mesa-dev] [PATCH] radeonsi: enable denorms for 64-bit and 16-bit floats

2016-02-08 Thread Ian Romanick
On 02/08/2016 03:37 PM, Roland Scheidegger wrote: > Am 09.02.2016 um 00:02 schrieb Ian Romanick: >> On 02/08/2016 12:38 PM, Marek Olšák wrote: >>> On Mon, Feb 8, 2016 at 5:08 PM, Tom Stellard wrote: On Sat, Feb 06, 2016 at 01:15:42PM +0100, Marek Olšák wrote: > From:

Re: [Mesa-dev] [PATCH 3/5] nir: Do opt_algebraic in reverse order.

2016-02-08 Thread Ian Romanick
On 02/04/2016 05:47 PM, Matt Turner wrote: > Walking the SSA definitions in order means that we consider the smallest > algebraic optimizations before larger optimizations. So if a smaller > rule is part of a larger rule, the smaller one will happen first, > preventing the larger one from

Re: [Mesa-dev] [PATCH 1/5] glsl/ir: add param index to variable.

2016-02-08 Thread Timothy Arceri
On Mon, 2016-02-08 at 13:45 +1000, Dave Airlie wrote: > From: Dave Airlie > > We have a requirement to store the index into the mesa parameterlist > for uniforms. Up until now we've overwritten var->data.location with > this info. However this then stops us accessing

[Mesa-dev] [PATCH] mesa: rewrite save_CallLists() code

2016-02-08 Thread Brian Paul
When glCallLists() is compiled into a display list, preserve the call as a single glCallLists rather than 'n' glCallList calls. This will matter for an upcoming display list optimization project. --- src/mesa/main/dlist.c | 61 +-- 1 file changed,

[Mesa-dev] [PATCH] mesa: add missing error check in _mesa_CallLists()

2016-02-08 Thread Brian Paul
Generate GL_INVALID_VALUE if n < 0. Return early if n==0 or lists==NULL. v2: fix formatting, also check for lists==NULL. --- src/mesa/main/dlist.c | 8 1 file changed, 8 insertions(+) diff --git a/src/mesa/main/dlist.c b/src/mesa/main/dlist.c index cd8e3b6..65f0929 100644 ---

Re: [Mesa-dev] [PATCH 6/7] glx: remove incorrect refcounting of DRIdrawable

2016-02-08 Thread Ian Romanick
On 02/05/2016 01:11 PM, Miklós Máté wrote: > dri drawables must never be released when unbound from a context > as long as their corresponding glx objects (window, pixmap, pbuffer) > still exist I'd really like to have Kristian weigh in, since DRI2 was his design, and this is all his code being

Re: [Mesa-dev] [PATCH] mesa: add missing error check in _mesa_CallLists()

2016-02-08 Thread Ian Romanick
On 02/08/2016 05:06 PM, Brian Paul wrote: > Generate GL_INVALID_VALUE if n < 0. Return early if n==0 or lists==NULL. > > v2: fix formatting, also check for lists==NULL. You were correct that I was looking at save_CallLists before. Reviewed-by: Ian Romanick > --- >

Re: [Mesa-dev] [PATCH] mesa: rewrite save_CallLists() code

2016-02-08 Thread Ian Romanick
On 02/08/2016 05:06 PM, Brian Paul wrote: > When glCallLists() is compiled into a display list, preserve the call > as a single glCallLists rather than 'n' glCallList calls. This will > matter for an upcoming display list optimization project. I think this code is generally better than what was

Re: [Mesa-dev] [PATCH v3] i965/blorp: Fix hiz ops on MSAA surfaces

2016-02-08 Thread Jordan Justen
On 2016-02-06 10:25:59, Ben Widawsky wrote: > On Sat, Feb 06, 2016 at 12:01:50PM +0100, Alejandro Piñeiro wrote: > > From: Chris Forbes > > > > Two things were broken here: > > - The depth/stencil surface dimensions were broken for MSAA. > > - Sample count was programmed

<    1   2