Re: [Mingw-w64-public] [RFC] Single filename per line in Makefiles

2013-08-04 Thread NightStrike
On Fri, Aug 2, 2013 at 2:59 PM, Derek Buitenhuis
derek.buitenh...@gmail.com wrote:
 As it stands right now, the grouping and wrapping of filenames
 in MinGW-w64's Makefiles makes tracking or viewing changes in
 version control very very hard, and makes it non-obvious what has
 changed.

 I propose that it move to a sorted, single-filename-per-line Makefile
 style, which will make additions/deletions/changes very easy to understand,
 and I volunteer to carry out the change if it is agreed upon.

 Comments, flames, or questions?

I have suggested this multiple times in IRC over the years, and it's
always been denied.  Usually, the reasoning is the effect on vertical
real estate.  Some people find it easier to not have to scroll
continuously to see everything they want to see.  And in truth, the
list of import libs is HUGE.  The current source listings for the
libraries support this.

In terms of making things look better, that's a bike shed that never
gets painted.  One man's blue is another's green.

I don't really buy the version control argument, either.  There's only
a few files on a line at most.  I really don't think this is very,
very hard:

-foo.c  bar.c   baz.c
+foo.c  baz.c

I mean.. honestly *two* very's ? :P

At any rate, if enough people want it, then I'm not going to stand in
your way.  But I'd like to see more than just a little support for
what is otherwise a whim of the week.  Otherwise, next week, three
more people will come along asking for it to be yellow.

I will say that one thing in particular that I would definitely want
to do now that automake 1.14 is out is to make use of the feature I've
been begging for since we started -- that is, the ability to have
subdirectory makefiles that can reference a parent directory
(%reldir%).  This would allow putting for instance all of the import
libs in lib/Makefile.am without requiring the evils of recursive make
nor requiring ../ in every file name.  Of course, people need to buy
into that, too.  Before %reldir% came out, when I floated that idea
around, I got the same kind of negative response.  Ah, well.  Such is
the fate of progress :)

--
Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711iu=/4140/ostg.clktrk
___
Mingw-w64-public mailing list
Mingw-w64-public@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public


Re: [Mingw-w64-public] [RFC] Single filename per line in Makefiles

2013-08-04 Thread Kai Tietz
I have about this issue no hard opinion.  I would welcome an more
easily and intuitive way to maintain this - and this block mode is
really bad for manual one.  And indeed to use here 1.14 automake's
%reldir% sounds fine to me, too.

So I am open-minded to this change ... and I agree it has all
potential of being a pretty nice bike-shed subject ;)

Kai

--
Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711iu=/4140/ostg.clktrk
___
Mingw-w64-public mailing list
Mingw-w64-public@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public


Re: [Mingw-w64-public] [RFC] Single filename per line in Makefiles

2013-08-02 Thread Rafaël Carré
Hi,

Le 02/08/2013 20:59, Derek Buitenhuis a écrit :
 As it stands right now, the grouping and wrapping of filenames
 in MinGW-w64's Makefiles makes tracking or viewing changes in
 version control very very hard, and makes it non-obvious what has
 changed.
 
 I propose that it move to a sorted, single-filename-per-line Makefile
 style, which will make additions/deletions/changes very easy to understand,
 and I volunteer to carry out the change if it is agreed upon.
 
 Comments, flames, or questions?

I would second that, I'm myself culprit of not realigning after the
removal/addition of a file to the build rules.

Since I spend quite a lot of time reading the code through git log in
form of patches (I know subversion users do not do it because svn is
very much less efficient for showing single changes), it would be
definitely better to have something like:

src_libmingwex = \
crt/dllentry.c \
crt/dllmain.c \


etc

With this change, patches would only show one single addition/deletion
per changed file, and be much more readable (Makefile.am would look
better as well IMHO)

 - Derek

--
Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711iu=/4140/ostg.clktrk
___
Mingw-w64-public mailing list
Mingw-w64-public@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public


Re: [Mingw-w64-public] [RFC] Single filename per line in Makefiles

2013-08-02 Thread dw

 Comments, flames, or questions?

I like this idea too.

dw

--
Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711iu=/4140/ostg.clktrk
___
Mingw-w64-public mailing list
Mingw-w64-public@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public