Re: An Athn ar9280 client seems to require cold boots of late?

2020-07-06 Thread Stefan Sperling
On Mon, Jul 06, 2020 at 11:10:13AM +, Kevin Chadwick wrote: > With this patch I have been able to bring the device down and back up with a > subsequently successful dhclient and http download. > > Annoying how quirky and poorly documented, chips often are! > > Thank You > Thanks for

Re: An Athn ar9280 client seems to require cold boots of late?

2020-07-06 Thread Kevin Chadwick
With this patch I have been able to bring the device down and back up with a subsequently successful dhclient and http download. Annoying how quirky and poorly documented, chips often are! Thank You

Re: An Athn ar9280 client seems to require cold boots of late?

2020-07-05 Thread Stefan Sperling
On Mon, Jun 29, 2020 at 12:09:12PM +, Kapfhammer, Stefan wrote: > Hi, > > I am using exactly the same WLE-200NX wifi card in an APU2B4. I have a > BlackBerry KeyONE > running at Android 8.1 / Version ABT975 which I use as hotspot for the APU2. > > After setting athn0 down, it is impossible

Re: An Athn ar9280 client seems to require cold boots of late?

2020-06-29 Thread Kapfhammer, Stefan
. AND: It works reliably everytime since month! Regards, Stefan > -Urspr√ľngliche Nachricht- > Von: owner-m...@openbsd.org Im Auftrag > von Austin Hook > Gesendet: Sonntag, 28. Juni 2020 23:43 > An: Kevin Chadwick > Cc: misc@openbsd.org > Betreff: Re: An Athn ar9280 cl

Re: An Athn ar9280 client seems to require cold boots of late?

2020-06-29 Thread Kevin Chadwick
On 2020-06-29 08:35, Kevin Chadwick wrote: > After leaving this up all weekend, the issue seems to have occurred without an > ifconfig down command too. Though the down triggers it immediately. Perhaps it's a hw issue. I have tried updating the coreboot firmware to see if it helps as well as

Re: An Athn ar9280 client seems to require cold boots of late?

2020-06-29 Thread Kevin Chadwick
On 2020-06-29 07:36, Stefan Sperling wrote: > There is one interop problem in 6.7 which has been fixed in -current > by reverting a change which was committted between 6.6 and 6.7: > https://marc.info/?l=openbsd-cvs=159100149411516=2 > Perhaps that applies to your situation? Could you check if a

Re: An Athn ar9280 client seems to require cold boots of late?

2020-06-29 Thread Stefan Sperling
On Sun, Jun 28, 2020 at 03:43:09PM -0600, Austin Hook wrote: > > I have a similar problem with the 6.7 release which I just installed today > on an 8Tb drive I'm using with my older ASUS laptop. > > athn0 at pci3 dev 0 function 0 "Atheros AR9285" rev 0x01: apic 2 int 17 > athn0: AR9285 rev 2

Re: An Athn ar9280 client seems to require cold boots of late?

2020-06-28 Thread Austin Hook
I have a similar problem with the 6.7 release which I just installed today on an 8Tb drive I'm using with my older ASUS laptop. athn0 at pci3 dev 0 function 0 "Atheros AR9285" rev 0x01: apic 2 int 17 athn0: AR9285 rev 2 (1T1R), ROM rev 13, address 74:f0:6d:7a:42:7f Can't seem to shake it with

An Athn ar9280 client seems to require cold boots of late?

2020-06-26 Thread Kevin Chadwick
After upgrading via sysupgrade for a few releases, I have had to cold boot to get dhclient athn0 working on an ar9280 in client mode. Since my latest upgrade to a snapshot of Jun 17 kernel #275 with the previous kernel being from Jun 2nd #237. I seem to have to cold boot after running ifconfig