Re: bgpd acting up, dropping connected/static network statements

2019-05-31 Thread Tommy Nevtelen
On 24/05/2019 12.25, open...@kene.nu wrote: Hello, I finally got to testing this and the bug seems to be fixed. What is the recommended way of implementing this fix into a critical production environment? Should we wait for a syspatch (will one be made available for this bug)? It is possible

Re: bgpd acting up, dropping connected/static network statements

2019-05-24 Thread openbsd
Hello, I finally got to testing this and the bug seems to be fixed. What is the recommended way of implementing this fix into a critical production environment? Should we wait for a syspatch (will one be made available for this bug)? On Fri, May 3, 2019 at 12:12 PM Claudio Jeker wrote: > > On

Re: bgpd acting up, dropping connected/static network statements

2019-05-03 Thread Claudio Jeker
On Fri, May 03, 2019 at 11:52:07AM +0200, open...@kene.nu wrote: > Much appreciated, will test. Did this also affect previous versions > (specifically thinking about 6.3 and 6.4)? No. This code was changed after 6.4 > On Fri, May 3, 2019 at 11:43 AM Claudio Jeker > wrote: > > > > On Fri, May

Re: bgpd acting up, dropping connected/static network statements

2019-05-03 Thread openbsd
Much appreciated, will test. Did this also affect previous versions (specifically thinking about 6.3 and 6.4)? On Fri, May 3, 2019 at 11:43 AM Claudio Jeker wrote: > > On Fri, May 03, 2019 at 09:59:40AM +0200, open...@kene.nu wrote: > > Hello, > > > > I am seeing strange behaviour of bgpd in

Re: bgpd acting up, dropping connected/static network statements

2019-05-03 Thread Claudio Jeker
On Fri, May 03, 2019 at 09:59:40AM +0200, open...@kene.nu wrote: > Hello, > > I am seeing strange behaviour of bgpd in 6.5. > > Not sure what causes the networks in bgpd to disappear but they do > disappear and performing a netstart pick the network back up again in > bgpd. I cannot see this in

bgpd acting up, dropping connected/static network statements

2019-05-03 Thread openbsd
Hello, I am seeing strange behaviour of bgpd in 6.5. Not sure what causes the networks in bgpd to disappear but they do disappear and performing a netstart pick the network back up again in bgpd. I cannot see this in either 6.4 or 6.3. One triggering factor seems to be restarting the bgpd