tool-stats: strptime failed

2018-04-02 Thread Denis
One minor problem with "Bonus: tool-stats script" from the tutorial. # cat /scripts/log-stat.sh #!/bin/sh /usr/bin/zcat /var/log/maillog.*.gz \ | /usr/local/bin/tool-stats \ | /usr/bin/mail -s "smtpd log report" root returns: tool-stats: strptime failed line 1: Undefined error: 0

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread edgar
On Apr 2, 2018 12:43 PM, Reio Remma wrote: > > Good news! > > I was using LMTP to relay to Amavisd, which worked for single > recipients, but I just switched relay to Amavisd to SMTP and now it all > seems to work! :) > > accept from !local for domain relay via

Re: smtpd wont start with OpenBSD 6.2 system starts

2018-04-02 Thread Raf Czlonka
On Mon, Apr 02, 2018 at 06:31:28PM BST, Denis wrote: > Hello, > > Having fully working OpenSMTPd setup with PostgreSQL user auth. > While starting 'smptd -dvv' OR 'rcctl start smtpd' it starts as expected > until next reboot. > > It is enabled by default in '/etc/rc.conf' by setting

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Chris Bennett
On Mon, Apr 02, 2018 at 05:25:29PM +, Vijay Sankar wrote: > Hi Reio, > > It may be better to continue this discussion on the list. That will allow > people more knowledgeable than I to help you out. > > Re. configuration, I actually use the defaults. Amavisd and OpenSMTPD always > use SMTP

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Reio Remma
Good news! I was using LMTP to relay to Amavisd, which worked for single recipients, but I just switched relay to Amavisd to SMTP and now it all seems to work! :) accept from !local for domain relay via lmtp://127.0.0.1:10024 accept from local for any relay via lmtp://127.0.0.1:10026 -->

smtpd wont start with OpenBSD 6.2 system starts

2018-04-02 Thread Denis
Hello, Having fully working OpenSMTPd setup with PostgreSQL user auth. While starting 'smptd -dvv' OR 'rcctl start smtpd' it starts as expected until next reboot. It is enabled by default in '/etc/rc.conf' by setting 'smtpd_flags=' flag. '/etc/rc.conf.local' has no any 'smtpd_flags=' flags in

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Vijay Sankar
Hi Reio, It may be better to continue this discussion on the list. That will allow people more knowledgeable than I to help you out. Re. configuration, I actually use the defaults. Amavisd and OpenSMTPD always use SMTP in my case. Re. versions, it is just OpenBSD 6.1 -stable. Vijay

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Vijay Sankar
Hi, FWIW, I looked through my logs for the past 60 days and see the error you described ONLY on four messages. ALL of them appear to be from a spammer. I am not sure if your set up is the same as mine but what I have is the following: Mail Exchanger with amavisd-new and OpenSMTPD that

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread edgar
On Apr 2, 2018 9:07 AM, Reio Remma wrote: > > I don't think it's that, because the messages are small. I've the limit > set at an ample 100M. > > It's almost as if Amavisd is trying to send the mail back twice (maybe, > for each recipient)? > That's what I thought as well,

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Reio Remma
I don't think it's that, because the messages are small. I've the limit set at an ample 100M. It's almost as if Amavisd is trying to send the mail back twice (maybe, for each recipient)? Reio On 02.04.18 17:04, ed...@pettijohn-web.com wrote: Best guess would be to look at bumping up:

Re: Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread edgar
Best guess would be to look at bumping up: max-message-size Seems odd that it would make it through to amavis without hitting the limit first. On Apr 2, 2018 8:08 AM, Reio Remma wrote: > > Hello all! > > Finally managed to upgrade our server from QMail to OpenSMTPD/Dovecot.

Problem with OpenSMTPD/Amavisd and mails with multiple recipients.

2018-04-02 Thread Reio Remma
Hello all! Finally managed to upgrade our server from QMail to OpenSMTPD/Dovecot. After ironing out a few small kinks I'm still left with a problem. Our mail comes in and is relayed to Amavisd port 10024, then back to OpenSMTPD port 10025. Everything works except when a mail comes in with