Re: Saving memory on small machines

2007-03-22 Thread Stefan Sperling
On Thu, Mar 22, 2007 at 01:47:11PM +0100, RedShift wrote: You may also stripe nearly all of your libraries, for example: # ls -lhS /usr/lib/libcrypto*a -r--r--r-- 1 root bin 11.7M Mar 22 13:53 /usr/lib/libcrypto_pic.a -r--r--r-- 1 root bin 11.6M Mar 22 13:53 /usr/lib/libcrypto_p.a

Re: Distorted sound with clcs(4) on Thinkpad 600X

2007-03-28 Thread Stefan Sperling
On Tue, Mar 27, 2007 at 08:26:29PM -0400, Julian Leyh wrote: Another problem with this Thinkpad is that the CPU speed is not detected properly on boot. You'll see the strange value in the attached dmesg. The value seems to be random after every reboot. Only if i detach the power supply it will

Re: Distorted sound with clcs(4) on Thinkpad 600X

2007-03-28 Thread Stefan Sperling
On Wed, Mar 28, 2007 at 02:16:58PM -0400, Julian Leyh wrote: On 15:13 Wed 28 Mar , Stefan Sperling wrote: Can you try the following patch and let me know if it makes SpeedStep work for you? http://stsp.in-berlin.de/piixpcib/piixpcib-2007-03-24_3.diff Examine the hw.cpuspeed

Re: Long WEP key

2007-03-28 Thread Stefan Sperling
On Wed, Mar 28, 2007 at 09:32:44AM -0500, Rafael Morales wrote: I have OpenBSD 4.0, and I have troubles trying to connect my wireless with my AP. I have in my /etc/hostname.wi0 dhcp NONE NONE NONE nwkey my key But when I restart the net I see this message: sudo sh /etc/netstart

Re: ral, ibss and packets larger than 200 bytes

2007-04-02 Thread Stefan Sperling
On Fri, Mar 16, 2007 at 01:27:38PM +0100, Stefan Sperling wrote: Hello, I've recently got a ral-based card and I have a problem in IBSS mode. It seems that ral fails to send any kind of packets larger than 200 bytes (192 bytes + 8 bytes icmp header). Just for the record, I've found

Re: bcw(4) is gone

2007-04-06 Thread Stefan Sperling
On Fri, Apr 06, 2007 at 01:30:35PM -0400, bofh wrote: On 4/6/07, Marcus Watts [EMAIL PROTECTED] wrote: It's a shame the gnu folks didn't release their reversed engineered specifications separately. Waitaminit - I thought they did?!?! Yes they did: http://bcm-v4.sipsolutions.net/ I've spent

Re: Beep!

2007-04-10 Thread Stefan Sperling
On Tue, Apr 10, 2007 at 06:16:55PM +0200, Reyk Floeter wrote: man speaker(4) for example, # echo 'CDEFGAHOC' /dev/speaker cat /bsd /dev/speaker is fun, too, especially if you're into weird electronic music ;-) -- stefan http://stsp.name PGP Key:

Re: radeon driver in -current Xorg 7.2?

2007-04-23 Thread Stefan Sperling
On Tue, Apr 24, 2007 at 03:23:59AM +1000, Sunnz wrote: Anyone running current with Xorg7.2 with a radeon card? I always used nVidia cards but I have been told that radeon has the best 3D support as far as free software solution goes... so I have been thinking of getting a radeon instead.

Re: default routes

2007-04-24 Thread Stefan Sperling
On Mon, Apr 23, 2007 at 09:56:56PM -0700, Bray Mailloux wrote: I'm setting up an OpenBSD box and need some advice on what my setup should reflect. I have static ip address, specifically 64.142.102.8 which is going to be used as a primary internet connection for my home network. There are

ral, ibss and packets larger than 200 bytes

2007-03-16 Thread Stefan Sperling
Hello, I've recently got a ral-based card and I have a problem in IBSS mode. It seems that ral fails to send any kind of packets larger than 200 bytes (192 bytes + 8 bytes icmp header). I want to use my ral-based card to connect to the freifunk network in Berlin, Germany. (Freifunk can be

Re: sendto: No buffer space available

2007-03-19 Thread Stefan Sperling
On Mon, Mar 19, 2007 at 01:40:02PM +0100, Walter Doerr wrote: Hello, I am using an OpenBSD 4.0 box connected to a 2Mbit SDSL line in Germany (using user space PPP). When pinging a host across the SDSL line, I get an occasional sendto: No buffer space available message: 64 bytes from

Re: adding X11 libraries after the fact

2007-03-20 Thread Stefan Sperling
On Tue, Mar 20, 2007 at 09:37:04AM -0400, Lars D. Nood??n wrote: I recall in the installation there were some sets that could be chosen. Or else, how can that process be revisited without going through the whole install? http://www.openbsd.org/faq/faq4.html#AddFileSet -- stefan

Re: cvs or cvsup

2007-03-21 Thread Stefan Sperling
On Wed, Mar 21, 2007 at 01:39:51AM -0700, Kernel Monkey wrote: I've been using the cvsup client to update my sources. What is the difference between cvs and cvsup when updating sources? Is one better than the other? There is no easy answer. It depends on what you want. + cvsup is much

Re: ospf6d trouble

2010-12-08 Thread Stefan Sperling
On Wed, Dec 08, 2010 at 04:28:55PM +0100, Michael Lechtermann wrote: Hello Claudio, Hallo Stefan, and hello misc@, since we've already talked osp6d stuff in earlier this year, I directly write to you (Claudio and Stefan) in addition to m...@. I am having some issues with ospf6d. The same

Re: wpa2 and osx

2009-02-13 Thread Stefan Sperling
On Fri, Feb 13, 2009 at 05:12:06PM +0100, Tim Saueressig, thepixelz.com wrote: damien.bergam...@free.fr schrieb: Because we are approaching release, I will probably stop advertising PSK-SHA-256 by default for 4.5 (AFAIK, only OpenBSD clients are currently capable of selecting this

Re: wpa2 and osx

2009-02-13 Thread Stefan Sperling
On Fri, Feb 13, 2009 at 05:39:24PM +0100, Tim Saueressig, thepixelz.com wrote: Stefan Sperling schrieb: The MacBook would always try to use WPA Enterprise no matter what. There was no apparent way (at least in the GUI) to convince the thing to just do WPA PSK instead. ot: there is a way

Re: Huawei Modem Setup

2009-02-16 Thread Stefan Sperling
On Sun, Feb 15, 2009 at 03:28:17PM +, Tom Jones wrote: I got a HUAWEI E169 usb modem on the three carrier, here in the UK. I am completely lost on how to set the modem up, Ive been through the example from the FAQ and from some Linux sources, but I would really appreciate if someone could

Re: Huawei Modem Setup

2009-02-16 Thread Stefan Sperling
On Mon, Feb 16, 2009 at 09:45:34PM +, Stefan Sperling wrote: The DNS servers three gave me didn't respond. You may need to use some other well-known DNS server instead. For this reason, if you connect for the first time, it's handy to have the IP address of my.three.ie handy in order

Re: Huawei Modem Setup

2009-02-18 Thread Stefan Sperling
On Wed, Feb 18, 2009 at 12:19:53PM +, Tom Jones wrote: Hi, Ive tried using your configs and the other pppd methods, but failed to get any to connect. Only just checked out the presentation slides suggested so I will dig out through the logs and try to figure out the connection. Show the

random panics on x60s, is a really high IRQ number a problem?

2009-02-21 Thread Stefan Sperling
Hi, I noticed when plugging in my cardbus-based ral, it's getting a really high IRQ assigned to it: ral0 at cardbus0 dev 0 function 0 Ralink RT2560 rev 0x01: irq 268505099, address 00:0e:2e:5c:55:4f ral0: MAC/BBP RT2560 (rev 0x04), RF RT2525 Is that a problem? I tried disabling ACPI but that

panics in VOP_LOCK (was: Re: random panics on x60s, is a really high IRQ number a problem?)

2009-02-26 Thread Stefan Sperling
On Sat, Feb 21, 2009 at 10:54:57AM +, Stefan Sperling wrote: I got more panics, both while using the laptop (in X, so no trace), and today I got another one at boot time (totally different than any other one I had before, and also not reproducable, I couldn't take pics of the trace

random panics on x60s with cardbus ral (Re: panics in VOP_LOCK) really high IRQ number a problem?)

2009-02-26 Thread Stefan Sperling
On Thu, Feb 26, 2009 at 05:46:33PM +, Stefan Sperling wrote: On Sat, Feb 21, 2009 at 10:54:57AM +, Stefan Sperling wrote: I got more panics, both while using the laptop (in X, so no trace), and today I got another one at boot time (totally different than any other one I had before

Re: Static IP address problems

2009-02-27 Thread Stefan Sperling
On Fri, Feb 27, 2009 at 09:20:08AM +, Ruan Kendall wrote: I've come across a strange problem whereby configuring an interface with DHCP lets my system run absolutely fine, but assigning a static IP to the nic results in a system that can only speak to the local subnet. I can ssh into it,

Re: random panics on x60s with cardbus ral (Re: panics in VOP_LOCK) really high IRQ number a problem?)

2009-02-27 Thread Stefan Sperling
(Damien, I'm putting you in Cc because there's a diff below I'd like your opinion on.) On Fri, Feb 27, 2009 at 07:29:45AM +, Stefan Sperling wrote: On Thu, Feb 26, 2009 at 05:46:33PM +, Stefan Sperling wrote: On Sat, Feb 21, 2009 at 10:54:57AM +, Stefan Sperling wrote: I got

Re: random panics on x60s with cardbus ral (Re: panics in VOP_LOCK) really high IRQ number a problem?)

2009-02-27 Thread Stefan Sperling
On Fri, Feb 27, 2009 at 09:59:21AM +, Stefan Sperling wrote: (Damien, I'm putting you in Cc because there's a diff below I'd like your opinion on.) Whoops, nevermind, art@ told me that you're allowed to call malloc from net interrupts and you don't need to to anything special, malloc does

Re: umts need help

2009-03-05 Thread Stefan Sperling
On Thu, Mar 05, 2009 at 09:58:22PM +0100, Didier Wiroth wrote: Hello, I must admit that I'm a ppp / dialup amateur, and did a copy/paste of the pppd options and chat files bellow. I saw different files in the misc@ archives which I tried too, but all failed with the same error, see below.

Re: umts need help

2009-03-05 Thread Stefan Sperling
On Thu, Mar 05, 2009 at 10:50:13PM +0100, Didier Wiroth wrote: Thanks a lot for the help!!! The logging help now returns the following error: Mar 5 22:42:54 406334G chat[14042]: SIGTERM Mar 5 22:43:01 406334G chat[9395]: abort on (BUSY) Mar 5 22:43:01 406334G chat[9395]: abort on (NO

Re: umts need help

2009-03-05 Thread Stefan Sperling
On Thu, Mar 05, 2009 at 06:00:27PM -0500, Marcus Watts wrote: Didier Wiroth dwir...@gmail.com writes: ... Mar 5 22:43:01 406334G chat[9395]: send (ATZ^M) Mar 5 22:43:01 406334G chat[9395]: expect (OK) Mar 5 22:43:01 406334G chat[9395]: TZ^M^M Mar 5 22:43:01 406334G chat[9395]:

Re: pkg_add -u updating same package

2009-03-06 Thread Stefan Sperling
On Fri, Mar 06, 2009 at 07:26:21PM +0100, Thomas Pfaff wrote: $ sudo pkg_add -ui ... libglade2-2.6.2p2 (extracting): complete libglade2-2.6.2p2 (deleting): complete libglade2-2.6.2p2 (installing): complete Maybe I'm just slow or haven't read the relevant FAQ, but what does this mean?

Re: Kernel Panic on 6th March i386 build

2009-03-06 Thread Stefan Sperling
On Fri, Mar 06, 2009 at 06:07:00PM -0500, Daniel Ouellet wrote: Insan Praja SW wrote: Hi, On Sat, 07 Mar 2009 03:17:57 +0700, FRLinux frli...@gmail.com wrote: On Fri, Mar 6, 2009 at 7:12 PM, Insan Praja SW insan.pr...@gmail.com wrote: Hi Misc@, on a i386 kernel recent build (6th march), I

Re: Kernel Panic on 6th March i386 build

2009-03-07 Thread Stefan Sperling
On Fri, Mar 06, 2009 at 08:58:08PM -0500, Daniel Ouellet wrote: Stefan Sperling wrote: And note that there have recently been changes in the way pf keeps track of icmp, so this may well be a valid report. Could sure be I give you that. However, still true that snapshot is the way to go

Re: Kernel Panic on 6th March i386 build

2009-03-08 Thread Stefan Sperling
On Sat, Mar 07, 2009 at 06:29:22PM -0500, Daniel Ouellet wrote: Claudio Jeker wrote: Fell free to disagree, that's fair. Sorry, I don't get it a non-developer tries to educate a developer about how kernel crashes should be reported? Sorry most of your standpoints are just wrong. Sure people

Re: halt -p does not powerdown ThinkPad X200 under 4.5beta

2009-03-10 Thread Stefan Sperling
On Tue, Mar 10, 2009 at 07:40:44PM +0800, David Schulz wrote: Hello all, ThinkPad X200 running with a recent Snapshot (Feb28-09), so 4.5 beta, oftentimes does not power down the machine when using halt -p. Sometimes it does, often enough it does not. I've been seeing this with my x60s,

Re: autoconf 2.62 build problem

2009-03-10 Thread Stefan Sperling
On Tue, Mar 10, 2009 at 02:40:35PM +0100, Sebastian Anding wrote: I tried to build subversion and ruby from ports current. While building autoconf 2.62 I in the following error: dmesg follows: OpenBSD 4.4 (GENERIC) #1021: Tue Aug 12 17:16:55 MDT 2008

Re: halt -p does not powerdown ThinkPad X200 under 4.5beta

2009-03-10 Thread Stefan Sperling
On Tue, Mar 10, 2009 at 09:34:38AM -0500, Marco Peereboom wrote: What happens here is that the bios lies and tells us to write a value to some register and nothing happens. We have debugged several of these machines and all to the same avail; we are doing it right but nothing happens. Do

Re: Browsers was: Re: firefox starts two times

2009-03-24 Thread Stefan Sperling
On Tue, Mar 24, 2009 at 05:19:22AM -0400, Kenneth R Westerback wrote: Actually I am interested in Flash support for work, so if you send me the diff I can try it out. I can't find it in my email archive. Or were you just looking for interested parties before making a diff? The diff was sent

Re: European orders

2009-03-27 Thread Stefan Sperling
On Fri, Mar 27, 2009 at 06:56:17PM +0100, Guido Tschakert wrote: Hello everybody, Just want to put my 2 cents in this discussion: some weeks ago, I thought that it would be time to pre-order 4.5. But then the following comes to my mind: in the last years I seldom used the CDs, most time I

Re: installation

2009-03-28 Thread Stefan Sperling
On Sat, Mar 28, 2009 at 04:51:25AM -0700, sameer.indirock wrote: I have a laptop with win, linux and open solaris on it. using this laptop i tried to install openbsd to my external harddrive which has no OS. There was no error in the installation process. but when i try booting from the

Re: installation

2009-03-28 Thread Stefan Sperling
On Sat, Mar 28, 2009 at 06:46:54PM +0530, Sameer Desai wrote: The partitions are definitely there. they show in linux. I can't mount them on it. The partition is flagged active too. And it is the only OS on the disk Sure, the partitions are fine. But you need new MBR bootcode, not a new

Re: European orders

2009-03-30 Thread Stefan Sperling
On Mon, Mar 30, 2009 at 10:25:42PM +0200, Sebastian Rother wrote: So did you had time to patch the OpenSSL bugs yet? I didn't knew if you really wants an answer to this, but yes, we is currently test an update to 0.9.8k by djm@ if that's what you mean. Stay tuned. Stefan

Re: European orders

2009-03-31 Thread Stefan Sperling
On Tue, Mar 31, 2009 at 10:43:19AM +0200, Peter N. M. Hansteen wrote: Lars NoodC)n larsnoo...@openoffice.org writes: 2) Bank transfer reputation - the banks have a reputation for being difficult about European inter-state transfers. That includes tacking on charges and fees even when

Re: European orders

2009-04-01 Thread Stefan Sperling
On Wed, Apr 01, 2009 at 02:36:55PM +0200, frantisek holop wrote: if wim says, yes, he sent the money i paid for the cd's to theo, and theo says no he didnt get anything, whom should i believe? That's up to you. And there's third option, since you don't necessarily have to believe anything

Re: European orders

2009-04-01 Thread Stefan Sperling
On Wed, Apr 01, 2009 at 03:44:16PM +0200, Martin Schrvder wrote: 2009/4/1, Stefan Sperling s...@stsp.name: Well, I guess you could figure out Theo's email address in no time. The question is rather whether it's worth wasting your time writing to him about this. No, the question

Re: Using 2 internet connections on OpenBSD Gateway

2009-04-02 Thread Stefan Sperling
On Thu, Apr 02, 2009 at 01:52:20AM -0700, LeiV wrote: Hi, I have a openbsd firewall/gateway and behind a webserver, users arrive to my webserver via 1 domain name, I have a cable connection 12Mbps down/500Kbps upthe down speed is OK I dont have so many incoming requests ...but the up

Re: Using 2 internet connections on OpenBSD Gateway

2009-04-02 Thread Stefan Sperling
On Thu, Apr 02, 2009 at 01:05:53PM +0100, Stefan Sperling wrote: On Thu, Apr 02, 2009 at 01:52:20AM -0700, LeiV wrote: Hi, I have a openbsd firewall/gateway and behind a webserver, users arrive to my webserver via 1 domain name, I have a cable connection 12Mbps down/500Kbps up

Re: Using 2 internet connections on OpenBSD Gateway

2009-04-02 Thread Stefan Sperling
On Thu, Apr 02, 2009 at 02:26:42PM +0200, Fernando Alvarez wrote: And... What if both connections doesn't have the same upstream bandwidth? Would it be possible to load-balance both Internet connections considering the upload/donwload capacity of each one, and not using a round-robin load

Re: git0 tunnel with any remote endpoint

2009-04-03 Thread Stefan Sperling
On Fri, Apr 03, 2009 at 02:17:41PM +, Stuart Henderson wrote: On 2009-04-03, Garry Dolley gdol...@arpnetworks.com wrote: Dear misc, Is it possible to have a git0 tunnel that accepts a remote endpoint of any address? I'm trying to set up a 6to4 anycast relay router. 6to4 is not

Re: mounting Blu-ray/HD-DVD reader causes system lockup

2009-04-06 Thread Stefan Sperling
On Mon, Apr 06, 2009 at 08:43:05AM -0700, Bryan wrote: I don't know if I've supplied enough information, but if you need something to help postulate a theory, please let me know. I don't mind tracking it down. I did a find for all .core files after I rebooted, and I do not see anything on my

Re: VLANs, bridge interface and PF

2009-04-06 Thread Stefan Sperling
On Mon, Apr 06, 2009 at 11:41:27AM -0700, Garry Dolley wrote: On Mon, Apr 06, 2009 at 11:27:08AM -0700, Chris Jones wrote: .---. | | | macbook | .--.+ sis0

Re: mounting Blu-ray/HD-DVD reader causes system lockup

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 01:36:21AM +, Bryan wrote: Okay I did exactly as your e-mail suggested. I started the box, put the blu-ray in, and issued a ctrl-alt-esc, and went to ddb, typed continue, and then ssh'ed into the box from antoher system. From the SSH session, I attempted to mount

Re: RES: How can I create a custom ramdisk

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 04:07:54PM -0300, Ricardo Augusto de Souza wrote: Hi, Thanks for reply. I really don?t know how I will get a bootable cd after make release command. I compiled ramdisk_cd and then copy /bsd and /bsd.rd to 4.4 installation cd but it also didn't find serveraid.

Re: How can I create a custom ramdisk

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 02:18:38PM -0300, Ricardo Augusto de Souza wrote: Hi, I wanna find a documentation about creating/booting a custom ramdisk. I need to install OpenBSD on a IBM 3550 and it requires aac* module. Read the release man page: man release

Re: RES: How can I create a custom ramdisk

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 08:30:25PM +0100, Stefan Sperling wrote: On Tue, Apr 07, 2009 at 04:07:54PM -0300, Ricardo Augusto de Souza wrote: Hi, Thanks for reply. I really don?t know how I will get a bootable cd after make release command. I compiled ramdisk_cd and then copy /bsd

Re: RES: RES: How can I create a custom ramdisk

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 04:33:19PM -0300, Ricardo Augusto de Souza wrote: OK. I AM currently running $ cd /sys/arch/${ARCH}/conf Edit the kernel configuration file. ${NAME} is your kernel configuration file. You should not edit GENERIC; create your own kernel

Re: I can't mount HDDs

2009-04-07 Thread Stefan Sperling
On Tue, Apr 07, 2009 at 10:33:09PM +0200, Jose P.G wrote: I swear that i am not a troll. I don't understand anything, LOL, why have to be a troll? My questions are REAL, i haven't read the faq carefully, i only seek for help (more fast, i think). Because asking questions on this list takes

Re: mounting Blu-ray/HD-DVD reader causes system lockup

2009-04-08 Thread Stefan Sperling
On Wed, Apr 08, 2009 at 01:31:05AM +, Bryan wrote: okay, I can pop back out to the ddb prompt if I ctrl-alt-esc again, but nothing is happening when I type continue, it goes back to the blinking cursor. No messages, but I did take a screenshot of ps and trace. By the way, the hangman

Re: European orders

2009-04-18 Thread Stefan Sperling
On Sat, Apr 18, 2009 at 04:57:35PM +0300, Mihai Popescu B.S. wrote: Can someone post a picture with Wim's news house. Just to see if it's a good match for the watch. Stop picking on him already. Picking on him is childish and is not gonna solve the problem. If you want to do something

Re: [l...@ecentrum.hu: Re: ls(1) multibyte support]

2012-03-22 Thread Stefan Sperling
On Thu, Mar 22, 2012 at 11:18:43AM +0100, Peter Hessler wrote: from what I can tell, the problems blocking this diff from going in have been fixed, and it looks good to me. (Putting misc@ on Cc so that everyone interested gets this information.) There is more to this than the wcwidth() bug

wol for nfe (was: Re: setting WOL for Realtek 8168)

2012-08-30 Thread Stefan Sperling
On Wed, Aug 29, 2012 at 07:53:54AM -0700, russell wrote: finally even though it did not work out for me. ( my nics were nfe(4) which has no WOL bits in OBSD, I blame nvidia, those secretive assholes.) Yes, but they cannot hide their secrets forever ;) The nfe driver already knows the which

Re: setting WOL for Realtek 8168

2012-08-30 Thread Stefan Sperling
On Wed, Aug 29, 2012 at 08:56:33AM -0500, Ed Ahlsen-Girard wrote: While I can set wol for this interface, the setting does not survive shutdown. I have found no bios settings that seem to pertain. This system is not dual-boot. Is this a quirk of the 8168? Do I need to look for jumpers? ;-)

Re: setting WOL for Realtek 8168

2012-08-31 Thread Stefan Sperling
On Thu, Aug 30, 2012 at 07:58:07PM -0500, Ed Ahlsen-Girard wrote: I'm all good now, actually - apparently wol has to be reset by rc.local each startup. Yes, or alternatively add the 'wol' keyword to '/etc/hostname.re0'. The option doesn't stick across reboots.

Re: Some probelms configuring dhcpd with iPXE options

2012-09-01 Thread Stefan Sperling
On Sat, Sep 01, 2012 at 12:22:17PM +0200, C. L. Martinez wrote: .. but when I launch /etc/rc.d/dhcpd start, a lot of errors appears (one for every option configured in dhcpd.conf): dhcpd[11205]: /etc/dhcpd.conf line 26: no option named space dhcpd[11205]: option space ipxe; dhcpd[11205]:

Re: HDMI and radeon

2012-09-01 Thread Stefan Sperling
On Sat, Sep 01, 2012 at 07:57:29PM +0200, Christiano F. Haesbaert wrote: Is anyone using HDMI with a radeon card ? Does it work ? Not sure if this is transparent to software ? I got a new monitor and not should if I should buy a HDMI or DVI cable. I've got a DVI monitor hooked up via an HDMI

Re: urtwn device timeouts

2012-09-03 Thread Stefan Sperling
On Mon, Sep 03, 2012 at 12:21:37PM +0200, frantisek holop wrote: hi there, urtwn(4) says that D-Link DWA-121 is supported. based on that i bought it. it is kind of working. after a while i get this: Sep 3 12:00:18 amaaq /bsd: urtwn0: device timeout I'm seeing those, too. I briefly

Re: question about radeon

2012-09-16 Thread Stefan Sperling
On Sun, Sep 16, 2012 at 10:47:24PM +0300, Onat I. wrote: I have Radeon HD 6520G card. I can only use it with vesa. I don't care about acceleration but vesa doesn't support 16:9 aspect. Everything looks fat. It's annoying. So I added appropriate lines to /usr/src/sys/dev/pci/drm/radeon_drv.c

Re: Compiling from the source on -current Failed

2012-09-24 Thread Stefan Sperling
On Tue, Sep 25, 2012 at 12:29:25AM +0700, Insan Praja SW wrote: Hi Misc@, I was just trying to upgrade to -current by compiling from the source, on an old (6 years) server. I updated make(1) first to the latest (compiling from the source, of course) and compiling the kernel. Using the FAQ

Re: Compiling from the source on -current Failed

2012-09-24 Thread Stefan Sperling
On Mon, Sep 24, 2012 at 07:52:44PM +0200, Stefan Sperling wrote: On Tue, Sep 25, 2012 at 12:29:25AM +0700, Insan Praja SW wrote: Hi Misc@, I was just trying to upgrade to -current by compiling from the source, on an old (6 years) server. I updated make(1) first to the latest (compiling

Re: Atheros driver.

2012-09-30 Thread Stefan Sperling
On Sun, Sep 30, 2012 at 04:39:16PM +0100, Peter Kay wrote: I've got this if it helps : athn0 at pci0 dev 15 function 0 Atheros AR5416 rev 0x01: irq 3 athn0: MAC AR5416 rev 2, RF AR2133 (3T2R), ROM rev 5 Works fine with OpenBSD with Windows devices, but there's a problem establishing a

Re: Regression with ATI Mobility Radeon HD 3400

2012-10-19 Thread Stefan Sperling
On Fri, Oct 19, 2012 at 09:06:24AM +0300, Lars Engblom wrote: At some point a half year to one year ago, some changes were made to current that made it impossible to watch movies on my computer. The graphics is lagging so terrible that it is not possible to watch. [26.263] (II) AIGLX:

Re: Regression with ATI Mobility Radeon HD 3400

2012-10-19 Thread Stefan Sperling
of the box. And remove it from the set once r600 support has been fixed to work without this config hack. On 10/19/12 11:59, Stefan Sperling wrote: On Fri, Oct 19, 2012 at 09:06:24AM +0300, Lars Engblom wrote: At some point a half year to one year ago, some changes were made to current that made

Re: boot(8) on amd64 asks for passphrase but keydisk...?

2012-11-04 Thread Stefan Sperling
On Sat, Nov 03, 2012 at 07:08:58PM -0400, Jiri B wrote: This is totally fantastic what jsing@ did, boot(8) can now ask for passphrase for root disk laying on softraid crypto volume. It works OK. But I didn't know it works with passphrase beforeso I first tried with keydisk... What a

Re: ath or ral?

2012-11-10 Thread Stefan Sperling
On Sat, Nov 10, 2012 at 05:13:22PM +0100, Zoran Kolic wrote: I have an old laptop on which I plan to install 5.2 i386. Using pcmcia it should go to internet. What wifi card to choose: atheros 5212 or ralink 2500? Both are considered supported quite well. If you don't intend to run hostap mode

Re: question about built-in support for full disk encryption

2012-11-11 Thread Stefan Sperling
On Sun, Nov 11, 2012 at 11:20:53AM +, hepta tor wrote: On 11/10/12, Barry Grumbine barry.grumb...@gmail.com wrote: On Fri, Nov 9, 2012 at 7:58 PM, hepta tor hepta...@gmail.com wrote: Read this thread: http://marc.info/?l=openbsd-miscm=135198427413548w=2 run -current. Thanks for

Re: atheros on acer aspire one netbook

2012-11-15 Thread Stefan Sperling
On Thu, Nov 15, 2012 at 09:06:44AM +0100, Peter J. Philipp wrote: Hi All, I have an Acer Aspire One 722 netbook. It looks like this with the GENERIC.MP kernel: I really want to get wireless working with this thing so I hacked in the kernel and added the following patch: ---

Re: atheros on acer aspire one netbook

2012-11-15 Thread Stefan Sperling
On Thu, Nov 15, 2012 at 11:23:24AM +0100, Stefan Sperling wrote: --- if_athn_pci.c.orig Thu Nov 15 06:55:19 2012 +++ if_athn_pci.c Thu Nov 15 06:55:37 2012 @@ -100,7 +100,8 @@ { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR2427 }, { PCI_VENDOR_ATHEROS

athn(4) Atheros AR9300 testing request

2012-11-16 Thread Stefan Sperling
Is anyone able to test athn(4) in -current with the following device, and report back to me (off-list is fine) whether or not it is working? Atheros AR9300 Vendor ID: 168c Product ID: 0030 (vendor and produced IDs are shown by 'sudo pcidump -v') I'm trying to get a similar device to work

Re: athn(4) Atheros AR9300 testing request

2012-11-17 Thread Stefan Sperling
On Fri, Nov 16, 2012 at 07:21:14PM -0800, Robert Connolly wrote: I have an AR9285. Is that useful? Not for what I want to know. Thanks though! Also, please while you're in there... I get device timeout's constantly, and it disconnects and reconnects to my router. Maybe you can find the

Re: [obsd] Re: ral(4) hard locks on 5.2

2012-11-27 Thread Stefan Sperling
On Mon, Nov 26, 2012 at 03:14:07PM +0100, Jeremie Le Hen wrote: But the problem seems to have been lurking since at leat 4.4 from my searching in the archives. When making such claims please give others an opportunity to verify your sources. Otherwise it's impossible to tell whether you're

Re: urtwn0: timeout waiting for MAC auto ON

2012-12-01 Thread Stefan Sperling
On Sat, Dec 01, 2012 at 05:15:22PM +, Heptas Torres wrote: Hi I run OpenBSD in a VMware workstation and I would like to connect the Edimax EW-7811Un nano USB wireless adapter: http://www.edimax.com/en/produce_detail.php?pd_id=347pl1_id=1pl2_id=44. I get the error: urtwn0:

Re: AR9485WB-EG libre port

2012-12-15 Thread Stefan Sperling
On Fri, Dec 14, 2012 at 04:43:19PM -0800, Sha'ul wrote: The driver for AR9485 seems to be fully function in libre Linux from what I've tried, don't need the vanilla Linux version for at least the wifi to work. Would it not be possible to thereby port over the libre linux driver version to get

Re: Wireless WPA and crypto hardware

2012-12-15 Thread Stefan Sperling
On Sat, Dec 15, 2012 at 12:00:07PM -0500, Nick Holland wrote: On 12/15/12 11:45, Martin Kjær Jørgensen wrote: Do you think an AMD Elan 133 Mhz is modern enough for at 54/mbit wireless WPA2 throughput? Are you kidding me? That's about as non-modern as OpenBSD/i386 supports. Seriously.

Re: Wireless WPA and crypto hardware

2012-12-16 Thread Stefan Sperling
On Sun, Dec 16, 2012 at 01:52:10PM +0100, Martin Kjær Jørgensen wrote: Sounds like OpenBSD is not quite ready for being a production Access Point. Well, that depends on your needs. But yes, alternatives like OpenWRT are tuned better for use as a speedy access point and run on smaller devices

Re: Can't back to command console after exit X-windows

2012-12-19 Thread Stefan Sperling
On Wed, Dec 19, 2012 at 10:55:47PM +0800, livemoon wrote: Hi, I installed 5.2 in my Fujitsu ph521 laptop. It use AMD Brazos E350. It can use X-windows by radeon driver. But the problem is: when I exit my cwm, the screen become white, and cannot back to console by type any key. How to fix it?

Re: issue tracker

2012-12-20 Thread Stefan Sperling
On Wed, Dec 19, 2012 at 09:43:18PM +, sickm...@lavabit.com wrote: Hi, I have been using OpenBSD for quite a long time, and find it awesome. I've got some spare time lately and decided to hunt some bugs, but I don't really know where to start. Any suggestions? P.S. Yeah, I know about

Re: issue tracker

2012-12-21 Thread Stefan Sperling
On Fri, Dec 21, 2012 at 01:17:06PM +, sickm...@lavabit.com wrote: On 12:25 Thu 20 Dec , Stefan Sperling wrote: On Wed, Dec 19, 2012 at 09:43:18PM +, sickm...@lavabit.com wrote: Hi, I have been using OpenBSD for quite a long time, and find it awesome. I've got some spare

Re: snapshots total freeze

2012-12-25 Thread Stefan Sperling
On Tue, Dec 25, 2012 at 06:05:10PM +0100, frantisek holop wrote: hi there, since a couple of snapshosts back i can quite reliably freeze my openbsd notebook simply by leaving it on overnight. the desktop is there, all the open windows are there, but it has become a painting... nothing in

Re: openbsd clusters

2012-12-26 Thread Stefan Sperling
On Wed, Dec 26, 2012 at 03:26:43PM -0500, Nick Holland wrote: On 12/25/12 19:50, Eric Furman wrote: Not long ago Nick did go into some detail about this very thing. I don't remember how long ago or what the thread was about, but you might find it in the archives. Just search for Nick

Re: Full disk encryption without root partition

2012-12-26 Thread Stefan Sperling
On Wed, Dec 26, 2012 at 10:16:09PM +0100, mhca12 wrote: What's the status of the root partion-less full disk encryption changes? Is it already good enough and are there (semi-)official install images with it enabled? You can create a crypto disk during or after installation (type ! at any

Re: Realtek r8712u Wireless Dongle .. OpenBSD 5.2 i386 ..

2012-12-29 Thread Stefan Sperling
On Sat, Dec 29, 2012 at 11:37:25AM +0300, Kirill Bychkov wrote: And don't forget to install rsu firmware. To install firmware make sure the rsu device is plugged in and you are connected to the internet via another network interface. Then run 'fw_update' as root. I can confirm that rsu works

Re: Locale

2012-12-30 Thread Stefan Sperling
On Sun, Dec 30, 2012 at 12:42:30PM -0300, Matias Moreno Meringer wrote: Hi there. I use mutt in a xterm to check my emails. I speak spanish, so have a lot of emails in that language. Problem is because mutt doesn't display regional character properly, neither others console based

Re: rsu problem

2012-12-31 Thread Stefan Sperling
On Mon, Dec 31, 2012 at 02:36:02AM -0500, Brad Smith wrote: On 12/30/12 00:56, Zoran Kolic wrote: Dongle blinks and the system gives a message: rsu0: could not send site survey command This is a known bug in the driver. It makes the driver essentially unusable. Can you provide a recipe

Re: Disk accesses freeze for a lot of seconds

2013-01-06 Thread Stefan Sperling
On Sun, Jan 06, 2013 at 12:22:44PM +0100, Federico Giannici wrote: We have an OpenBSD 5.2 amd64 where every 5 minutes a few thousand of .rrd files from MRTG are written (actually, updated) to disk. The problem is that for a few seconds (15-20) every other access to the disk is totally

Re: Strange ksh history behaviour

2013-01-07 Thread Stefan Sperling
On Mon, Jan 07, 2013 at 02:09:01PM +0100, Lars von den Driesch wrote: However, I like vim and as soon as I set the EDITOR env variable to it the arrow up/down functionality is gone. In fact even if EDITOR is set with export EDITOR= the functionality is gone. Commands typed in still appear in

Re: Foxconn NanoPC nT-i1250 fails to boot after install

2013-01-09 Thread Stefan Sperling
On Wed, Jan 09, 2013 at 04:30:21PM -0800, Kent Fritz wrote: Install works fine, but consistently stops after printing: wskbd0 at pckbd0: console keyboard, using wsdisplay0 Same behavior for 5.2 release, current, amd64 and i386, and another model nT-i2847. Any hints where to poke next? Shot

Re: Foxconn NanoPC nT-i1250 fails to boot after install

2013-01-10 Thread Stefan Sperling
On Thu, Jan 10, 2013 at 08:56:15AM -0800, Kent Fritz wrote: On Wed, Jan 9, 2013 at 5:34 PM, Stefan Sperling s...@openbsd.org wrote: Shot in the dark: Does it not hang if you disable the pms driver via boot -c? See the boot_config(8) man page. The RAMDISK_CD kernel doesn't have pms

Re: Foxconn NanoPC nT-i1250 fails to boot after install

2013-01-11 Thread Stefan Sperling
On Fri, Jan 11, 2013 at 04:44:07PM -0800, Kent Fritz wrote: I dug a little deeper, and defined PCKBCDEBUG in /usr/src/sys/dev/ic/pckbc.c, and it spews: pckbc_cmd: lost 0xfc Looking at pckbc_poll_cmd1, it looks like there's an infinite loop if it doesn't get back a response it expects.

Re: ImageMagick and perl

2013-01-12 Thread Stefan Sperling
On Sat, Jan 12, 2013 at 01:51:55PM +0100, Dmitrij D. Czarkoff wrote: On Sat, Jan 12, 2013 at 12:31:40PM +, Stuart Henderson wrote: Set LD_PRELOAD=/usr/lib/libpthread.so Thanks, it solved the problem for me. Now, do I have to provide LD_PRELOAD in environment for any perl script

Re: I need a little more Enlightenment

2013-01-15 Thread Stefan Sperling
On Tue, Jan 15, 2013 at 04:35:24PM +1100, Rod Whitworth wrote: E installs without whining. I changed xinitrc to remove the icewm setting and added:- exec enlightenment_start startx gives a very dark screen and a mouse cursor pops up in the centre. Then the screen has a short flash of

Re: I need a little more Enlightenment

2013-01-17 Thread Stefan Sperling
On Wed, Jan 16, 2013 at 10:50:36AM +1100, Rod Whitworth wrote: On Tue, 15 Jan 2013 11:33:54 +0100, Stefan Sperling wrote: The dmesg you quoted is from 5.2. Please show the -current dmesg from the USB stick install which actually has the problem. I was not clear enough. I only ran the USB

Re: two equal filenames in one dir

2013-01-27 Thread Stefan Sperling
On Sun, Jan 27, 2013 at 05:23:05AM -0500, Jiri B wrote: On Sun, Jan 27, 2013 at 05:20:14AM -0500, Jiri B wrote: Hello, I'm confused, how is it possible I have two files with same names in one dir? $ ls -li total 1245376 3611817 -rw-r--r-- 1 jirib jirib 168392755 Jan 14 23:35

  1   2   3   4   5   6   7   8   9   >