Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-06-06 Thread Norman Golisz
On Wed May 1 2019 14:53, Daniel Bolgheroni wrote: > On Wed, May 01, 2019 at 04:43:09PM +, Jonathan Gray wrote: > > On Wed, May 01, 2019 at 12:34:12PM -0300, Daniel Bolgheroni wrote: > > > On Mon, Apr 29, 2019 at 07:05:25AM +, Jonathan Gray wrote: > > > > Does this help? > > > > > > It

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-05-01 Thread Daniel Bolgheroni
On Wed, May 01, 2019 at 04:43:09PM +, Jonathan Gray wrote: > On Wed, May 01, 2019 at 12:34:12PM -0300, Daniel Bolgheroni wrote: > > On Mon, Apr 29, 2019 at 07:05:25AM +, Jonathan Gray wrote: > > > Does this help? > > > > It was already commited but fixed the problem here. > > > >

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-05-01 Thread Jonathan Gray
On Wed, May 01, 2019 at 12:34:12PM -0300, Daniel Bolgheroni wrote: > On Mon, Apr 29, 2019 at 07:05:25AM +, Jonathan Gray wrote: > > Does this help? > > It was already commited but fixed the problem here. > > However, I still can't see the correct modes set for LVDS-1 and for the > external

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-05-01 Thread Daniel Bolgheroni
On Mon, Apr 29, 2019 at 07:05:25AM +, Jonathan Gray wrote: > Does this help? It was already commited but fixed the problem here. However, I still can't see the correct modes set for LVDS-1 and for the external monitor on HDMI-1. An ultrawide 2560x1080 monitor can see at most 1920x1080, but

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-05-01 Thread Gregory Edigarov
On 29.04.19 10:05, Jonathan Gray wrote: On Sun, Apr 28, 2019 at 07:26:54PM -0400, Charles wrote: Hello list, Ever since the new inteldrm driver got merged into -current, shortly before the 6.5 release, I'm seeing an odd new behavior on my Thinkpad T430 -- when an external display is

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-04-30 Thread Charles
On Mon, Apr 29, 2019 at 05:05:25PM +1000, Jonathan Gray wrote: > On Sun, Apr 28, 2019 at 07:26:54PM -0400, Charles wrote: > > Hello list, > > > > Ever since the new inteldrm driver got merged into -current, shortly > > before the 6.5 release, I'm seeing an odd new behavior on my Thinkpad > > T430

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-04-29 Thread Jonathan Gray
On Sun, Apr 28, 2019 at 07:26:54PM -0400, Charles wrote: > Hello list, > > Ever since the new inteldrm driver got merged into -current, shortly > before the 6.5 release, I'm seeing an odd new behavior on my Thinkpad > T430 -- when an external display is connected, Xorg blanks all screens > (but

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-04-28 Thread Jordan Geoghegan
On 4/28/19 4:26 PM, Charles wrote: Hello list, Ever since the new inteldrm driver got merged into -current, shortly before the 6.5 release, I'm seeing an odd new behavior on my Thinkpad T430 -- when an external display is connected, Xorg blanks all screens (but the mouse can still be seen)

Re: Xorg blanks until I switch to a TTY and back on 6.5

2019-04-28 Thread Daniel Bolgheroni
On Sun, Apr 28, 2019 at 11:26:54PM +, Charles wrote: > Is anyone else experiencing this issue on third gen core-I series Intel > chips with integrated graphics? Or on any other chips for that matter? Yes, can confirm on a ThinkPad X220. Also, with the latest snapshot, the correct modes for