Re: [MTT devel] reporter error using pyclient

2016-09-07 Thread Van Dresser, Daniel N
for the MPI Testing Tool <mtt-devel@lists.open-mpi.org> Subject: Re: [MTT devel] reporter error using pyclient No, mtt python client tip of the tree is broken. Looking into it now…. You can change line 534 to “if 0:” to work around the issue until we have a fix. > /home/test/jenkins/mtt/py

Re: [MTT devel] reporter error using pyclient

2016-09-07 Thread Van Dresser, Daniel N
rom: mtt-devel [mailto:mtt-devel-boun...@lists.open-mpi.org] On Behalf Of Josh Hursey Sent: Wednesday, September 07, 2016 11:10 AM To: Development list for the MPI Testing Tool <mtt-devel@lists.open-mpi.org> Subject: Re: [MTT devel] reporter error using pyclient I ran with the Perl client and

Re: [MTT devel] reporter error using pyclient

2016-09-07 Thread Josh Hursey
I ran with the Perl client and it worked fine. I'm struggling to get a valid .ini file for the python client to test further. I keep getting internal NoneType errors in the python client, which probably (hopefully) means that the .ini is not quite correct. Can you send me a simple, valid pyclient

Re: [MTT devel] reporter error using pyclient

2016-09-02 Thread r...@open-mpi.org
I tried converting all the stdout/stderr input to single strings using a “join”, and now I’m getting a different error - looks like we are failing to get a submit id? <<< Raw Output (Start) >> http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd;>

Re: [MTT devel] reporter error using pyclient

2016-08-29 Thread Josh Hursey
Looking at the cherrypy server log it looks like the error is related to this: "result_stderr": [ "Option middleware is not supported" ], This value was set to an array instead of string. result_stdout is coming through fine as a string, but it looks like

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
Hmmm...Hey Josh - is it possible that your server is requiring an MPI_Install phase? We don’t have one since we just build and then set the path accordingly - is it complaining about missing data for an install phase? > On Aug 26, 2016, at 7:33 PM, r...@open-mpi.org wrote: > > Okay, I cleaned

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
Okay, I cleaned things up some more and got a little bit further - now hitting an error in the server? <<< Payload (End ) -->> INFO:requests.packages.urllib3.connectionpool:Resetting dropped connection: mtt.open-mpi.org

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
That appears to resolve the connection issue: <<< Payload (End ) -->> INFO:requests.packages.urllib3.connectionpool:Resetting dropped connection: mtt.open-mpi.org DEBUG:requests.packages.urllib3.connectionpool:"POST /submit/cpy/api/submit

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread Josh Hursey
Try this for the url: url = https://mtt.open-mpi.org/submit/cpy/api I'm looking back at one of my testing scripts and that's what I was using. On Fri, Aug 26, 2016 at 2:11 PM, r...@open-mpi.org wrote: > FWIW: the extra “/“ is inserted in the IUDatabase reporter plugin. >

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
Even though I can get there with the browser, I do still hit this error: <<< Raw Output (Start) >> 404 Not Found Not Found The requested URL /submit/cpy//submit was not found on this server. Apache/2.2.15 (Red Hat) Server at mtt.open-mpi.org Port 443

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
FWIW: the extra “/“ is inserted in the IUDatabase reporter plugin. Removing it didn’t make any difference Must be something on the server side, I fear > On Aug 26, 2016, at 12:08 PM, r...@open-mpi.org wrote: > > BTW: here is my .ini snippet > > > [Reporter:IUdatabase] > plugin = IUDatabase

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
BTW: here is my .ini snippet [Reporter:IUdatabase] plugin = IUDatabase realm = OMPI username = intel pwfile = /home/common/mttpwd.txt platform = bend-rsh hostname = rhc00[1-2] url = https://mtt.open-mpi.org/submit/cpy/ email = r...@open-mpi.org So it looks like the CherryPi server is adding a

Re: [MTT devel] reporter error using pyclient

2016-08-26 Thread r...@open-mpi.org
I checked it with my browser and got the expected return message > On Aug 25, 2016, at 1:46 PM, Josh Hursey wrote: > > Can you send me the portion of the ini script that you are using? > > Can you access this site via the browser (you will need your login >

Re: [MTT devel] reporter error using pyclient

2016-08-25 Thread Josh Hursey
Can you send me the portion of the ini script that you are using? Can you access this site via the browser (you will need your login credentials): https://mtt.open-mpi.org/submit/cpy/api/ It should return: {"status": 0, "status_message": "Success"} On Thu, Aug 25, 2016 at 3:01 PM, Howard

Re: [MTT devel] reporter error using pyclient

2016-08-25 Thread Howard Pritchard
HI Josh, That doesn't seem to help: <<< Payload (End ) -->> INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): mtt.open-mpi.org

Re: [MTT devel] reporter error using pyclient

2016-08-23 Thread Josh Hursey
For the CherryPy submission you need to change the url to: https://mtt.open-mpi.org/submit/cpy/ This is so we can have the old PHP version and the CherryPy version running concurrently. Give that a try. I checked and the server is still running. On Tue, Aug 23, 2016 at 10:53 AM, Howard