Re: RFR 8168663: Nashorn: ant testng tests doesn't support external java options

2016-12-02 Thread Sundararajan Athijegannathan
+1 On 02/12/16, 12:11 PM, Srinivas Dama wrote: Hi, Please review http://cr.openjdk.java.net/~sdama/8168663/webrev.00/ for https://bugs.openjdk.java.net/browse/JDK-8168663 Added run.test.jvmargs.external property so that we can pass jvm options for complete test run as below. ant

SourceMaps

2016-12-02 Thread Art Fiedler
A long time from now, in a galaxy far, far away... jdk9 came today 07/27/2017 :) I definitely do believe it's an important feature, most web tech now a days supports source maps and a portion of the open source project I'm working on uses a source transformer to inject some Interrupt checks among

Re: RFR 8170565: JSObject call() is passed undefined for the argument 'thiz'

2016-12-02 Thread Sundararajan Athijegannathan
Thanks. I've tested the patch on jdk8u. I've sent for approval request: http://mail.openjdk.java.net/pipermail/jdk8u-dev/2016-December/006186.html -Sundar On 12/2/2016 12:56 PM, Art Fiedler wrote: > This seems to be working as expected. I tested your modifications on jdk8 > nashorn-dev > > Good

Re: Error Stack Column number

2016-12-02 Thread Sundararajan Athijegannathan
Error has columnNumber property - but as you've noted it is not always available :( If the error is thrown from script code anywhere via ECMAScript throw statement, we do populate column number - because nashorn could compile the code appropriately to put column number! But, there are places in

Re: Error Stack Column number

2016-12-02 Thread Sundararajan Athijegannathan
StackTraceElement being final is not the only issue here. How do to pass around & populate column numbers for the script frames? That is the main issue here.. -Sundar On 12/2/2016 3:00 PM, Art Fiedler wrote: > Yeah I almost mentioned that StackTraceElement doesn't provide a column > number to

What about JSObject? Object.prototype.hasOwnProperty.call(obj, prop)

2016-12-02 Thread Art Fiedler
Thanks for pointing out the alternative, I hadn't thought of that option. However. ;) I would still argue this as a bug or overlooked. I understand JSObject is not intended to be a real ScriptObject with a prototype etc. However let me ask you the difference between hasMember and hasOwnProperty?

Error Stack Column number

2016-12-02 Thread Art Fiedler
Your right it's still not standard even in the EMCAScript 2016, it just seems to be the commonality. When thinking java yes line only makes sense as typically one who writes java does not minify the code. When thinking javascript however minified code is quite normal and myfile:1 might mean 5000

Confusing ScriptObjectMirror size() vs mirror.get("length")

2016-12-02 Thread Art Fiedler
Thanks for making it more confusing! ;) The reason I used array.get(iStr) instead of array.getSlot(I) just happened to be because of my previous post about array.getSlot() returning the undefined object. I should however have used getSlot in this example to make it more clear that I knew I was

RFR: JDK-8170629 Remove code duplication in test makefiles

2016-12-02 Thread Magnus Ihse Bursie
There is a lot of common code that has been duplicated in */test/Makefile. For jdk, hotspot, jaxp and nashorn, most of the code in the corresponding files are identical. (The odd-man-out is langtools which is quite different.) These files should be unified to share a single code base, to

Re: Error Stack Column number

2016-12-02 Thread Art Fiedler
Yeah I almost mentioned that StackTraceElement doesn't provide a column number to populate but removed that comment, thinking "well, StackTraceElement could just be extended for NashornStackTraceElement", but now looking at it I notice it's final. ugh. But it doesn't technically mean an array of

Re: Error Stack Column number

2016-12-02 Thread Art Fiedler
I had a few thoughts on this but after evaluating it wouldn't work out... If it were possible to modify java.lang.Throwable & StackTraceElement I had thought to do some bit shifting to combine line & column numbers into a negative number and place that as the line number value stored in the

Re: RFR: JDK-8170629 Remove code duplication in test makefiles

2016-12-02 Thread Erik Joelsson
Looks good. /Erik On 2016-12-02 10:24, Magnus Ihse Bursie wrote: There is a lot of common code that has been duplicated in */test/Makefile. For jdk, hotspot, jaxp and nashorn, most of the code in the corresponding files are identical. (The odd-man-out is langtools which is quite different.)