Re: raw socket ICMP change buggy

2005-07-28 Thread David S. Miller
From: "David S. Miller" <[EMAIL PROTECTED]> Date: Thu, 28 Jul 2005 20:54:24 -0700 (PDT) > Patrick, I think some parts of this change: > > [IPV4/6]: Check if packet was actually delivered to a raw socket to > decide whether to send an ICMP unreachable > > might be buggy and create SKB refcou

raw socket ICMP change buggy

2005-07-28 Thread David S. Miller
Patrick, I think some parts of this change: [IPV4/6]: Check if packet was actually delivered to a raw socket to decide whether to send an ICMP unreachable might be buggy and create SKB refcount problems. Andrew Morton was seeing all kinds of weird problems and we narrowed it down to this s

Re: [2.6 patch] net: Spelling mistakes threshoulds -> thresholds

2005-07-28 Thread David S. Miller
From: Adrian Bunk <[EMAIL PROTECTED]> Date: Fri, 29 Jul 2005 00:04:10 +0200 > Just simple spelling mistake fixes. > > From: aruch Even <[EMAIL PROTECTED]> > > Signed-Off-By: Baruch Even <[EMAIL PROTECTED]> > Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> The include/net/tcp.h part of this patch

[PATCH] SCTP: fix many sparse endian warnings

2005-07-28 Thread Alexey Dobriyan
* Use __be16, __be32. * Add SCTP_NL() in the spirit of SCTP_U32() and friends. * Tiny tweak in sctp_chunk_assign_ssn(). Signed-off-by: Alexey Dobriyan <[EMAIL PROTECTED]> --- include/linux/sctp.h | 60 ++--- include/net/sctp/command.h |2 + inc

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-28 Thread Herbert Xu
On Thu, Jul 28, 2005 at 04:23:18PM +0400, Alexey Kuznetsov wrote: > > > You're right. That makes it safe with preemption. However, netfilter > > could still queue the packet which means the neigh entry and dev can > > go away under it, right? > > Netfilter is very clean about this. Each hook ge

Re: Resend: [RFC/PATCH] "safer ipv4 reassembly"

2005-07-28 Thread Herbert Xu
On Wed, Jul 27, 2005 at 10:24:44AM -0700, Arthur Kepner wrote: > > Resending and requesting comments. (Patch was against 2.6.13-rc1, > so it's a little stale by now.) Thanks for reminding me Arthur. I'm working on a patch based on your work. Hopefully I'll have something ready around this week

[PATCH 2.6 6/5] tg3: Fix bug in setting a tg3_flag

2005-07-28 Thread Michael Chan
Found a bug while reviewing the patches the second time. The TG3_FLAG_TXD_MBOX_HWBUG flag is set after the register access methods have been determined. This patch fixes it by moving it up before the various access methods are assigned. Signed-off-by: Michael Chan <[EMAIL PROTECTED]> diff -Nrup

[PATCH] sysfs feature enablement for gianfar

2005-07-28 Thread Andy Fleming
This patch uses sysfs to enable several features for the ethernet controllers supported by the gianfar driver: * The ability to stash or lock n bytes of all rx buffers directly in the L2 * The ability to stash or lock the buffer descriptors in the L2 * The ability to trigger transmission at a low

Re: [patch 2.6.13-rc3] bonding: ALB -- allow slave to use bond's MAC address if its own MAC address conflicts

2005-07-28 Thread Jay Vosburgh
Jeff Garzik <[EMAIL PROTECTED]> wrote: >John W. Linville wrote: >> In ALB mode, allow new slave to use bond's MAC address if the new >> slave's MAC address is being used within the bond and no other slave >> is using the bond's MAC address. >> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> [.

[2.6 patch] net: Spelling mistakes threshoulds -> thresholds

2005-07-28 Thread Adrian Bunk
Just simple spelling mistake fixes. From: aruch Even <[EMAIL PROTECTED]> Signed-Off-By: Baruch Even <[EMAIL PROTECTED]> Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> --- This patch was already sent on: - 12 Jul 2005 This patch was sent by Baruch Even on: - 05 Apr 2005 --- 2.6.11.orig/include

[-mm patch] drivers/net/wireless/hostap/hostap.c: EXPORT_SYMTAB does nothing

2005-07-28 Thread Adrian Bunk
There's no need to define something if it doesn't has any effect. Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> --- This patch was already sent on: - 10 Jul 2005 --- linux-2.6.13-rc2-mm1-full/drivers/net/wireless/hostap/hostap.c.old 2005-07-10 17:31:01.0 +0200 +++ linux-2.6.13-rc2-mm

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread Jeff Garzik
David S. Miller wrote: struct ethtool_perm_addr { unsigned int cmd; int size; char data[0]; }; and the user says how large his buffer is in the request, and if that is not large enough you return -ETOOBIG or some similarly discernable error code so that userspace can allocat

Re: [PATCH 2.6 1/5] tg3: Add basic register access function pointers

2005-07-28 Thread Jeff Garzik
If the register access function selection will truly be an 'if' test cascade, then I ACK these patches. Jeff - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.

Re: [PATCH 2.6 1/5] tg3: Add basic register access function pointers

2005-07-28 Thread David S. Miller
From: Jeff Garzik <[EMAIL PROTECTED]> Date: Thu, 28 Jul 2005 16:29:11 -0400 > If the register access function selection will truly be an 'if' test > cascade, then I ACK these patches. Yeah, it would. I'll more deeply review and integrate Michael's work later today. - To unsubscribe from this li

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread John W. Linville
On Thu, Jul 28, 2005 at 12:50:20PM -0700, David S. Miller wrote: > Netlink uses this kind of thing a lot, but not too much ethtool > stuff does. But something like: > > struct ethtool_perm_addr { >unsigned int cmd; >int size; >char data[0]; > }; > > and the user says how

[PATCH] update to the nf_log logging api

2005-07-28 Thread Harald Welte
Hi Dave, please apply to your net-2.6.14 tree. I'm still working out some glitches with nfnetlink_log, but will submit it fairly soon, too. I've also already some patch to make ebt_ulog.c use the nfnetlink_log core. Stay tuned... [oh yes, I didn't forget my 'virtual ethernet device' code, eithe

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread David S. Miller
From: "John W. Linville" <[EMAIL PROTECTED]> Date: Thu, 28 Jul 2005 15:47:02 -0400 > On Thu, Jul 28, 2005 at 12:38:53PM -0700, David S. Miller wrote: > > Probably it is better to define the ethtool object returned to the > > user as some kind of TLV, so the size doesn't matter. > > Can you point

Re: [patch 2.6.13-rc3] bonding: ALB -- allow slave to use bond's MAC address if its own MAC address conflicts

2005-07-28 Thread Jeff Garzik
John W. Linville wrote: In ALB mode, allow new slave to use bond's MAC address if the new slave's MAC address is being used within the bond and no other slave is using the bond's MAC address. Signed-off-by: John W. Linville <[EMAIL PROTECTED]> --- When a bond in ALB mode goes down and quickly co

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread John W. Linville
On Thu, Jul 28, 2005 at 12:38:53PM -0700, David S. Miller wrote: > From: "John W. Linville" <[EMAIL PROTECTED]> > Date: Thu, 28 Jul 2005 10:56:20 -0400 > > > I wonder how many files include ethtool.h w/o including netdevice.h...? > > This makes userspace inclusion a pain, in fact I bet adding > t

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread David S. Miller
From: "John W. Linville" <[EMAIL PROTECTED]> Date: Thu, 28 Jul 2005 10:56:20 -0400 > I wonder how many files include ethtool.h w/o including netdevice.h...? This makes userspace inclusion a pain, in fact I bet adding the linux/netdevice.h include will break the build for somebody. And what if we

[PATCH 2/3][SOCK] Introduce sk_setup_caps

2005-07-28 Thread Arnaldo Carvalho de Melo
Hi David, Please consider pulling from: rsync://rsync.kernel.org/pub/scm/linux/kernel/git/acme/net-2.6.14-2.git - Arnaldo tree 4388ccbbc9199e3d3779ade9e5f2e1f44cb50932 parent 5302ca03847ab31e8e477cf6b76c02d3c9ccb188 author Arnaldo Carvalho de Melo <[EMAIL PROTECT

[patch 2.6.13-rc3] bonding: ALB -- allow slave to use bond's MAC address if its own MAC address conflicts

2005-07-28 Thread John W. Linville
In ALB mode, allow new slave to use bond's MAC address if the new slave's MAC address is being used within the bond and no other slave is using the bond's MAC address. Signed-off-by: John W. Linville <[EMAIL PROTECTED]> --- When a bond in ALB mode goes down and quickly comes back up, it is possibl

Re: [PATCH 2.6 1/5] tg3: Add basic register access function pointers

2005-07-28 Thread John W. Linville
On Thu, Jul 28, 2005 at 10:33:12AM -0700, Michael Chan wrote: > If on the other hand, tg3 is loaded on different chips all using different > access > function pointers, and there is steady and equal amount of traffic going > through > all these chips, I suppose the call destinations will no longer

Re: [PATCH 1/1] e1000: minor bug on debug module parm

2005-07-28 Thread Jesse Brandeburg
On 7/28/05, Holger Eitzenberger <[EMAIL PROTECTED]> wrote: > I found a minor bug in e1000 debug initialization. > > The previous initaliazation resulted in log of level NETIF_MSG_DRV, > NETIF_MSG_PROBE and NETIF_MSG_LINK ('debug' is used as shift factor) > while it obviously was intended that only

[PATCH 2/3][SOCK] Introduce sk_setup_caps

2005-07-28 Thread Arnaldo Carvalho de Melo
Hope a duplicate doesn't show up, but so far this hasn't made it to netdev after a long time, so I'm resending it. Hi David, Please consider pulling from: rsync://rsync.kernel.org/pub/scm/linux/kernel/git/acme/net-2.6.14-2.git - Arnaldo tree 4388ccbbc9199e3d3779

Re: [PATCH 2.6 1/5] tg3: Add basic register access function pointers

2005-07-28 Thread Michael Chan
Jeff Garzik wrote: > In x86-based CPUs at least (the largest tg3 platform), branch > prediction > often prefers > > if (...) > direct_func_1() > else > direct_func_2() > > to > > tp->func() > The following is from Intel Pentium 4 and Intel Xeon

Re: more complex processing in ing_filter ?

2005-07-28 Thread Stephen Hemminger
On Thu, 28 Jul 2005 08:21:36 +0200 Lucas Nussbaum <[EMAIL PROTECTED]> wrote: > On Wed, Jul 27, 2005 at 10:50:41AM -0700, Stephen Hemminger > <[EMAIL PROTECTED]> wrote: > > On Wed, 27 Jul 2005 10:06:45 +0200 > > Lucas Nussbaum <[EMAIL PROTECTED]> wrote: > > > > > Hi, > > > > > > I'm interested in

[PATCH 3/3][INET] Introduce inet_sk_rebuild_header

2005-07-28 Thread Arnaldo Carvalho de Melo
Hi David, Please consider pulling from: rsync://rsync.kernel.org/pub/scm/linux/kernel/git/acme/net-2.6.14-2.git - Arnaldo tree 57a14ec73c746a1f74f59fffa640a38adb353824 parent 8d2d5b8420a3f5d2a68fa8cfcc87a572475c340f author Arnaldo Carvalho de Melo <[EMAIL PROTE

[PATCH 1/3][SOCK] Rename __tcp_v4_rehash to __sk_prot_rehash

2005-07-28 Thread Arnaldo Carvalho de Melo
Hi David, Please consider pulling from: rsync://rsync.kernel.org/pub/scm/linux/kernel/git/acme/net-2.6.14-2.git This tree contains the INET_REFCNT_DEBUG, that is the only outstanding changeset in the net-2.6.14.git tree (without the -2), I did this because you may well have some

Re: Upcoming 2.6.13 and hostap driver

2005-07-28 Thread Jeff Garzik
Jar wrote: Hostap driver has been in the -mm tree for a long time. Any plans to merge it to upcoming 2.6.13? It needs to be merged with the ieee80211 generic layer, before it can go upstream. Jeff - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a

RE: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread Jon_Wetzel
John W. Linville wrote: > I wonder how many files include ethtool.h w/o including > netdevice.h...? > > Anyway, why not just include netdevice.h at the top of ethtool.h? > Lots of other header files do it e.g. ethdevice.h, inetdevice.h, > if_arp.h, if_bridge.h, if_vlan.h, ip.h, neighbour.h, sock.

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread John W. Linville
On Thu, Jul 28, 2005 at 09:42:14AM -0500, Jon Wetzel wrote: > On Wed, Jul 27, 2005 at 09:56:05PM -0400, John W. Linville wrote: > > Jon, you should probably add a patch (or redo you current patch) > > and use MAX_ADDR_LEN instead of adding the new ETH_MAX_ADDR_LEN... > > I wanted to do this initi

Re: [patch 2.6.13-rc3] ethtool: add generic ethtool_op_get_perm_addr routine

2005-07-28 Thread Jon Wetzel
First off, I think making the get_perm_addr function into an ethtool op is a fine idea. Also, thanks for catching the unmatched bracket; once again I have been humbled by the "errant backspace". On Wed, Jul 27, 2005 at 09:56:05PM -0400, John W. Linville wrote: > Drivers would still have the op

Network Card which checksum

2005-07-28 Thread John Que
Hello, One of the possible policies for skb->ip_summed is CHECKSUM_HW. In this case the device can perform checksums in hardware. According to Linux Device Drivers 3, an example of a such network card is the SPARC HME interface. I looked a bit at the code (it's in /drivers/net/sunhme.c)

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-28 Thread Alexey Kuznetsov
Hello! > Just double checking (I think we are saying the same thing), > that using ifindices and requiring refcounting for input_dev means you > have to use __dev_get_by_index() on a per-packet basis. The third check, I do not follow... You just compare ifindex stored in skb (skb->iif) with ifin

Re: Fw: Re: [Bugme-new] [Bug 4952] New: IPSec incompabilty. Linux kernel waits to long to start using new SA for outbound traffic.

2005-07-28 Thread Krzysztof Oledzki
On Wed, 27 Jul 2005, Andrew Morton wrote: Please cc netdev@vger.kernel.org, [EMAIL PROTECTED], [EMAIL PROTECTED] on any reply. Begin forwarded message: Date: Wed, 27 Jul 2005 15:18:39 -0700 (PDT) From: "David S. Miller" <[EMAIL PROTECTED]> To: [EMAIL PROTECTED] Cc: netdev@vger.kernel.org,

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-28 Thread Alexey Kuznetsov
Hello! > You're right. That makes it safe with preemption. However, netfilter > could still queue the packet which means the neigh entry and dev can > go away under it, right? Netfilter is very clean about this. Each hook gets two devices as _arguments_ (input and output, skb->dev is one of the

Re: more complex processing in ing_filter ?

2005-07-28 Thread jamal
On Thu, 2005-28-07 at 08:19 +0200, Lucas Nussbaum wrote: > On Wed, Jul 27, 2005 at 08:59:56AM -0400, jamal <[EMAIL PROTECTED]> wrote: > > On Wed, 2005-27-07 at 10:06 +0200, Lucas Nussbaum wrote: > > > Hi, > > > > > > I'm interested in doing more complex stuff on inbound packets than what > > > is

Re: [RFC PATCH 1/4] PHY Abstraction Layer III (now with more splitiness)

2005-07-28 Thread Jörn Engel
On Wed, 27 July 2005 14:34:19 -0700, Randy Dunlap wrote: > > > > Ok, here I won't agree to disagree with you. !foo as a check for > > NULL is a reasonable idea, but not my style. If that's the preferred > > style for the kernel, I will do that. > > > > But (var == constant) is a style that

Re: [RFC] Zero-copy sniffer. Reincarnation #1.

2005-07-28 Thread Evgeniy Polyakov
On Thu, Jul 28, 2005 at 12:44:41PM +0400, Evgeniy Polyakov ([EMAIL PROTECTED]) wrote: > Hello, developers. > > This cruft works now much better. > Unfortunately I need to add some scary PTE insults- you can find them in > update_address(). > One big nitpick is that this module can not be unloaded

[PATCH 1/1] e1000: minor bug on debug module parm

2005-07-28 Thread Holger Eitzenberger
Hi, I found a minor bug in e1000 debug initialization. The previous initaliazation resulted in log of level NETIF_MSG_DRV, NETIF_MSG_PROBE and NETIF_MSG_LINK ('debug' is used as shift factor) while it obviously was intended that only NETIF_MSG_DRV and NETIF_MSG_PROBE should be logged. The a

[RFC] Zero-copy sniffer. Reincarnation #1.

2005-07-28 Thread Evgeniy Polyakov
Hello, developers. This cruft works now much better. Unfortunately I need to add some scary PTE insults- you can find them in update_address(). One big nitpick is that this module can not be unloaded if application do not closes socket - socket is being removed after mapping is destroyed, so I n