Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Dave Young
On Nov 22, 2007 11:56 AM, Rusty Russell [EMAIL PROTECTED] wrote: On Thursday 22 November 2007 13:43:06 Andi Kleen wrote: There seems to be rough consensus that the kernel currently has too many exported symbols. A lot of these exports are generally usable utility functions or important

Re: [PATCHv6 0/3] Interface group patches

2007-11-22 Thread Laszlo Attila Toth
David Miller írta: From: Patrick McHardy [EMAIL PROTECTED] Date: Wed, 21 Nov 2007 01:25:54 +0100 I'm working on the incremental ruleset changing API BTW :) One of the changes will be that interface matching is not a default part of every rule, and without wildcards it will use the ifindex. But

Re: [RFC PATCH 1/2] [TCP]: MTUprobe: receiver window data available checks fixed

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 06:01:27PM +0200, Ilpo Järvinen wrote: Signed-off-by: Ilpo Järvinen [EMAIL PROTECTED] Thanks for the patch Ilpo! I've just got a couple small questions. @@ -1307,6 +1308,7 @@ static int tcp_mtu_probe(struct sock *sk) /* Very simple search strategy: just double

Re: [RFC][PATCH 1/3] NET_SCHED: PSPacer qdisc module

2007-11-22 Thread TAKANO Ryousei
Hi Patrick, Looks good, but please run checkpatch over it. A few more comments below. I am sorry I forgot to run checkpatch. Thanks for your comments. They are very useful for me. I will fix them and resent the patch. Best regards, Ryousei Takano - To unsubscribe from this list: send the

Re: [RFC][PATCH 1/3] NET_SCHED: PSPacer qdisc module

2007-11-22 Thread TAKANO Ryousei
Hi Eric, +static struct sk_buff *alloc_gap_packet(struct Qdisc* sch, int size) +{ + struct sk_buff *skb; + struct net_device *dev = sch-dev; + unsigned char *pkt; + int pause_time = 0; + int pktsize = size + 2; + + skb = alloc_skb(pktsize, GFP_ATOMIC); + if

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Christoph Hellwig
On Thu, Nov 22, 2007 at 02:56:22PM +1100, Rusty Russell wrote: This is an interesting idea, thanks for the code! My only question is whether we can get most of this benefit by dropping the indirection of namespaces and have something like EXPORT_SYMBOL_TO(sym, modname)? It doesn't work

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Christoph Hellwig
Very nice, looking forward to organize the exports mess a bit more. - To unsubscribe from this list: send the line unsubscribe netdev in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH][IRDA] Compilation for CONFIG_INET=n case

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 07:03:16PM +0300, Pavel Emelyanov wrote: Found this occasionally. The CONFIG_INET=n is hardly ever set, but if it is the irlan_eth_send_gratuitous_arp() compilation should produce a warning about unused variable in_dev. Too pedantic? :) Signed-off-by: Pavel

Re: [RFC PATCH 2/2] [TCP] MTUprobe: Cleanup send queue check (no need to loop)

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 06:01:28PM +0200, Ilpo Järvinen wrote: The original code has striking complexity to perform a query which can be reduced to a very simple compare. FIN seqno may be included to write_seq but it should not make any significant difference here compared to skb-len which

Re: [patch 1/4] pfkey: sending an SADB_GET responds with an SADB_GET

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 11:02:13PM +, [EMAIL PROTECTED] wrote: From: Charles Hardin [EMAIL PROTECTED] Kernel needs to respond to an SADB_GET with the same message type to conform to the RFC 2367 Section 3.1.5 Cc: David S. Miller [EMAIL PROTECTED] Signed-off-by: Andrew Morton [EMAIL

Re: [patch 2/4] make sunrpc/xprtsock.c:xs_setup_{udp,tcp}() static

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 11:02:14PM +, [EMAIL PROTECTED] wrote: From: Adrian Bunk [EMAIL PROTECTED] xs_setup_{udp,tcp}() can now become static. Signed-off-by: Adrian Bunk [EMAIL PROTECTED] Signed-off-by: Andrew Morton [EMAIL PROTECTED] Applied. -- Visit Openswan at

Re: [patch 4/4] Net: sunrpc, remove SPIN_LOCK_UNLOCKED

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 11:02:15PM +, [EMAIL PROTECTED] wrote: From: Jiri Slaby [EMAIL PROTECTED] sunrpc, remove SPIN_LOCK_UNLOCKED SPIN_LOCK_UNLOCKED is deprecated, use DEFINE_SPINLOCK instead Signed-off-by: Jiri Slaby [EMAIL PROTECTED] Cc: David S. Miller [EMAIL PROTECTED]

Re: [patch 3/4] tlan list is subscribers-only

2007-11-22 Thread Herbert Xu
On Wed, Nov 21, 2007 at 11:02:15PM +, [EMAIL PROTECTED] wrote: From: Gabriel C [EMAIL PROTECTED] Your mail to 'Tlan-devel' with the subject drivers/net/tlan question Is being held until the list moderator can review it for approval. The reason it is being held: Post by

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Andi Kleen
On Thursday 22 November 2007 04:56, Rusty Russell wrote: This is an interesting idea, thanks for the code! My only question is whether we can get most of this benefit by dropping the indirection of namespaces and have something like EXPORT_SYMBOL_TO(sym, modname)? It doesn't work so

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Andi Kleen
On Thursday 22 November 2007 12:06, Christoph Hellwig wrote: Very nice, looking forward to organize the exports mess a bit more. I would need people to help me converting more subsystems to this new scheme. In particular all exports that are only used by a single module are direct candidates

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Arnaldo Carvalho de Melo
Em Thu, Nov 22, 2007 at 03:43:06AM +0100, Andi Kleen escreveu: There seems to be rough consensus that the kernel currently has too many exported symbols. A lot of these exports are generally usable utility functions or important driver interfaces; but another large part are functions

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Christoph Hellwig
On Thu, Nov 22, 2007 at 12:54:49PM +0100, Andi Kleen wrote: On Thursday 22 November 2007 12:06, Christoph Hellwig wrote: Very nice, looking forward to organize the exports mess a bit more. I would need people to help me converting more subsystems to this new scheme. In particular all

[PATCH] smc911x: Fix multicast handling

2007-11-22 Thread Peter Korsgaard
smc911x_set_multicast_list fails to fill out the multicast hash table correctly; Bit 1 was used rather than bit 5 to decide if the lower or upper register should be used. The function is at the same time cleaned up by calling ether_crc rather than using it's own bit reversal table.

Re: [README] away until Dec 3rd

2007-11-22 Thread Tetsuo Handa
Hello. I have a question. Yesterday, I posted a patch based on 2.6.24-rc3-mm1 that modifies the following files. include/linux/security.h | 34 +- net/core/datagram.c | 26 -- net/socket.c |7 +--

Re: [README] away until Dec 3rd

2007-11-22 Thread Herbert Xu
On Thu, Nov 22, 2007 at 09:57:14PM +0900, Tetsuo Handa wrote: But you say that I should make patches based on the net-2.6.25 tree. Which tree (-mm or net-2.6.25) should I use for making this patch? The net-2.6.25 tree is the one. Please use the tree at

Re: [RFC PATCH 1/2] [TCP]: MTUprobe: receiver window data available checks fixed

2007-11-22 Thread Ilpo Järvinen
On Thu, 22 Nov 2007, Herbert Xu wrote: On Wed, Nov 21, 2007 at 06:01:27PM +0200, Ilpo Järvinen wrote: Signed-off-by: Ilpo Järvinen [EMAIL PROTECTED] Thanks for the patch Ilpo! I've just got a couple small questions. ...Thanks for actually commenting it. :-) @@ -1307,6 +1308,7 @@

[PATCH][UNIX] Move the unix sock iterators in to proper place

2007-11-22 Thread Pavel Emelyanov
The first_unix_socket() and next_unix_sockets() are now used in proc file and in forall_unix_socets macro only. The forall_unix_sockets is not used in this file at all so remove it. After this move the helpers to where they really belong, i.e. closer to proc code under the #ifdef CONFIG_PROC_FS

[RFC] bridging: don't forward EAPOL frames

2007-11-22 Thread Johannes Berg
This patch makes the bridging code drop EAPOL frames as recommended by 802.1X-2004 in C.3.3. Is this really the right place to put it? --- include/linux/if_ether.h |1 + include/net/ieee80211.h |6 -- net/bridge/br_input.c|3 +++ 3 files changed, 4 insertions(+), 6

[PATCH net-2.6.25] Add packet filtering based on process's security context.

2007-11-22 Thread Tetsuo Handa
Hello. Herbert Xu wrote: On Thu, Nov 22, 2007 at 09:57:14PM +0900, Tetsuo Handa wrote: But you say that I should make patches based on the net-2.6.25 tree. Which tree (-mm or net-2.6.25) should I use for making this patch? The net-2.6.25 tree is the one. Please use the tree at

Re: [RFC PATCH 1/2] [TCP]: MTUprobe: receiver window data available checks fixed

2007-11-22 Thread Herbert Xu
On Thu, Nov 22, 2007 at 03:11:35PM +0200, Ilpo Järvinen wrote: ...We'll be using current MTU sized packets except for the probe until the probe has succeeded, only from that point onward will the new packets will be sent with the larger MTU. If the probe succeeds, all reservations we made

Re: [PATCHv6 0/3] Interface group patches

2007-11-22 Thread Wolfgang Walter
From: Patrick McHardy I'm working on the incremental ruleset changing API BTW :) One of the changes will be that interface matching is not a default part of every rule, and without wildcards it will use the ifindex. But since the cost of this feature seems pretty low, I don't see a

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Andi Kleen
Creating the DCCP and its congestion control infrastructure (CCID) module namespaces is now on my TODO list. :-) My original patchkit had DCCP actually done, but I ran into some problem while forward porting and disabled it again. But should be reasonably easy to resurrect. -Andi - To

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Andi Kleen
Andy, I like your idea. IMHO, as Rusty said a simple EXPORT_SYMBOL_TO is better. I don't think so. e.g. tcpcong would be very very messy this way. And I wonder if it is possible to export to something like the struct device_driver? If it's possible then it will not limited to modules.

2.6.23 WARNING: at kernel/softirq.c:139 local_bh_enable()

2007-11-22 Thread Simon Arlott
WARN during log message being output to ttyS0 and netconsole: [2059664.615816] __iptables__: init4 IN=ppp0 OUT=ppp0 WARNING: at kernel/softirq.c:139 local_bh_enable() [2059664.620535] [80120364] local_bh_enable+0x3c/0x97 [2059664.620553] [802e3356] __nf_ct_ext_destroy+0x35/0x5b

NET: dmfe.c : fix access to card's pci config space in D3

2007-11-22 Thread Maxim Levitsky
Hi, I somehow assumed that pci_save_state should be called while device is powered off, but actually the opposite is true. Thus I am sending this patch to fix it. Sorry for this mistake, Best regards, Maxim Levitsky - To unsubscribe from this list: send the line

[PATCH] NET: dmfe: don't access configuration space in D3 state

2007-11-22 Thread Maxim Levitsky
From 7e24227257f315e52fe0b494dc1253d2a0ce5dff Mon Sep 17 00:00:00 2001 From: Maxim Levitsky [EMAIL PROTECTED] Date: Fri, 23 Nov 2007 01:15:36 +0200 Subject: [PATCH] NET: dmfe: don't access configuration space in D3 state Accidently I reversed the order of pci_save_state and pci_set_power_state

Re: [PATCH net-2.6.25] Add packet filtering based on process's security context.

2007-11-22 Thread James Morris
On Thu, 22 Nov 2007, Tetsuo Handa wrote: This patch allows LSM modules filter incoming connections/datagrams based on the process's security context who is attempting to pick up. There are already hooks to filter incoming connections/datagrams based on the socket's security context, but

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Rusty Russell
On Thursday 22 November 2007 22:46:23 Andi Kleen wrote: On Thursday 22 November 2007 04:56, Rusty Russell wrote: This is an interesting idea, thanks for the code! My only question is whether we can get most of this benefit by dropping the indirection of namespaces and have something

[PATCH] add compare_ether_addr_unaligned

2007-11-22 Thread Daniel Drake
David Miller found a problem in a wireless driver where I was using compare_ether_addr() on potentially unaligned data. Document that compare_ether_addr() is not safe for use everywhere, and add an equivalent function that works regardless of alignment. Signed-off-by: Daniel Drake [EMAIL

Re: [PATCH] cassini: NAPI configuration

2007-11-22 Thread David Miller
From: Stephen Hemminger [EMAIL PROTECTED] Date: Wed, 21 Nov 2007 11:53:58 -0800 The Cassini driver has NAPI support, but it not possible to configure it. Compile tested only, no idea if it works (no hardware). Get rid of warning from lefover variable in now visible code. Signed-off-by:

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Rusty Russell
On Thursday 22 November 2007 22:05:45 Christoph Hellwig wrote: On Thu, Nov 22, 2007 at 02:56:22PM +1100, Rusty Russell wrote: This is an interesting idea, thanks for the code! My only question is whether we can get most of this benefit by dropping the indirection of namespaces and have

RE: [RFC/PATCH] SO_NO_CHECK for IPv6

2007-11-22 Thread David Schwartz
Regardless of whatever verifications your application is doing on the data, it is not checksumming the ports and that's what the pseudo-header is helping with. So what? We are in the case where the data has already gotten to him. If it got to him in error, he'll reject it anyway. The receive

Re: [RFC/PATCH] SO_NO_CHECK for IPv6

2007-11-22 Thread David Miller
From: Jeff Garzik [EMAIL PROTECTED] Date: Wed, 21 Nov 2007 19:17:40 -0500 YOSHIFUJI Hideaki / 吉藤英明 wrote: In article [EMAIL PROTECTED] (at Wed, 21 Nov 2007 07:45:32 -0500), Jeff Garzik [EMAIL PROTECTED] says: SO_NO_CHECK support for IPv6 appeared to be missing. This is presented,

Re: [PATCH] add compare_ether_addr_unaligned

2007-11-22 Thread Stephen Hemminger
On Fri, 23 Nov 2007 00:09:22 + (GMT) Daniel Drake [EMAIL PROTECTED] wrote: David Miller found a problem in a wireless driver where I was using compare_ether_addr() on potentially unaligned data. Document that compare_ether_addr() is not safe for use everywhere, and add an equivalent

Re: [Bugme-new] [Bug 9440] New: Problem in joinning a socket to ipv6 multicast address in specific scenario

2007-11-22 Thread Andrew Morton
On Thu, 22 Nov 2007 11:02:04 -0800 (PST) [EMAIL PROTECTED] wrote: http://bugzilla.kernel.org/show_bug.cgi?id=9440 Summary: Problem in joinning a socket to ipv6 multicast address in specific scenario Product: Networking Version: 2.5

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Dave Young
On Nov 23, 2007 2:19 AM, Andi Kleen [EMAIL PROTECTED] wrote: Andy, I like your idea. IMHO, as Rusty said a simple EXPORT_SYMBOL_TO is better. I don't think so. e.g. tcpcong would be very very messy this way. And I wonder if it is possible to export to something like the struct

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Andi Kleen
On Friday 23 November 2007 01:25, Rusty Russell wrote: On Thursday 22 November 2007 22:05:45 Christoph Hellwig wrote: On Thu, Nov 22, 2007 at 02:56:22PM +1100, Rusty Russell wrote: This is an interesting idea, thanks for the code! My only question is whether we can get most of this

Re: [PATCH RFC] [1/9] Core module symbol namespaces code and intro.

2007-11-22 Thread Rusty Russell
On Friday 23 November 2007 12:36:22 Andi Kleen wrote: On Friday 23 November 2007 01:25, Rusty Russell wrote: That's my point. If there's a whole class of modules which can use a symbol, why are we ruling out external modules? The point is to get cleaner interfaces. But this doesn't change

Re: [PATCH 12/21] r8169: confusion between hardware and IP header alignment

2007-11-22 Thread Martin Michlmayr
Hi Francois, A Debian user reported that NFS transfers are not working correctly on a Thecus N2100 (which has two 8169 ports). I confirmed this bug with 2.6.18 and 2.6.22 but couldn't reproduce it with 2.6.23. A git bisect has revealed that your patch confusion between hardware and IP header