[PATCH v2] net/9p: trans_xen: add missing MODULE_AUTHOR/DESCRIPTION/LICENSE

2017-11-19 Thread Jesse Chan
This change resolves a new compile-time warning when built as a loadable module: WARNING: modpost: missing MODULE_LICENSE() in net/9p/9pnet_xen.o see include/linux/module.h for more information This adds the license as "Dual MIT/GPL", which matches the header of the file. MODULE_DESCRIPTION and

[PATCH RFC 5/5] esp: Don't require synchronous crypto fallback on offloading anymore.

2017-11-19 Thread Steffen Klassert
We support asynchronous crypto on layer 2 ESP now. So no need to force synchronous crypto fallback on offloading anymore. Signed-off-by: Steffen Klassert --- net/ipv4/esp4.c | 12 ++-- net/ipv6/esp6.c | 12 ++-- 2 files changed, 4 insertions(+), 20

[PATCH RFC 2/5] net: Add asynchronous callbacks for xfrm on layer 2.

2017-11-19 Thread Steffen Klassert
This patch implements asynchronous crypto callbacks and a backlog handler that can be used when IPsec is done at layer 2 in the TX path. It also extends the skb validate functions so that we can update the driver transmit return codes based on async crypto operation or to indicate that we queued

[PATCH RFC 4/5] xfrm: Allow IPsec GSO with software crypto for local sockets.

2017-11-19 Thread Steffen Klassert
With support of async crypto operations in the GSO codepath we have everything in place to allow GSO for local sockets. This patch enables the GSO codepath. Signed-off-by: Steffen Klassert --- include/net/xfrm.h | 2 ++ 1 file changed, 2 insertions(+) diff --git

[PATCH RFC 0/5] Support asynchronous crypto for IPsec GSO.

2017-11-19 Thread Steffen Klassert
This patchset implements asynchronous crypto handling in the layer 2 TX path. With this we can allow IPsec ESP GSO for software crypto. This also merges the IPsec GSO and non-GSO paths to both use validate_xmit_xfrm(). 1) Separate ESP handling from segmentation for GRO packets. This unifies

[PATCH RFC 1/5] xfrm: Separate ESP handling from segmentation for GRO packets.

2017-11-19 Thread Steffen Klassert
We change the ESP GSO handlers to only segment the packets. The ESP handling and encryption is defered to validate_xmit_xfrm() where this is done for non GRO packets too. This makes the code more robust and prepares for asynchronous crypto handling. Signed-off-by: Steffen Klassert

[PATCH RFC 3/5] xfrm: Allow to use the layer2 IPsec GSO codepath for software crypto.

2017-11-19 Thread Steffen Klassert
We now have support for asynchronous crypto operations in the layer 2 TX path. This was the missing part to allow the GSO codepath for software crypto, so allow this codepath now. Signed-off-by: Steffen Klassert --- net/xfrm/xfrm_device.c | 4 ++-- 1 file changed,

Re: Linux ECN Handling

2017-11-19 Thread Steve Ibanez
Hi Folks, I wanted to check back in on this for another update and to solicit some more suggestions. I did a bit more digging to try an isolate the problem. As I explained earlier, the log generated by tcp_probe indicates that the snd_cwnd is set to 1 just before the end host receives an ECN

Re: [PATCH net 04/10] bpf: offload: move offload device validation out to the drivers

2017-11-19 Thread Jiri Pirko
Mon, Nov 20, 2017 at 05:55:16AM CET, jakub.kicin...@netronome.com wrote: >With TC shared block changes we can't depend on correct netdev >pointer being available in cls_bpf. Move the device validation >to the driver. Core will only make sure that offloaded programs >are always attached in the

Re: [PATCH net,stable] net: qmi_wwan: add Quectel BG96 2c7c:0296

2017-11-19 Thread Bjørn Mork
On November 20, 2017 5:19:21 AM GMT+01:00, ssjoh...@mac.com wrote: >From: ssjoholm > >Signed-off-by: ssjoholm > >Quectel BG96 is an Qualcomm MDM9206 based IoT modem, supporting both >CAT-M and NB-IoT. Tested hardware is BG96 mounted on Quectel >development

RE: NETDEV WATCHDOG: eth0 (dwc-eth-dwmac): transmit queue 1 timed out

2017-11-19 Thread Bhadram Varka
Hi Joao/Peppe, Observed this issue more frequently with multi-channel case. Am I missing something in DT ? Please help here to understand the issue. Thanks, Bhadram -Original Message- From: Bhadram Varka Sent: Thursday, November 16, 2017 9:41 AM To: linux-netdev

[PATCH] net/9p: trans_xen: add missing MODULE_AUTHOR/DESCRIPTION/LICENSE

2017-11-19 Thread Jesse Chan
Signed-off-by: Jesse Chan --- net/9p/trans_xen.c | 4 1 file changed, 4 insertions(+) diff --git a/net/9p/trans_xen.c b/net/9p/trans_xen.c index 6ad3e043c617..90402e744fbf 100644 --- a/net/9p/trans_xen.c +++ b/net/9p/trans_xen.c @@ -543,3 +543,7 @@ static void

Re: [PATCH net] net: accept UFO datagrams from tuntap and packet

2017-11-19 Thread David Miller
From: Jason Wang Date: Mon, 20 Nov 2017 11:03:54 +0800 > Looks good to me. The only concern is that whether or not stable can > accept this patch: Stable submission will not be a problem, please do not worry about it :-)

[PATCH net,stable] net: qmi_wwan: add Quectel BG96 2c7c:0296

2017-11-19 Thread ssjoholm
From: ssjoholm Signed-off-by: ssjoholm Quectel BG96 is an Qualcomm MDM9206 based IoT modem, supporting both CAT-M and NB-IoT. Tested hardware is BG96 mounted on Quectel development board (EVB). The USB id is added to qmi_wwan.c to allow QMI communication

[PATCH net 01/10] bpf: offload: add comment warning developers about double destroy

2017-11-19 Thread Jakub Kicinski
Offload state may get destroyed either because the device for which it was constructed is going away, or because the refcount of bpf program itself has reached 0. In both of those cases we will call __bpf_prog_offload_destroy() to unlink the offload from the device. We may in fact call it twice,

[PATCH net 06/10] bpf: turn bpf_prog_get_type() into a wrapper

2017-11-19 Thread Jakub Kicinski
bpf_prog_get_type() is identical to bpf_prog_get_type_dev(), with false passed as attach_drv. Instead of keeping it as an exported symbol turn it into static inline wrapper. Signed-off-by: Jakub Kicinski Reviewed-by: Quentin Monnet

[PATCH net 00/10] bpf: offload: check netdev pointer in the drivers and namespace trouble

2017-11-19 Thread Jakub Kicinski
Hi! This series addresses some late comments and moves checking if program has been loaded for the correct device to the drivers. There are also some problems with net namespaces which I didn't take into consideration. On the kernel side we will now simply ignore namespace moves. Since the user

[PATCH net 03/10] bpf: offload: rename the ifindex field

2017-11-19 Thread Jakub Kicinski
bpf_target_prog seems long and clunky, rename it to prog_ifindex. We don't want to call this field just ifindex, because maps may need a similar field in the future and bpf_attr members for programs and maps are unnamed. Signed-off-by: Jakub Kicinski Reviewed-by:

[PATCH net 04/10] bpf: offload: move offload device validation out to the drivers

2017-11-19 Thread Jakub Kicinski
With TC shared block changes we can't depend on correct netdev pointer being available in cls_bpf. Move the device validation to the driver. Core will only make sure that offloaded programs are always attached in the driver (or in HW by the driver). We trust that drivers which implement offload

[PATCH net 08/10] bpftool: revert printing program device bound info

2017-11-19 Thread Jakub Kicinski
This reverts commit 928631e05495 ("bpftool: print program device bound info"). We will remove this API and redo it right in -next. Signed-off-by: Jakub Kicinski --- tools/bpf/bpftool/prog.c | 31 --- tools/include/uapi/linux/bpf.h

[PATCH net 09/10] bpf: revert report offload info to user space

2017-11-19 Thread Jakub Kicinski
This reverts commit bd601b6ada11 ("bpf: report offload info to user space"). The ifindex by itself is not sufficient, we should provide information on which network namespace this ifindex belongs to. After considering some options we concluded that it's best to just remove this API for now, and

[PATCH net 02/10] bpf: offload: limit offload to cls_bpf and xdp programs only

2017-11-19 Thread Jakub Kicinski
We are currently only allowing attachment of device-bound cls_bpf and XDP programs. Make this restriction explicit in the BPF offload code. This way we can potentially reuse the ifindex field in the future. Since XDP and cls_bpf programs can only be loaded by admin, we can drop the explicit

[PATCH net 05/10] net: xdp: don't allow device-bound programs in driver mode

2017-11-19 Thread Jakub Kicinski
Currently device-bound programs are not able to run on the host to save resources (host JIT is not invoked). Don't allow XDP programs to be attached without the HW_MODE flag. In theory if program is already translated for device offload the driver should choose to offload it instead of loading

[PATCH net 07/10] bpf: offload: ignore namespace moves

2017-11-19 Thread Jakub Kicinski
We are currently destroying the device offload state when device moves to another net namespace. This doesn't break with current NFP code, because offload state is not used on program removal, but it's not correct behaviour. Ignore the device unregister notifications on namespace move.

[PATCH net 10/10] bpf: make bpf_prog_offload_verifier_prep() static inline

2017-11-19 Thread Jakub Kicinski
Header implementation of bpf_prog_offload_verifier_prep() which is used if CONFIG_NET=n should be a static inline. Signed-off-by: Jakub Kicinski --- include/linux/bpf_verifier.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH iproute2] iproute2: fixes to compile on some systems.

2017-11-19 Thread Lorenzo Colitti
1. Put the declarations of strlcpy and strlcat inside an #ifdef NEED_STRLCPY. Their declarations were already in a similar #ifdef. 2. In bpf_scm.h, include sys/un.h for struct sockaddr_un. 3. In utils.h, include time.h for struct timeval. Tested: builds on ubuntu 14.04 with "make clean

[PATCHv2 net-next 1/1] forcedeth: replace pci_unmap_page with dma_unmap_page

2017-11-19 Thread Zhu Yanjun
The function pci_unmap_page is obsolete. So it is replaced with the function dma_unmap_page. CC: Srinivas Eeda CC: Joe Jin CC: Junxiao Bi Signed-off-by: Zhu Yanjun --- V1->V2: fix direction flag error.

Re: [PATCH net] net: accept UFO datagrams from tuntap and packet

2017-11-19 Thread Jason Wang
On 2017年11月18日 06:59, Willem de Bruijn wrote: From: Willem de Bruijn Tuntap and similar devices can inject GSO packets. Accept type VIRTIO_NET_HDR_GSO_UDP, even though not generating UFO natively. Processes are expected to use feature negotiation such as TUNSETOFFLOAD to

Re: [PATCH net-next 1/1] forcedeth: replace pci_unmap_page with dma_unmap_page

2017-11-19 Thread David Miller
From: Zhu Yanjun Date: Sun, 19 Nov 2017 09:05:31 -0500 > @@ -1986,7 +1986,7 @@ static void nv_unmap_txskb(struct fe_priv *np, struct > nv_skb_map *tx_skb) >tx_skb->dma_len, >DMA_TO_DEVICE); >

Re: [PATCH net] net: ena: fix race condition between device reset and link up setup

2017-11-19 Thread David Miller
From: Date: Sun, 19 Nov 2017 18:03:40 + > From: Netanel Belgazal > > In rare cases, ena driver would reset and re-start the device, > for example, in case of misbehaving application that causes > transmit timeout > > The first step in the reset

Re: [PATCH] net: vxge: Fix some indentation issues

2017-11-19 Thread David Miller
From: Christophe JAILLET Date: Sun, 19 Nov 2017 13:41:33 +0100 > Some statements are not enough or too much indented. > Fix it to improve readalbility. > > Signed-off-by: Christophe JAILLET Applied.

Re: [kernel-hardening] [PATCH v4] scripts: add leaking_addresses.pl

2017-11-19 Thread Tobin C. Harding
On Fri, Nov 10, 2017 at 07:26:34PM +0530, kaiwan.billimo...@gmail.com wrote: > On Tue, 2017-11-07 at 21:32 +1100, Tobin C. Harding wrote: [snip] > Finally, unsure if am working against the latest ver of your script Tobin, > apologies if not. The latest version of leaking_addresses.pl is now in

Re: [patch net-next v2 2/4] net: sched: introduce per-egress action device callbacks

2017-11-19 Thread Jiri Pirko
Sun, Nov 19, 2017 at 08:37:49PM CET, manish.cho...@cavium.com wrote: >> -Original Message- >> From: netdev-ow...@vger.kernel.org [mailto:netdev-ow...@vger.kernel.org] >> On Behalf Of Jiri Pirko >> Sent: Wednesday, October 11, 2017 1:11 PM >> To: netdev@vger.kernel.org >> Cc:

RE: [patch net-next v2 2/4] net: sched: introduce per-egress action device callbacks

2017-11-19 Thread Chopra, Manish
> -Original Message- > From: netdev-ow...@vger.kernel.org [mailto:netdev-ow...@vger.kernel.org] > On Behalf Of Jiri Pirko > Sent: Wednesday, October 11, 2017 1:11 PM > To: netdev@vger.kernel.org > Cc: da...@davemloft.net; j...@mojatatu.com; xiyou.wangc...@gmail.com; > sae...@mellanox.com;

[PATCH net] net: ena: fix race condition between device reset and link up setup

2017-11-19 Thread netanel
From: Netanel Belgazal In rare cases, ena driver would reset and re-start the device, for example, in case of misbehaving application that causes transmit timeout The first step in the reset procedure is to stop the Tx traffic by calling ena_carrier_off(). After the driver

Re: [PATCH] net: sched: fix crash when deleting secondary chains

2017-11-19 Thread Jiri Pirko
Sun, Nov 19, 2017 at 12:44:05PM CET, c...@rkapl.cz wrote: >If you flush (delete) a filter chain other than chain 0 (such as when >deleting the device), the kernel may run into a use-after-free. The >chain refcount must not be decremented unless we are sure we are done >with the chain. > >To

Re: [patch net-next RFC v2 08/11] mlxsw: spectrum_dpipe: Connect dpipe tables to resources

2017-11-19 Thread David Ahern
On 11/19/17 2:16 AM, Arkadi Sharshevsky wrote: > > > On 11/18/2017 09:19 PM, David Ahern wrote: >> On 11/14/17 9:18 AM, Jiri Pirko wrote: >>> From: Arkadi Sharshevsky >>> >>> Connect current dpipe tables to resources. The tables are connected >>> in the following fashion:

Re: [patch net-next RFC v2 02/11] devlink: Add support for resource abstraction

2017-11-19 Thread David Ahern
On 11/19/17 1:17 AM, Arkadi Sharshevsky wrote: > > > On 11/18/2017 08:34 PM, David Ahern wrote: >> On 11/14/17 9:18 AM, Jiri Pirko wrote: >>> diff --git a/include/net/devlink.h b/include/net/devlink.h >>> index 4d2c6fc..960e80a 100644 >>> --- a/include/net/devlink.h >>> +++

[PATCH net-next 1/1] forcedeth: replace pci_unmap_page with dma_unmap_page

2017-11-19 Thread Zhu Yanjun
The function pci_unmap_page is obsolete. So it is replaced with the function dma_unmap_page. CC: Srinivas Eeda CC: Joe Jin CC: Junxiao Bi Signed-off-by: Zhu Yanjun ---

[PATCH net-next] netlink: optimize err assignment

2017-11-19 Thread yuan linyu
From: yuan linyu Signed-off-by: yuan linyu --- net/netlink/af_netlink.c | 54 +--- 1 file changed, 23 insertions(+), 31 deletions(-) diff --git a/net/netlink/af_netlink.c

[PATCH ethtool] ethtool: Add extended compliance codes parsing to sfp modules

2017-11-19 Thread Gal Pressman
Update parsing according to SFP28 spec with extended compliance codes. SFF-8472, SFF-8024 specify the description of module capability present in the 36th byte. Signed-off-by: Gal Pressman Reviewed-by: Eran Ben Elisha --- sfpid.c | 25

general protection fault in dst_destroy() - 4.13.9

2017-11-19 Thread Anders K. Pedersen | Cohaesio
Hello, A few days ago, one of our routers (running Linux 4.13.9) crashed due to a general protection fault in dst_destroy(). At the time, it had run for several weeks without any problems, but then crashed three times in a row within a few minutes - all due to a general protection fault at

[PATCH] net: vxge: Fix some indentation issues

2017-11-19 Thread Christophe JAILLET
Some statements are not enough or too much indented. Fix it to improve readalbility. Signed-off-by: Christophe JAILLET --- drivers/net/ethernet/neterion/vxge/vxge-main.c | 37 +- 1 file changed, 18 insertions(+), 19 deletions(-) diff --git

Re: [PATCH v2 1/2] r8169: fix RTL8111EVL EEE and green settings

2017-11-19 Thread David Miller
From: Heiner Kallweit Date: Sun, 19 Nov 2017 11:09:58 +0100 > Name of functions rtl_w0w1_eri and rtl_w0w1_phy is somewhat misleading > regarding order of arguments. One could assume that w0w1 means > argument with bits to be reset comes before argument with bits to set. >

Re: [PATCH v2 2/2] r8169: use same RTL8111EVL green settings as in vendor driver

2017-11-19 Thread David Miller
From: Heiner Kallweit Date: Sun, 19 Nov 2017 11:15:46 +0100 > Adjust the code to use the same green settings as in the latest > vendor driver. > > Signed-off-by: Heiner Kallweit Applied.

Re: [PATCH net] tun: fix rcu_read_lock imbalance in tun_build_skb

2017-11-19 Thread David Miller
From: Xin Long Date: Sun, 19 Nov 2017 19:31:04 +0800 > rcu_read_lock in tun_build_skb is used to rcu_dereference tun->xdp_prog > safely, rcu_read_unlock should be done in every return path. > > Now I could see one place missing it, where it returns NULL in switch-case >

[PATCH net] tun: fix rcu_read_lock imbalance in tun_build_skb

2017-11-19 Thread Xin Long
rcu_read_lock in tun_build_skb is used to rcu_dereference tun->xdp_prog safely, rcu_read_unlock should be done in every return path. Now I could see one place missing it, where it returns NULL in switch-case XDP_REDIRECT, another palce using rcu_read_lock wrongly, where it returns NULL in if

[PATCH v2 2/2] r8169: use same RTL8111EVL green settings as in vendor driver

2017-11-19 Thread Heiner Kallweit
Adjust the code to use the same green settings as in the latest vendor driver. Signed-off-by: Heiner Kallweit --- v2: - replace magic numbers with constants --- drivers/net/ethernet/realtek/r8169.c | 5 + 1 file changed, 5 insertions(+) diff --git

[PATCH v2 1/2] r8169: fix RTL8111EVL EEE and green settings

2017-11-19 Thread Heiner Kallweit
Name of functions rtl_w0w1_eri and rtl_w0w1_phy is somewhat misleading regarding order of arguments. One could assume that w0w1 means argument with bits to be reset comes before argument with bits to set. However this is not the case. So fix the order of arguments in several statements. In

Re: [patch net-next RFC v2 09/11] mlxsw: spectrum: Add support for getting kvdl occupancy

2017-11-19 Thread Arkadi Sharshevsky
On 11/18/2017 09:21 PM, David Ahern wrote: > On 11/14/17 9:18 AM, Jiri Pirko wrote: >> From: Arkadi Sharshevsky >> >> Add support for getting the kvdl occupancy through the resource interface. >> > > Do you intend to add occ_get for the other kvd partitions? > Yes of

Re: [patch net-next RFC v2 08/11] mlxsw: spectrum_dpipe: Connect dpipe tables to resources

2017-11-19 Thread Arkadi Sharshevsky
On 11/18/2017 09:19 PM, David Ahern wrote: > On 11/14/17 9:18 AM, Jiri Pirko wrote: >> From: Arkadi Sharshevsky >> >> Connect current dpipe tables to resources. The tables are connected >> in the following fashion: >> 1. IPv4 host - KVD hash single >> 2. IPv6 host - KVD

Re: [patch net-next RFC v2 07/11] mlxsw: spectrum: Register KVD resources with devlink

2017-11-19 Thread Arkadi Sharshevsky
On 11/18/2017 09:18 PM, David Ahern wrote: > On 11/14/17 9:18 AM, Jiri Pirko wrote: >> diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum.c >> b/drivers/net/ethernet/mellanox/mlxsw/spectrum.c >> index d02c130..f0cbd67 100644 >> --- a/drivers/net/ethernet/mellanox/mlxsw/spectrum.c >> +++

Re: [patch net-next RFC v2 02/11] devlink: Add support for resource abstraction

2017-11-19 Thread Arkadi Sharshevsky
On 11/18/2017 08:34 PM, David Ahern wrote: > On 11/14/17 9:18 AM, Jiri Pirko wrote: >> diff --git a/include/net/devlink.h b/include/net/devlink.h >> index 4d2c6fc..960e80a 100644 >> --- a/include/net/devlink.h >> +++ b/include/net/devlink.h > ... > >> @@ -469,6 +523,32 @@