Re: [PATCH 4/9] net: mvmdio: move the read valid check into its own function

2017-06-07 Thread Antoine Tenart
Hello, On Wed, Jun 07, 2017 at 01:00:21PM +0300, Sergei Shtylyov wrote: > On 6/7/2017 11:38 AM, Antoine Tenart wrote: > > > > - val = readl(dev->regs); > > - if (!(val & MVMDIO_SMI_READ_VALID)) { > > + if (orion_mdio_smi_is_read_valid(dev)) { > > dev_err(bus->parent, "SMI bus

Re: [PATCH 4/9] net: mvmdio: move the read valid check into its own function

2017-06-07 Thread Sergei Shtylyov
Hello! On 6/7/2017 11:38 AM, Antoine Tenart wrote: Move the read valid check in its own function. This is needed as a requirement to factorize the driver to add the xMDIO support in the future. Signed-off-by: Antoine Tenart ---

[PATCH 4/9] net: mvmdio: move the read valid check into its own function

2017-06-07 Thread Antoine Tenart
Move the read valid check in its own function. This is needed as a requirement to factorize the driver to add the xMDIO support in the future. Signed-off-by: Antoine Tenart --- drivers/net/ethernet/marvell/mvmdio.c | 11 +++ 1 file changed, 7