Re: [Intel-wired-lan] [iwl next-queue PATCH 02/10] macvlan: Rename fwd_priv to accel_priv and add accessor function

2018-04-04 Thread Alexander Duyck
On Wed, Apr 4, 2018 at 9:53 AM, Shannon Nelson
 wrote:
> On 4/3/2018 2:16 PM, Alexander Duyck wrote:
>
> [...]
>>
>>   +static inline void *macvlan_accel_priv(struct net_device *dev)
>> +{
>> +   struct macvlan_dev *macvlan = netdev_priv(dev);
>> +
>> +   return macvlan->accel_priv;
>
>
> Perhaps a check for (macvlan == NULL) before using it?
> sln
>
>

The macvlan pointer cannot be NULL.The netdev_priv() function adds an
offset to the dev pointer. So I would have to be checking for a NULL
netdev. If the netdev was NULL then there was probably no point in
calling this function in the first place.

- Alex


Re: [Intel-wired-lan] [iwl next-queue PATCH 02/10] macvlan: Rename fwd_priv to accel_priv and add accessor function

2018-04-04 Thread Shannon Nelson

On 4/3/2018 2:16 PM, Alexander Duyck wrote:

[...]
  
+static inline void *macvlan_accel_priv(struct net_device *dev)

+{
+   struct macvlan_dev *macvlan = netdev_priv(dev);
+
+   return macvlan->accel_priv;


Perhaps a check for (macvlan == NULL) before using it?
sln


+}
  #endif /* _LINUX_IF_MACVLAN_H */

___
Intel-wired-lan mailing list
intel-wired-...@osuosl.org
https://lists.osuosl.org/mailman/listinfo/intel-wired-lan