Re: [PATCH net-next] rps: flow_dissector: Add the const for the parameter of flow_keys_have_l4

2016-09-01 Thread David Miller
From: f...@ikuai8.com
Date: Wed, 31 Aug 2016 11:16:22 +0800

> From: Gao Feng 
> 
> Add the const for the parameter of flow_keys_have_l4 for the readability.
> 
> Signed-off-by: Gao Feng 

Applied.


[PATCH net-next] rps: flow_dissector: Add the const for the parameter of flow_keys_have_l4

2016-08-30 Thread fgao
From: Gao Feng 

Add the const for the parameter of flow_keys_have_l4 for the readability.

Signed-off-by: Gao Feng 
---
 include/net/flow_dissector.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/net/flow_dissector.h b/include/net/flow_dissector.h
index f266b51..d953492 100644
--- a/include/net/flow_dissector.h
+++ b/include/net/flow_dissector.h
@@ -183,7 +183,7 @@ struct flow_keys_digest {
 void make_flow_keys_digest(struct flow_keys_digest *digest,
   const struct flow_keys *flow);
 
-static inline bool flow_keys_have_l4(struct flow_keys *keys)
+static inline bool flow_keys_have_l4(const struct flow_keys *keys)
 {
return (keys->ports.ports || keys->tags.flow_label);
 }
-- 
1.9.1