Re: [PATCH net 2/5] sctp: reuse sent_count to avoid retransmitted chunks for RTT measurements

2016-09-27 Thread Xin Long
> > Maybe wrap this in a macro? i.e.: > #define chunk_retransmitted(chunk) (chunk->sent_count > 1) > > For readability? > That's a nice suggestion. chunk->sent_count == 1 is confusing there for reading. will improve it in v2. Thanks.

Re: [PATCH net 2/5] sctp: reuse sent_count to avoid retransmitted chunks for RTT measurements

2016-09-26 Thread Neil Horman
On Mon, Sep 26, 2016 at 05:47:51PM +0800, Xin Long wrote: > Now sctp uses chunk->resent to record if a chunk is retransmitted, for > RTT measurements with retransmitted DATA chunks. chunk->sent_count was > introduced to record how many times one chunk has been sent for prsctp > RTX policy before.

[PATCH net 2/5] sctp: reuse sent_count to avoid retransmitted chunks for RTT measurements

2016-09-26 Thread Xin Long
Now sctp uses chunk->resent to record if a chunk is retransmitted, for RTT measurements with retransmitted DATA chunks. chunk->sent_count was introduced to record how many times one chunk has been sent for prsctp RTX policy before. We actually can know if one chunk is retransmitted by checking