[patch net-next RFC v1] mlxsw: core: Add the hottest thermal zone detection

2019-05-29 Thread Vadim Pasternak
e next trip point. Thus, the highest score will always be assigned objectively to the hottest thermal zone. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 64 +++--- 1 file changed, 57 insertions(+), 7 deletions(-) d

RE: [patch net-next RFC 00/10] introduce line card support for modular switch

2021-01-29 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn > Sent: Friday, January 29, 2021 5:50 PM > To: Jiri Pirko > Cc: David Ahern ; Jakub Kicinski ; > netdev@vger.kernel.org; da...@davemloft.net; jacob.e.kel...@intel.com; > Roopa Prabhu ; mlxsw ; Vadim > Pasternak > S

RE: [PATCH net-next 3/3] mlxsw: core: Add support for negative temperature readout

2019-06-23 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn > Sent: Sunday, June 23, 2019 6:44 PM > To: Ido Schimmel > Cc: netdev@vger.kernel.org; da...@davemloft.net; Jiri Pirko > ; mlxsw ; Vadim Pasternak > ; Ido Schimmel > Subject: Re: [PATCH net-next 3/3] mlxsw: core:

RE: [PATCH net-next 3/3] mlxsw: core: Add support for negative temperature readout

2019-06-23 Thread Vadim Pasternak
> -Original Message- > From: Vadim Pasternak > Sent: Sunday, June 23, 2019 7:01 PM > To: Andrew Lunn ; Ido Schimmel > Cc: netdev@vger.kernel.org; da...@davemloft.net; Jiri Pirko > ; mlxsw ; Ido Schimmel > > Subject: RE: [PATCH net-next 3/3] mlxsw: core:

RE: [PATCH net-next 3/3] mlxsw: core: Add support for negative temperature readout

2019-06-23 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn > Sent: Sunday, June 23, 2019 7:26 PM > To: Vadim Pasternak > Cc: Ido Schimmel ; netdev@vger.kernel.org; > da...@davemloft.net; Jiri Pirko ; mlxsw > ; Ido Schimmel > Subject: Re: [PATCH net-next 3/3] mlxsw: core:

[PATCH v0 01/12] mlxsw: spectrum: Move QSFP EEPROM defenitons to common location

2018-06-21 Thread Vadim Pasternak
Move QSFP EEPROM definitions to common location from the spectrum driver in order to make them available for other mlxsw modules. They are common for all kind of chips and have relation to SFF specifications 8024, 8436, 8472, 8636, rather then to chip type. Signed-off-by: Vadim Pasternak Acked

[PATCH v0 10/12] mlxsw: core: Extend cooling device with cooling levels

2018-06-21 Thread Vadim Pasternak
such device will be stall on zero speed. Cooling levels allow to configure state vector according to the particular system requirements. For example, if PWM speed is not allowed to be below 30%, cooling levels could be configured as 30%, 30%, 30%, 30%, 40%, 50% and so on. Signed-off-by: Vadim Past

[PATCH v0 12/12] mlxsw: core: Add ports temperature measurement to thermal algorithm

2018-06-21 Thread Vadim Pasternak
accumulated value of a chip and ports temperature sensing, normalized according to the basic constant thresholds. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 66 -- 1 file changed, 62 insertions(+), 4 deletions

[PATCH v0 09/12] mlxsw: core: Extend thermal zone operations with get_trend method

2018-06-21 Thread Vadim Pasternak
only once and could stay in not optimal high state. Notification will allow user to take an appropriate action if necessary. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 27 ++ 1 file changed, 27 insertions(+) diff

[PATCH v0 11/12] mlxsw: core: Rename cooling device

2018-06-21 Thread Vadim Pasternak
Name "Fan" is too common name, and such name is misleading, while it's interpreted by user. For example name "Fan" could be used by ACPI. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 3 ++- 1 file ch

[PATCH v0 02/12] mlxsw: reg: Add MTBR register

2018-06-21 Thread Vadim Pasternak
Add MTBR (Management Temperature Bulk Register), which is used for port temperature reading in a bulk mode. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/reg.h | 69 +++ 1 file changed, 69 insertions(+) diff --git a

[PATCH v0 04/12] mlxsw: core: Extend hwmon interface with FAN fault attribute

2018-06-21 Thread Vadim Pasternak
Add new FAN hwmon attribute for exposing FAN faults (fault is set in case FAN tachometer is below allowed minimum). Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_hwmon.c | 62 +++- 1 file changed, 60 insertions(+), 2

[PATCH v0 06/12] mlxsw: core: Add bus frequency capability flag for the bus type

2018-06-21 Thread Vadim Pasternak
, should be increased. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core.h | 1 + drivers/net/ethernet/mellanox/mlxsw/i2c.c | 1 + 2 files changed, 2 insertions(+) diff --git a/drivers/net/ethernet/mellanox/mlxsw/core.h b/drivers/net/ethernet/mellanox

[PATCH v0 07/12] mlxsw: core: Set different thermal polling time based on bus type

2018-06-21 Thread Vadim Pasternak
Use different thermal monitoring based on bus type. For I2C bus time is set to 20 seconds, while for PCIe 1 second polling interval is used. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 11 +-- 1 file changed, 9 insertions

[PATCH v0 05/12] mlxsw: core: Extend hwmon interface with port temperature attributes

2018-06-21 Thread Vadim Pasternak
Add new attributes to hwmon object for exposing accumulative ports temperature input and accumulative port temperature fault (if one of sensors in untrusted - fault is set. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_hwmon.c | 102

[PATCH v0 00/12] mlxsw thermal monitoring amendments

2018-06-21 Thread Vadim Pasternak
faults, port temperature fault will improve system monitoring abilities. Vadim Pasternak (12): mlxsw: spectrum: Move QSFP EEPROM defenitons to common location mlxsw: reg: Add MTBR register mlxsw: core: Add core environment module for port temperature reading mlxsw: core: Extend hwmon

[PATCH v0 08/12] mlxsw: core: Modify thermal zone definition

2018-06-21 Thread Vadim Pasternak
thermal trip point boundary. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 63 ++ 1 file changed, 41 insertions(+), 22 deletions(-) diff --git a/drivers/net/ethernet/mellanox/mlxsw/core_thermal.c b/drivers/net

[PATCH v0 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-21 Thread Vadim Pasternak
r and exposes temperature according to the worst measure. All individual temperature values are normalized to pre-defined range. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/Makefile | 2 +- drivers/net/ethernet/mellanox/mlxsw/core_env.c

RE: [PATCH v0 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-21 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Thursday, June 21, 2018 8:11 PM > To: Vadim Pasternak > Cc: da...@davemloft.net; netdev@vger.kernel.org; j...@resnulli.us > Subject: Re: [PATCH v0 03/12] mlxsw: core: Add core environment

RE: [PATCH v0 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-21 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Thursday, June 21, 2018 9:35 PM > To: Vadim Pasternak ; Guenter Roeck us.net> > Cc: da...@davemloft.net; netdev@vger.kernel.org; j...@resnulli.us > Subject: Re: [PATCH v0 03/12] mlxsw: core:

RE: [PATCH v0 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-21 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Thursday, June 21, 2018 10:49 PM > To: Vadim Pasternak > Cc: Guenter Roeck ; da...@davemloft.net; > netdev@vger.kernel.org; j...@resnulli.us > Subject: Re: [PATCH v0 03/12] mlxsw: core: Add co

RE: [PATCH v0 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-22 Thread Vadim Pasternak
> -Original Message- > From: Guenter Roeck [mailto:li...@roeck-us.net] > Sent: Friday, June 22, 2018 1:07 AM > To: Andrew Lunn > Cc: Vadim Pasternak ; da...@davemloft.net; > netdev@vger.kernel.org; j...@resnulli.us > Subject: Re: [PATCH v0 03/12] mlxsw: core:

[patch net-next RFC 08/12] mlxsw: core: Extend cooling device with cooling levels

2018-06-26 Thread Vadim Pasternak
such device will be stall on zero speed. Cooling levels allow to configure state vector according to the particular system requirements. For example, if PWM speed is not allowed to be below 30%, cooling levels could be configured as 30%, 30%, 30%, 30%, 40%, 50% and so on. Signed-off-by: Vadim Past

[patch net-next RFC 04/12] mlxsw: core: Add bus frequency capability flag for the bus type

2018-06-26 Thread Vadim Pasternak
, should be increased. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core.h | 1 + drivers/net/ethernet/mellanox/mlxsw/i2c.c | 1 + 2 files changed, 2 insertions(+) diff --git a/drivers/net/ethernet/mellanox/mlxsw/core.h b/drivers/net/ethernet/mellanox

[patch net-next RFC 07/12] mlxsw: core: Extend thermal zone operations with get_trend method

2018-06-26 Thread Vadim Pasternak
only once and could stay in not optimal high state. Notification will allow user to take an appropriate action if necessary. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 27 ++ 1 file changed, 27 insertions(+) diff

[patch net-next RFC 05/12] mlxsw: core: Set different thermal polling time based on bus type

2018-06-26 Thread Vadim Pasternak
Use different thermal monitoring based on bus type. For I2C bus time is set to 20 seconds, while for PCIe 1 second polling interval is used. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 11 +-- 1 file changed, 9 insertions

[patch net-next RFC 09/12] mlxsw: core: Rename cooling device

2018-06-26 Thread Vadim Pasternak
Name "Fan" is too common name, and such name is misleading, while it's interpreted by user. For example name "Fan" could be used by ACPI. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 3 ++- 1 file ch

[patch net-next RFC 06/12] mlxsw: core: Modify thermal zone definition

2018-06-26 Thread Vadim Pasternak
thermal trip point boundary. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 63 ++ 1 file changed, 41 insertions(+), 22 deletions(-) diff --git a/drivers/net/ethernet/mellanox/mlxsw/core_thermal.c b/drivers/net

[patch net-next RFC 11/12] mlxsw: core: Extend hwmon interface with FAN fault attribute

2018-06-26 Thread Vadim Pasternak
Add new FAN hwmon attribute for exposing FAN faults (fault is set in case FAN tachometer is below allowed minimum). Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_hwmon.c | 62 +++- 1 file changed, 60 insertions(+), 2

[patch net-next RFC 00/12] mlxsw thermal monitoring amendments

2018-06-26 Thread Vadim Pasternak
faults, port temperature fault will improve system monitoring abilities. Vadim Pasternak (12): mlxsw: spectrum: Move QSFP EEPROM defenitons to common location mlxsw: reg: Add MTBR register mlxsw: core: Add core environment module for port temperature reading mlxsw: core: Add bus frequency

[patch net-next RFC 02/12] mlxsw: reg: Add MTBR register

2018-06-26 Thread Vadim Pasternak
Add MTBR (Management Temperature Bulk Register), which is used for port temperature reading in a bulk mode. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/reg.h | 69 +++ 1 file changed, 69 insertions(+) diff --git a

[patch net-next RFC 10/12] mlxsw: core: Add ports temperature measurement to thermal algorithm

2018-06-26 Thread Vadim Pasternak
accumulated value of a chip and ports temperature sensing, normalized according to the basic constant thresholds. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 66 -- 1 file changed, 62 insertions(+), 4 deletions

[patch net-next RFC 12/12] mlxsw: core: Extend hwmon interface with port temperature attributes

2018-06-26 Thread Vadim Pasternak
case at least one port fault is detected, user can consider it in the thermal algorithm. For example, in such case, FAN speed could be increased. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_hwmon.c | 102 +++ 1 file changed

[patch net-next RFC 01/12] mlxsw: spectrum: Move QSFP EEPROM defenitons to common location

2018-06-26 Thread Vadim Pasternak
Move QSFP EEPROM definitions to common location from the spectrum driver in order to make them available for other mlxsw modules. They are common for all kind of chips and have relation to SFF specifications 8024, 8436, 8472, 8636, rather then to chip type. Signed-off-by: Vadim Pasternak Acked

[patch net-next RFC 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-26 Thread Vadim Pasternak
r and exposes temperature according to the worst measure. All individual temperature values are normalized to pre-defined range. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/Makefile | 2 +- drivers/net/ethernet/mellanox/mlxsw/core_env.c

[patch net-next RFC 05/12] mlxsw: core: Set different thermal polling time based on bus type

2018-06-26 Thread Vadim Pasternak
Use different thermal monitoring based on bus type. For I2C bus time is set to 20 seconds, while for PCIe 1 second polling interval is used. Signed-off-by: Vadim Pasternak Acked-by: Jiri Pirko --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 11 +-- 1 file changed, 9 insertions

RE: [patch net-next RFC 11/12] mlxsw: core: Extend hwmon interface with FAN fault attribute

2018-06-26 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Tuesday, June 26, 2018 5:29 PM > To: Vadim Pasternak > Cc: da...@davemloft.net; netdev@vger.kernel.org; li...@roeck-us.net; > rui.zh...@intel.com; edubez...@gmail.com; j...@resnulli.us; mlxsw

RE: [patch net-next RFC 11/12] mlxsw: core: Extend hwmon interface with FAN fault attribute

2018-06-26 Thread Vadim Pasternak
> -Original Message- > From: Guenter Roeck [mailto:li...@roeck-us.net] > Sent: Tuesday, June 26, 2018 7:33 PM > To: Vadim Pasternak > Cc: Andrew Lunn ; da...@davemloft.net; > netdev@vger.kernel.org; rui.zh...@intel.com; edubez...@gmail.com; > j...@resnulli.us;

RE: [patch net-next RFC 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-26 Thread Vadim Pasternak
> -Original Message- > From: Guenter Roeck [mailto:li...@roeck-us.net] > Sent: Tuesday, June 26, 2018 8:00 PM > To: Andrew Lunn > Cc: Vadim Pasternak ; linux...@vger.kernel.org; > netdev@vger.kernel.org; rui.zh...@intel.com; edubez...@gmail.com; > j...@resnulli.us

RE: [patch net-next RFC 03/12] mlxsw: core: Add core environment module for port temperature reading

2018-06-26 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Tuesday, June 26, 2018 9:18 PM > To: Vadim Pasternak > Cc: Guenter Roeck ; linux...@vger.kernel.org; > netdev@vger.kernel.org; rui.zh...@intel.com; edubez...@gmail.com; > j...@resnulli.us >

RE: [PATCH net-next 09/12] mlxsw: core: Extend hwmon interface with fan fault attribute

2019-02-13 Thread Vadim Pasternak
> -Original Message- > From: Guenter Roeck On Behalf Of Guenter Roeck > Sent: Wednesday, February 13, 2019 5:03 PM > To: Andrew Lunn ; Ido Schimmel > Cc: netdev@vger.kernel.org; da...@davemloft.net; Jiri Pirko > ; mlxsw ; Vadim Pasternak > > Subject: Re: [PAT

RE: [PATCH net-next 1/2] mlxsw: core: Add ethtool support for QSFP-DD transceivers

2020-06-30 Thread Vadim Pasternak
> -Original Message- > From: Ido Schimmel > Sent: Tuesday, June 30, 2020 9:00 AM > To: Andrew Lunn ; Vadim Pasternak > > Cc: Adrian Pop ; netdev@vger.kernel.org; > da...@davemloft.net; k...@kernel.org; Jiri Pirko ; > mlxsw ; Ido Schimmel > Subject: Re:

[patch v1 1/2] dt-bindings: net: add binding documentation for mlxsw thermal control

2017-08-29 Thread Vadim Pasternak
Add binding document for Mellanox switch devices. Signed-off-by: Vadim Pasternak --- .../devicetree/bindings/net/mellanox,mlxsw.txt | 46 ++ 1 file changed, 46 insertions(+) create mode 100644 Documentation/devicetree/bindings/net/mellanox,mlxsw.txt diff --git a

[patch v1 0/2] add support for the external thermal zone and cooling device binding for Mellanox network devices

2017-08-29 Thread Vadim Pasternak
It allows binding of AISC thermal sensor to externally defined thermal zones and cooling device. Such definition can be provided from DTS. Vadim Pasternak (2): dt-bindings: net: add binding documentation for mlxsw thermal control mlxsw: core: add support for the external thermal zone setting

[patch v1 2/2] mlxsw: core: add support for the external thermal zone setting (by DTS)

2017-08-29 Thread Vadim Pasternak
It allows: - thermal zone setting for mlxsw based HW and from DTS file; - binding ASIC temperature sensor to cooling devices. It requires setting of CONFIG_OF. Signed-off-by: Vadim Pasternak --- drivers/net/ethernet/mellanox/mlxsw/core_thermal.c | 107 - drivers/net

RE: [patch v1 1/2] dt-bindings: net: add binding documentation for mlxsw thermal control

2017-08-29 Thread Vadim Pasternak
> -Original Message- > From: Andrew Lunn [mailto:and...@lunn.ch] > Sent: Tuesday, August 29, 2017 8:23 PM > To: Vadim Pasternak > Cc: robh...@kernel.org; da...@davemloft.net; j...@resnulli.us; > ivec...@redhat.com; devicet...@vger.kernel.org; netdev@vger.kernel.org >