Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-09 Thread Nikolay Amiantov
Given that it's basically a PCI card which is hotplugged I'd bet on first three configuration options (they sound OK to be enabled unconditionally anyway). I see that kernel has parallel building enabled (unless I mistakenly look somewhere else); do you have `build-cores` set in Nix? On NixOS

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-09 Thread Peter Hoeg
Hi, Why do I get suggestions to try to plug in USB Hardware then, and try it under Ubuntu? Because lspci -v -s will tell you what driver is in use. Here's an example on my side for an unrelated device: 01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-09 Thread Christoph-Simon Senjak
Hi. I said in my first E-Mail that I tried the thing under Ubuntu, and that it is already the Expresscard Slot that NixOS does not recognize. Why do I get suggestions to try to plug in USB Hardware then, and try it under Ubuntu? Anyway, I tried it under Ubuntu und Arch, it worked, I diffed

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-07 Thread David Izquierdo
And while you're at it, you should probably check `lspci -k` on the working system to see what kernel module it uses, in case it's missing from NixOS. On 07/02/17 12:26, Tomasz Czyż wrote: What about doing quick check and running ubuntu from livecd/usb to confirm if card still is alive?

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-07 Thread Tomasz Czyż
What about doing quick check and running ubuntu from livecd/usb to confirm if card still is alive? 2017-02-07 2:23 GMT+00:00 Roger Qiu : > It might be a missing driver. Ultimately is the kernel, its drivers and > modules that deal with hardware and IO. You might need to

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-06 Thread Roger Qiu
It might be a missing driver. Ultimately is the kernel, its drivers and modules that deal with hardware and IO. You might need to google around and ask specifically for the given pci expess hardware serial code and model. On 07/02/2017 9:39 AM, "Christoph-Simon Senjak" <

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-06 Thread Christoph-Simon Senjak
Hello. On 06.02.2017 06:36, Roger Qiu wrote: When you plug something in, the kernel log should show something. If it doesn't then the kernel doesn't know about it, nothing in the userspace can help. How can that be? Make sure you're running those commands before you plug the usb in. >

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-05 Thread Roger Qiu
When you plug something in, the kernel log should show something. If it doesn't then the kernel doesn't know about it, nothing in the userspace can help. Make sure you're running those commands before you plug the usb in. Also I used to have faulty usb cables, but even then the kernel showed

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-05 Thread Christoph-Simon Senjak
Hi. On 06.02.2017 04:46, Peter Hoeg wrote: Hi, My USB 3.0 Expresscard does not work under NixOS, it used to work under other distros. I already tried to add Can you be a little more specific about "does not work"? Nothing happens. Like, really nothing. No new hub is shown in lsusb (as it

Re: [Nix-dev] PCI Expresscard not working under NixOS

2017-02-05 Thread Peter Hoeg
Hi, My USB 3.0 Expresscard does not work under NixOS, it used to work under other distros. I already tried to add Can you be a little more specific about "does not work"? When you plug it in, what messages are you seeing while running these 2 commands in separate terminals: journalctl -k -f