[jira] [Assigned] (OFBIZ-10438) Add method attribute to request-map to controll a uri can be called GET or POST only

2018-06-21 Thread Shi Jinghai (JIRA)


 [ 
https://issues.apache.org/jira/browse/OFBIZ-10438?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Shi Jinghai reassigned OFBIZ-10438:
---

Assignee: Shi Jinghai

> Add method attribute to request-map to controll a uri can be called GET or 
> POST only
> 
>
> Key: OFBIZ-10438
> URL: https://issues.apache.org/jira/browse/OFBIZ-10438
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Shi Jinghai
>Assignee: Shi Jinghai
>Priority: Minor
> Attachments: 
> OFBIZ-10438_0001-Improved-Add-ControlServlet-service-method.patch, 
> OFBIZ-10438_0002-Improved-Add-optional-method-attribute-in-request-ma.patch, 
> OFBIZ-10438_0003-Improved-Factorize-default-request-search-in-Request.patch, 
> OFBIZ-10438_0004-Improved-Add-RequestHandler-resolveURI-method.patch
>
>
> As discussed in OFBIZ-4274, OFBiz runs doGet method in ControlServlet no 
> matter what request it is.
> I like Mathieu's comment on adding a method attribute to the request-map 
> element, it's almost the same as we implemented in our openapi:
>  
> {code:java}
> 
>    
>    
>    
>    
> 
> {code}
>  The difference is that we DON'T support method list expression:
> {code:java}
> ...
> {code}
>   
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Commented] (OFBIZ-10430) Use `in` and spread operator in `gradlewSubprocess`

2018-06-21 Thread Mathieu Lirzin (JIRA)


[ 
https://issues.apache.org/jira/browse/OFBIZ-10430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519292#comment-16519292
 ] 

Mathieu Lirzin commented on OFBIZ-10430:


Thanks Jacques

> Use `in` and spread operator in `gradlewSubprocess`
> ---
>
> Key: OFBIZ-10430
> URL: https://issues.apache.org/jira/browse/OFBIZ-10430
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Upcoming Branch
>
> Attachments: 
> OFBIZ-10430_Use-in-and-spread-operator-in-gradlewSubprocess.patch
>
>
> No functional change.  The idea of using the spread operator is to have less 
> mutation involved.  In Groovy, using operator overloads like {{in}} is more 
> idiomatic  than using explicitly the associated method.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Closed] (OFBIZ-10430) Use `in` and spread operator in `gradlewSubprocess`

2018-06-21 Thread Jacques Le Roux (JIRA)


 [ 
https://issues.apache.org/jira/browse/OFBIZ-10430?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jacques Le Roux closed OFBIZ-10430.
---
   Resolution: Implemented
Fix Version/s: (was: Trunk)
   Upcoming Branch

Thanks Mathieu,

Your last "patch" worked and is in trunk at revision: 1833997  

> Use `in` and spread operator in `gradlewSubprocess`
> ---
>
> Key: OFBIZ-10430
> URL: https://issues.apache.org/jira/browse/OFBIZ-10430
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Upcoming Branch
>
> Attachments: 
> OFBIZ-10430_Use-in-and-spread-operator-in-gradlewSubprocess.patch
>
>
> No functional change.  The idea of using the spread operator is to have less 
> mutation involved.  In Groovy, using operator overloads like {{in}} is more 
> idiomatic  than using explicitly the associated method.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Commented] (OFBIZ-10430) Use `in` and spread operator in `gradlewSubprocess`

2018-06-21 Thread Mathieu Lirzin (JIRA)


[ 
https://issues.apache.org/jira/browse/OFBIZ-10430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519208#comment-16519208
 ] 

Mathieu Lirzin commented on OFBIZ-10430:


Hum I was trusting compilation to detect such issue but indeed at runtime the 
patch fails.
 Here is a version that should work:
{code}
def gradlewSubprocess(commandList) {
def gradlew = os.contains('windows') ? 'gradlew.bat' : './gradlew'
exec { commandLine(gradlew, "--no-daemon", *commandList) }
}
{code}

> Use `in` and spread operator in `gradlewSubprocess`
> ---
>
> Key: OFBIZ-10430
> URL: https://issues.apache.org/jira/browse/OFBIZ-10430
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Trunk
>
> Attachments: 
> OFBIZ-10430_Use-in-and-spread-operator-in-gradlewSubprocess.patch
>
>
> No functional change.  The idea of using the spread operator is to have less 
> mutation involved.  In Groovy, using operator overloads like {{in}} is more 
> idiomatic  than using explicitly the associated method.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Commented] (OFBIZ-10431) Use list literals when possible

2018-06-21 Thread Mathieu Lirzin (JIRA)


[ 
https://issues.apache.org/jira/browse/OFBIZ-10431?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519097#comment-16519097
 ] 

Mathieu Lirzin commented on OFBIZ-10431:


Thanks Jacques

> Use list literals when possible
> ---
>
> Key: OFBIZ-10431
> URL: https://issues.apache.org/jira/browse/OFBIZ-10431
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-10431_use-list-literals-when-possible.patch
>
>
> No functional change.  List literals feels simply more readable.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Commented] (OFBIZ-10437) <#if containerId?has_content> id="${containerId}" is missed in renderFormOpen

2018-06-21 Thread Jacques Le Roux (JIRA)


[ 
https://issues.apache.org/jira/browse/OFBIZ-10437?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519044#comment-16519044
 ] 

Jacques Le Roux commented on OFBIZ-10437:
-

Hi Wei,

Yes I'll ASAP, possibly tomorrow morning :)

> <#if containerId?has_content> id="${containerId}" is missed in 
> renderFormOpen
> ---
>
> Key: OFBIZ-10437
> URL: https://issues.apache.org/jira/browse/OFBIZ-10437
> Project: OFBiz
>  Issue Type: Bug
>  Components: framework
>Affects Versions: Trunk
>Reporter: Wei Zhang
>Assignee: Jacques Le Roux
>Priority: Minor
>
> <#if containerId?has_content> id="${containerId}" is missed for 
> renderFormOpen in revision 1832307. And there is no id for html form in 
> rendered html.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Closed] (OFBIZ-10431) Use list literals when possible

2018-06-21 Thread Jacques Le Roux (JIRA)


 [ 
https://issues.apache.org/jira/browse/OFBIZ-10431?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jacques Le Roux closed OFBIZ-10431.
---
   Resolution: Implemented
Fix Version/s: (was: Trunk)
   Upcoming Branch

Thanks Mathieu,

Your slightly modified patch is in at revision: 1833981  

I simply kept my long comment :P

> Use list literals when possible
> ---
>
> Key: OFBIZ-10431
> URL: https://issues.apache.org/jira/browse/OFBIZ-10431
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-10431_use-list-literals-when-possible.patch
>
>
> No functional change.  List literals feels simply more readable.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Commented] (OFBIZ-10430) Use `in` and spread operator in `gradlewSubprocess`

2018-06-21 Thread Jacques Le Roux (JIRA)


[ 
https://issues.apache.org/jira/browse/OFBIZ-10430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519039#comment-16519039
 ] 

Jacques Le Roux commented on OFBIZ-10430:
-

Hi Mathieu,

As I partly reported at OFBIZ-10428 for the in operator, this does not work on 
Windows. Also I got an error on line 
bq. exec \{ commandLine [gradleRunner, "--no-daemon", *commandList] }
while using
{{gradlew pullPluginSource -PpluginId=ebay}}
with this code
 {code}
def gradlewSubprocess(commandList) {
    def gradleRunner = os.contains('windows') ? 'gradlew.bat' : './gradlew'
    exec { commandLine [gradleRunner, "--no-daemon", *commandList] }
 {code}

 {code}
C:\projectsASF\ofbiz>gradlew pullPluginSource -PpluginId=ebay
:pullPluginFromSvn
:pullPluginSource FAILED

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\projectsASF\ofbiz\build.gradle' line: 1045

* What went wrong:
Execution failed for task ':pullPluginSource'.
> Cannot cast object 'gradlew.bat' with class 'java.lang.String' to class 'int'
 {code}

> Use `in` and spread operator in `gradlewSubprocess`
> ---
>
> Key: OFBIZ-10430
> URL: https://issues.apache.org/jira/browse/OFBIZ-10430
> Project: OFBiz
>  Issue Type: Improvement
>Reporter: Mathieu Lirzin
>Assignee: Jacques Le Roux
>Priority: Minor
> Fix For: Trunk
>
> Attachments: 
> OFBIZ-10430_Use-in-and-spread-operator-in-gradlewSubprocess.patch
>
>
> No functional change.  The idea of using the spread operator is to have less 
> mutation involved.  In Groovy, using operator overloads like {{in}} is more 
> idiomatic  than using explicitly the associated method.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)