[jira] [Commented] (OFBIZ-9696) Fix type entities to follow convention of hasTable

2017-10-21 Thread Pierre Smits (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-9696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16213909#comment-16213909
 ] 

Pierre Smits commented on OFBIZ-9696:
-

Please list the thread of the discussion.

> Fix type entities to follow convention of hasTable
> --
>
> Key: OFBIZ-9696
> URL: https://issues.apache.org/jira/browse/OFBIZ-9696
> Project: OFBiz
>  Issue Type: Improvement
>  Components: ALL COMPONENTS
>Affects Versions: Trunk
>Reporter: Arun Patidar
>Assignee: Arun Patidar
> Fix For: Upcoming Release
>
> Attachments: OFBIZ-9696-2.patch, OFBIZ-9696.patch
>
>
> 'hasTable' field of 'Type' entities is used to give an idea that detail 
> entity exists or not. We generally get the name of detail entity on the basis 
> of typeId field value. 
> For example : 
> ContactMechType,contactMechTypeId = "POSTAL_ADDRESS"  then we go to 
> PostalAddress for detail.
> similarly,
> ContactMechType,contactMechTypeId = "TELECOM_NUMBER"  then we go to 
> TelecomNumber for detail.
> We should follow the naming convention.
> Below are some entities that are not following the pattern. Some of them are:
>- ShipmentGatewayConfigType
>- PaymentGatewayConfigType



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Commented] (OFBIZ-9696) Fix type entities to follow convention of hasTable

2017-09-23 Thread Arun Patidar (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-9696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16177737#comment-16177737
 ] 

Arun Patidar commented on OFBIZ-9696:
-

Committed changes in rev: 1809396.

Also, added data update queries to confluence page: 
https://cwiki.apache.org/confluence/x/LoBr

Thanks Aman Agrawal for your contribution.

> Fix type entities to follow convention of hasTable
> --
>
> Key: OFBIZ-9696
> URL: https://issues.apache.org/jira/browse/OFBIZ-9696
> Project: OFBiz
>  Issue Type: Improvement
>  Components: ALL COMPONENTS
>Affects Versions: Trunk
>Reporter: Arun Patidar
>Assignee: Arun Patidar
> Fix For: Upcoming Release
>
> Attachments: OFBIZ-9696-2.patch, OFBIZ-9696.patch
>
>
> 'hasTable' field of 'Type' entities is used to give an idea that detail 
> entity exists or not. We generally get the name of detail entity on the basis 
> of typeId field value. 
> For example : 
> ContactMechType,contactMechTypeId = "POSTAL_ADDRESS"  then we go to 
> PostalAddress for detail.
> similarly,
> ContactMechType,contactMechTypeId = "TELECOM_NUMBER"  then we go to 
> TelecomNumber for detail.
> We should follow the naming convention.
> Below are some entities that are not following the pattern. Some of them are:
>- ShipmentGatewayConfigType
>- PaymentGatewayConfigType



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Commented] (OFBIZ-9696) Fix type entities to follow convention of hasTable

2017-09-23 Thread Aman Agrawal (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-9696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16177659#comment-16177659
 ] 

Aman Agrawal commented on OFBIZ-9696:
-

Update SQL queries for ShipmentGatewayConfig and PaymentGatewayConfig entity 
modifications.

UPDATE Shipment_Gateway_Config SET shipment_gateway_conf_type_id = 
'SHIP_GATEWAY_DHL' WHERE shipment_gateway_conf_type_id = 'DHL';
UPDATE Shipment_Gateway_Config SET shipment_gateway_conf_type_id = 
'SHIP_GATEWAY_FEDEX' WHERE shipment_gateway_conf_type_id = 'FEDEX';
UPDATE Shipment_Gateway_Config SET shipment_gateway_conf_type_id = 
'SHIP_GATEWAY_UPS' WHERE shipment_gateway_conf_type_id = 'UPS';
UPDATE Shipment_Gateway_Config SET shipment_gateway_conf_type_id = 
'SHIP_GATEWAY_USPS' WHERE shipment_gateway_conf_type_id = 'USPS';

UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_SAGEPAY' WHERE payment_gateway_config_type_id = 'SAGEPAY';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_AUTH_NET' WHERE payment_gateway_config_type_id = 'AUTHORIZE_NET';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_CYBERSRC' WHERE payment_gateway_config_type_id = 'CYBERSOURCE';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_EWAY' WHERE payment_gateway_config_type_id = 'EWAY';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_PAYFLOWPRO' WHERE payment_gateway_config_type_id = 'PAYFLOWPRO';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_PAYPAL' WHERE payment_gateway_config_type_id = 'PAYPAL';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_CLRCOMRC' WHERE payment_gateway_config_type_id = 'CLEARCOMMERCE';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_WORLDPAY' WHERE payment_gateway_config_type_id = 'WORLDPAY';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_ORBITAL' WHERE payment_gateway_config_type_id = 'ORBITAL';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_SECUREPAY' WHERE payment_gateway_config_type_id = 'SECUREPAY';
UPDATE Payment_Gateway_Config SET payment_gateway_config_type_id = 
'PAY_GATWY_IDEAL' WHERE payment_gateway_config_type_id = 'IDEAL';

> Fix type entities to follow convention of hasTable
> --
>
> Key: OFBIZ-9696
> URL: https://issues.apache.org/jira/browse/OFBIZ-9696
> Project: OFBiz
>  Issue Type: Improvement
>  Components: ALL COMPONENTS
>Affects Versions: Trunk
>Reporter: Arun Patidar
>Assignee: Arun Patidar
> Attachments: OFBIZ-9696-2.patch, OFBIZ-9696.patch
>
>
> 'hasTable' field of 'Type' entities is used to give an idea that detail 
> entity exists or not. We generally get the name of detail entity on the basis 
> of typeId field value. 
> For example : 
> ContactMechType,contactMechTypeId = "POSTAL_ADDRESS"  then we go to 
> PostalAddress for detail.
> similarly,
> ContactMechType,contactMechTypeId = "TELECOM_NUMBER"  then we go to 
> TelecomNumber for detail.
> We should follow the naming convention.
> Below are some entities that are not following the pattern. Some of them are:
>- ShipmentGatewayConfigType
>- PaymentGatewayConfigType



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)