Dennis Balkir created OFBIZ-9560:
------------------------------------

             Summary: [FB] Package org.apache.ofbiz.base.component
                 Key: OFBIZ-9560
                 URL: https://issues.apache.org/jira/browse/OFBIZ-9560
             Project: OFBiz
          Issue Type: Sub-task
          Components: base
    Affects Versions: Trunk
            Reporter: Dennis Balkir
            Priority: Minor


ComponentConfig.java:270, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of cc, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig.getFullLocation(String, String, 
String)

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:291, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of cc, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig.getRootLocation(String)

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:299, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of cc, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig.getStream(String, String, 
String)

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:307, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of cc, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig.getURL(String, String, String)

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:330, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of cc, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig.isFileResourceLoader(String, 
String)

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:704, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE

- RCN: Redundant nullcheck of rh, which is known to be non-null in 
org.apache.ofbiz.base.component.ComponentConfig$KeystoreInfo.getKeyStore()

This method contains a redundant check of a known non-null value against the 
constant null.

ComponentConfig.java:839, DM_CONVERT_CASE

- Dm: Use of non-localized String.toUpperCase() or String.toLowerCase() in new 
org.apache.ofbiz.base.component.ComponentConfig$WebappInfo(ComponentConfig, 
Element)

A String is being converted to upper or lowercase, using the platform's default 
encoding. This may result in improper conversions when used with international 
characters. Use the

String.toUpperCase( Locale l )
    String.toLowerCase( Locale l )
versions instead.

ComponentConfig.java:925, EI_EXPOSE_REP

- EI: 
org.apache.ofbiz.base.component.ComponentConfig$WebappInfo.getBasePermission() 
may expose internal representation by returning 
ComponentConfig$WebappInfo.basePermission

Returning a reference to a mutable object value stored in one of the object's 
fields exposes the internal representation of the object. If instances are 
accessed by untrusted code, and unchecked changes to the mutable object would 
compromise security or other important properties, you will need to do 
something different. Returning a new copy of the object is better approach in 
many situations.

ComponentResourceHandler.java:39, SE_NO_SERIALVERSIONID

- SnVI: org.apache.ofbiz.base.component.ComponentResourceHandler is 
Serializable; consider declaring a serialVersionUID

This class implements the Serializable interface, but does not define a 
serialVersionUID field. A change as simple as adding a reference to a .class 
object will add synthetic fields to the class, which will unfortunately change 
the implicit serialVersionUID (e.g., adding a reference to String.class will 
generate a static field class$java$lang$String). Also, different source code to 
bytecode compilers may use different naming conventions for synthetic variables 
generated for references to class objects or inner classes. To ensure 
interoperability of Serializable across versions, consider adding an explicit 
serialVersionUID.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to