[jira] [Updated] (OFBIZ-8500) Product: Use UtilValidate's isEmpty and isNotEmpty methods correctly

2016-10-15 Thread Pawan Verma (JIRA)

 [ 
https://issues.apache.org/jira/browse/OFBIZ-8500?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Pawan Verma updated OFBIZ-8500:
---
Attachment: OFBIZ-8500.patch

Attaching patch for this improvement.

> Product: Use UtilValidate's isEmpty and isNotEmpty methods correctly
> 
>
> Key: OFBIZ-8500
> URL: https://issues.apache.org/jira/browse/OFBIZ-8500
> Project: OFBiz
>  Issue Type: Sub-task
>  Components: party
>Affects Versions: Trunk
>Reporter: Pawan Verma
>Priority: Minor
> Attachments: OFBIZ-8500.patch
>
>
> Use UtilValidate's isEmpty and isNotEmpty methods correctly, like,
> – used: if(!UtilValidate.isEmpty(productId)) correct use of it: 
> if(UtilValidate.isNotEmpty(productId))
> – used: if(!UtilValidate.isNotEmpty(productId)) correct use of it: 
> if(UtilValidate.isEmpty(productId))
> This would improve code readability of project.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (OFBIZ-8500) Product: Use UtilValidate's isEmpty and isNotEmpty methods correctly

2016-10-15 Thread Pawan Verma (JIRA)

 [ 
https://issues.apache.org/jira/browse/OFBIZ-8500?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Pawan Verma updated OFBIZ-8500:
---
Summary: Product: Use UtilValidate's isEmpty and isNotEmpty methods 
correctly  (was: Party: Use UtilValidate's isEmpty and isNotEmpty methods 
correctly)

> Product: Use UtilValidate's isEmpty and isNotEmpty methods correctly
> 
>
> Key: OFBIZ-8500
> URL: https://issues.apache.org/jira/browse/OFBIZ-8500
> Project: OFBiz
>  Issue Type: Sub-task
>  Components: party
>Affects Versions: Trunk
>Reporter: Pawan Verma
>Priority: Minor
>
> Use UtilValidate's isEmpty and isNotEmpty methods correctly, like,
> – used: if(!UtilValidate.isEmpty(productId)) correct use of it: 
> if(UtilValidate.isNotEmpty(productId))
> – used: if(!UtilValidate.isNotEmpty(productId)) correct use of it: 
> if(UtilValidate.isEmpty(productId))
> This would improve code readability of project.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)