Re: Notmuch removing messages from the index, when calling `new` two times in a row

2015-09-25 Thread Jani Nikula
On Fri, 24 Apr 2015, Mayeu wrote: > On Fri, 24 Apr 2015 07:25:28 +0900 > David Bremner wrote: >> OK. Please try running "notmuch new" (the second time) with --debug. > > The output is exactly the same, no other information. I also tried to > add --verbose

[PATCH 2/3] lib: add interface to delete directory documents

2015-09-25 Thread Jani Nikula
As mentioned in commit acd66cdec075312944e527febd46382e54d99367 Author: Jani Nikula Date: Sat Sep 5 12:35:31 2015 +0300 cli: reset db directory mtime upon directory removal we don't have an interface to delete directory documents, and they're left behind. Add the

[PATCH 0/3] delete directory documents on directory removal

2015-09-25 Thread Jani Nikula
Hi all, this is a bit RFC-ish series for fixing some issues on directory renames and removals. The commit messages could use some polish, but I think I added enough to make it reasonable to follow. I'm not sure if the directory document removal API does enough or not, or whether it's a good API.

[PATCH 3/3] cli: delete directory documents on directory removal

2015-09-25 Thread Jani Nikula
There was a problem with the directory documents being left behind when the filesystem directory was removed. This was worked around in commit acd66cdec075312944e527febd46382e54d99367 Author: Jani Nikula Date: Sat Sep 5 12:35:31 2015 +0300 cli: reset db directory mtime

[PATCH 1/3] test: flag one more notmuch new test as broken

2015-09-25 Thread Jani Nikula
Drop the test update added in commit e4e04bbc328f990e36b77f508aef904d156029b1 Author: David Bremner Date: Tue Aug 4 08:48:33 2015 +0200 cli/new: add more debugging output and mark the test as broken, like the tests flagged as broken in commit

[PATCH] emacs/Makefile.local: notmuch-lib.elc depend on notmuch-version.elc

2015-09-25 Thread Tomi Ollila
emacs/make-depend.el will compute all other related dependencies except this one: notmuch-version is not top-level `require' expression in notmuc-lib.el[c] but conditional based on the existence of notmuch-version.el[c]. emacs/make-depend.el does not know now notmuch-version.el[c] becomes into

Re: [PATCH] cli: use designated initializer to initialize add_files_state

2015-09-25 Thread Tomi Ollila
On Fri, Sep 25 2015, Jani Nikula wrote: > The side effect is that all of add_files_state will be initialized to > zero, removing any lingering doubt that some of it might not be > initialized. It's not a small struct, and the initialization is > scattered around a bit, so this

[PATCH] cli: use designated initializer to initialize add_files_state

2015-09-25 Thread Jani Nikula
The side effect is that all of add_files_state will be initialized to zero, removing any lingering doubt that some of it might not be initialized. It's not a small struct, and the initialization is scattered around a bit, so this makes the code more readable. --- notmuch-new.c | 13 +

Re: [PATCH] test suite: don't consider skipped individual tests as failing

2015-09-25 Thread Tomi Ollila
On Fri, Sep 25 2015, David Bremner wrote: > Tomi Ollila writes: > >> >> Looks OK, but I think there should be (some good) comment here informing >> any potential viewer that we're not checking $skipped... >> > > I put some vaguely threatening comment in

[PATCH 6/9 v3 part 1/2] util: add strcmp_null, a strcmp that handles NULL parameters

2015-09-25 Thread Jani Nikula
Add strcmp_null, a strcmp that handles NULL strings; in strcmp terms a NULL string is considered to be less than a non-NULL string. --- util/string-util.c | 13 + util/string-util.h | 5 + 2 files changed, 18 insertions(+) diff --git a/util/string-util.c b/util/string-util.c

[PATCH 6/9 v3 part 2/2] cli: change the data structure for notmuch address deduplication

2015-09-25 Thread Jani Nikula
Currently we key the address hash table with the case sensitive "name ". Switch to case insensitive keying with just address, and store the case sensitive name and address in linked lists. This will be helpful in adding support for different deduplication schemes in the future. There will be a

[PATCH v2 7½/9] test: add notmuch address --deduplicate=(no|mailbox|address) tests

2015-09-25 Thread Jani Nikula
First a simple smoke test first, next generate messages with multiple email address variants and check the behaviour of deduplication schemes with these. --- v2: more variation in name parts of email addresses --- test/T095-address.sh | 74 1

Re: [PATCH] lib: add support for date:..! to mean date:..

2015-09-25 Thread David Bremner
Jani Nikula writes: > It doesn't seem likely we can support simple date: expanding to > date:.. any time soon. (This can be done with a future > version of Xapian, or with a custom query query parser.) In the mean > time, provide shorthand date:..! to mean the same. This is >

expose notmuch_database_new to libraries?

2015-09-25 Thread Wael M. Nasreddine
Hello, I have a use case where I'd like to call 'notmuch new' programmatically via the bindings (custom Go bindings). Is it at all possible to expose notmuch_new_command[0] through lib/notmuch.h? The logic of notmuch_new_command would probably have to extracted to lib/database.cc for the

Re: [PATCH] make test: NOTMUCH_TEST_QUIET=1 is now the default

2015-09-25 Thread David Bremner
Tomi Ollila writes: > make test V=1 (or any other value than 0) and make test V=0 > works similar way as build in general pushed, d ___ notmuch mailing list notmuch@notmuchmail.org http://notmuchmail.org/mailman/listinfo/notmuch

Re: [PATCH] test suite: don't consider skipped individual tests as failing

2015-09-25 Thread David Bremner
Tomi Ollila writes: > > Looks OK, but I think there should be (some good) comment here informing > any potential viewer that we're not checking $skipped... > I put some vaguely threatening comment in test/README, and a brief comment in the file. I've merged the commit, but