[PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Tomi Ollila
On Thu, Oct 18 2012, Ethan wrote: > On Thu, Oct 18, 2012 at 5:50 AM, Tomi Ollila wrote: > >> On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: >> >> > Ethan Glasser-Camp writes: >> > >> >> This patch, and its predecessors, all look great to me. >> > >> > But a note: many of the first lines in your

[PATCH] test: Move tests from emacs to emacs-show

2012-10-18 Thread Tomi Ollila
On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: > This requires changing the contents of the crypto tests, as one thread > that was marked read by the earlier tests in test/emacs is no longer > marked read. > > This moves tests for: > > - 09d19ac "test: emacs: toggle eliding of non-matching

[PATCH 1/2] test: add check for filename argument for test_expect_equal_file

2012-10-18 Thread Tomi Ollila
On Fri, Oct 12 2012, Ethan Glasser-Camp wrote: > Dmitry Kurochkin writes: > >> Actually, we can do both: check file name for consistent diff order >> (from expected to actual) and use file names that the caller provides. > > Hi! Reviewing the patch queue a little bit here. It seems like this >

[PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Tomi Ollila
On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: > Ethan Glasser-Camp writes: > >> This patch, and its predecessors, all look great to me. > > But a note: many of the first lines in your commit messages ("{show, Hmm, first lines -- IIRC mailman adds those tabs to the subject line -- and those are

[PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Tomi Ollila
On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: > Ethan Glasser-Camp writes: > >> This patch, and its predecessors, all look great to me. > > But a note: many of the first lines in your commit messages ("{show, > hide} message headers") contain tabs. I hate tabs. Is this intentional? > I have

[PATCH 1/3] Add notmuch_database_close_compact

2012-10-18 Thread Tomi Ollila
On Wed, Oct 17 2012, Ben Gamari wrote: > --- > configure | 21 - > lib/database.cc | 54 ++ > lib/notmuch.h | 14 ++ > 3 files changed, 88 insertions(+), 1 deletion(-) > > diff --git a/configure

[PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Ethan
.launchpad.net/mailman/+bug/265915 I guess I can stop complaining about it ;) Patches 1-3 are probably ready then. Thanks, Tomi. Ethan -- next part -- An HTML attachment was scrubbed... URL: <http://notmuchmail.org/pipermail/notmuch/attachments/20121018/291cc76a/attachment.html>

[PATCH 3/3] Add notmuch compact command

2012-10-18 Thread Tomi Ollila
On Wed, Oct 17 2012, Jani Nikula wrote: > Nag nag nag: Commit message. ;) > > The custom is to have a man page for each notmuch cli command. > > Small nitpicks below. > > > BR, > Jani. > > > On Wed, 17 Oct 2012, Ben Gamari wrote: >> --- >> Makefile.local|1 + >> notmuch-client.h |

[PATCH] test: handle filenames that have directories in them

2012-10-18 Thread David Bremner
Ethan Glasser-Camp writes: > Since $TEST_DIRECTORY is an absolute path, any filenames generated > with it will be complete paths. Only use the basename to generate > suffixes for filenames. pushed. d

[PATCH] test: Move tests from emacs to emacs-show

2012-10-18 Thread David Bremner
Ethan Glasser-Camp writes: > This requires changing the contents of the crypto tests, as one thread > that was marked read by the earlier tests in test/emacs is no longer > marked read. pushed. d

[PATCH] test: handle filenames that have directories in them

2012-10-18 Thread Tomi Ollila
On Fri, Oct 12 2012, Ethan Glasser-Camp wrote: > Since $TEST_DIRECTORY is an absolute path, any filenames generated > with it will be complete paths. Only use the basename to generate > suffixes for filenames. > > Signed-off-by: Ethan Glasser-Camp > --- > Discovered this while reviewing the

[PATCH 2/2] Add notmuch_database_reopen method

2012-10-18 Thread Adrien Bustany
Calling notmuch_database_reopen is needed to refresh the database contents when the database on disk was modified by another notmuch_database_t instance, for example in a different thread. --- lib/database.cc | 17 + lib/notmuch.h | 8 2 files changed, 25 insertions(+)

[PATCH 1/2] Add notmuch_database_flush method

2012-10-18 Thread Adrien Bustany
This method explicitly flushes the pending modifications to disk. It is useful if your program has various threads, each with a read only DB and one writer thread with a read/write DB. In that case, you most likely want the writer to sync the changes to disk so that the readers can see them,

[PATCH v2 0/2] Add flush/reopen methods to notmuch_database_t

2012-10-18 Thread Adrien Bustany
The code of the patches in unchanged, but the formatting issues are now hopefully fixed.

[PATCH 1/2] Add notmuch_database_flush method

2012-10-18 Thread Adrien Bustany
Le 17/10/2012 18:53, Ethan Glasser-Camp a ?crit : > Adrien Bustany writes: > >> This method explicitly flushes the pending modifications to disk. It is >> useful if your program has various threads, each with a read only DB and >> one writer thread with a read/write DB. In that case, you most

Re: [PATCH 3/3] Add notmuch compact command

2012-10-18 Thread Tomi Ollila
On Wed, Oct 17 2012, Jani Nikula j...@nikula.org wrote: Nag nag nag: Commit message. ;) The custom is to have a man page for each notmuch cli command. Small nitpicks below. BR, Jani. On Wed, 17 Oct 2012, Ben Gamari bgamari.f...@gmail.com wrote: --- Makefile.local|1 +

Re: [PATCH 1/3] Add notmuch_database_close_compact

2012-10-18 Thread Tomi Ollila
On Wed, Oct 17 2012, Ben Gamari bgamari.f...@gmail.com wrote: --- configure | 21 - lib/database.cc | 54 ++ lib/notmuch.h | 14 ++ 3 files changed, 88 insertions(+), 1 deletion(-) diff --git

Re: [PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Tomi Ollila
On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: Ethan Glasser-Camp ethan.glasser.c...@gmail.com writes: This patch, and its predecessors, all look great to me. But a note: many of the first lines in your commit messages ({show, hide} message headers) contain tabs. I hate tabs. Is this

Re: [PATCH 1/2] test: add check for expected filename argument for test_expect_equal_file

2012-10-18 Thread Tomi Ollila
On Fri, Oct 12 2012, Ethan Glasser-Camp wrote: Dmitry Kurochkin dmitry.kuroch...@gmail.com writes: Actually, we can do both: check file name for consistent diff order (from expected to actual) and use file names that the caller provides. Hi! Reviewing the patch queue a little bit here. It

Re: [PATCH] test: Move tests from emacs to emacs-show

2012-10-18 Thread David Bremner
Ethan Glasser-Camp ethan.glasser.c...@gmail.com writes: This requires changing the contents of the crypto tests, as one thread that was marked read by the earlier tests in test/emacs is no longer marked read. pushed. d ___ notmuch mailing list

Re: [PATCH] test: handle filenames that have directories in them

2012-10-18 Thread David Bremner
Ethan Glasser-Camp ethan.glasser.c...@gmail.com writes: Since $TEST_DIRECTORY is an absolute path, any filenames generated with it will be complete paths. Only use the basename to generate suffixes for filenames. pushed. d ___ notmuch mailing list

Re: [PATCH v2 3/7] emacs: rename `notmuch-show-toggle-headers' to `notmuch-show-toggle-visibility-headers'

2012-10-18 Thread Ethan
On Thu, Oct 18, 2012 at 5:50 AM, Tomi Ollila tomi.oll...@iki.fi wrote: On Thu, Oct 18 2012, Ethan Glasser-Camp wrote: Ethan Glasser-Camp ethan.glasser.c...@gmail.com writes: This patch, and its predecessors, all look great to me. But a note: many of the first lines in your commit

Re: [PATCH v2 0/2] Add flush/reopen methods to notmuch_database_t

2012-10-18 Thread Ethan Glasser-Camp
Adrien Bustany adr...@bustany.org writes: The code of the patches in unchanged, but the formatting issues are now hopefully fixed. These look fine to me, and they're pretty trivial. Ethan ___ notmuch mailing list notmuch@notmuchmail.org

Re: Notmuch scripts (again), now with more usenet

2012-10-18 Thread Ethan Glasser-Camp
c...@webprojekty.cz writes: Hello, for quite some time my set of scripts just lied in my repo and waited for polish before release. So tonight I finally managed to update the docs, remove old stuff, rewrite some unfortunate things etc. One notable addition is slrn2maildir script which can

Re: [PATCH 7/8] lib: add NOTMUCH_EXCLUDE_FLAG to notmuch_exclude_t

2012-10-18 Thread Ethan Glasser-Camp
Peter Wang noval...@gmail.com writes: Add NOTMUCH_EXCLUDE_FLAG to notmuch_exclude_t so that it can cover all four values of search --exclude in the cli. This series looks good to me. It's a nice clean up and a nice new feature. Patches all apply. However, I'm getting test failures like: