[PATCH v2] emacs: jump: sort-order bugfix

2014-09-02 Thread Mark Walters
default-value needs its argument to be quoted. Slightly strangely default-value of 't or nil is 't or nil respectively so the code (default-value notmuch-search-oldest-first) just gives the current value of notmuch-search-oldest-first rather than intended default-value of this variable. The

[PATCH v2] emacs: jump: sort-order bugfix

2014-09-02 Thread Austin Clements
LGTM. Quoth Mark Walters on Sep 02 at 7:56 pm: > default-value needs its argument to be quoted. > > Slightly strangely default-value of 't or nil is 't or nil > respectively so the code > > (default-value notmuch-search-oldest-first) > > just gives the current value of

sending email using different server for different 'From:' field

2014-09-02 Thread David Belohrad
Dear All, I have my emacs/notmuch installation setup such, that I send the emails usually directly using local exim4 installation. For particular 'From:' field however I need to use my work server. Nowadays I do that manually. Hence if I write an email using my work address, I manually call a

[PATCH] emacs: jump: sort-order bugfix

2014-09-02 Thread Mark Walters
default-value needs its argument to be quoted. --- Slightly strangely default-value of 't or nil is 't or nil respectively so the code didn't give an error but just did the wrong thing. Thanks to Jani for finding the bug. Best wishes Mark emacs/notmuch-jump.el |2 +- 1 file changed, 1

[Vagrant Cascadian] Bug#759646: notmuch-emacs: switching mode= to invalid value sends unencrypted mail

2014-09-02 Thread Tomi Ollila
On Tue, Sep 02 2014, Daniel Kahn Gillmor wrote: > On 08/30/2014 03:37 AM, Jani Nikula wrote: >> I'm inclined to think this is a bug in message-mode. > > I agree it's a bug in message-mode, not in notmuch itself. I think it might be here:

[PATCH] doc: 'rm -f' potential doxygen temporary output file

2014-09-02 Thread David Bremner
Tomi Ollila writes: > Some (older) Doxygen versions do not create such a temporary file. > > --- pushed. d

[PATCH] lib: Fix endless upgrade problem

2014-09-02 Thread Tomi Ollila
On Tue, Sep 02 2014, Austin Clements wrote: > 48db8c8 introduced a disagreement between when > notmuch_database_needs_upgrade returned TRUE and when > notmuch_database_upgrade actually performed an upgrade. As a result, > if a database had a version less than 3, but no new features were >

sending email using different server for different 'From:' field

2014-09-02 Thread Keith Amidon
On Tue, 2014-09-02 at 14:26 +0200, David Belohrad wrote: > could that scenario be somehow fitted automatically, so when I overwrite > the default 'From:' address (by hand. is it possible to do some > automatic cycling?) to work address, so that message sender in emacs > would automatically use

[PATCH] lib: Fix endless upgrade problem

2014-09-02 Thread Mark Walters
On Tue, 02 Sep 2014, Tomi Ollila wrote: > On Tue, Sep 02 2014, Austin Clements wrote: > >> 48db8c8 introduced a disagreement between when >> notmuch_database_needs_upgrade returned TRUE and when >> notmuch_database_upgrade actually performed an upgrade. As a result, >> if a database had a

[Vagrant Cascadian] Bug#759646: notmuch-emacs: switching mode= to invalid value sends unencrypted mail

2014-09-02 Thread Daniel Kahn Gillmor
esc: OpenPGP digital signature URL: <http://notmuchmail.org/pipermail/notmuch/attachments/20140902/f0656afa/attachment.pgp>

[PATCH] lib: Fix endless upgrade problem

2014-09-02 Thread David Bremner
Austin Clements writes: > 48db8c8 introduced a disagreement between when > notmuch_database_needs_upgrade returned TRUE and when > notmuch_database_upgrade actually performed an upgrade. As a result, > if a database had a version less than 3, but no new features were > required, notmuch new

Re: [PATCH] lib: Fix endless upgrade problem

2014-09-02 Thread Mark Walters
On Tue, 02 Sep 2014, Tomi Ollila tomi.oll...@iki.fi wrote: On Tue, Sep 02 2014, Austin Clements amdra...@mit.edu wrote: 48db8c8 introduced a disagreement between when notmuch_database_needs_upgrade returned TRUE and when notmuch_database_upgrade actually performed an upgrade. As a result,

Re: [PATCH] lib: Fix endless upgrade problem

2014-09-02 Thread David Bremner
Austin Clements amdra...@mit.edu writes: 48db8c8 introduced a disagreement between when notmuch_database_needs_upgrade returned TRUE and when notmuch_database_upgrade actually performed an upgrade. As a result, if a database had a version less than 3, but no new features were required,

Re: [Vagrant Cascadian] Bug#759646: notmuch-emacs: switching mode= to invalid value sends unencrypted mail

2014-09-02 Thread Tomi Ollila
On Tue, Sep 02 2014, Daniel Kahn Gillmor d...@fifthhorseman.net wrote: On 08/30/2014 03:37 AM, Jani Nikula wrote: I'm inclined to think this is a bug in message-mode. I agree it's a bug in message-mode, not in notmuch itself. I think it might be here:

sending email using different server for different 'From:' field

2014-09-02 Thread David Belohrad
Dear All, I have my emacs/notmuch installation setup such, that I send the emails usually directly using local exim4 installation. For particular 'From:' field however I need to use my work server. Nowadays I do that manually. Hence if I write an email using my work address, I manually call a

[PATCH] emacs: jump: sort-order bugfix

2014-09-02 Thread Mark Walters
default-value needs its argument to be quoted. --- Slightly strangely default-value of 't or nil is 't or nil respectively so the code didn't give an error but just did the wrong thing. Thanks to Jani for finding the bug. Best wishes Mark emacs/notmuch-jump.el |2 +- 1 file changed, 1

Re: sending email using different server for different 'From:' field

2014-09-02 Thread Keith Amidon
On Tue, 2014-09-02 at 14:26 +0200, David Belohrad wrote: could that scenario be somehow fitted automatically, so when I overwrite the default 'From:' address (by hand. is it possible to do some automatic cycling?) to work address, so that message sender in emacs would automatically use work

Re: [PATCH] doc: 'rm -f' potential doxygen temporary output file

2014-09-02 Thread David Bremner
Tomi Ollila tomi.oll...@iki.fi writes: Some (older) Doxygen versions do not create such a temporary file. --- pushed. d ___ notmuch mailing list notmuch@notmuchmail.org http://notmuchmail.org/mailman/listinfo/notmuch

Re: [PATCH] emacs: jump: sort-order bugfix

2014-09-02 Thread Carl Worth
Mark Walters markwalters1...@gmail.com writes: default-value needs its argument to be quoted. --- Hi Mark, I really appreciate you sending in a bug fix. Thanks! I'd prefer to see the commit message describing the bug and the fix a bit. You do have some text here that would be a great

[PATCH v2] emacs: jump: sort-order bugfix

2014-09-02 Thread Mark Walters
default-value needs its argument to be quoted. Slightly strangely default-value of 't or nil is 't or nil respectively so the code (default-value notmuch-search-oldest-first) just gives the current value of notmuch-search-oldest-first rather than intended default-value of this variable. The

Re: [PATCH v2] emacs: jump: sort-order bugfix

2014-09-02 Thread Austin Clements
LGTM. Quoth Mark Walters on Sep 02 at 7:56 pm: default-value needs its argument to be quoted. Slightly strangely default-value of 't or nil is 't or nil respectively so the code (default-value notmuch-search-oldest-first) just gives the current value of notmuch-search-oldest-first

Re: [PATCH v2] emacs: jump: sort-order bugfix

2014-09-02 Thread Jani Nikula
On Tue, 02 Sep 2014, Mark Walters markwalters1...@gmail.com wrote: default-value needs its argument to be quoted. Slightly strangely default-value of 't or nil is 't or nil respectively so the code (default-value notmuch-search-oldest-first) just gives the current value of

Re: How to debug 'ignoring non-mail file' issues

2014-09-02 Thread Jani Nikula
On Mon, 01 Sep 2014, Perttu Luukko perttu.luu...@iki.fi wrote: Yes, upgrading to GMime 2.6.20 caused all the messages on my server classified as mail. What was the old version? If it was 2.4 we should probably consider dropping support for that in future notmuch. Even more reason to give a

Re: How to debug 'ignoring non-mail file' issues

2014-09-02 Thread Perttu Luukko
On 2014-09-02 23:37:12, Jani Nikula wrote: On Mon, 01 Sep 2014, Perttu Luukko perttu.luu...@iki.fi wrote: Yes, upgrading to GMime 2.6.20 caused all the messages on my server classified as mail. What was the old version? If it was 2.4 we should probably consider dropping support for that