Re: Python binding documentation on readthedocs out of date

2019-09-23 Thread David Bremner
Johannes Löthberg  writes:

> Hello,
>
> I just noticed that the python binding documentation hosted on 
> readthedocs are very out of date.  The "latest" version is for 0.25rc1, 
> and the "stable" version is for 0.24.2.  Would be great if someone could 
> build more current versions.

Unfortunately the (active) notmuch developers don't control either the
notmuch related sites on readthedocs.com.

If I could figure out how, I'd petition to have them taken down,
since neither is maintained.

Alternatively of course someone could maintain them, but that hasn't
happened so far.  I would also consider patches that integrated
readthedocs updates into the notmuch release process, if that could be
managed in a not too horrible way.

d

___
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch


Re: bug#23747: bug present without emacs25 or notmuch

2019-09-23 Thread Lars Ingebrigtsen
David Bremner  writes:

> David Bremner  writes:
>
>> I have managed to duplicate (I think) this bug without notmuch or emacs
>> 25.
>>
>> In emacs 24.5.1 (on debian)
>>
>> (require 'mml2015)
>> (setq mml2015-sign-with-sender t)
>>
>> M-x toggle-debug-on-error
>>
>> M-x message-mail
>> (fill in some headers, From: me)
>> C-c C-m C-s
>> C-c C-c
>
> I just tried this script in emacs 25.1 (debian) and could not reproduce
> the bug. So maybe it's fixed?

OK; thanks for checking.  I'm closing the bug report.

-- 
(domestic pets only, the antidote for overdose, milk.)
   bloggy blog: http://lars.ingebrigtsen.no
___
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch


Python binding documentation on readthedocs out of date

2019-09-23 Thread Johannes Löthberg

Hello,

I just noticed that the python binding documentation hosted on 
readthedocs are very out of date.  The "latest" version is for 0.25rc1, 
and the "stable" version is for 0.24.2.  Would be great if someone could 
build more current versions.


Stumbled upon this when I tried to use add_message but got a 
DeprecationWarning telling me to use index_file instead, which is 
nowhere to be found in the currently available documentation.


--
Sincerely,
 Johannes Löthberg :: SA0DEM


pgpRgPkTQxeQX.pgp
Description: PGP signature
___
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch