> For consistency with Emacs' own elisp, perhaps rename > notmuch-mua-pre-send-check-hooks to > notmuch-mua-pre-send-check-functions? Hi Yes you are correct. (Annoyingly I had thought about this and thought it was OK since I didn't need to pass an argument. I had missed the return value case).
Hey Mark, For consistency with Emacs' own elisp, perhaps rename notmuch-mua-pre-send-check-hooks to notmuch-mua-pre-send-check-functions? This patch reminded me of a recent discussion on emacs-devel about the definition of "hook" in Emacs code and documentation. There is the broad meaning of
This add a pre-send hook for any checks the user wants to run before sending the message. If any function in the hook returns nil then the send will abort. One use would be to check that the from address is appropriate for the recipients (i.e., test From: based on To: and Cc:), but many other