Re: [PATCH] cli/lib: remove support for GMime 2.4

2015-08-26 Thread David Bremner
David Bremner da...@tethera.net writes: It's becoming a maintenance burden to do anything things with the crypto glue code twice, once for 2.4 and once for 2.6. I don't have any 2.4 version available to test on my development machine anymore, so the 2.4 specific code paths are likely not very

Re: [PATCH] cli/lib: remove support for GMime 2.4

2015-08-17 Thread Tomi Ollila
On Mon, Aug 17 2015, Daniel Kahn Gillmor d...@fifthhorseman.net wrote: On Sun 2015-08-16 21:53:36 +0200, Tomi Ollila wrote: On Sun, Aug 16 2015, David Bremner da...@tethera.net wrote: It's becoming a maintenance burden to do anything things with the crypto glue code twice, once for 2.4 and

Re: [PATCH] cli/lib: remove support for GMime 2.4

2015-08-17 Thread Daniel Kahn Gillmor
On Sun 2015-08-16 21:53:36 +0200, Tomi Ollila wrote: On Sun, Aug 16 2015, David Bremner da...@tethera.net wrote: It's becoming a maintenance burden to do anything things with the crypto glue code twice, once for 2.4 and once for 2.6. I don't have any 2.4 version available to test on my

[PATCH] cli/lib: remove support for GMime 2.4

2015-08-16 Thread David Bremner
It's becoming a maintenance burden to do anything things with the crypto glue code twice, once for 2.4 and once for 2.6. I don't have any 2.4 version available to test on my development machine anymore, so the 2.4 specific code paths are likely not very well tested. --- I started to rebase the

Re: [PATCH] cli/lib: remove support for GMime 2.4

2015-08-16 Thread Tomi Ollila
On Sun, Aug 16 2015, David Bremner da...@tethera.net wrote: It's becoming a maintenance burden to do anything things with the crypto glue code twice, once for 2.4 and once for 2.6. I don't have any 2.4 version available to test on my development machine anymore, so the 2.4 specific code paths