Re: [PATCH 0/6] python: add bindings for notmuch_database_get_config{, _list}

2017-12-19 Thread David Bremner
l-...@web.de writes:

> Comming back after a long time (sorry for the wait).
>
> I now changed the binding for notmuch_database_get_config_list into a
> generator.  It is called get_configs in the python bindings (the "s"
> should indicate the iterable/generator nature like for dict.items or
> dict.keys).

Series pushed to master. Thanks for contributing to notmuch.

d
___
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch


[PATCH 0/6] python: add bindings for notmuch_database_get_config{, _list}

2017-12-07 Thread l-m-h
Comming back after a long time (sorry for the wait).

I now changed the binding for notmuch_database_get_config_list into a
generator.  It is called get_configs in the python bindings (the "s"
should indicate the iterable/generator nature like for dict.items or
dict.keys).

Tests and the set_config entry point were also added.

If you want you can merge it as is or I can squash the commits in any
way you want.

Lucas Hoffmann (6):
  python: add bindings to access config
  python: add default arg to get_config_list
  python: turn get_config_list into a generator
  test: Add tests for new python bindings
  python: Rename get_config_list to get_configs
  test: Add test to unset config items with the python bindings

 bindings/python/docs/source/database.rst |   6 ++
 bindings/python/notmuch/database.py  | 111 ++-
 bindings/python/notmuch/globals.py   |   5 ++
 test/T390-python.sh  |  81 ++
 4 files changed, 202 insertions(+), 1 deletion(-)

-- 
2.15.1
___
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch