[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-06 Thread Austin Clements
On Mon, 06 Oct 2014, David Bremner wrote: > Austin Clements writes: > >> >> I'm used to reading this stuff, so either way is fine with me. Do we >> have bit set / clear / read macros? >> > > I guess not. the things we have in query.cc are related but different. I added some macros for doing

[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-06 Thread David Bremner
Austin Clements writes: > > I'm used to reading this stuff, so either way is fine with me. Do we > have bit set / clear / read macros? > I guess not. the things we have in query.cc are related but different. >> > + else if (*i == "Tghost") >> > + message->flags |= (1 <<

Re: [PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-06 Thread David Bremner
Austin Clements acleme...@csail.mit.edu writes: I'm used to reading this stuff, so either way is fine with me. Do we have bit set / clear / read macros? I guess not. the things we have in query.cc are related but different. + else if (*i == Tghost) + message-flags |= (1

Re: [PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-06 Thread Austin Clements
On Mon, 06 Oct 2014, David Bremner da...@tethera.net wrote: Austin Clements acleme...@csail.mit.edu writes: I'm used to reading this stuff, so either way is fine with me. Do we have bit set / clear / read macros? I guess not. the things we have in query.cc are related but different. I

[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-05 Thread Austin Clements
Quoth David Bremner on Oct 05 at 10:30 am: > Austin Clements writes: > > > + message->flags &= ~(1 << NOTMUCH_MESSAGE_FLAG_GHOST); > > What do you think about using bit set / clear / read macros? I don't > insist, but I wonder if it would make this part more readable. I'm used to

[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-05 Thread David Bremner
Austin Clements writes: > + message->flags &= ~(1 << NOTMUCH_MESSAGE_FLAG_GHOST); What do you think about using bit set / clear / read macros? I don't insist, but I wonder if it would make this part more readable. > + else if (*i == "Tghost") > + message->flags |= (1 <<

Re: [PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-05 Thread David Bremner
Austin Clements acleme...@csail.mit.edu writes: + message-flags = ~(1 NOTMUCH_MESSAGE_FLAG_GHOST); What do you think about using bit set / clear / read macros? I don't insist, but I wonder if it would make this part more readable. + else if (*i == Tghost) +

Re: [PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-05 Thread Austin Clements
Quoth David Bremner on Oct 05 at 10:30 am: Austin Clements acleme...@csail.mit.edu writes: + message-flags = ~(1 NOTMUCH_MESSAGE_FLAG_GHOST); What do you think about using bit set / clear / read macros? I don't insist, but I wonder if it would make this part more readable. I'm

[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-03 Thread Austin Clements
From: Austin Clements This updates the message abstraction to support ghost messages: it adds a message flag that distinguishes regular messages from ghost messages, and an internal function for initializing a newly created (blank) message as a ghost message. ---

[PATCH 06/11] lib: Internal support for querying and creating ghost messages

2014-10-03 Thread Austin Clements
From: Austin Clements amdra...@mit.edu This updates the message abstraction to support ghost messages: it adds a message flag that distinguishes regular messages from ghost messages, and an internal function for initializing a newly created (blank) message as a ghost message. --- lib/message.cc