Re: [PATCH] nouveau: Add missing break statement

2024-04-30 Thread Lucas De Marchi
default: + break; since reg->type is an enum and we are handling all the values, another possible approach is to remove the default handling and then the compiler will warn you of missing cases if built with -Wswitch. Any of the approaches seem good to me. Reviewed-by: Lucas De M

Re: [PATCH] [v7] nouveau: add command-line GSP-RM registry support

2024-04-30 Thread Lucas De Marchi
On Fri, Apr 26, 2024 at 06:08:19PM GMT, Danilo Krummrich wrote: On 4/25/24 18:38, Timur Tabi wrote: On Thu, 2024-04-25 at 15:22 +0200, Danilo Krummrich wrote: + size_t length; + + /* Remove any whitespace from the parameter string */ + length =

Re: [PATCH 1/2] drm/print: drop include debugfs.h and include where needed

2024-04-24 Thread Lucas De Marchi
On Mon, Apr 22, 2024 at 03:10:10PM GMT, Jani Nikula wrote: drivers/gpu/drm/xe/xe_debugfs.c | 1 + drivers/gpu/drm/xe/xe_gt_debugfs.c | 2 ++ drivers/gpu/drm/xe/xe_uc_debugfs.c | 2 ++ Acked-by: Lucas De Marchi thanks Lucas De Marchi

Re: [linux-next:master] BUILD REGRESSION 20af1ca418d2c0b11bc2a1fe8c0c88f67bcc2a7e

2024-02-28 Thread Lucas De Marchi
] this is fixed now in drm-xe-next. Lucas De Marchi

Re: Re: [PATCH 3/5] drm/ttm: replace busy placement with flags v6

2024-02-21 Thread Lucas De Marchi
with another patch that got applied a few days ago: a201c6ee37d6 ("drm/xe/bo: Evict VRAM to TT rather than to system") Lucas De Marchi But worserthere are some regressions in the dma-buf ktest (it tests evicting of a dynamic dma-buf), https://patchwork.freedesktop.org/series/128873/

Re: Re: Re: [PATCH 3/5] drm/ttm: replace busy placement with flags v6

2024-02-21 Thread Lucas De Marchi
On Fri, Jan 26, 2024 at 04:16:58PM -0600, Lucas De Marchi wrote: On Thu, Jan 18, 2024 at 05:38:16PM +0100, Thomas Hellström wrote: On 1/17/24 13:27, Thomas Hellström wrote: On 1/17/24 11:47, Thomas Hellström wrote: Hi, Christian Xe changes look good. Will send the series to xe ci to check

Re: [Nouveau] [PATCH v3] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
On Thu, Feb 03, 2022 at 12:56:14AM -0800, Lucas De Marchi wrote: Rename struct dma_buf_map to struct iosys_map and corresponding APIs. Over time dma-buf-map grew up to more functionality than the one used by dma-buf: in fact it's just a shim layer to abstract system memory, that can be accessed

Re: [Nouveau] [PATCH v2] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
On Wed, Feb 02, 2022 at 11:20:16AM +0100, Thomas Zimmermann wrote: Hi Am 02.02.22 um 10:11 schrieb Lucas De Marchi: diff --git a/Documentation/driver-api/dma-buf.rst b/Documentation/driver-api/dma-buf.rst index 2cd7db82d9fe..ea1e81894d7c 100644 --- a/Documentation/driver-api/dma-buf.rst

Re: [Nouveau] [PATCH v2] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
On Wed, Feb 02, 2022 at 10:25:28AM +0100, Christian König wrote: Am 02.02.22 um 10:11 schrieb Lucas De Marchi: [SNIP] diff --git a/MAINTAINERS b/MAINTAINERS index d03ad8da1f36..112676f11792 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -5675,7 +5675,6 @@ T:git git

[Nouveau] [PATCH v2] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
their includes adjusted and some comments were update to remove mentions to dma-buf-map. Signed-off-by: Lucas De Marchi --- Documentation/driver-api/dma-buf.rst | 4 +- Documentation/gpu/todo.rst| 20 +- MAINTAINERS | 8

[Nouveau] [PATCH v4] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
S - Move documentation from dma-buf.rst to device-io.rst v4: - Change documentation tile and level Signed-off-by: Lucas De Marchi Acked-by: Christian König Acked-by: Sumit Semwal Acked-by: Thomas Zimmermann --- Documentation/driver-api/device-io.rst| 9 + Documentation/driver-api/d

[Nouveau] [PATCH v3] dma-buf-map: Rename to iosys-map

2022-02-09 Thread Lucas De Marchi
S - Move documentation from dma-buf.rst to device-io.rst Signed-off-by: Lucas De Marchi Acked-by: Christian König Acked-by: Sumit Semwal --- Documentation/driver-api/device-io.rst| 9 + Documentation/driver-api/dma-buf.rst | 9 - Documentation/gpu/todo.rst

Re: [Nouveau] [PATCH 00/14] Rename dma-buf-map

2022-02-09 Thread Lucas De Marchi
On Tue, Feb 01, 2022 at 08:46:15AM +0100, Christian König wrote: Am 01.02.22 um 01:36 schrieb Lucas De Marchi: On Fri, Jan 28, 2022 at 10:48:42AM +0100, Christian König wrote: Am 28.01.22 um 10:40 schrieb Lucas De Marchi: On Fri, Jan 28, 2022 at 10:22:00AM +0100, Christian König wrote: Am

Re: [Nouveau] [PATCH 00/14] Rename dma-buf-map

2022-02-09 Thread Lucas De Marchi
On Fri, Jan 28, 2022 at 10:48:42AM +0100, Christian König wrote: Am 28.01.22 um 10:40 schrieb Lucas De Marchi: On Fri, Jan 28, 2022 at 10:22:00AM +0100, Christian König wrote: Am 28.01.22 um 10:12 schrieb Lucas De Marchi: On Fri, Jan 28, 2022 at 09:41:14AM +0100, Christian König wrote: Rule

[Nouveau] [PATCH 09/14] drm/nouveau: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in nouveau. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/nouveau/nouveau_gem.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/gpu/drm/nouveau/nouveau_gem.c b/drivers/gpu

[Nouveau] [PATCH 01/14] iosys-map: Introduce renamed dma-buf-map

2022-01-28 Thread Lucas De Marchi
to access IO memory. Once all the drivers using dma_buf_map are converted, the dma_buf_map can be retired and iosys_map extended to cover new use cases. Signed-off-by: Lucas De Marchi --- MAINTAINERS | 1 + include/linux/dma-buf-map.h | 3 + include/linux/iosys-map.h | 254

[Nouveau] [PATCH 03/14] dma-buf: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API. Signed-off-by: Lucas De Marchi --- drivers/dma-buf/dma-buf.c | 22 +++--- drivers/dma-buf/heaps/cma_heap.c| 10 +- drivers/dma-buf/heaps/system_heap.c | 10

[Nouveau] [PATCH 11/14] drm/radeon: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in radeon. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/radeon/radeon_gem.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/gpu/drm/radeon/radeon_gem.c b/drivers/gpu/drm

[Nouveau] [PATCH 14/14] dma-buf-map: Remove API in favor of iosys-map

2022-01-28 Thread Lucas De Marchi
All users are now converted to iosys-map, which is the renamed version of dma-buf-map. Remove remaining references to dma-buf-map. Signed-off-by: Lucas De Marchi --- MAINTAINERS | 1 - include/linux/dma-buf-map.h | 269 include/linux/iosys

[Nouveau] [PATCH 07/14] drm/i915: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in i915. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/i915/gem/i915_gem_dmabuf.c | 8 +--- drivers/gpu/drm/i915/gem/selftests/i915_gem_dmabuf.c | 6 +++--- drivers/gpu/drm

[Nouveau] [PATCH 10/14] drm/tegra: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in tegra. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/tegra/gem.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/gpu/drm/tegra/gem.c b/drivers/gpu

[Nouveau] [PATCH 04/14] media: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API. Signed-off-by: Lucas De Marchi --- drivers/media/common/videobuf2/videobuf2-dma-contig.c | 8 drivers/media/common/videobuf2/videobuf2-dma-sg.c | 9 + drivers/media

Re: [Nouveau] [PATCH 00/14] Rename dma-buf-map

2022-01-28 Thread Lucas De Marchi
On Fri, Jan 28, 2022 at 10:22:00AM +0100, Christian König wrote: Am 28.01.22 um 10:12 schrieb Lucas De Marchi: On Fri, Jan 28, 2022 at 09:41:14AM +0100, Christian König wrote: Rule #1 is to never ever break the build. Because of this all those patches needs to be squashed into a single one

Re: [Nouveau] [PATCH 01/14] iosys-map: Introduce renamed dma-buf-map

2022-01-28 Thread Lucas De Marchi
On Fri, Jan 28, 2022 at 09:53:59AM +0100, Thomas Zimmermann wrote: Hi Am 28.01.22 um 09:36 schrieb Lucas De Marchi: Add a new type, struct iosys_map, to eventually replace struct dma_buf_map and its helpers defiend in include/linux/dma-buf-map.h. This is mostly a copy of dma-buf-map

[Nouveau] [PATCH 08/14] drm/msm: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in msm. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/msm/msm_drv.h | 4 ++-- drivers/gpu/drm/msm/msm_gem_prime.c | 6 +++--- 2 files changed, 5 insertions(+), 5 deletions(-) diff

Re: [Nouveau] [PATCH 00/14] Rename dma-buf-map

2022-01-28 Thread Lucas De Marchi
e to merge, though. It will be hard on the conflicts later, but should get the job done much quicker. Lucas De Marchi Regards, Christian. Am 28.01.22 um 09:36 schrieb Lucas De Marchi: Motivation for this started in https://lore.kernel.org/lkml/20220126203702.1784589-1-lucas.demar...@intel.com/ w

[Nouveau] [PATCH 13/14] Documentation: Refer to iosys-map instead of dma-buf-map

2022-01-28 Thread Lucas De Marchi
dma-buf-map is being phased out in favor of the equivalent and renamed interface: iosys-map. Use the new header in documentation. Signed-off-by: Lucas De Marchi --- Documentation/driver-api/dma-buf.rst | 4 ++-- Documentation/gpu/todo.rst | 20 ++-- 2 files changed

[Nouveau] [PATCH 12/14] drm: Replace dma-buf-map with iosys-map in common code

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in all the helpers and common code for the drivers. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/drm_cache.c | 18 +++--- drivers/gpu/drm/drm_client.c

[Nouveau] [PATCH 00/14] Rename dma-buf-map

2022-01-28 Thread Lucas De Marchi
, and radeon in their own patches in case it's preferred to take those through their own trees. Lucas De Marchi Lucas De Marchi (14): iosys-map: Introduce renamed dma-buf-map misc: fastrpc: Replace dma-buf-map with iosys-map dma-buf: Replace dma-buf-map with iosys-map media: Replace dma-buf-map

[Nouveau] [PATCH 06/14] drm: Replace dma-buf-map with iosys-map in drivers

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in some drivers. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/ast/ast_drv.h | 2 +- drivers/gpu/drm/ast/ast_mode.c | 8 drivers/gpu/drm/etnaviv

[Nouveau] [PATCH 05/14] drm/ttm: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API in the ttm layer. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/ttm/ttm_bo_util.c | 16 drivers/gpu/drm/ttm/ttm_resource.c | 26 +- drivers/gpu/drm

[Nouveau] [PATCH 02/14] misc: fastrpc: Replace dma-buf-map with iosys-map

2022-01-28 Thread Lucas De Marchi
iosys-map is the new name for dma-buf-map and will gain new capabitilities. Replace with the new API. Signed-off-by: Lucas De Marchi --- drivers/misc/fastrpc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/misc/fastrpc.c b/drivers/misc/fastrpc.c index

[Nouveau] [PATCH v2 06/11] drm/i915: Use str_on_off()

2022-01-26 Thread Lucas De Marchi
Remove the local onoff() implementation and adopt the str_on_off() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi Acked-by: Daniel Vetter Acked-by: Jani Nikula --- drivers/gpu/drm/i915/display/g4x_dp.c | 6 -- drivers/gpu/drm/i915/display/intel_display.c

[Nouveau] [PATCH v2 05/11] drm/i915: Use str_enabled_disabled()

2022-01-26 Thread Lucas De Marchi
Remove the local enableddisabled() implementation and adopt the str_enabled_disabled() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi Acked-by: Daniel Vetter Acked-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_backlight.c | 3 ++- drivers/gpu/drm/i915/display

[Nouveau] [PATCH v2 09/11] drm: Convert open-coded yes/no strings to yesno()

2022-01-26 Thread Lucas De Marchi
u.ko.old 1973432 1096402352 2085424 1fd230 nouveau/nouveau.ko Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/amd/amdgpu/atom.c | 4 +++- drivers/gpu/drm/dp/drm_dp.c | 3 ++- drivers/gpu/drm/drm_client_modeset.c | 3 ++- drivers/gpu/drm/drm_gem.c

[Nouveau] [PATCH v2 11/11] cxgb4: Use str_yes_no()

2022-01-26 Thread Lucas De Marchi
Remove the local yesno() implementation and adopt the str_yes_no() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi --- .../ethernet/chelsio/cxgb4/cxgb4_debugfs.c| 249 ++ 1 file changed, 137 insertions(+), 112 deletions(-) diff --git a/drivers/net/ethernet

[Nouveau] [PATCH v2 01/11] lib/string_helpers: Consolidate string helpers implementation

2022-01-26 Thread Lucas De Marchi
20 The inlined function should keep the const strings local to each compilation unit, the same way it's now, thus not changing the current behavior. Signed-off-by: Lucas De Marchi Reviewed-by: Andy Shevchenko Acked-by: Jani Nikula Acked-by: Daniel Vetter --- include/linux/string_helpers.h | 20

Re: [Nouveau] [PATCH 3/3] drm: Convert open yes/no strings to yesno()

2022-01-26 Thread Lucas De Marchi
On Wed, Jan 19, 2022 at 09:30:47PM +0200, Andy Shevchenko wrote: On Tue, Jan 18, 2022 at 11:24:50PM -0800, Lucas De Marchi wrote: linux/string_helpers.h provides a helper to return "yes"/"no" strings. Replace the open coded versions with yesno(). The places were identifie

[Nouveau] [PATCH v2 08/11] drm/gem: Sort includes alphabetically

2022-01-26 Thread Lucas De Marchi
Sort includes alphabetically so it's easier to add/remove includes and know when that is needed. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/drm_gem.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/gpu/drm/drm_gem.c b/drivers/gpu/drm

Re: [Nouveau] [Intel-gfx] [PATCH v2 09/11] drm: Convert open-coded yes/no strings to yesno()

2022-01-26 Thread Lucas De Marchi
On Wed, Jan 26, 2022 at 12:12:50PM +0200, Andy Shevchenko wrote: On Wed, Jan 26, 2022 at 11:39 AM Lucas De Marchi wrote: linux/string_helpers.h provides a helper to return "yes"/"no" strings. Replace the open coded versions with str_yes_no(). The places were oops, I r

[Nouveau] [PATCH v2 04/11] drm/i915: Use str_enable_disable()

2022-01-26 Thread Lucas De Marchi
Remove the local enabledisable() implementation and adopt the str_enable_disable() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi Acked-by: Daniel Vetter Acked-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_ddi.c | 4 +++- drivers/gpu/drm/i915/display

[Nouveau] [PATCH v2 10/11] tomoyo: Use str_yes_no()

2022-01-26 Thread Lucas De Marchi
Remove the local yesno() implementation and adopt the str_yes_no() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi Reviewed-by: Sakari Ailus --- security/tomoyo/audit.c | 2 +- security/tomoyo/common.c | 19 +-- security/tomoyo/common.h | 1 - 3 files changed, 6

[Nouveau] [PATCH v2 00/11] lib/string_helpers: Add a few string helpers

2022-01-26 Thread Lucas De Marchi
with other work going in drm-intel-next since the bulk of the rename is there. I tried to figure out acks and reviews from v1 and apply them to how the patches are now split. thanks Lucas De Marchi Lucas De Marchi (11): lib/string_helpers: Consolidate string helpers implementation drm/i915

[Nouveau] [PATCH v2 03/11] drm/i915: Use str_yes_no()

2022-01-26 Thread Lucas De Marchi
Remove the local yesno() implementation and adopt the str_yes_no() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi Acked-by: Daniel Vetter Acked-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_display.c | 23 +++ .../drm/i915/display/intel_display_debugfs.c | 66

[Nouveau] [PATCH v2 02/11] drm/i915: Fix trailing semicolon

2022-01-26 Thread Lucas De Marchi
me, yesno(info->display.name)); Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/i915/intel_device_info.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/i915/intel_device_info.c b/drivers/gpu/drm/i915/intel_device_info.c index 93b251b25aba..94da5a

[Nouveau] [PATCH v2 07/11] drm/amd/display: Use str_yes_no()

2022-01-26 Thread Lucas De Marchi
Remove the local yesno() implementation and adopt the str_yes_no() from linux/string_helpers.h. Signed-off-by: Lucas De Marchi --- .../drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c | 14 +- 1 file changed, 5 insertions(+), 9 deletions(-) diff --git a/drivers/gpu/drm/amd/display

Re: [Nouveau] [Intel-gfx] [PATCH 1/3] lib/string_helpers: Consolidate yesno() implementation

2022-01-20 Thread Lucas De Marchi
On Wed, Jan 19, 2022 at 10:06:35AM -0500, Steven Rostedt wrote: On Wed, 19 Jan 2022 11:18:59 +0200 Sakari Ailus wrote: On Tue, Jan 18, 2022 at 11:24:48PM -0800, Lucas De Marchi wrote: > @@ -1354,8 +1345,7 @@ static bool tomoyo_print_condition(struct tomoyo_io_buffer *head, >

Re: [Nouveau] [PATCH 2/3] lib/string_helpers: Add helpers for enable[d]/disable[d]

2022-01-20 Thread Lucas De Marchi
On Wed, Jan 19, 2022 at 11:20:38AM +0200, Andy Shevchenko wrote: On Wednesday, January 19, 2022, Lucas De Marchi wrote: Follow the yes/no logic and add helpers for enabled/disabled and enable/disable - those are not so common throughout the kernel, but they give a nice way to reuse

[Nouveau] [PATCH 1/3] lib/string_helpers: Consolidate yesno() implementation

2022-01-20 Thread Lucas De Marchi
ined function should keep the const strings local to each compilation unit, the same way it's now, thus not changing the current behavior. Signed-off-by: Lucas De Marchi --- .../amd/display/amdgpu_dm/amdgpu_dm_debugfs.c | 6 +- drivers/gpu/drm/i915/i915_utils.h | 5 - .../

[Nouveau] [PATCH 2/3] lib/string_helpers: Add helpers for enable[d]/disable[d]

2022-01-20 Thread Lucas De Marchi
Follow the yes/no logic and add helpers for enabled/disabled and enable/disable - those are not so common throughout the kernel, but they give a nice way to reuse the strings to log things as enabled/disabled or enable/disable. Signed-off-by: Lucas De Marchi --- drivers/gpu/drm/i915

[Nouveau] [PATCH 0/3] lib/string_helpers: Add a few string helpers

2022-01-20 Thread Lucas De Marchi
e or maybe vsprintf. Last patch can be taken later through drm. thanks Lucas De Marchi Cc: Alex Deucher Cc: Andrew Morton Cc: Andy Shevchenko Cc: Andy Shevchenko Cc: Ben Skeggs Cc: Christian König Cc: Chris Wilson Cc: Daniel Vetter Cc: David Airlie Cc: David S. Miller Cc: Emma Anholt Cc: Ery

[Nouveau] [PATCH 3/3] drm: Convert open yes/no strings to yesno()

2022-01-20 Thread Lucas De Marchi
./drivers/gpu/drm/drm.ko 411986 104906176 428652 68a6c ./drivers/gpu/drm/drm.ko.old 1970292 1095152352 2082159 1fc56f ./drivers/gpu/drm/nouveau/nouveau.ko 1970292 1095152352 2082159 1fc56f ./drivers/gpu/drm/nouveau/nouveau.ko.old Signed-off-by: Lucas De Marchi --- drivers/gp

Re: [Nouveau] [Intel-gfx] [PATCH 0/3] lib/string_helpers: Add a few string helpers

2022-01-20 Thread Lucas De Marchi
On Wed, Jan 19, 2022 at 05:15:02PM +0100, Daniel Vetter wrote: On Wed, Jan 19, 2022 at 04:16:12PM +0200, Jani Nikula wrote: On Wed, 19 Jan 2022, Petr Mladek wrote: > On Tue 2022-01-18 23:24:47, Lucas De Marchi wrote: >> Add some helpers under lib/string_helpers.h so they ca