[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-18 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 Michel Dänzer changed: What|Removed |Added Component|Driver/nouveau |Server/General

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #8 from Chris Wilson --- (In reply to Michel Dänzer from comment #7) > (In reply to Chris Wilson from comment #6) > > -if (NewOutputPending) > > -FlushAllOutput(); > > +

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #7 from Michel Dänzer --- (In reply to Chris Wilson from comment #6) > -if (NewOutputPending) > -FlushAllOutput(); > + FlushAllOutput(); This doesn't fix the problem for me. -- You are

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #6 from Chris Wilson --- The change in 8f1edf4bd3a1f050ce9eeb5eac45dd1a8f7a6d5e is that we no longer wakeup and flush writers when space in the write queue becomes available - instead before we poll() we

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #5 from Michel Dänzer --- (In reply to Mario Kleiner from comment #3) > If otoh i run applications which use fullscreen kms page-flipped windows, > e.g., Gnome shell, or regular fullscreen GL apps, they work fine

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 Michel Dänzer changed: What|Removed |Added CC||a...@nwnk.net,

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #3 from Mario Kleiner --- Ok, i think this is related: On 1.19-rc1 (current git master) under DRI2, windowed OpenGL apps like glxgears get stuck unless i press keys on the keyboard or move the mouse to

[Nouveau] [Bug 98030] Stuttering video playback in totem after update to 1.19-rc1

2016-10-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=98030 --- Comment #2 from Ilia Mirkin --- Apparently the issue also exists with modesetting on top of nouveau - i.e. if you run e.g. LIBGL_DRI3_DISABLE=1 glxgears, you'll end up with the same lag. Trying to collect more data to