[Nouveau] [PATCH] drm: Only select I2C_ALGOBIT for drivers that actually need it

2021-05-14 Thread Uwe Kleine-König
for the individual drivers. Signed-off-by: Uwe Kleine-König --- drivers/gpu/drm/Kconfig | 5 - drivers/gpu/drm/ast/Kconfig | 2 ++ drivers/gpu/drm/gma500/Kconfig | 2 ++ drivers/gpu/drm/hisilicon/hibmc/Kconfig | 2 ++ drivers/gpu/drm/i915/Kconfig| 2

Re: [Nouveau] [PATCH] drm: Only select I2C_ALGOBIT for drivers that actually need it

2022-02-21 Thread Uwe Kleine-König
Hello, On Fri, May 14, 2021 at 12:01:42PM +0200, Uwe Kleine-König wrote: > While working on a drm driver that doesn't need the i2c algobit stuff I > noticed that DRM selects this code even tough only 8 drivers actually use > it. While also only some drivers use i2c, keep the selec

[Nouveau] [PATCH v3 14/16] drm/nouveau: Convert to platform remove callback returning void

2023-11-02 Thread Uwe Kleine-König
-by: Jyri Sarha Signed-off-by: Uwe Kleine-König --- drivers/gpu/drm/nouveau/nouveau_platform.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_platform.c b/drivers/gpu/drm/nouveau/nouveau_platform.c index 23cd43a7fd19..bf2dc7567ea4 100644

[Nouveau] [PATCH v3 00/16] drm: Convert to platform remove callback returning void

2023-11-02 Thread Uwe Kleine-König
Otherwise there is no relevant change. Best regards Uwe Uwe Kleine-König (16): drm/bridge: tpd12s015: Drop buggy __exit annotation for remove function drm/arcpgu: Convert to platform remove callback returning void drm/armada: Convert to platform remove callback returning void drm/bridge: cdn

[Nouveau] [PATCH v3] drm: Only select I2C_ALGOBIT for drivers that actually need it

2022-12-19 Thread Uwe Kleine-König
for the individual drivers. Signed-off-by: Uwe Kleine-König --- drivers/gpu/drm/Kconfig | 1 - drivers/gpu/drm/amd/amdgpu/Kconfig | 2 ++ drivers/gpu/drm/ast/Kconfig | 2 ++ drivers/gpu/drm/gma500/Kconfig | 2 ++ drivers/gpu/drm/hisilicon/hibmc/Kconfig | 2

[Nouveau] [PATCH RFC v1 26/52] drm/nouveau: Use struct drm_crtc::drm_dev instead of struct drm_crtc::dev

2023-07-12 Thread Uwe Kleine-König
Prepare dropping the alias "dev" for struct drm_crtc::drm_dev. "drm_dev" is the better name as "dev" is usually a struct device pointer. No semantic changes. Signed-off-by: Uwe Kleine-König --- drivers/gpu/drm/nouveau/dispnv04/crtc.c | 58 +++-

[Nouveau] [PATCH v2 09/12] drm/nouveau: Convert to platform remove callback returning void

2023-08-01 Thread Uwe Kleine-König
-by: Jyri Sarha Signed-off-by: Uwe Kleine-König --- drivers/gpu/drm/nouveau/nouveau_platform.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_platform.c b/drivers/gpu/drm/nouveau/nouveau_platform.c index 23cd43a7fd19..bf2dc7567ea4 100644

[Nouveau] [PATCH v2 00/12] drm: Convert to platform remove callback returning void

2023-08-01 Thread Uwe Kleine-König
Uwe Kleine-König (12): drm/armada: Convert to platform remove callback returning void drm/etnaviv: Convert to platform remove callback returning void drm/imx/dcss: Convert to platform remove callback returning void drm/imx/ipuv3: Convert to platform remove callback returning void drm

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
Hello Jani, On Wed, Jul 12, 2023 at 05:34:28PM +0300, Jani Nikula wrote: > On Wed, 12 Jul 2023, Uwe Kleine-König wrote: > > Hello, > > > > while I debugged an issue in the imx-lcdc driver I was constantly > > irritated about struct drm_device pointer variables be

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
Hello Maxime, On Wed, Jul 12, 2023 at 02:52:38PM +0200, Maxime Ripard wrote: > On Wed, Jul 12, 2023 at 01:02:53PM +0200, Uwe Kleine-König wrote: > > > Background is that this makes merge conflicts easier to handle and detect. > > > > Really? > > FWIW, I agree wi

Re: [Nouveau] [Freedreno] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
easy measurable as "conflicts when backporting", but it also matters in say two years from now, while backporting shouldn't be an issue then any more. Thanks for your input, best regards Uwe -- Pengutronix e.K. | Uwe Kleine-König| Industrial Linux Solution

Re: [Nouveau] [Freedreno] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
On Thu, Jul 13, 2023 at 10:41:45AM -0400, Sean Paul wrote: > On Thu, Jul 13, 2023 at 9:04 AM Uwe Kleine-König > > But even with the one-patch-per-rename approach I'd consider the > > renaming a net win, because ease of understanding code has a big value. > > It's value is n

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
On Wed, Jul 12, 2023 at 12:46:33PM +0200, Christian König wrote: > Am 12.07.23 um 11:46 schrieb Uwe Kleine-König: > > Hello, > > > > while I debugged an issue in the imx-lcdc driver I was constantly > > irritated about struct drm_device pointer variables be

[Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
odconfig (though I only build drivers/gpu/). Best regards Uwe Uwe Kleine-König (52): drm/crtc: Start renaming struct drm_crtc::dev to drm_dev drm/core: Use struct drm_crtc::drm_dev instead of struct drm_crtc::dev drm/amd: Use struct drm_crtc::drm_dev instead of struct drm_crtc::dev drm/arma

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
On Thu, Jul 13, 2023 at 12:03:05PM +0300, Jani Nikula wrote: > On Wed, 12 Jul 2023, Uwe Kleine-König wrote: > > Hello Jani, > > > > On Wed, Jul 12, 2023 at 05:34:28PM +0300, Jani Nikula wrote: > >> On Wed, 12 Jul 2023, Uwe Kleine-König > >> wrote: >

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
On Thu, Jul 13, 2023 at 08:52:12AM +0200, Geert Uytterhoeven wrote: > Hi Uwe, > > Let's add some fuel to keep the thread alive ;-) > > On Wed, Jul 12, 2023 at 6:13 PM Uwe Kleine-König > wrote: > > On Wed, Jul 12, 2023 at 05:34:28PM +0300, Jani Nikula wrote: > > &g

Re: [Nouveau] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-23 Thread Uwe Kleine-König
Hello Thomas, On Wed, Jul 12, 2023 at 12:19:37PM +0200, Thomas Zimmermann wrote: > Am 12.07.23 um 11:46 schrieb Uwe Kleine-König: > > Hello, > > > > while I debugged an issue in the imx-lcdc driver I was constantly > > irritated about struct drm_device pointer

[Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
[expanding recipents by the other affected persons] On Thu, Jun 08, 2023 at 09:08:15AM -0700, Doug Anderson wrote: > On Thu, Jun 1, 2023 at 8:40 AM Uwe Kleine-König > wrote: > > > > Hello, > > > > On Sun, May 07, 2023 at 06:25:23PM +0200, Uwe Kleine-König wrote:

Re: [Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
Hello Doug, On Sat, Jun 17, 2023 at 10:57:23AM -0700, Doug Anderson wrote: > On Sat, Jun 17, 2023 at 9:15 AM Uwe Kleine-König > wrote: > > > > [expanding recipents by the other affected persons] > > > > On Thu, Jun 08, 2023 at 09:08:15AM -0700, Doug Anderson wrote:

Re: [Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
Hello Maxime, On Sun, Jun 18, 2023 at 04:32:55PM +0200, Maxime Ripard wrote: > On Sun, Jun 18, 2023 at 02:39:15PM +0200, Uwe Kleine-König wrote: > > On Sat, Jun 17, 2023 at 10:57:23AM -0700, Doug Anderson wrote: > > > On Sat, Jun 17, 2023 at 9:15 AM Uwe Kleine-König > > &g

Re: [Nouveau] [PATCH 00/53] drm: Convert to platform remove callback returning void

2023-06-20 Thread Uwe Kleine-König
On Mon, May 15, 2023 at 04:50:57PM +0900, Inki Dae wrote: > Hi, > > 2023년 5월 8일 (월) 오전 1:32, Uwe Kleine-König 님이 > 작성: > > > > Hello, > > > > this patch series adapts the platform drivers below drivers/gpu/drm > > to use the .remove_new() cal

Re: [Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
On Mon, Jun 19, 2023 at 11:45:37AM +0200, Maxime Ripard wrote: > On Sun, Jun 18, 2023 at 06:29:50PM +0200, Uwe Kleine-König wrote: > > Hello Maxime, > > > > On Sun, Jun 18, 2023 at 04:32:55PM +0200, Maxime Ripard wrote: > > > On Sun, Jun 18, 2023 at 02:39:15PM

[Nouveau] [PATCH 00/53] drm: Convert to platform remove callback returning void

2023-06-20 Thread Uwe Kleine-König
that there happens some kind of cleanup later. Best regards Uwe Uwe Kleine-König (53): drm/komeda: Convert to platform remove callback returning void drm/arm/hdlcd: Convert to platform remove callback returning void drm/arm/malidp: Convert to platform remove callback returning void drm/armada

Re: [Nouveau] [PATCH 00/53] drm: Convert to platform remove callback returning void

2023-06-20 Thread Uwe Kleine-König
-- Pengutronix e.K. | Uwe Kleine-König| Industrial Linux Solutions | https://www.pengutronix.de/ | signature.asc Description: PGP signature

Re: [Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
Hello again, On Sun, Jun 18, 2023 at 02:39:15PM +0200, Uwe Kleine-König wrote: > > Actually, it was probably a mistake that these patches got merged to > > linuxnext during the 4 days that you noticed. However, your patches > > aren't dropped and are still present in drm-misc-

Re: [Nouveau] patches dropped from drm-misc-next [Was: Re: [PATCH 00/53] drm: Convert to platform remove callback returning] void

2023-06-20 Thread Uwe Kleine-König
Hello Maxime, On Mon, Jun 19, 2023 at 02:47:09PM +0200, Maxime Ripard wrote: > On Mon, Jun 19, 2023 at 12:53:42PM +0200, Uwe Kleine-König wrote: > > IMHO you still should ensure that only commits make it into any next > > snapshot via your tree before X-rc1 for some X (e.g.

Re: [Nouveau] [PATCH 00/53] drm: Convert to platform remove callback returning void

2023-06-20 Thread Uwe Kleine-König
Hello, On Sun, May 07, 2023 at 06:25:23PM +0200, Uwe Kleine-König wrote: > this patch series adapts the platform drivers below drivers/gpu/drm > to use the .remove_new() callback. Compared to the traditional .remove() > callback .remove_new() returns no value. This is a good thin

[Nouveau] [PATCH 33/53] drm/nouveau: Convert to platform remove callback returning void

2023-05-07 Thread Uwe Kleine-König
to make the remove callback return void. In the first step of this quest all drivers are converted to .remove_new() which already returns void. Trivially convert this driver from always returning zero in the remove callback to the void returning variant. Signed-off-by: Uwe Kleine-König --- drivers

Re: [Nouveau] [PATCH v3 00/16] drm: Convert to platform remove callback returning void

2023-11-20 Thread Uwe Kleine-König
[Dropped a few people from To that resulted in bounces before.] On Thu, Nov 02, 2023 at 05:56:41PM +0100, Uwe Kleine-König wrote: > Hello, > > this series converts all platform drivers below drivers/gpu/drm to use > .remove_new(). It starts with a fix for a problem that potentially m