Re: [Nouveau] NVAC "No Signal"

2017-01-20 Thread poma
On 09.01.2017 19:20, Roy Spliet wrote: > Op 09-01-17 om 00:24 schreef Ben Skeggs: >> On 12/24/2016 07:48 PM, Roy Spliet wrote: >>> I've observed this regression on my NVAC board; a 1920x1080 TV on HDMI >>> (single monitor set-up) gets no signal with Fedora kernels from 4.8. >>> Trace sent to the

Re: [Nouveau] NVAC "No Signal"

2017-01-09 Thread Roy Spliet
Op 09-01-17 om 00:24 schreef Ben Skeggs: On 12/24/2016 07:48 PM, Roy Spliet wrote: I've observed this regression on my NVAC board; a 1920x1080 TV on HDMI (single monitor set-up) gets no signal with Fedora kernels from 4.8. Trace sent to the mmio dumps mailbox. A brief scan already revealed that

Re: [Nouveau] NVAC "No Signal"

2017-01-08 Thread Ben Skeggs
On 12/24/2016 07:48 PM, Roy Spliet wrote: > I've observed this regression on my NVAC board; a 1920x1080 TV on HDMI > (single monitor set-up) gets no signal with Fedora kernels from 4.8. > Trace sent to the mmio dumps mailbox. A brief scan already revealed that > register 0xe840 is never touched,

Re: [Nouveau] NVAC "No Signal"

2016-12-28 Thread Jeff Backus
Hi all, My apologies - I'm trying to reply to a thread and the web interface doesn't play well with Mutt. I tried to hack it. Hopefully I didn't goof it up too much! I am also getting a "No Signal" on the HDMI port when the resolution changes on boot. This is on an ION-based desktop. VGA is

Re: [Nouveau] NVAC "No Signal"

2016-12-24 Thread Roy Spliet
I've observed this regression on my NVAC board; a 1920x1080 TV on HDMI (single monitor set-up) gets no signal with Fedora kernels from 4.8. Trace sent to the mmio dumps mailbox. A brief scan already revealed that register 0xe840 is never touched, so it appears that NVIDIA does something

Re: [Nouveau] NVAC "No Signal"

2016-11-22 Thread poma
On 20.10.2016 00:46, Ben Skeggs wrote: [...] > I'd like to see a mmiotrace of the NVIDIA binary driver on a system > where this WAR breaks things. I applied it to all the GPUs that NVIDIA > told me required it. > > Ben. > Still broken, more than four months, tested with mainline 4.9-rc6.

Re: [Nouveau] NVAC "No Signal"

2016-11-09 Thread Pierre Moreau
I retested with both 4.8.4, Ben’s linux-4.9 and linux-4.10 branches (so only the linux-4.10 branch had the atomic+MST patches). For all branches, if I bootplug the external screen, I get nothing on the external screen, and the laptop screen is frozen with some mix of images (but the laptop itself

Re: [Nouveau] NVAC "No Signal"

2016-11-07 Thread poma
On 21.10.2016 10:56, Pierre Moreau wrote: > On 01:15 am - Oct 21 2016, Lukas Wunner wrote: >> On Thu, Oct 20, 2016 at 10:08:28AM +0200, Lukas Wunner wrote: >>> On Wed, Oct 19, 2016 at 07:58:06PM +0200, Pierre Moreau wrote: For example, my laptop (which also has an NVAC) has been triggering

Re: [Nouveau] NVAC "No Signal"

2016-11-07 Thread poma
On 06.11.2016 18:02, poma wrote: > > http://goo.gl/Gm4ffO > mmiotrace-nouveau/ > $ uname -r 4.9.0-0.rc4.git0.1.fc26.x86_64+debug $ dmesg -t | grep -P '(?=.*nouveau)(?=.*MMIO)' nouveau :01:00.0: bus: MMIO write of 8015 FAULT at 61a804 nouveau :01:00.0: bus: MMIO read of 0010

Re: [Nouveau] NVAC "No Signal"

2016-11-06 Thread poma
http://goo.gl/Gm4ffO mmiotrace-nouveau/ ___ Nouveau mailing list Nouveau@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/nouveau

Re: [Nouveau] NVAC "No Signal"

2016-10-21 Thread Pierre Moreau
On 01:15 am - Oct 21 2016, Lukas Wunner wrote: > On Thu, Oct 20, 2016 at 10:08:28AM +0200, Lukas Wunner wrote: > > On Wed, Oct 19, 2016 at 07:58:06PM +0200, Pierre Moreau wrote: > > > For example, my laptop (which also has an NVAC) has been triggering the > > > no-signal message on external

Re: [Nouveau] NVAC "No Signal"

2016-10-20 Thread Lukas Wunner
On Thu, Oct 20, 2016 at 10:08:28AM +0200, Lukas Wunner wrote: > On Wed, Oct 19, 2016 at 07:58:06PM +0200, Pierre Moreau wrote: > > For example, my laptop (which also has an NVAC) has been triggering the > > no-signal message on external monitors way before Ben???s patch landed, > > but only for

Re: [Nouveau] NVAC "No Signal"

2016-10-20 Thread Lukas Wunner
On Wed, Oct 19, 2016 at 07:58:06PM +0200, Pierre Moreau wrote: > For example, my laptop (which also has an NVAC) has been triggering the > no-signal message on external monitors way before Ben???s patch landed, > but only for some adapters. I haven???t tried Ben???s patch yet, nor > yours, but I

Re: [Nouveau] NVAC "No Signal"

2016-10-19 Thread Ben Skeggs
On 10/20/2016 03:58 AM, Pierre Moreau wrote: > Hello, > > On 07:37 pm - Oct 19 2016, poma wrote: >> On 19.10.2016 17:03, Karol Herbst wrote: >> >>> You don't get why I try to say. We have to actually find out when to >>> apply this workaround, not to create some silly whitelist/blacklist. >>>

Re: [Nouveau] NVAC "No Signal"

2016-10-19 Thread Pierre Moreau
Hello, On 07:37 pm - Oct 19 2016, poma wrote: > On 19.10.2016 17:03, Karol Herbst wrote: > > > You don't get why I try to say. We have to actually find out when to > > apply this workaround, not to create some silly whitelist/blacklist. > > It's the last option, we never want to actually use. >

Re: [Nouveau] NVAC "No Signal"

2016-10-19 Thread poma
On 19.10.2016 17:03, Karol Herbst wrote: > You don't get why I try to say. We have to actually find out when to > apply this workaround, not to create some silly whitelist/blacklist. > It's the last option, we never want to actually use. > Well if you do not say, who can understand!? :)

Re: [Nouveau] NVAC "No Signal"

2016-10-19 Thread Karol Herbst
2016-10-19 16:47 GMT+02:00 poma : > On 18.10.2016 16:02, Karol Herbst wrote: >> well, I just don't want that this fix breaks the same thing for other >> users, that's why I am asking. >> > > Affected device ID: >

Re: [Nouveau] NVAC "No Signal"

2016-10-19 Thread poma
On 18.10.2016 16:02, Karol Herbst wrote: > well, I just don't want that this fix breaks the same thing for other > users, that's why I am asking. > Affected device ID: https://github.com/skeggsb/nouveau/blob/master/drm/nouveau/nvkm/engine/device/pci.c#L1229 can it be excluded from

Re: [Nouveau] NVAC "No Signal"

2016-10-18 Thread Karol Herbst
well, I just don't want that this fix breaks the same thing for other users, that's why I am asking. 2016-10-18 13:56 GMT+02:00 poma : > On 18.10.2016 09:35, Karol Herbst wrote: >> how sure are you, that this is needed for _every_ nvac? >> > > Thank you for asking. > >

Re: [Nouveau] NVAC "No Signal"

2016-10-18 Thread poma
On 18.10.2016 09:35, Karol Herbst wrote: > how sure are you, that this is needed for _every_ nvac? > Thank you for asking. If you consider, as relevant, referring to the original commit: "drm/nouveau/disp/g94: implement workaround for dvi issue on fx380"

Re: [Nouveau] NVAC "No Signal"

2016-10-18 Thread Karol Herbst
how sure are you, that this is needed for _every_ nvac? 2016-10-18 5:55 GMT+02:00 poma : > Fixes "No Signal" via HDMI from NVIDIA Corporation ION VGA (rev b1) > > Ref. > "drm/nouveau/disp/g94: implement workaround for dvi issue on fx380" >

[Nouveau] NVAC "No Signal"

2016-10-17 Thread poma
Fixes "No Signal" via HDMI from NVIDIA Corporation ION VGA (rev b1) Ref. "drm/nouveau/disp/g94: implement workaround for dvi issue on fx380" https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2a4bd8a The last working Fedora kernel 4.8.0-0.rc0.git3.1.fc25 Patched and