Re: [ns] regarding ns2 error :for i in indep-utils/cmu-scen-gen/setdest indep-utils/webtrace-conv/dec indep-utils/webtrace-conv/epa indep-utils/webtrace-conv/nlanr indep-utils/webtrace-conv/ucb; do (

2010-04-23 Thread Shyam Sundar

Hi siva,

The printed message is not a error.It reveals that make successful and it
checks all the following folder for making changes but the ns2 finds there
is no changes made in those files.

If your protocol is not getting implemented means then you may missed to add
your protocol in Makefile.in or your protocol has some problem.
check this for successful make
http://old.nabble.com/How-to-recomplie-ns2-using-make
-command--tp27950946p27950946.html


With Regards
S.Shyam Sundar


On Fri, Apr 23, 2010 at 12:17 PM, siva kiran balijepalli 
b.sivaki...@gmail.com wrote:


 Hello every body,

 i am implementing a new protocol. While doing make i am getting following
 things and the make gets stopped. The modifications of make are not getting
 done. please help me regarding this.

 This is the output of make:


 for i in indep-utils/cmu-scen-gen/setdest indep-utils/webtrace-conv/dec
 indep-utils/webtrace-conv/epa indep-utils/webtrace-conv/nlanr
 indep-utils/webtrace-conv/ucb; do ( cd $i; make all; ) done
 make[1]: Entering directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/cmu-scen-gen/setdest'
 make[1]: Nothing to be done for `all'.
 make[1]: Leaving directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/cmu-scen-gen/setdest'
 make[1]: Entering directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/dec'
 make[1]: Nothing to be done for `all'.
 make[1]: Leaving directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/dec'
 make[1]: Entering directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/epa'
 make[1]: Nothing to be done for `all'.
 make[1]: Leaving directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/epa'
 make[1]: Entering directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/nlanr'
 make[1]: Nothing to be done for `all'.
 make[1]: Leaving directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/nlanr'
 make[1]: Entering directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/ucb'
 make[1]: Nothing to be done for `all'.
 make[1]: Leaving directory

 `/root/Desktop/realproject/ns-allinone-2.34/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/ucb'


 thanks


 waiting for ur reply

 regards
 sivakiran.B



Re: [ns] erreur de segmantation why this error?

2010-04-23 Thread Shyam Sundar

Hi

Running scenario csmavoie-scenario.tcl
loading scenario file ..
Creating 6 nodes
num_nodes is set 6
INITIALIZE THE LIST xListHead
Starting Simulation...
channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
highestAntennaZ_ = 1.5,  distCST_ = 550.0
SORTING LISTS ...DONE!

This is not a error. This display the successful creation of your simulation

Erreur de segmentation

If you get this message immediately after the Done, it means there is a
segmentation fault in your simulation. It means that your packets cant able
to reach the destination node. There is a problem in your packet
transmission or problem in your agent. If you explore, packet transmission
through agent you may rectify the problem


With Regards
S.Shyam Sundar


On Fri, Apr 23, 2010 at 7:22 PM, Emma Ch di.anni...@yahoo.fr wrote:


 hi every body;

 i am creating a scenario for wlan using infrastructure mode.
 when running the tcl script, i have this error:

 Running scenario csmavoie-scenario.tcl
 loading scenario file ..
 Creating 6 nodes
 num_nodes is set 6
 INITIALIZE THE LIST xListHead
 Starting Simulation...
 channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
 highestAntennaZ_ = 1.5,  distCST_ = 550.0
 SORTING LISTS ...DONE!
 Erreur de segmentation

 why this error is coming? what's wrong?

 please some help







Re: [ns] Configuration of sensor node

2010-04-22 Thread Shyam Sundar

Hi,
To create wireless sensor node add this -sensorNode ON  in node-config.
Some may use mac\802_11 and some may use mac\802_15_4 (wpan) for sensor
network.
There are few sensor patches available in ns2. like sensorsim and mannasim
are available. These sensor patches are used to make different from other
wireless networks. The sensor node uses sensing work which is unavailable in
wireless.


With Regards
S.Shyam Sundar


On Thu, Apr 22, 2010 at 3:56 PM, ahlam BCH ahlam@gmail.com wrote:


 Hi
 Please is there any difference between a configuration of a wireless node
 and a sensor node?
 If yes,please can you tell me the difference.
 Best regards



Re: [ns] how to add energy model

2010-04-22 Thread Shyam Sundar

Hi,
Add the following
set val(engmodel) EnergyModel
set val(txPower) 1.0 ;# transmitting power consumed in mW
set val(rxPower) 1.0 ;# receiving power consumed in mW
set val(initeng) 1000.0 ;# Initial energy in Joules

$ns node-config   -energyModel $val(engmodel) \
-initialEnergy $val(initeng) \
-rxPower $val(rxPower) \
-txPower $val(txPower) \

With Regards
S.Shyam Sundar


On Thu, Apr 22, 2010 at 4:13 PM, jeni martin jeni_m...@yahoo.com wrote:




 --- On Thu, 4/22/10, jeni martin jeni_m...@yahoo.com wrote:








 hi all,

 i want to add an energy model to my scenario, could anyone tell me how to
 add it?
 is it enough to add these???

 set opt(energymodel)EnergyModel ;
 set opt(initialenergy)  1000

 but it dosen't work for me.

 thanks a lot







Re: [ns] help with assigning cbr connections

2010-04-21 Thread Shyam Sundar

Hi,
I am also doing dynamic clustering algorithm. I need your help how to write
the clustering algorithm in NS2. I need a sample. Please help me.

With Regards
S.Shyam Sundar


Re: [ns] Need help to transmit Video Packets via wireless

2010-04-21 Thread Shyam Sundar

Hi,
I am trying to transmit video packet via wireless network.I tried Evalvid
for transmission of video but video packets getting dropped. Please help me.
I need any sample for video transmission in pure wireless network


With Regards
S.Shyam Sundar


Re: [ns] voice and video traffic in ns2(help)

2010-04-21 Thread Shyam Sundar

Hi,
I am trying to transmit video packet via wireless network.I tried Evalvid
for transmission of video but video packets getting dropped. Please help me.
I need any sample for video transmission in pure wireless network


With Regards
S.Shyam Sundar


Re: [ns] Video Streaming Simulation

2010-04-21 Thread Shyam Sundar

Hi,
I am trying to transmit video packet via wireless network.I tried Evalvid
for transmission of video but video packets getting dropped. Please help me.
I need any sample for video transmission in pure wireless network


With Regards
S.Shyam Sundar


Re: [ns] Simulation of real time video in ns2

2010-04-21 Thread Shyam Sundar

Hi,
I am trying to transmit video packet via wireless network.I tried Evalvid
for transmission of video but video packets getting dropped. Please help me.
I need any sample for video transmission in pure wireless network


With Regards
S.Shyam Sundar


Re: [ns] streaming video over wireless networks

2010-04-21 Thread Shyam Sundar

Hi
I saw your mail in ns users group. I am trying to do the same using Evalvid
but the video packets getting dropped in my scenario. Please help me.

With Regards
S.Shyam Sundar


[ns] Re : UDP agent in wireless topology

2010-04-20 Thread Shyam Sundar

With Regards
S.Shyam Sundar


-- Forwarded message --
From: Shyam Sundar handsomesun...@gmail.com
Date: Tue, Apr 20, 2010 at 8:25 PM
Subject: ARP problem in wireless networks
To: andrey.krend...@cttc.es, ns-users@isi.edu, yasser.t...@gmail.com,
bluem...@hotmail.com, wg.nsm...@gmail.com


Hi,
I saw your mail in ns2 groups. I am also has similar problem. I need to send
packet from node 0 to node 1 and then to node 2. ie from node 0 to node 2
via node 1. When send CBR packet to node 1, after ifqLen all the CBR packets
gets dropped and someother routing packet gets send to node 2. Please help
me soon. Please I need a sample tcl for the above scenario. Thanks in
advance.


With Regards
S.Shyam Sundar


[ns] request for help about how to get MAC link in my Program

2010-04-20 Thread Shyam Sundar

Hi,
I saw your mail in ns2 groups. I am also has similar problem. I need to send
packet from node 0 to node 1 and then to node 2. ie from node 0 to node 2
via node 1. When send CBR packet to node 1, after ifqLen all the CBR packets
gets dropped and someother routing packet gets send to node 2. Please help
me soon. Please I need a sample tcl for the above scenario. Thanks in
advance.


With Regards
S.Shyam Sundar


Re: [ns] here is a wirless code if it helps you have look

2010-04-20 Thread Shyam Sundar

Hi,
I saw your mail in ns2 groups. I am also has similar problem. I need to send
packet from node 0 to node 1 and then to node 2. ie from node 0 to node 2
via node 1. When send CBR packet to node 1, after ifqLen all the CBR packets
gets dropped and someother routing packet gets send to node 2. Please help
me soon. Please I need a sample tcl for the above scenario. Thanks in
advance.


With Regards
S.Shyam Sundar


[ns] ARP problem in wireless networks

2010-04-20 Thread Shyam Sundar

Hi,
I saw your mail in ns2 groups. I am also has similar problem. I need to send
packet from node 0 to node 1 and then to node 2. ie from node 0 to node 2
via node 1. When send CBR packet to node 1, after ifqLen all the CBR packets
gets dropped and someother routing packet gets send to node 2. Please help
me soon. Please I need a sample tcl for the above scenario. Thanks in
advance.


With Regards
S.Shyam Sundar


[ns] Help with energy consumption measurement

2010-04-16 Thread Shyam Sundar

Hi,

I saw your post on ns users group. I am also working on the same. I need to
fetch energy of a node with respect to time. Please help me out.
Thanks


With Regards
S.Shyam Sundar


[ns] How to get a graph for time and power consumption using XGRAPH for a scenario wid energy model....

2010-04-16 Thread Shyam Sundar

Hi,

I am also working on the same type of xgraph generation. I need to compare
energy model of a node. So i need to get energy of a node Vs time trace. If
you get any solution please help me out.

Thanks in advance


With Regards
S.Shyam Sundar


[ns] Xgraph for LEACH

2010-04-16 Thread Shyam Sundar

Hi,
I saw your post on ns-users group. I am also working on the same. If you get
any solution please reply me soon. Thanks in advance.


With Regards
S.Shyam Sundar


[ns] Priority Queue for wireless network

2010-04-08 Thread Shyam Sundar

Hi,

My project is about transfering packets with multiple queues in wireless
network. If anyone have sample to transfer packets in different queues for
different priority.Please i need a sample. Thank you.

With Regards
S.Shyam Sundar


Re: [ns] Error when running etmp4 of Evalvid

2010-03-25 Thread Shyam Sundar

Hi,

I am also new to myevalvid. I tried to use this in cygwin in windows, it is
working fine. xvid, MP4BOX, mp4trace, etmp4 are available only in exe
format. So it ll working in windows.
Can you tell me how to use this in linux system?

With Regards
S.Shyam Sundar


On Thu, Mar 25, 2010 at 4:32 PM, Nestor Michael C. Tiglao 
nmctig...@yahoo.com wrote:


 Hello,

 Following the steps in 
 http://140.116.72.80/~smallko/ns2/myevalvid2.htmhttp://140.116.72.80/%7Esmallko/ns2/myevalvid2.htm,
 I get the following error when I run etmp4:

 etmp4 -p -x sd_a01 rd_a01 st_a01 a01.mp4 a01e
 *** loss_a01e.txt ***: percentage of lost [frames|packets]
 column 1: I (including H)
 column 2: P
 column 3: B
 column 4: overall

 *** delay_a01e.txt ***: jitter/delay statistics
 column 1: [frame|packet] id
 column 2: loss flag
 column 3: end-to-end delay [s]
 column 4: sender inter [frame|packet] lag [s]
 column 5: receiver inter
  [frame|packet] lag [s]
 column 6: cumulative jitter [s] [Hartanto et. al.]

 *** rate_s_a01e.txt ***: sender rate
 column 1: time [s]
 column 2: momentary rate [bytes/s]
 column 3: cumulative rate [bytes/s]

 *** rate_r_a01e.txt ***: receiver rate
 column 1: time [s]
 column 2: momentary rate [bytes/s]
 column 3: cumulative rate [bytes/s]

 *** glibc detected *** etmp4: double free or corruption (fasttop):
 0x099066e8 ***
 === Backtrace: =
 /lib32/libc.so.6[0xf7e96044]
 /lib32/libc.so.6(cfree+0x96)[0xf7e980d6]
 etmp4[0x807b412]
 etmp4[0x807d317]
 etmp4[0x804c440]
 etmp4[0x804d7c3]
 etmp4[0x804dc1e]
 /lib32/libc.so.6(__libc_start_main+0xe5)[0xf7e3c685]
 etmp4[0x8049271]
 === Memory map: 
 08048000-080b r-xp  08:05
  2535398/usr/local/bin/etmp4
 080b-080b1000 rw-p 00067000 08:05 2535398
 /usr/local/bin/etmp4
 09902000-09945000 rw-p 09902000 00:00 0
 [heap]
 f7a0-f7a21000 rw-p f7a0 00:00 0
 f7a21000-f7b0 ---p f7a21000 00:00 0
 f7be2000-f7e26000 rw-p f7be2000 00:00 0
 f7e26000-f7f7e000 r-xp  08:05
  12509189   /lib32/libc-2.8.90.so
 f7f7e000-f7f8 r--p 00158000 08:05 12509189
 /lib32/libc-2.8.90.so
 f7f8-f7f81000 rw-p 0015a000 08:05 12509189
 /lib32/libc-2.8.90.so
 f7f81000-f7f84000 rw-p f7f81000 00:00 0
 f7f84000-f7fa8000 r-xp  08:05 12509193
 /lib32/libm-2.8.90.so
 f7fa8000-f7fa9000 r--p 00023000 08:05
  12509193   /lib32/libm-2.8.90.so
 f7fa9000-f7faa000 rw-p 00024000 08:05 12509193
 /lib32/libm-2.8.90.so
 f7fae000-f7fbb000 r-xp  08:05 2819601
 /usr/lib32/libgcc_s.so.1
 f7fbb000-f7fbc000 r--p c000 08:05 2819601
 /usr/lib32/libgcc_s.so.1
 f7fbc000-f7fbd000 rw-p d000 08:05
  2819601/usr/lib32/libgcc_s.so.1
 f7fbd000-f7fc2000 rw-p f7fbd000 00:00 0
 f7fc2000-f7fc3000 r-xp f7fc2000 00:00 0
 [vdso]
 f7fc3000-f7fe1000 r-xp  08:05 12509186
 /lib32/ld-2.8.90.so
 f7fe1000-f7fe2000 r--p 0001d000 08:05 12509186
 /lib32/ld-2.8.90.so
 f7fe2000-f7fe3000 rw-p
  0001e000 08:05 12509186   /lib32/ld-2.8.90.so
 ffece000-ffee3000 rw-p 7ffea000 00:00 0
 [stack]
 Aborted

 I executed the command in Ubuntu 8.10 on a Quad core machine.  What could
 be the problem here?


 Nestor Tiglao
 Instituto Superior Técnico
 Lisbon, Portugal



[ns] evalvid wireless problem

2010-03-22 Thread Shyam Sundar

Hi,

I am trying to use  evalvid for wireless network. I am getting wrong
receiving trace.
can anyone please help me, what is the problem in my tcl file? Am i need to
change myevalvid.cc to work for wireless node?

sending trace file

0.00 id 0udp 1252
0.04 id 1udp 1252
0.08 id 2udp 1252
0.12 id 3udp 1252
0.16 id 4udp 1252
0.20 id 5udp 1252
0.24 id 6udp 1252
0.28 id 7udp 1252
0.32 id 8udp 1252
0.36 id 9udp 1252

receiving trace file

0.484667 id 4984354  udp 264
0.494607 id 4984354  udp 1020
0.502140 id 4984354  udp 244
0.529636 id 4984354  udp 1020
0.533389 id 4984354  udp 244
0.570076 id 4984354  udp 1020
0.573989 id 4984354  udp 244
0.609856 id 4984354  udp 1020

With Regards
S.Shyam Sundar


Re: [ns] evalvid wireless problem

2010-03-22 Thread Shyam Sundar

Hi,

I just followed the steps which is given in this site
http://140.116.72.80/~smallko/ns2/myevalvid2.htm
which is working perfectly. I need for wireless network, so i tried wireless
code for myevalvid but it is generating a wrong receiver trace.

With Regards
S.Shyam Sundar


On Mon, Mar 22, 2010 at 2:24 PM, pedro chaparro pdr...@gmail.com wrote:

 have u tried already evalvid over a wire topology?? it works well there?

 2010/3/22 Shyam Sundar handsomesun...@gmail.com


 Hi,

 I am trying to use  evalvid for wireless network. I am getting wrong
 receiving trace.
 can anyone please help me, what is the problem in my tcl file? Am i need
 to
 change myevalvid.cc to work for wireless node?

 sending trace file

 0.00 id 0udp 1252
 0.04 id 1udp 1252
 0.08 id 2udp 1252
 0.12 id 3udp 1252
 0.16 id 4udp 1252
 0.20 id 5udp 1252
 0.24 id 6udp 1252
 0.28 id 7udp 1252
 0.32 id 8udp 1252
 0.36 id 9udp 1252

 receiving trace file

 0.484667 id 4984354  udp 264
 0.494607 id 4984354  udp 1020
 0.502140 id 4984354  udp 244
 0.529636 id 4984354  udp 1020
 0.533389 id 4984354  udp 244
 0.570076 id 4984354  udp 1020
 0.573989 id 4984354  udp 244
 0.609856 id 4984354  udp 1020

 With Regards
 S.Shyam Sundar




 --
 Ing Pedro Alonso Chaparro Valero
 Ciudad Politecnica de la Innovación
 iTEAM - Mobile Communications Group
 Polytechnic University of Valencia
 C\ Camino de Vera S/N, Edificio 8G
 46022 Valencia, Spain



Re: [ns] How to recomplie ns2 using make command?

2010-03-19 Thread Shyam Sundar

Hi,

Follow these procedure
1. Goto ns2 location in terminal ( If you are using ns-allinone-2.xx, then
goto ns-allinone-2.xx/ns2x)
for example: cd /usr/share/ns-allinone-2.34/ns2.34
2. then type ./configure in terminal
3. then type make clean (*optional)[use this, If you want to recompile the
whole ns2. This will remove all the object files in ns2. i.e xx.o files get
removed]
4. then type make [ this will make all object files which are missing]


Note: If you are creating/editing/deleting any of files in ns2 folder, you
must make changes in Makefile.in which is available in ns2 folder before
doing the above steps.


With Regards
S.Shyam Sundar


On Fri, Mar 19, 2010 at 5:22 PM, The Learner
deeptisabnani.i...@pec.edu.inwrote:




 what is the procedure to recompile ns2 using make command?

 --
 View this message in context:
 http://old.nabble.com/How-to-recomplie-ns2-using-make-command--tp27950947p27950947.html
 Sent from the ns-users mailing list archive at Nabble.com.




Re: [ns] please remove me from NS2 user group

2010-03-14 Thread Shyam Sundar

go to this link and type your id at unsubscribe text box and click
unsubscribe. Then you wont get further mails from ns2 users group.

http://mailman.isi.edu/mailman/listinfo/ns-users

If you want to avoid more mails from ns2, for those case dont unsubscribe
your id. Better go to your login and edit your option to digest message
which will send you 10 -15 messages as a single...

With Regards
S.Shyam Sundar


On Mon, Mar 15, 2010 at 9:07 AM, al ael...@cox.net wrote:


 ael...@cox.net




[ns] Fwd: multimedia packet in wsn

2010-03-04 Thread Shyam Sundar

-- Forwarded message --
From: Shyam Sundar handsomesun...@gmail.com
Date: Fri, Mar 5, 2010 at 11:21 AM
Subject: multimedia packet in wsn
To: ns-users@isi.edu


Hi,
I need to send multimedia packets (like audio,video traces) through
wireless  sensor network.If anyone have any sample ns2 program for
multimedia streaming thro'  any network more preferrable wsn. please help me

-- 
With Regards
S.Shyam Sundar



-- 
With Regards
S.Shyam Sundar


[ns] mannasim - ns2.34

2010-02-24 Thread Shyam Sundar

Hi,

I am trying to convert mannasim for ns-allinone-2.29 to ns-allinone-2.34.
Once i converted all ns modified files of ns-2.29 to ns-2.34. I can able to
make it successfully, but i cant able to run mannasim tcl code. During the
make the following warning appears on the screen. So anyone please help out
of this warning.


With Regards
S.Shyam Sundar

Make of mannasim in ns-allinone-2.34

accessPointLeachApp.o mannasim/leach/app/accessPointLeachApp.cc
In file included from mannasim/leach/app/../../processing.h:48,
 from mannasim/leach/app/../../accessPointApp.h:46,
 from mannasim/leach/app/accessPointLeachApp.h:5,
 from mannasim/leach/app/accessPointLeachApp.cc:2:
mannasim/leach/app/../../dataGenerator.h: In member function ‘virtual
AppData* DataGenerator::collect()’:
mannasim/leach/app/../../dataGenerator.h:95: warning: no return statement in
function returning non-void
mannasim/leach/app/../../dataGenerator.h: In member function ‘virtual
AppData* DataGenerator::getMaximumAllowedValue()’:
mannasim/leach/app/../../dataGenerator.h:133: warning: no return statement
in function returning non-void
mannasim/leach/app/../../dataGenerator.h: At global scope:
mannasim/leach/app/../../dataGenerator.h:66: warning: inline function
‘virtual void EventTimer::expire(Event*)’ used but never defined
mannasim/leach/app/../../dataGenerator.h:53: warning: inline function
‘virtual void SensingTimer::expire(Event*)’ used but never defined
mannasim/leach/app/../../sensorBaseApp.h:83: warning: inline function
‘virtual void DisseminatingTimer::expire(Event*)’ used but never defined
g++ -c -Wall -Wno-write-strings  -DTCP_DELAY_BIND_ALL -DNO_TK
-DTCLCL_CLASSINSTVAR  -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL
-DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H
-DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H  -DHAVE_CONFIG_H
-DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE
-Drng_test  -I. -I. -I/usr/share/ns-allinone-2.34/tclcl-1.19
-I/usr/share/ns-allinone-2.34/otcl -I/usr/share/ns-allinone-2.34/include
-I/usr/share/ns-allinone-2.34/include -I/usr/share/ns-allinone-2.34/include
-I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc
-I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier
-I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr
-I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv
-I./satellite -I./wpan -o diffusion3/lib/nr/nr.o diffusion3/lib/nr/nr.cc
g++ -c -Wall -Wno-write-strings  -DTCP_DELAY_BIND_ALL -DNO_TK
-DTCLCL_CLASSINSTVAR  -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL
-DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H
-DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H  -DHAVE_CONFIG_H
-DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE
-Drng_test  -I. -I. -I/usr/share/ns-allinone-2.34/tclcl-1.19
-I/usr/share/ns-allinone-2.34/otcl -I/usr/share/ns-allinone-2.34/include
-I/usr/share/ns-allinone-2.34/include -I/usr/share/ns-allinone-2.34/include
-I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc
-I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier
-I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr
-I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv
-I./satellite -I./wpan -o diffusion3/lib/dr.o diffusion3/lib/dr.cc
diffusion3/lib/dr.cc: In member function ‘virtual int
DiffusionRouting::send(long int, NRAttrVec*)’:
diffusion3/lib/dr.cc:442: warning: suggest parentheses around  within ||
g++ -c -Wall -Wno-write-strings  -DTCP_DELAY_BIND_ALL -DNO_TK
-DTCLCL_CLASSINSTVAR  -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL
-DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H
-DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H  -DHAVE_CONFIG_H
-DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE
-Drng_test  -I. -I. -I/usr/share/ns-allinone-2.34/tclcl-1.19
-I/usr/share/ns-allinone-2.34/otcl -I/usr/share/ns-allinone-2.34/include
-I/usr/share/ns-allinone-2.34/include -I/usr/share/ns-allinone-2.34/include
-I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc
-I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier
-I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr
-I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv
-I./satellite -I./wpan -o diffusion3/filters/diffusion/one_phase_pull.o
diffusion3/filters/diffusion/one_phase_pull.cc
g++ -c -Wall -Wno-write-strings  -DTCP_DELAY_BIND_ALL -DNO_TK
-DTCLCL_CLASSINSTVAR  -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL
-DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H
-DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H  -DHAVE_CONFIG_H
-DNS_DIFFUSION -DSMAC_NO_SYNC 

[ns] Shedule UID error

2010-02-24 Thread Shyam Sundar

Hi,
I am trying to modify mannasim files to work on ns-allinone-2.34. For this i
just added few mannasim code into mac-802_11.cc file of ns-allinone-2.34.
After this modification ns throwing sheduler: UID error. So anyone please
help me.

With Regards
S.Shyam Sundar


[ns] cluster implementation

2010-02-21 Thread Shyam Sundar

Hi,

Any one implemented cluster algorithm in wireless. Please i need
implementation of cluster setup algorithm in ns2. Please help me. my mail id
handsomesun...@gmail.com


With Regards
S.Shyam Sundar


[ns] Multimedia Packet

2010-02-16 Thread Shyam Sundar

Hi,
I am new to ns2. I am using ns-allinone-2.34. I need to send multimedia
streaming through wireless nodes. Does anyone know how to send a multimedia
files/packets through wireless networks? Please reply me soon.

With Regards
S.Shyam Sundar


[ns] Multimedia Packet

2010-02-11 Thread Shyam Sundar

Hi,

My project is all about sending a multimedia packet through WSN in NS2. So
please help me, how to send multimedia packets through NS2.

-- 
With Regards
S.Shyam Sundar


Re: [ns] NS2.26 with NRLSensorsim on Fedora 8

2010-02-10 Thread Shyam Sundar

Hi,
I am usinf fedora 10. I followed the steps which you gave on blog. But still
it get failed during tclcl installation of ns-allinone-2.26. So please help
me out of this problem. I need to use nrlsensorsim for my project.

-- 
With Regards
S.Shyam Sundar

On Wed, Feb 10, 2010 at 5:34 PM, Mohit Tahiliani mohit.ni...@yahoo.comwrote:

 Hello,

 Due to newer versions of gcc, ns2.26 with nrlsensorsim cannot be installed
 directly.

 Hence i have designed few patches that help to install ns2.26 with
 nrlsensorsim on fedora 8 (and possibly with other linux distributions having
 similar gcc version).

 The patches and the installation procedure can be found on the link given
 below:


 http://mohittahiliani.blogspot.com/2010/02/installing-ns226-with-nrlsensorsim-on.html

 Hope it helps.

 Regards,
 Mohit P. Tahiliani

[r...@localhost nrlsensorsim]# patch -p1 -t  ns226nrl226-2.patch 
patching file sensornets-NRL/sensoragent.h
Reversed (or previously applied) patch detected!  Assuming -R.


r...@localhost nrlsensorsim]# ./patch_script.sh 

CHECKING PATH AND PERMISSIONS ON ../ns-allinone-2.1b9a/ OR ../ns-allinone-2.26/

PATH AND PERMISSIONS ARE GOOD


Checking for recently modified files...
WARNING!!! I THINK I FOUND MODIFIED FILES IN THE ../ns-allinone-2.26 TREE!
PATCHES MAY NOT WORK CORRECTLY ON ALREADY MODIFIED FILES!

Do you want to try anyway? (yes/no)
yes

Okay, trying anyway...
  NS2 tree is unmodified.  Good.

COPYING PHENOM AND SENSERNET-NRL DIRECTORIES TO ../ns-allinone-2.26/

`phenom' - `../ns-allinone-2.26/ns-2.26/phenom'
`phenom/debug.cpp' - `../ns-allinone-2.26/ns-2.26/phenom/debug.cpp'
`phenom/debug.h' - `../ns-allinone-2.26/ns-2.26/phenom/debug.h'
`phenom/readme.ian' - `../ns-allinone-2.26/ns-2.26/phenom/readme.ian'
`phenom/phenom_packet.h' - `../ns-allinone-2.26/ns-2.26/phenom/phenom_packet.h'
`phenom/phenom.h' - `../ns-allinone-2.26/ns-2.26/phenom/phenom.h'
`phenom/phenom.cc' - `../ns-allinone-2.26/ns-2.26/phenom/phenom.cc'
`sensornets-NRL' - `../ns-allinone-2.26/ns-2.26/sensornets-NRL'
`sensornets-NRL/sensorapp02.h' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensorapp02.h'
`sensornets-NRL/sensoragent.cc' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensoragent.cc'
`sensornets-NRL/sensoragent.h.orig' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensoragent.h.orig'
`sensornets-NRL/sensorapp02.cc' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensorapp02.cc'
`sensornets-NRL/sensorapp.cc' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensorapp.cc'
`sensornets-NRL/sensoragent.h' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensoragent.h'
`sensornets-NRL/sensorapp.h' - 
`../ns-allinone-2.26/ns-2.26/sensornets-NRL/sensorapp.h'
`nrlolsr' - `../ns-allinone-2.26/ns-2.26/nrlolsr'
`nrlolsr/debug.cpp' - `../ns-allinone-2.26/ns-2.26/nrlolsr/debug.cpp'
`nrlolsr/nbr_queue.h' - `../ns-allinone-2.26/ns-2.26/nrlolsr/nbr_queue.h'
`nrlolsr/debug.h' - `../ns-allinone-2.26/ns-2.26/nrlolsr/debug.h'
`nrlolsr/nrlolsr_packet.h' - 
`../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr_packet.h'
`nrlolsr/nbr_queue.cc' - `../ns-allinone-2.26/ns-2.26/nrlolsr/nbr_queue.cc'
`nrlolsr/nrlolsr.cc' - `../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr.cc'
`nrlolsr/nrlolsr_rtable.cc' - 
`../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr_rtable.cc'
`nrlolsr/nrlolsr_rqueue.h' - 
`../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr_rqueue.h'
`nrlolsr/nrlolsr_rtable.h' - 
`../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr_rtable.h'
`nrlolsr/nrlolsr_rqueue.cc' - 
`../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr_rqueue.cc'
`nrlolsr/readme' - `../ns-allinone-2.26/ns-2.26/nrlolsr/readme'
`nrlolsr/nrlolsr.h' - `../ns-allinone-2.26/ns-2.26/nrlolsr/nrlolsr.h'
`nrlolsr/sysdefs.h' - `../ns-allinone-2.26/ns-2.26/nrlolsr/sysdefs.h'
`nrlolsr/basicmhop.tcl' - `../ns-allinone-2.26/ns-2.26/nrlolsr/basicmhop.tcl'

DONE COPYING DIRECTORIES


PATCHING ns-allinone-2.26.

Hmm...  Looks like a normal diff to me...
Patching file ../ns-allinone-2.26/ns-2.26/trace/cmu-trace.cc using Plan A...
Hunk #1 succeeded at 54.
Hunk #2 succeeded at 114.
Hunk #3 succeeded at 1011.
done
Hmm...  Looks like a normal diff to me...
Patching file ../ns-allinone-2.26/ns-2.26/trace/cmu-trace.h using Plan A...
Hunk #1 succeeded at 123.
done
Hmm...  Looks like a normal diff to me...
Patching file ../ns-allinone-2.26/ns-2.26/mac/mac.cc using Plan A...
Hunk #1 succeeded at 108.
Hunk #2 succeeded at 115.
done
Hmm...  Looks like a normal diff to me...
Patching file ../ns-allinone-2.26/ns-2.26/Makefile.in using Plan A...
Hunk #1 succeeded at 277.
Hunk #2 succeeded at 281.
Hunk #3 succeeded at 315.
Hunk #4 succeeded at 319.
done
Hmm...  Looks like a normal diff to me...
Patching file ../ns-allinone-2.26/ns-2.26/tcl/lib/ns-lib.tcl using Plan A...
Hunk #1 succeeded at 310.
Hunk #2 succeeded at 312.
Hunk #3 succeeded at 320.
Hunk #4 succeeded at 339.
Hunk #5 succeeded at 350.
Hunk #6 succeeded at 425.
Hunk #7 succeeded at 465.
Hunk #8 succeeded at 567.
Hunk #9 succeeded at 607.
Hunk #10 succeeded at 662.
Hunk #11 

[ns] How to include phenom.cc and phenom.h

2010-02-03 Thread Shyam Sundar

Hi,
I am working on Wireless Sensor network. I searched and find that
nrlsensorsim can be used for WSN. but nrlsensorsim is available only for
ns-allinone-2.26 which is a out dated version. I am using ns-allinone-2.34
in which some of the sensor packages are included. In ns-allinone-2.34,
sensor simulating packages like phenom.cc  phenom.h are not included. Can
anyone help me how to include those two packages into ns-allinone-2.34? so
that i can able to use that without anyproblem...

-- 
With Regards
S.Shyam Sundar


[ns] Fwd: WSN for ns-allinone-2.34

2010-02-02 Thread Shyam Sundar

-- Forwarded message --
From: Shyam Sundar handsomesun...@gmail.com
Date: Tue, Feb 2, 2010 at 6:58 PM
Subject: Re: [ns] WSN for ns-allinone-2.34
To: Ruchik Jani janiruc...@yahoo.co.in


Hi,

Thanks Jani. I referred both the materials but both didnt mentioned about
wireless sensor network. It is given only about wired  wireless both
stationary and non-stationary nodes. I need information about stationary
wireless sensor network.

-- 

With Regards
S.Shyam Sundar


On Tue, Feb 2, 2010 at 12:02 PM, Ruchik Jani janiruc...@yahoo.co.in wrote:

 Hello,

 You first refer to Mac-Griew's Tutorial available on NS site. and NS-Manual
 you will find answer of your question.

 With warm regards,

 Ruchik N. Jani,
 Lecturer,
 Information Technology Department,
 V.V.P. engineering college,
 Rajkot.

 --- On *Tue, 2/2/10, Shyam Sundar handsomesun...@gmail.com* wrote:


 From: Shyam Sundar handsomesun...@gmail.com
 Subject: [ns] WSN for ns-allinone-2.34
 To: ns-users@ISI.EDU
 Date: Tuesday, 2 February, 2010, 7:56 AM



 Hi,
 I am new to network simulator. can anyone help me how to use wireless
 sensor
 network(WSN) in ns-allinone-2.34? Is there any patch required for
 ns-allinone-2.34 to use WSN?

 --
 With Regards
 S.Shyam Sundar


 --
 Your Mail works best with the New Yahoo Optimized IE8. Get it 
 NOW!http://in.rd.yahoo.com/tagline_ie8_new/*http://downloads.yahoo.com/in/internetexplorer/
 .








-- 
With Regards
S.Shyam Sundar


[ns] WSN for ns-allinone-2.34

2010-02-01 Thread Shyam Sundar

Hi,
I am new to network simulator. can anyone help me how to use wireless sensor
network(WSN) in ns-allinone-2.34? Is there any patch required for
ns-allinone-2.34 to use WSN?

-- 
With Regards
S.Shyam Sundar