[NTG-context] luatex crash around page 1000

2019-04-12 Thread Akira Kakuto
The event manager says, that it is a stack exhaustion (0xc0fd, STATUS_STACK_OVERFLOW). Many thanks. I'll increase size of stack. Best, Akira ___ If your question is of interest to others as well, please add an

[NTG-context] luatex crash around page 1000

2019-04-12 Thread Akira Kakuto
mtx-context | fatal error: return code: -1073741571 I suspect that may be a limitation in 32bit binary. Try to install 64bit ConTeXt if you are using 32bit one and your OS is 64bit. Best, Akira ___ If your

[NTG-context] textext with plain MetaFun

2019-01-21 Thread Akira Kakuto
> You should see the text at the bottom left. > It seems that there is a string _s_ not initialized. If I remove all _s_ in mp-text.mpii, metafun test.mp worked for hobbiestextext := true; beginfig(1) draw textext("MetaFun") ; endfig; end. Best, Akira

[NTG-context] MetaPost shading broken with latest beta

2018-06-23 Thread Akira Kakuto
With this, I get a full A4 page with the shading colors. This worked until the beta 2018-06-22 16:02 and the desired output is shown when using live.contextgarden.net. Even in the previous mtx-context | current version: 2018.06.22 15:55 I get a full A4 page with the shading colors if I use

[NTG-context] beta

2018-06-23 Thread Akira Kakuto
On Linux armhf i get with the same context and luatex: ... 1.09.0 is varying. Please see Development id by luatex --credits Best, Akira ___ If your question is of interest to others as well, please add an entry to

[NTG-context] beta

2018-06-22 Thread Akira Kakuto
I get the same error after the update with \starttext \externalfigure[A] \stoptext where A.pdf is in the current folder. I'm on windows 10. Here it works OK: LuaTeX, Version 1.09.0 Development id: 6822 Thanks, Akira

[NTG-context] Asymptote with Context

2017-11-01 Thread Akira Kakuto
If this has something to do with OpenGL, a properly built asymptote might solve the problem. I'm using on windows the cygwin binary provided by the Asymptote developers: http://asymptote.sourceforge.net/ The binary is included in TeX Live 2017 for windows. context ntg71.tex works fine. Akira

[NTG-context] problem loading attachments (important for my work)

2017-06-08 Thread Akira Kakuto
Could anyone confirm the issue in Windows? Here, in both of examples below, the file is successfully attached in Windows: \setupinteraction[state=start] \setupinteractionscreen[option=attachment] \setuppapersize[A5, landscape] \setuppagenumbering[location=] \starttext File:

[NTG-context] slashes in paths (Lua code)

2017-05-31 Thread Akira Kakuto
Directories are a problem here. I mean, \shatwo{Desktop/i-context.pdf} cannot work in Windows. Here both of your example and an example by Hans worked fine on Windows. Note that \shatwo{Desktop/i-context.pdf} works only if the current directory is your %USERPROFILE%. Best, Akira

[NTG-context] mathdigits no longer works

2017-05-15 Thread Akira Kakuto
The small modification I was talking about ... The following change for Mohammad's one may also be ok: \startttext \switchtobodyfont[minionmath] ---> \switchtobodyfont[minionmath] \starttext Best, Akira ___

[NTG-context] Location of primes and strange latin modern font

2017-05-14 Thread Akira Kakuto
Will the primes also get fixed? In the latest standalone (I downloaded it minutes ago), I get the attached result running the same test file. It seems that the primes are not yet fixed in mtx-context | current version: 2017.05.14 19:09 It requires, for example: \starttext Compare

[NTG-context] Problem loading a DLL with the latest Ctx beta

2017-04-08 Thread Akira Kakuto
Any way to re-enable user DLL loading into ConTeXt, even in the future, would be appreciated... I have just uploaded dynamically linked luatex and luajittex. I hope that you can again load your lua DLL modules in a few days. Further, standard C functions can be used in ffi without loading a C

[NTG-context] Problem loading a DLL with the latest Ctx beta

2017-04-06 Thread Akira Kakuto
How exactly do you mean to combine "ffi" and "--shell-escape" to work with latest ConTeXt/LuaTeX? In usual luatex, ffi needs --shell-escape, since ffi is dangerous from the point of view of the security. As you know, ConTeXt allows --shell-escape, so the following works with context test.tex.

[NTG-context] Problem loading a DLL with the latest Ctx beta

2017-04-05 Thread Akira Kakuto
I encountered problem loading WinCon.dll (a module that I wrote and I've been using for several years) In the new lua(jit)tex, one cannot use DLL modules. See my mail in http://tug.org/pipermail/luatex/2017-March/006410.html http://tug.org/pipermail/luatex/2017-March/006413.html Reason: I

[NTG-context] Specifying the cell column: are \TD[n] and \TD[m] broken?

2017-02-19 Thread Akira Kakuto
(Context Standalone, ver. 2017.01.27, ver. 2017.02.19) and in context from TeX Live 2016 (ver. 2016.05.17) these two examples give identical tables that differ from results on the wiki page. Confirmed. ConTeXt mkii gives results on the wiki page. Best, Akira

[NTG-context] LuaTeX 1.0.3 announcement

2017-02-18 Thread Akira Kakuto
Luigi has shown me a simple and useful application of ffi: In the case of lua(jit)tex in W32TeX, which are used in context, standard C libraries are linked statically. Thus it is necessary to load a necessary DLL for standard C functions, like the following meaningless example: \starttext $$

[NTG-context] cambria.ttc problem

2016-09-29 Thread Akira Kakuto
Yes, right, but after mtxrun --script fonts --reload the regular cambria disappears again. Confirmed. mtxrun --script fonts --reload --force gives a solution. Best, Akira ___ If your question is of interest to

[NTG-context] cambria.ttc problem

2016-09-29 Thread Akira Kakuto
it seems that luatex 1.0.0 doesn't recognise the cambria normal ... I experienced the same problem. After removing font caches, I can obtain normal shape cambria. Best, Akira ___ If your question is of interest to

[NTG-context] bug in latest beta?

2016-09-05 Thread Akira Kakuto
the following sample gives a Lua error with latest beta (2016.09.04 13:46): Compilation is fine in the latest luatex 0.98.4 with mtx-context | current version: 2016.09.04 13:46. -- Akira ___ If your question

Re: [NTG-context] command reference not searchable

2016-05-20 Thread Akira Kakuto
mtxrun --launch context-todo.pdf Thanks a lot. mtxrun --launch i-context.pdf worked fine. Best, Akira ___ If your question is of interest to others as well, please add an entry to the Wiki! maillist :

[NTG-context] command reference not searchable

2016-05-19 Thread Akira Kakuto
It will be convenient for TeX Live users if i-context.pdf is copied like $TEXMF/doc/context/documents/general/commands/i-context.pdf Then one can read it by texdoc i-context.pdf Best, Akira ___ If your question is

[NTG-context] Luatex 0.95.0 error with bidi and Hebrew

2016-05-01 Thread Akira Kakuto
Code: ... My installation, or is this a bug? Confirmed. By testing i, your example is compiled: if i then -- line 1205 in font-otj.lua local leftkern = i.leftkern if leftkern and leftkern ~= 0 then setfield(prev,"replace",newkern(leftkern)) -- maybe also leftkern end end

[NTG-context] beta

2016-01-30 Thread Akira Kakuto
Doesn’t work here. This is LuaTeX, Version beta-0.88.0 (TeX Live 2016/dev) (INITEX) Here there is no problem with This is LuaTeX, Version beta-0.89.0 (TeX Live 2016/W32TeX/dev) Does the version 2016.01.29 19:00 require beta-0.89.0? Best, Akira

Re: [NTG-context] Synchronize ERROR: unknown node type 12

2015-12-20 Thread Akira Kakuto
Will this update also appear in the ConTeXt standalone version? Alan On Sun, Dec 20, 2015 at 10:30 AM, Akira Kakuto wrote: ... ... I have updated web2c/synctexdir/synctex-luatex.h in the TeX Live SVN to support synctex in beta-0.87.0. The latest beta-0.87.0 binaries for win32 and win64

Re: [NTG-context] Synchronize ERROR: unknown node type 12

2015-12-20 Thread Akira Kakuto
I have updated web2c/synctexdir/synctex-luatex.h in the TeX Live SVN to support synctex in beta-0.87.0. The latest beta-0.87.0 binaries for win32 and win64 support synctex. For the other platforms, it was too late for the released beta-0.87.0 sources. SyncTeX will be supported in beta-0.87.1

[NTG-context] Synchronize ERROR: unknown node type 12

2015-12-20 Thread Akira Kakuto
indeed, as synctex used different node numbers than luatex (and is maintained outside the luatex source tree) ... btw as i never use synctex this went unnoticed I have updated web2c/synctexdir/synctex-luatex.h in the TeX Live SVN to support synctex in beta-0.87.0. Thanks, Akira

[NTG-context] new bets

2015-12-17 Thread Akira Kakuto
l.397 ...edef\pdfreplacefont {\pdfvariable r eplacefont} Your ConTeXt must be older than mtx-context | current version: 2015.12.17 15:57 Best, Akira

[NTG-context] Bug with ConTeXt and pgfplot library fillbetween

2015-10-26 Thread Akira Kakuto
\starttext \the\catcode`| \catcode`|=12 \catcodetable\ctxcatcodes \the\catcode`| \stoptext mkiv gives 13, and 12. mkii gives 13, and 13. Best, Akira ___ If your question is of interest to others as well,

Re: [NTG-context] ConTeXt installation problem with Windows 8.1

2015-05-02 Thread Akira Kakuto
Dear Mojca, There's also completely untested temporary http://minimals.contextgarden.net/setup2/ [A] In context-setup-win32.zip the following are 64bit binaries: (01) kpathsea620w64.dll can be removed (02) kpathsea621w64.dll can be removed (03) lua52w64.dll can be removed since

Re: [NTG-context] ConTeXt installation problem with Windows 8.1

2015-04-30 Thread Akira Kakuto
Dear Mojca, I don't know installers, so ... I have read first-setup.bat and have recognized that binaries for LuaTeX and LuajitTeX themselves in the zip are not installed. Sorry for my misunderstanding. Best, Akira

[NTG-context] ConTeXt installation problem with Windows 8.1

2015-04-29 Thread Akira Kakuto
Dear Mojca, Please try again (you need to download http://distribution.contextgarden.net/setup/context-setup-mswin.zip again). I added the missing dll. If any other file is still missing, please say which file exactly. That is a mixup of 32bit and 64bit binaries. Note that dlls and exes are

[NTG-context] SyncTeX and mkiv

2015-04-07 Thread Akira Kakuto
Dear Mojca, Here (1) context --synctex filename (2) context --synctex=1 filename (3) context --synctex=-1 filename all work. (1) and (2) are equivalent. \enabledirectives[system.synctex] \starttext ... ... \stoptext in a source does not work correctly. (Input files are not recorded in a data

[NTG-context] Different versions of Lua and error in the same versions of ConTeXt (Fedora vs Win7)

2015-02-22 Thread Akira Kakuto
The point is that Pablo Rodriguez use Fedora 20, which comes with Lua-5.2.2. I think TeX Live 2014 uses Lua-5.2.3 on all platforms. I don't know differences between 5.2.2 and 5.2.3. Current windows version of standalone ConTeXt also uses 5.2.3. Best, Akira

[NTG-context] \executesystemcommand dont work?

2015-02-17 Thread Akira Kakuto
Dear Jaroslav, I tested path settings, but it seems it is OK (c:\windows\system32 is in my PATH) Sorry for my mistake. Very difficult problem!! % latex.tex \documentclass{article} \begin{document} \immediate\write18{echo } \end{document} should print ... ... No

[NTG-context] \executesystemcommand dont work?

2015-02-17 Thread Akira Kakuto
Dear Jaroslav, See your PATH carefully. For example I find a space between C:\1da\support\batch; and C:\Ruby\bin;C:\Windows\system32 i.e., C:\1da\support\batch; C:\Ruby\bin;C:\Windows\system32 There are many such spaces which should be removed. I think quotations such as C:\Program Files

[NTG-context] \executesystemcommand dont work?

2015-02-17 Thread Akira Kakuto
Dear Jaroslav, Does anyone know how to fix it? I'm not ConTeXt expert and I'm not Windows expert too. I don't know a reason, but ... Very rare case: c:\windows\system32 is erased from your PATH by an accident, so cmd.exe cannot be found by luatex. Please check the PATH variable on your

[NTG-context] \executesystemcommand dont work?

2015-02-17 Thread Akira Kakuto
No file latex.aux. (./latex.aux) ) No pages of output. OK, as I said previously, c:\windows\system32 does not exist in your PATH. In your command prompt echo 000 will work, but cmd /c echo 000 will not work. Please test in your command prompt set PATH=c:\windows\system32;%PATH% pdflatex

[NTG-context] \executesystemcommand dont work?

2015-02-16 Thread Akira Kakuto
Dear Jaroslav, Here your lines fonts'fallback modern-designsize rm 12pt' is loaded test before calling shell command test after calling shell command close source 2 3 C:/$~1da/ConTeXt/ConTeXt-Tests/my_way/ScanCSV/t-scancs... are like fonts

[NTG-context] Code that run in Metapost but not in starMPcode enviroment

2015-02-01 Thread Akira Kakuto
What is wrong with this code? Interestingly it seems to work in mkii, probably because mkii calls external metafun: context --pdftex --passon=--shell-escape test.tex test.pdf is attached. Best, Akira test.pdf Description: Adobe PDF document

Re: [NTG-context] Code that run in Metapost but not in starMPcode enviroment

2015-02-01 Thread Akira Kakuto
Interestingly it seems to work in mkii, probably because mkii calls external metafun: Sorry, I didn't notice explanation by Hans. Best, Akira ___ If your question is of interest to others as well, please add an

[NTG-context] plot data from file: cld

2015-01-03 Thread Akira Kakuto
Dear John, How to make this a polygon? An example: \starttext \startluacode local metafun = context.metafun metafun.start() io.input(DATA) local i, j local x, y, s, t1, t2 i = 1 x={} y={} s=draw while true do x[i], y[i] = io.read(*n, *n) if not x[i] then break end metafun(filldraw

[NTG-context] bug in beta from 2014.12.29 10:01

2014-12-31 Thread Akira Kakuto
$ contextjit --version mtxrun | unknown script 'context.lua' or 'mtx-context.lua' I have reproduced it, after some trials, by removing files in trees in cache. So try mtxrun --generate Best, Akira ___

[NTG-context] luatex files

2014-12-30 Thread Akira Kakuto
Dear Idris Samawi Hamid, What is the minimum set of files are needed to update luatex? They are luajittex.dll, and luatex.dll. Best, Akira ___ If your question is of interest to others as well, please add an

[NTG-context] Define a new type section with metafun

2014-12-27 Thread Akira Kakuto
Dear Fabrice, A try and error method which you may not want: % macros=mkvi \setuppapersize[A4][A4] \setupcolors[state=start,cmyk=yes,mpcmyk=yes] \definecolor[mycolor][c=0.45,m=0.00,y=0.1,k=0.00] \definecolor[colortext][c=1,m=0.00,y=0.3,k=0.3] \starttext \startuniqueMPgraphic{funny} path p ;

Re: [NTG-context] PSTricks in Context

2014-12-16 Thread Akira Kakuto
Hi Luigi, The example works if one copies colo-rgb.mkii as colo-rgb.tex in the same folder of the example ... It is OK by changing line 46 in m-pstricks.mkii: \loadpstrickscolors{colo-rgb}} to \loadpstrickscolors{colo-rgb.mkii}} as Herbert said. In the recent beta's, the change was

[NTG-context] PSTricks in Context

2014-12-15 Thread Akira Kakuto
Anyway, the version in TeX Live now runs, but creates wrong results (it prints out (0,0)(3,3) instead of drawing the line for example). In the case of mtx-context | current version: 2014.12.11 12:02 The following is OK. % % context test.tex % \usemodule[pstricks] \starttext

[NTG-context] pgfplots broken?

2014-11-04 Thread Akira Kakuto
Can confirm not working in latest Beta. It looks like there is no problem here. mtx-context | current version: 2014.11.04 11:02 Best, Akira open source 1 1 c:/usr/local/share/texmf-dist/tex/context/base/cont-yes.mkiv ConTeXt ver: 2014.11.04 11:02 MKIV beta fmt: 2014.11.4 int:

Re: [NTG-context] pgfplots broken?

2014-11-04 Thread Akira Kakuto
you can try with \enabletrackers[resolvers.swiglib] to see what gets checked I (if you meant me) get the attached log file. A log file in my case for \enabletrackers[resolvers.swiglib] \usemodule[pgfplots] \starttext Foo \stoptext is attached. Best, Akira open source 1 1

Re: [NTG-context] pgfplots broken?

2014-11-04 Thread Akira Kakuto
Dear Mikael, An example from PGFPlots Gallery. Please try if it works. Here on windows, it seems to work. Attached files are tt.log.txt and tt.pdf. Best, Akira % % tt.tex: from PGFPlots Gallery % \setupcolors[state=start] \usemodule[tikz] \usemodule[pgfplots] \starttext \midaligned{%

[NTG-context] korean unfonts globbing path error

2014-10-23 Thread Akira Kakuto
hi below is error message But i don,t know how korean unfonts is default in ConTeXt system i know help The example worked on my windows. However, after removing all cache files, I can confirm the crash. Best, Akira

Re: [NTG-context] korean unfonts globbing path error

2014-10-23 Thread Akira Kakuto
Hi Hans, mtxrun --script font --reload --force --trackers=* and see at what font it aborts? Thanks a lot. Interestingly the command ran without abort, and names.tma and names.tmc are successfully created. After the creation of names.tma and names.tmc, the example by NY Park works fine again.

[NTG-context] error in animation

2014-10-01 Thread Akira Kakuto
Works fine with ConTeXt ver: 2014.09.26 11:42 MKIV beta Jeong is saying about ConTeXt ver: 2014.09.27 14:46 MKIV beta which contains a bug. Best, Akira ___ If your question is of interest to others as well,

Re: [NTG-context] about Noto Sans CJK font problem

2014-09-27 Thread Akira Kakuto
There may be another problem which I don’t know. I have tested your source by installing NotoSansCJKkr-Regular.otf etc. It seems to work OK. Note that I'm using .otf fonts, not .ttf ones. I attach cjkkrtest.tar.gz in which there are k.tex and k.pdf. Best, Akira cjkkrtest.tar.gz Description:

[NTG-context] about Noto Sans CJK font problem

2014-09-27 Thread Akira Kakuto
However the resulting PDF shows incorrect characters. Incorrect characters are in Hirakana and Katakana. The incorrect Japanese characters are also shown in the case of SourceHanSans-Regular.otf, the same feature in the case of NotoSansCJKjp-Regular.otf. On the other hand, if I use

[NTG-context] about Noto Sans CJK font problem

2014-09-27 Thread Akira Kakuto
Hi Hans, ... ... gives the same output here. You must be testing with the 1.000 fonts. Yes, version 1.000 fonts worked with the ConTeXt. Best, Akira ___ If your question is of interest to others as well, please

Re: [NTG-context] about Noto Sans CJK font problem

2014-09-27 Thread Akira Kakuto
new beta ... it took me quite some tracing and time to figure out that we can better ignore the Identity cidmap .. Thank you very much. The PDF is correct now with 1.001 HanSans CJK fonts. Best regards, Akira ___

[NTG-context] about Noto Sans CJK font problem

2014-09-27 Thread Akira Kakuto
But I still get an error message which is as same as Luigi mentioned. Here the TeX Live 2014 version: 0.79.1 (rev 4971) does not work with the NotoSansCJKkr-Regular.otf. I'm using the current trunk version: 0.79.1 (rev 5041). Experimental version (rev 5057) will be better. Best, Akira

[NTG-context] about Noto Sans CJK font problem

2014-09-26 Thread Akira Kakuto
Recently, I installed “Noto Sans CJK” font which is developed by Adobe and Google. After “mtxrun —generate”, luatex locates the font. For test, I run the following code and got “fatal error:no return code” message. Even though I didn’t include Korea test, it says the same error message. In

Re: [NTG-context] Fany break - no solution?

2014-08-24 Thread Akira Kakuto
The first and the second line are processed without problems. The third command produces some output and hangs then after ?language 'en‘ is enabled?. After terminating with ^C, I get this: Sorry. You should first make and edit the files mkiiexample.tex and mkivexample.tex in the current

[NTG-context] Fany break - no solution?

2014-08-23 Thread Akira Kakuto
Who can tell me what to do? Try on the terminal /usr/local/texlive/2014/bin/x86_64-darwin/context --generate /usr/local/texlive/2014/bin/x86_64-darwin/texexec mkiiexample.tex /usr/local/texlive/2014/bin/x86_64-darwin/context mkivexample.tex If the path is different, use your own path. Best,

[NTG-context] Intsalling modules - once more

2014-08-18 Thread Akira Kakuto
If nobody can tell me how to install the module ”fancybreak« on Mac OS ... It may be OK by the following: After checking files /usr/local/texlive/texmf-local/doc/context/third/fancybreak/fancybreak-doc.pdf /usr/local/texlive/texmf-local/doc/context/third/fancybreak/README

[NTG-context] Bug with vimtyping: no line numbers

2014-08-12 Thread Akira Kakuto
\starttext \startlinenumbering \input knuth \stoplinenumbering \stoptext The line numbers seem better in mkii than in mkiv. Best regards, Akira ___ If your question is of interest to others as well, please add an

[NTG-context] underbraces get progressively more misaligned (w/ minimal example)

2014-07-04 Thread Akira Kakuto
It does also depend on the width of the text because when I use 48pt in the example below the height of the brace is always the same but with 49pt the height increases after the first page. An experiment: width = 48.0719985pt height = 4.968pt (constant) width = 48.0719986pt height =

[NTG-context] Problem with module lettrine

2014-07-03 Thread Akira Kakuto
I send a minimal example to know why it looks bad the initial letter using the module lettrine . I am using TeXLive 2013 under Windows XP. mtx-context | current version: 2014.06.27 10:53 gives an attached one on windows. Best, Akira test.pdf Description: Adobe PDF document

[NTG-context] [***SPAM***] context works, contextjit fails with Junicode

2014-07-02 Thread Akira Kakuto
I can confirm the error when font cache is empty. After creation of font cache by executing context test.tex, contextjit test.tex ran ok: This is LuajitTeX, Version beta-0.79.1 (TeX Live 2014/W32TeX) (rev 5024) \write18 enabled. open source 1 1

[NTG-context] Fwd: bug in switch.rb

2013-11-02 Thread Akira Kakuto
Hi Hans, /usr/local/texlive/2013/texmf-dist/scripts/context/ruby/base/switch.rb:501: You added two lines in the latest swith.rb: #encoding: ASCII-8BIT # module: base/switch ... ... There may be no errors if the new switch.rb is used. Best, Akira

[NTG-context] [fontloader] cached fonts have invalid tounicode values

2013-06-27 Thread Akira Kakuto
Hi Philipp, I’ve traced it to luatex-basics-gen.lua. luaotfload-basics-gen.lua and luaotfload-merged.lua? Thank you very much. Akira ___ If your question is of interest to others as well, please add an entry to

Re: [NTG-context] Anyone using dvipdfmx in minimals?

2011-07-14 Thread Akira Kakuto
Dear Mojca, I'm trying to remember why we are shipping dvipdfmx in ConTeXt: was it because of Aleph or because of Eastern scripts? Aleph is no more supported as a ConTeXt engine because it is not etex-2.* compatible. Therefore you can remove dvipdfmx from the minimals. Thanks, Akira

Re: [NTG-context] Anyone using dvipdfmx in minimals?

2011-07-14 Thread Akira Kakuto
Dear Mojca, Therefore you can remove dvipdfmx from the minimals. I'm personally using dvipdfmx in ConTeXt on an engines eptex (experimental), and dvi mode of pdftex. But I believe it is not needed in the 'minimals'. Thanks, Akira

Re: [NTG-context] synctex broken

2010-03-23 Thread Akira Kakuto
Hi Taco, Synctex support should be fixed in the latest revision (3536). Thanks very much. I have confirmed that synctex works as before in revision 3536. Thanks, Akira ___ If your question is of interest to others