Re: [NTG-context] Macro argument handling problem!

2011-04-23 Thread Verhaag, G.C.H.M.
On 04/21/2011 01:32 PM, Wolfgang Schuster wrote: Am 21.04.2011 um 12:28 schrieb Verhaag, G.C.H.M.: Hi, I try this example from the wiki page System Macros/Argument handling: \def\dodefinesomething[#1][#2]% {\getparameters[\??xx#1][#2]} \def\definesomething%

[NTG-context] Macro argument handling problem!

2011-04-21 Thread Verhaag, G.C.H.M.
Hi, I try this example from the wiki page System Macros/Argument handling: \def\dodefinesomething[#1][#2]% {\getparameters[\??xx#1][#2]} \def\definesomething% {\dodoubleargumentwithset\dodefinesomething} \starttext \definesomething[alfa][variable=test] \stoptext Running this yields !

Re: [NTG-context] Macro argument handling problem!

2011-04-21 Thread Wolfgang Schuster
Am 21.04.2011 um 12:28 schrieb Verhaag, G.C.H.M.: Hi, I try this example from the wiki page System Macros/Argument handling: \def\dodefinesomething[#1][#2]% {\getparameters[\??xx#1][#2]} \def\definesomething% {\dodoubleargumentwithset\dodefinesomething} \starttext

Re: [NTG-context] Macro argument handling problem!

2011-04-21 Thread luigi scarso
On Thu, Apr 21, 2011 at 1:32 PM, Wolfgang Schuster schuster.wolfg...@googlemail.com wrote: Am 21.04.2011 um 12:28 schrieb Verhaag, G.C.H.M.: Hi, I try this example from the wiki page System Macros/Argument handling: \def\dodefinesomething[#1][#2]%  {\getparameters[\??xx#1][#2]}

Re: [NTG-context] Macro argument handling problem!

2011-04-21 Thread Wolfgang Schuster
Am 21.04.2011 um 13:35 schrieb luigi scarso: On Thu, Apr 21, 2011 at 1:32 PM, Wolfgang Schuster schuster.wolfg...@googlemail.com wrote: Am 21.04.2011 um 12:28 schrieb Verhaag, G.C.H.M.: Hi, I try this example from the wiki page System Macros/Argument handling: