Re: [NTG-context] Strange problem related to \usemodule

2011-10-10 Thread Hongwen Qiu
It seems that if I copied all of the module files under the current
directory, it works perfectly.
And of course mtxrun --locate t-vim.tex gives the correct location just
as indicated by my previously attached log file.

And there's only one environment variable corresponding to TeX settings:
$ env |grep -i TEX
PATH=/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-linux-64/bin: (It's
very long)

Actually not only the modules under tex/texmf-modules not work on the
Remote, but also modules under tex/texmf-local don't work either.

On Mon, 2011-10-10 at 12:57 +0800, Hongwen Qiu wrote:
 Hi,
 
 I have access to three machines both running GNU/Linux x86-64, I call
 them Laptop, Desktop and Remote respectively here on.
 
 The Laptop has full access to the internet, so I always install and
 upgrade my ConTeXt Standalone on it when I'm home.
 
 At workplace, I can surfer the internet with the Desktop while the
 RSYNC port is blocked.
 
 I only can access the Remote through ssh from the Desktop without
 root privilege and can not access the internet.
 
 So, I always copied the ConTeXt standalone from my Laptop onto my
 Desktop, and from my Desktop onto Remote if necessary. Then, I'll
 delete the cache before I set the PATH to the appropriate location and
 run context --make and mtxrun --generate.
 
 So the ConTeXt standalones are almost identical on both my Desktop and
 Remote. And the following minimal example just works fine on my
 Desktop but failed on the Remote,
 === Minimal Example 
 \usemodule[vim]
 
 \definevimtyping[RUBY][syntax=ruby]
 
 \starttext
 
 \startRUBY
 puts Hello
 \stopRUBY
 
 \stoptext
 =
 Actually, on Remote, whatever module I use, it will prompt the
 Undefined Control Sequence error regarding the first command I used from
 that module with the module loaded correctly. Attached is the error log
 accompany the above minimal example.
 
 So, what can be the problem with my Remote.
 
 TIA. for any help. 


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] doublesided layout with floating text blocks wrapped in the main text

2011-10-10 Thread Alexandre Leray

Hi,

how can I insert text blocks of texts of half the width of the text zone 
(+ gutter) tand make the main text flow wrap around them?
I'd like the blocks to be aligned on the outer side of the page (the 
document is doublesided).


My guess was to use floats but I don't need captions. Could you give me 
a snipet of how i'd need to do it?


You'll find a quick example of what I have in mind at this address:

http://stdin.fr/wrapped_text.pdf

Thanks!

Alex

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] doublesided layout with floating text blocks wrapped in the main text

2011-10-10 Thread luigi scarso
On Mon, Oct 10, 2011 at 11:31 AM, Alexandre Leray
newslett...@alexandreleray.com wrote:
 Hi,

 how can I insert text blocks of texts of half the width of the text zone (+
 gutter) tand make the main text flow wrap around them?
 I'd like the blocks to be aligned on the outer side of the page (the
 document is doublesided).

 My guess was to use floats but I don't need captions. Could you give me a
 snipet of how i'd need to do it?

 You'll find a quick example of what I have in mind at this address:

 http://stdin.fr/wrapped_text.pdf

 Thanks!
Do they have fixed dimensions ?
If so maybe column sets can help:
cfr. http://wiki.contextgarden.net/Columns#Column_Sets
-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] doublesided layout with floating text blocks wrapped in the main text

2011-10-10 Thread Alexandre Leray

Thanks,

Unfortunatly they don't have a fixed height... any other option?

;)

Alex

On 10/10/2011 11:38, luigi scarso wrote:

On Mon, Oct 10, 2011 at 11:31 AM, Alexandre Leray
newslett...@alexandreleray.com  wrote:

Hi,

how can I insert text blocks of texts of half the width of the text zone (+
gutter) tand make the main text flow wrap around them?
I'd like the blocks to be aligned on the outer side of the page (the
document is doublesided).

My guess was to use floats but I don't need captions. Could you give me a
snipet of how i'd need to do it?

You'll find a quick example of what I have in mind at this address:

http://stdin.fr/wrapped_text.pdf

Thanks!

Do they have fixed dimensions ?
If so maybe column sets can help:
cfr. http://wiki.contextgarden.net/Columns#Column_Sets


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] jump to PDF page

2011-10-10 Thread Hans Hagen

On 9-10-2011 18:57, Steffen Wolfrum wrote:


Am 28.09.2010 um 16:38 schrieb Hans Hagen:


I'll upload a beta that supports

\setupinteraction[state=start]

\starttext
\startstandardmakeup
no page
\stopstandardmakeup
one \goto{page 2}[page(2)]
one \goto{realpage 2}[realpage(2)]
one \goto{userpage 2}[userpage(2)]
\page
two \goto{page 1}[page(1)]
two \goto{realpage 1}[realpage(1)]
two \goto{userpage 1}[userpage(1)]
\stoptext




The last one

\goto{...}[userpage(...)]

doesn't work anymore!


fixed in next beta

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Strange problem related to \usemodule

2011-10-10 Thread Hans Hagen

On 10-10-2011 06:57, Hongwen Qiu wrote:


Actually, on Remote, whatever module I use, it will prompt the
Undefined Control Sequence error regarding the first command I used from
that module with the module loaded correctly. Attached is the error log
accompany the above minimal example.

So, what can be the problem with my Remote.


weird, as the log mentions that the file is loaded

can you run with \enabletrackers[modules.loading]

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] Possible bug with \date in french

2011-10-10 Thread Romain Diss
Hi,

Since a recent upgrade of the beta the \date command give day+ octobre 2011 
if \mainlanguage[fr] is set. Minimal example:

\mainlanguage[fr]
\starttext
\date
\language[en]
(\date)
\stoptext

A rapid search lead me to these lines (560-571) in lang-def.mkiv:
\installlanguage
  [\s!fr]
  [\c!spacing=\v!packed,
  (...)
  \c!date={\v!day+,\v!space,\v!month,\v!space,\v!year}]

where the day+ appears. Several lines further (line 670), one found:
\defineconversion [\s!fr] [\v!day+] [\frordinaldaynumber]

but I have not find any file defining \frordinaldaynumber (except lang-
ita.mkii for MKII). Is there something to fix in the beta or is there 
something I missed ?

Thank you in advance.

-- 
Romain Diss
romain.d...@yahoo.fr
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Any (other) ConTeXt users in Finland?

2011-10-10 Thread Mari Voipio
On Wed, Oct 5, 2011 at 15:20, Martin Schröder mar...@oneiros.de wrote:
 I just checked the nordic TUGS:
 - Nordic TeX (http://folk.uio.no/dag/ntug/) seems to be long dead
 - Danish TUG (http://www.tug.dk/) is active
 - CyrTUG (http://www.cemi.rssi.ru/cyrtug/) gives a page not found
 - ÍsTeX (http://www3.hi.is/pub/istex/) seems to be dormant

 So there is room for a Finnish TUG :-)

Well, this far I'm up to *4* ConTeXt users resident in Finland - me,
my brother Ville, Salil and Otso. Which doubles the amount of users I
know, but still...
(Alan is in France and Martin, AFAIK, in Germany, so they don't count
even though they replied to this thread.)

While by Finnish law 3 can make an official society/organization, I
think we'll stick to informal meetings this far. At least we four are
all in the same area so getting together is somewhat possible,
especially as I have a meeting space at my disposal.


BUT: Nobody else in Finland???


Best Regards/Terveisin,

Mari Voipio
Vantaa, Finland
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Any (other) ConTeXt users in Finland?

2011-10-10 Thread Alan Braslau
On Mon, Oct 10, 2011 at 03:42:36PM +0300, Mari Voipio wrote:
 (Alan is in France and Martin, AFAIK, in Germany, so they don't count
 even though they replied to this thread.)

My reply was just as a suggestion for the 7th International ConTeXt Users' 
Meeting in 2013. :)

Alan
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Possible bug with \date in french

2011-10-10 Thread Hans Hagen

On 10-10-2011 14:39, Romain Diss wrote:

Hi,

Since a recent upgrade of the beta the \date command give day+ octobre 2011
if \mainlanguage[fr] is set. Minimal example:

\mainlanguage[fr]
\starttext
 \date
 \language[en]
 (\date)
\stoptext

A rapid search lead me to these lines (560-571) in lang-def.mkiv:
\installlanguage
   [\s!fr]
   [\c!spacing=\v!packed,
   (...)
   \c!date={\v!day+,\v!space,\v!month,\v!space,\v!year}]

where the day+ appears. Several lines further (line 670), one found:
\defineconversion [\s!fr] [\v!day+] [\frordinaldaynumber]

but I have not find any file defining \frordinaldaynumber (except lang-
ita.mkii for MKII). Is there something to fix in the beta or is there
something I missed ?


does day:mnem work ok?


-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] doublesided layout with floating text blocks wrapped in the main text

2011-10-10 Thread luigi scarso
On Mon, Oct 10, 2011 at 1:37 PM, Alexandre Leray
newslett...@alexandreleray.com wrote:
 Thanks,

 Unfortunatly they don't have a fixed height... any other option?

 ;)
http://www.mail-archive.com/ntg-context@ntg.nl/msg27842.html


-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Possible bug with \date in french

2011-10-10 Thread Romain Diss
On 10-10-2011, you wrote
 On 10-10-2011 14:39, Romain Diss wrote:
  Hi,
  
  Since a recent upgrade of the beta the \date command give day+ octobre
  2011 if \mainlanguage[fr] is set. Minimal example:
  
  \mainlanguage[fr]
  \starttext
  
   \date
   \language[en]
   (\date)
  
  \stoptext
  (...)
 does day:mnem work ok?
I had :
\setuplanguage [fr] [date={day:mnem,space,month,space,year}]
to the minimal exemple and it prints 10 mai 2011.

Don’t know if it is exactly what you meant I should test but it seems to 
work... 

-- 
Romain Diss
romain.d...@yahoo.fr
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Possible bug with \date in french

2011-10-10 Thread Hans Hagen

On 10-10-2011 18:35, Romain Diss wrote:

On 10-10-2011, you wrote

On 10-10-2011 14:39, Romain Diss wrote:

Hi,

Since a recent upgrade of the beta the \date command give day+ octobre
2011 if \mainlanguage[fr] is set. Minimal example:

\mainlanguage[fr]
\starttext

  \date
  \language[en]
  (\date)

\stoptext
(...)

does day:mnem work ok?

I had :
\setuplanguage [fr] [date={day:mnem,space,month,space,year}]
to the minimal exemple and it prints 10 mai 2011.

Don’t know if it is exactly what you meant I should test but it seems to
work...


day+ was a shortcut for day:mnem (or actually it was there before we had 
:mnem) but in mkiv that shortcut is gone


-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Strange problem related to \usemodule

2011-10-10 Thread Hongwen Qiu
On Mon, 2011-10-10 at 14:09 +0200, Hans Hagen wrote:
 can you run with \enabletrackers[modules.loading]
Attached is the log with \enabletrackers[modules.loading].
(b.tex

ConTeXt  ver: 2011.10.08 11:42 MKIV  fmt: 2011.10.10  int: english/english

system   cont-new.mkiv loaded
(/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-context/tex/context/base/cont-new.mkiv
system   beware: some patches loaded from cont-new.mkiv
)
system   b.top loaded

system   options  start used options

used options % runtime options files (command line driven)
used options \unprotect
used options % feedback and basic job control
used options % handy for special styles
used options \startluacode
used options document = document or { }
used options document.arguments={
used options }
used options document.files={
used options  b.tex,
used options }
used options \stopluacode
used options % process info
used options \setupsystem[inputfile=b.tex]
used options \setupsystem[\c!n=1,\c!m=1]
used options % modes
used options % options (not that important)
used options \startsetups *runtime:options
used options \stopsetups
used options % styles and modules
used options \startsetups *runtime:modules
used options \stopsetups
used options % done
used options \protect \endinput

system   options  stop used options

(b.top)
fontslatin modern fonts are not preloaded
languageslanguage en is active
resolversmodules  locating: prefix: '', askedname: 'vim', truename: 'vim'
resolversmodules  checking file: 'm-vim.mkvi'
resolversmodules  checking file: 'm-vim.mkiv'
resolversmodules  checking file: 'm-vim.tex'
resolversmodules  checking file: 'm-vim.cld'
resolversmodules  checking file: 'm-vim.lua'
resolversmodules  checking file: 'p-vim.mkvi'
resolversmodules  checking file: 'p-vim.mkiv'
resolversmodules  checking file: 'p-vim.tex'
resolversmodules  checking file: 'p-vim.cld'
resolversmodules  checking file: 'p-vim.lua'
resolversmodules  checking file: 's-vim.mkvi'
resolversmodules  checking file: 's-vim.mkiv'
resolversmodules  checking file: 's-vim.tex'
resolversmodules  checking file: 's-vim.cld'
resolversmodules  checking file: 's-vim.lua'
resolversmodules  checking file: 'x-vim.mkvi'
resolversmodules  checking file: 'x-vim.mkiv'
resolversmodules  checking file: 'x-vim.tex'
resolversmodules  checking file: 'x-vim.cld'
resolversmodules  checking file: 'x-vim.lua'
resolversmodules  checking file: 'v-vim.mkvi'
resolversmodules  checking file: 'v-vim.mkiv'
resolversmodules  checking file: 'v-vim.tex'
resolversmodules  checking file: 'v-vim.cld'
resolversmodules  checking file: 'v-vim.lua'
resolversmodules  checking file: 't-vim.mkvi'
resolversmodules  checking file: 't-vim.mkiv'
resolversmodules  checking file: 't-vim.tex'
resolversmodules  loading: '/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-modules/tex/context/third/vim/t-vim.tex'
resolversmodules  loaded: 'vim'
! Undefined control sequence.

system   tex  error on line 4 in file b.tex: Undefined control sequence ...

 1 \enabletrackers[modules.loading]
 2 \usemodule[vim]
 3 
 4   \definevimtyping[RUBY][syntax=ruby]
 5 
 6 \starttext
 7 
 8 \startRUBY
 9 puts Hello
10 \stopRUBY
11 
12 \stoptext
13 

l.4 \definevimtyping
[RUBY][syntax=ruby]
? X

system   files  start used files

used files  1: filename=mult-mps.lua | filetype=tex | format=tex | foundname=/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-context/tex/context/base/mult-mps.lua | usedmethod=database
used files  2: filename=b.tex | foundname=b.tex | usedmethod=direct
used files  3: filename=cont-new.mkiv | filetype=tex | foundname=/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-context/tex/context/base/cont-new.mkiv | usedmethod=database
used files  4: filename=b.top | foundname=b.top | usedmethod=direct
used files  5: filename=lang-us.lua | filetype=lua | foundname=/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-context/tex/context/patterns/lang-us.lua | usedmethod=database
used files  6: filename=t-vim.tex | filetype=tex | foundname=/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-modules/tex/context/third/vim/t-vim.tex | usedmethod=database

system   files  stop used files


system   structure  start used structure

used structure   text: b

system   structure  stop used structure

mkiv lua stats   used config file  - selfautoparent:texmf/web2c/texmfcnf.lua
mkiv lua stats   used cache path   - 

Re: [NTG-context] Strange problem related to \usemodule

2011-10-10 Thread Aditya Mahajan

On Tue, 11 Oct 2011, Hongwen Qiu wrote:


On Mon, 2011-10-10 at 14:09 +0200, Hans Hagen wrote:

can you run with \enabletrackers[modules.loading]

Attached is the log with \enabletrackers[modules.loading].


What are the first 10-15 lines of
/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-modules/tex/context/third/vim/t-vim.tex?

The vim module usually gives a message

loadingVim syntax highlighting

(or some variation of it...I have changed the default message recently), 
but that message is missing in your log.


My guess is that the t-vim module that you have is somehow corrupted, and 
therefore, \definevimtyping command is undefined.


Aditya
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] Bug in export with \definehighlight

2011-10-10 Thread Aditya Mahajan

Compiling the following document

~~~
\definehighlight [object] [style=mono]

\setupbackend [export=yes]

\starttext
\object{test}
\stoptext
~~~

gives

backend  export  saving xml data in 'test.export
backend  export  saving css image definitions in 
'test-images.css
backend  export  saving css style definitions in 
'test-styles.css

! LuaTeX error bad argument #3 to '?' (value expected).

system   tex  error on line 0 in file : LuaTeX error  ...

empty file

* ./test
   \stoptext


Aditya
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Strange problem related to \usemodule

2011-10-10 Thread Hongwen Qiu
On Mon, 2011-10-10 at 23:09 -0400, Aditya Mahajan wrote:
 What are the first 10-15 lines of
 /ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-modules/tex/context/third/vim/t-vim.tex?

$ head
-15 
/ifs2/S2PH/qiuhw/opt/context-1008/tex/texmf-modules/tex/context/third/vim/t-vim.tex
%D \module
%D   [ file=t-vim,
%D  version=2011.09.03,
%Dtitle=\CONTEXT\ User Module,
%D subtitle=Vim syntax highlighting,
%D   author=Aditya Mahajan,
%D date=\currentdate,
%Dcopyright=Aditya Mahajan,
%Demail=adityam at ieee dot org,
%D  license=Simplified BSD License]

\writestatus{loading}{Vim syntax highlighting (ver: 2011.09.03)}

\startmodule[vim]
\usemodule  [filter]

 
 The vim module usually gives a message
 
 loadingVim syntax highlighting
 
 (or some variation of it...I have changed the default message
 recently), 
 but that message is missing in your log.
 
 My guess is that the t-vim module that you have is somehow corrupted,
 and 
 therefore, \definevimtyping command is undefined. 
This couldn't be the problem (anyhow, I attached the 15 lines of
t-vim.tex above), since I have said in my previous messages that if I
copied the neccessary files from the tex/texmf-modules to the current
directory it works just fine, and the problem are not only relates to
t-vim module, all of the modules under tex/texmf-modules and
tex/texmf-local just does not work.

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___