[NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Charles Doherty
Dear Hans and Wolfgang, I have started experimenting with the Lua engine through TeXShop. I use \EnglishRule in a Newsletter to separate major items. When I use it in the attached file it works as always when I use the ConteXt engine (TL2009) and in my minimals installation it works fine using

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 13:57 schrieb Charles Doherty: Dear Hans and Wolfgang, I have started experimenting with the Lua engine through TeXShop. I use \EnglishRule in a Newsletter to separate major items. When I use it in the attached file it works as always when I use the ConteXt engine

[NTG-context] Simplefonts and math fonts

2009-11-24 Thread Khaled Hosny
Though there is a \setmathfont command, it doesn't seem to work. The following example still typeset in LM. \usemodule[simplefonts] \setmathfont[Asana Math] \starttext $\sqrt{x+y}=z$ \stoptext Any idea? Regards, Khaled -- Khaled Hosny Arabic localiser and member of Arabeyes.org team Free

Re: [NTG-context] Simplefonts and math fonts

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 14:39 schrieb Khaled Hosny: Though there is a \setmathfont command, it doesn't seem to work. The following example still typeset in LM. \usemodule[simplefonts] \setmathfont[Asana Math] \starttext $\sqrt{x+y}=z$ \stoptext Any idea? For math fonts only typescripts

[NTG-context] first-setup.sh on MacOSX problem...

2009-11-24 Thread Bernhard Rosensteiner
Hello all, after my new OSX installation i did first-setup.sh as always but now i get: This is LuaTeX, Version beta-0.40.6-2009100310 (TeX Live 2009) (INITEX) \write18 enabled. (/Applications/ConTeXt/tex/texmf-context/tex/context/base/cont-en.tex ! I can't find file `context.tex'. l.16 \input

[NTG-context] Problems with wide floating tables in context mkIV

2009-11-24 Thread Massimiliano Lambertini
Hello, all Maybe this problem has been already addressed before, but I didn't find anything about it in contextgarden and ML archives. So, here you are. I have a document laid out in two columns, and some wide tables laid out using Natural Tables syntax. These tables are then placed on the

[NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Otared Kavian
Hi all, maybe more particularly Mojca, I noticed that in the latest release of the minimals (ConTeXt version 2009.11.24 10:13) something is broken: neither mkii nor mkiv work (actually this happened also with the release of Friday November 20, then it was solved with November 23 release and

Re: [NTG-context] Problems with wide floating tables in context mkIV

2009-11-24 Thread Massimiliano Lambertini
Massimiliano Lambertini wrote: Hello, all Maybe this problem has been already addressed before, but I didn't find anything about it in contextgarden and ML archives. So, here you are. Forgot some details about my tex/context distribution: I use w32tex Tex distribution on Windows. Context

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread luigi scarso
On Tue, Nov 24, 2009 at 3:31 PM, Otared Kavian ota...@gmail.com wrote: Hi all, maybe more particularly Mojca, I noticed that in the latest release of the minimals (ConTeXt version 2009.11.24 10:13) something is broken: neither mkii nor mkiv work (actually this happened also with the

Re: [NTG-context] Problems with wide floating tables in context mkIV

2009-11-24 Thread luigi scarso
On Tue, Nov 24, 2009 at 3:29 PM, Massimiliano Lambertini nof0...@iperbole.bologna.it wrote: Hello, all Maybe this problem has been already addressed before, but I didn't find anything about it in contextgarden and ML archives. So, here you are. I have a document laid out in two columns, and

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Mojca Miklavec
On Tue, Nov 24, 2009 at 15:31, Otared Kavian wrote: Hi all, maybe more particularly Mojca, I noticed that in the latest release of the minimals (ConTeXt version 2009.11.24 10:13) something is broken: neither mkii nor mkiv work (actually this happened also with the release of Friday

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Charles Doherty
Dear Wolfgang, I deleted my Minimals folder and did a complete re-install following instructions on ConTeXtGarden curl -o first-setup.sh http://minimals.contextgarden.net/setup/first-setup.sh etc. I also downloaded simplefonts using the sh ./first-setup.sh --extras=t-simplefonts I still get

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Otared Kavian
On 24 nov. 2009, at 15:36, luigi scarso wrote: […] No problem here with # context --version MTXrun | main context file: /opt/luatex/minimals-beta/tex/texmf-context/tex/context/base/context.tex MTXrun | current version: 2009.11.24 10:13 r...@john:/opt/luatex/test-mkiv# luatex --credits

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Otared Kavian
Hi Mojca, Thanks for your message and attention: I replied to Luigi's message and the saw your answer… I am going to do what you suggest and the let you know. I'll write you again in a few minutes… Best regards: OK On 24 nov. 2009, at 15:50, Mojca Miklavec wrote: On Tue, Nov 24, 2009 at

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Mojca Miklavec
On Tue, Nov 24, 2009 at 16:08, Otared Kavian wrote: Looks like the new setuptex files behave differently, or has something changed with first-setup.sh? Both. Mojca ___ If your question is of interest to others as

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread luigi scarso
On Tue, Nov 24, 2009 at 4:08 PM, Otared Kavian ota...@gmail.com wrote: On 24 nov. 2009, at 15:36, luigi scarso wrote: […] No problem here with # context --version MTXrun | main context file: /opt/luatex/minimals-beta/tex/texmf-context/tex/context/base/context.tex MTXrun | current version:

Re: [NTG-context] first-setup.sh on MacOSX problem...

2009-11-24 Thread Hans Hagen
Bernhard Rosensteiner wrote: Hello all, after my new OSX installation i did first-setup.sh as always but now i get: This is LuaTeX, Version beta-0.40.6-2009100310 (TeX Live 2009) (INITEX) \write18 enabled. (/Applications/ConTeXt/tex/texmf-context/tex/context/base/cont-en.tex ! I can't find

Re: [NTG-context] first-setup.sh on MacOSX problem...

2009-11-24 Thread Bernhard Rosensteiner
Hello, thanks for your advice. I solved the problem 5 minutes ago: i used the context file version in texmf-osx-64\bin and suddenly some mysterious command line magic happened (only the first time i did context...) and LuaTeX 0.45 worked. best regards Bernhard Am 24.11.2009 um 16:21 schrieb

Re: [NTG-context] setuptex files broken in the latest release 2009-11-24

2009-11-24 Thread Otared Kavian
Dear Mojca, I did what you suggest. Now, after updating first-setup.sh, the behaviour is different but neither mkii nor mkiv work… In my log file I obtain only ………MTXrun | unknown script 'context.lua' or 'mtx-context.lua' and no typesetting. However, as I said in my previous explanations,

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 15:52 schrieb Charles Doherty: Dear Wolfgang, I deleted my Minimals folder and did a complete re-install following instructions on ConTeXtGarden curl -o first-setup.sh http://minimals.contextgarden.net/setup/first-setup.sh etc. I also downloaded simplefonts using

Re: [NTG-context] first-setup.sh on MacOSX problem...

2009-11-24 Thread Mojca Miklavec
On Tue, Nov 24, 2009 at 15:24, Bernhard Rosensteiner wrote: Hello all, after my new OSX installation i did first-setup.sh as always but now i get: This is LuaTeX, Version beta-0.40.6-2009100310 (TeX Live 2009) (INITEX)  \write18 enabled.

Re: [NTG-context] first-setup.sh on MacOSX problem...

2009-11-24 Thread Mojca Miklavec
On Tue, Nov 24, 2009 at 16:21, Hans Hagen wrote: Bernhard Rosensteiner wrote: Hello all, after my new OSX installation i did first-setup.sh as always but now i get: This is LuaTeX, Version beta-0.40.6-2009100310 (TeX Live 2009) (INITEX)  \write18 enabled.

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Charles Doherty
Here it is:Thanks for taking the time.Charlie EnglishRuleTest.log Description: Binary data On 24 Nov 2009, at 15:36, Wolfgang Schuster wrote:Am 24.11.2009 um 15:52 schrieb Charles Doherty:Dear Wolfgang,I deleted my Minimals folder and did a complete re-install following instructions on

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 17:17 schrieb Charles Doherty: Here it is: Thanks for taking the time. There is nothing I can see here which produce this results. What do you get with the following lines on the command line: mtxrun --script font --list dejavuserif mtxrun --script font --list

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Charles Doherty
Dear Wolfgang, I deleted the luatex cashe. I got the same output. Then I ran the scripts. This is the result: dejavuserif dejavuserif /Library/Fonts/DejaVuSerif.ttf dejavuserifnormal dejavuserifitalic /Library/Fonts/DejaVuSerif-Italic.ttf Charlie On 24 Nov 2009, at 17:07, Wolfgang

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Otared Kavian
Hi Charles and Wolfgang, I have noticed the same problem, as the one Charles is describing, with the « English rule » or the « swelled rule » and mkiv, and I think that this has nothing to do with fonts. Maybe, it is rather with the way \localhsize is defined in recent versions of mkiv: the «

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 19:06 schrieb Otared Kavian: Hi Charles and Wolfgang, I have noticed the same problem, as the one Charles is describing, with the « English rule » or the « swelled rule » and mkiv, and I think that this has nothing to do with fonts. Maybe, it is rather with the way

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Wolfgang Schuster
Am 24.11.2009 um 19:03 schrieb Charles Doherty: Dear Wolfgang, I deleted the luatex cashe. I got the same output. Then I ran the scripts. This is the result: dejavuserif dejavuserif /Library/Fonts/DejaVuSerif.ttf dejavuserifnormal dejavuserifitalic

Re: [NTG-context] EnglishRule and Lua / Simplefonts module

2009-11-24 Thread Otared Kavian
On 24 nov. 2009, at 19:16, Wolfgang Schuster wrote: […] And what should I see here, I get the same rule on each page. Wolfgang Sorry, Wolfgang I didn't attach the PDF file in order to pass through the mailing list. I get English rules of various sizes placed almost at random somewhere

[NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Alan BRASLAU
MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle} pickup pencircle scaled 1pt ; draw fullcircle scaled 2cm ; \stopuniqueMPgraphic \uniqueMPgraphic{circle} \stoptext

[NTG-context] How to show footer only with chapter head

2009-11-24 Thread Elliot Clifton
Hi, I have page numbers and chapter headings displayed in my document's header. The header is suppressed on a page with a chapter head i.e. \setuphead[chapter][header=high] therefore I want a footer on these pages to display the page number. The footer should disabled on all other pages.

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread luigi scarso
On Tue, Nov 24, 2009 at 9:05 PM, Alan BRASLAU alan.bras...@cea.fr wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle}        pickup pencircle scaled 1pt ;        draw fullcircle scaled 2cm ; \stopuniqueMPgraphic

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Hans Hagen
Alan BRASLAU wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle} pickup pencircle scaled 1pt ; draw fullcircle scaled 2cm ; \stopuniqueMPgraphic \uniqueMPgraphic{circle} \stoptext the problem was in the backend of

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Mojca Miklavec
On Tue, Nov 24, 2009 at 21:21, Hans Hagen wrote: Alan BRASLAU wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle}        pickup pencircle scaled 1pt ;        draw fullcircle scaled 2cm ; \stopuniqueMPgraphic

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Alan BRASLAU
On Tuesday 24 November 2009 21:20:05 luigi scarso wrote: On Tue, Nov 24, 2009 at 9:05 PM, Alan BRASLAU alan.bras...@cea.fr wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle} pickup pencircle scaled 1pt ;

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Hans Hagen
Mojca Miklavec wrote: On Tue, Nov 24, 2009 at 21:21, Hans Hagen wrote: Alan BRASLAU wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle} pickup pencircle scaled 1pt ; draw fullcircle scaled 2cm ; \stopuniqueMPgraphic

[NTG-context] Chicago citations in endnotes; short titles in bibliographies

2009-11-24 Thread Peter Park Nelson
I was just looking at the documentation for the Bibliography module and wondering if anyone has tried to implement the full-on Chicago Manual of Style Author-Title documentation format for endnotes/footnotes in books -- i.e. citations of the form Author, Full Title, Publisher, page followed in

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Alan BRASLAU
On Tuesday 24 November 2009 21:49:06 Hans Hagen wrote: Mojca Miklavec wrote: On Tue, Nov 24, 2009 at 21:21, Hans Hagen wrote: Alan BRASLAU wrote: MetaPost is broken in mkiv (works in mkii). minimal example: \starttext \startuniqueMPgraphic{circle} pickup pencircle

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread luigi scarso
On Tue, Nov 24, 2009 at 10:51 PM, Alan BRASLAU alan.bras...@cea.fr wrote: I rebuilt luatex from svn on Debian x86_64 and MP is fixed. hm. Can you also try with beta source http://foundry.supelec.fr/gf/download/frsrelease/359/1390/luatex-beta-0.45.0.tar.bz2 ? -- luigi

Re: [NTG-context] MetaPost broken mkiv latest minimals

2009-11-24 Thread Taco Hoekwater
luigi scarso wrote: On Tue, Nov 24, 2009 at 10:51 PM, Alan BRASLAU alan.bras...@cea.fr wrote: I rebuilt luatex from svn on Debian x86_64 and MP is fixed. hm. Can you also try with beta source http://foundry.supelec.fr/gf/download/frsrelease/359/1390/luatex-beta-0.45.0.tar.bz2 That one is

Re: [NTG-context] Chicago citations in endnotes; short titles in bibliographies

2009-11-24 Thread Andreas Schneider
Hi Peter, a similar question was asked not long ago ... and as it happens, some time before that even by me. My solution for ibid footnote citations can be found here: http://thread.gmane.org/gmane.comp.tex.context/54129 It's surely not the Chicago Manual of Style-style but probably the

[NTG-context] Adjusting the size of a figure when using placefigure

2009-11-24 Thread Curiouslearn
Please see the figure generated by the following minimal example. Due to the dimensions chosen in the figure, the figure is wider than the text width. Is there an option in \placefigure or another command that can help to make this figure smaller (without changing the code of the original figure)?

Re: [NTG-context] definereferenceformat problem...

2009-11-24 Thread Chen Shen
I have the same problem with the latest mkiv beta (2009.11.25). left/right works fine, but text does not. regards, shenchen On Thu, Nov 12, 2009 at 1:26 AM, Bernhard Rosensteiner brosenstei...@gmail.com wrote: Hello, \definereferenceformat[fig][left=(, right=), label=reffigure,

Re: [NTG-context] Adjusting the size of a figure when using placefigure

2009-11-24 Thread luigi scarso
On Wed, Nov 25, 2009 at 2:44 AM, Curiouslearn curiousle...@gmail.com wrote: Please see the figure generated by the following minimal example. Due to the dimensions chosen in the figure, the figure is wider than the text width. Is there an option in \placefigure or another command that can help

Re: [NTG-context] Adjusting the size of a figure when using placefigure

2009-11-24 Thread Curiouslearn
Thanks Luigi. I did not know where exactly to put the width command. Your solution works great. On Tue, Nov 24, 2009 at 9:20 PM, luigi scarso luigi.sca...@gmail.com wrote: On Wed, Nov 25, 2009 at 2:44 AM, Curiouslearn curiousle...@gmail.com wrote: Please see the figure generated by the

[NTG-context] Metapost - Seems like weird behavior. Is it a bug?

2009-11-24 Thread Curiouslearn
The code below shows a cyclic path that I am interested in creating (it is in red if you run the code). The example works fine as long as I have, u:=1cm, as in the code below. But if I replace it by , u:=0.6cm, there is no output. There is an error saying that paths 4 and 3 do not intersect. Is

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread Thomas A. Schmitz
On Nov 22, 2009, at 10:19 PM, Hans Hagen wrote: that line says data_state = resolvers.data_state(), so resolvers has no data_state entry which in turn means that you run an old mtxrun, so maybe you need top copy mtxrun.lua manually to where it currently sits in yout path (as

Re: [NTG-context] Metapost - Seems like weird behavior. Is it a bug?

2009-11-24 Thread luigi scarso
On Wed, Nov 25, 2009 at 5:45 AM, Curiouslearn curiousle...@gmail.com wrote: The code below shows a cyclic path that I am interested in creating (it is in red if you run the code). The example works fine as long as I have, u:=1cm, as in the code below. But if I replace it by , u:=0.6cm, there

Re: [NTG-context] Adjusting the size of a figure when using placefigure

2009-11-24 Thread Alan BRASLAU
Luigi, Thank you for bringing to our attention the command \scale allowing the easy rescaling of MP graphics. On Wednesday 25 November 2009 03:20:09 luigi scarso wrote: \definemeasure[textgap] [\dimexpr 1em\relax] Why the \dimexpr? \definemeasure[textgap] [1em] works just fine. Alan

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread luigi scarso
On Wed, Nov 25, 2009 at 8:05 AM, Thomas A. Schmitz thomas.schm...@uni-bonn.de wrote: On Nov 22, 2009, at 10:19 PM, Hans Hagen wrote: that line says        data_state = resolvers.data_state(), so resolvers has no data_state entry which in turn means that you run an old mtxrun, so maybe

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread Taco Hoekwater
Thomas A. Schmitz wrote: Just an afterthought to this problem: I discovered yesterday that the same file behaved quite differently in different viewers. It was a file compiled with the latest beta under linux, luatex 0.44, and with my own fonts. Sounds like this bug in 0.44 that was fixed

Re: [NTG-context] Metapost - Seems like weird behavior. Is it a bug?

2009-11-24 Thread Taco Hoekwater
luigi scarso wrote: On Wed, Nov 25, 2009 at 5:45 AM, Curiouslearn curiousle...@gmail.com wrote: The code below shows a cyclic path that I am interested in creating (it is in red if you run the code). The example works fine as long as I have, u:=1cm, as in the code below. But if I replace it by

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread Thomas A. Schmitz
On Nov 25, 2009, at 8:20 AM, Taco Hoekwater wrote: Sounds like this bug in 0.44 that was fixed already: Bug fixes in 0.45: Yes, the bug has been fixed, and I should have mentioned that; I just wanted to point out that tests may be sometimes deceptive: when I see an empty pdf in preview

Re: [NTG-context] Metapost - Seems like weird behavior. Is it a bug?

2009-11-24 Thread Taco Hoekwater
Taco Hoekwater wrote: The solution is to add an explicit fix to Lint[4] just after its current assignment: Lint[4]:=(xpart Lint[4], 0); Even better is to not use intersectionpoint at all: use intersectiontimes instead. With that, you can select a point that is guaranteed to be on one of

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread Thomas A. Schmitz
On Nov 25, 2009, at 8:15 AM, luigi scarso wrote: 1. In evince under linux, the file looked fine, no problems were apparent. what about xpdf and ghostscript? Can you also try with mupdf ? That wasn't the point, I was not trying to give a comparative table of pdf-viewers. luatex was buggy,

Re: [NTG-context] font-syn.lua error

2009-11-24 Thread Alan BRASLAU
On Wednesday 25 November 2009 08:15:48 luigi scarso wrote: On Wed, Nov 25, 2009 at 8:05 AM, Thomas A. Schmitz thomas.schm...@uni-bonn.de wrote: On Nov 22, 2009, at 10:19 PM, Hans Hagen wrote: Just an afterthought to this problem: I discovered yesterday that the same file behaved quite