Re: [NTG-context] Indents, enumerations, and modes (mk2+mk4)

2010-06-02 Thread Aditya Mahajan

On Wed, 2 Jun 2010, Wolfgang Schuster wrote:


Am 02.06.10 00:14, schrieb Matthias Weber:

 Dear all,

 I have two questions regarding using spacing in enumerations. Depending on
 a mode being enabled, I would like to add a command at the beginning of
 an enumeration (I want to place something in the margin, but it doesn't
 actually matter what I do, only when).
 As shown in the minimal example below, invoking the macro that does
 something, a little extra space is added.
 I don't know why, it is probably something very TeX-basic I am ignorant
 of. So: How do I get rid of the extra space?
 The problem occurs both in mk2 and mk4, I would prefer a solution that
 also works in mk2.

 Thanks!


 Matthias



 \def\mma{
 \startmode[mma]
 {}
 \stopmode
 }


\def\mma
  {\startmode[mma]% not sure here
   ...%
   \stopmode}


or maybe

\def\mma{\doifmode{mma}{}}

or perhaps

\def\mma{}%default

% override the definition in a mode
\startmode[mma]
\def\mma{in mode mma}
\stopmode


or use setups


Aditya
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] first-setup.sh

2010-06-02 Thread Mojca Miklavec
Thomas,

On Tue, Jun 1, 2010 at 13:20, Mojca Miklavec wrote:
 On Tue, Jun 1, 2010 at 12:49, Thomas A. Schmitz wrote:
 Hi all, esp. Mojca,

 I don't know if anything changed recently, but first-setup.sh doesn't fetch
 the latest beta for me anymore, even when I feed it the --context=beta
 switch. At first, I thought it was a glitch, but I have now tried on 3
 different computers, and after running first-setup.sh, I always get

 MTXrun | main context file:
 /Users/tas/context/tex/texmf-context/tex/context/base/context.tex
 MTXrun | current version: 2010.05.24 13:05

 Interesting. Hans has changed configuration of his rsync server. I
 have noticed that while fetching docs, but didn't think about the fact
 that this has influenced fetching of the latest context as well.

You may try again with --context=experimental as a temporary solution.

I have updated  fixed the scripts on server, so everything should
(hopefully) work fine after Hans fixes the server (except that
kfreebsd-amd64 will probably break until the next beta comes out). As
long as the server reports

 wget http://www.pragma-ade.com/context/beta/cont-tmf.zip
HTTP request sent, awaiting response... 403 Forbidden

with both HTTP and RSYNC access, there's not much I can do (except for
temporary renaming experimental to beta which I don't particularly
like to do).

Mojca
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] first-setup.sh

2010-06-02 Thread Taco Hoekwater


Mojca Miklavec wrote:
 As long as the server reports
 
  wget http://www.pragma-ade.com/context/beta/cont-tmf.zip
 HTTP request sent, awaiting response... 403 Forbidden

Looks like Hans' new NAS also considers working with context a
security risk. :)




___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Multiple pleas for help (long)

2010-06-02 Thread Wolfgang Schuster

Am 01.06.10 00:29, schrieb Scott Steele:
If anyone has any insight on how to keep the footnotes from having 
their numbers in the margin and from having line-breaks after each 
one, that is the only issue from the original email that is still 
unsolved, I think.


———

In Latex, \fancybreak was part of a package called, I believe, 
fancyheader or fancypage. It produced a break frequently seen in 
published prose (I'm currently reading {\em Bluebeard} where Kurt 
Vonnegut uses it liberally) with significant vertical space between 
two paragraphs and, centered both in that vertical space as well as 
horizontally, a number of well-spaced marks. There are usually 3 
marks, and they are frequently asterisks or traditional 
dingbats/fleurons. This sort of break is generally used when the 
author wishes to indicate a break more significant than a change in 
paragraph but short of an outright new chapter.


\def\FancyBreak{\par\blank\hfill* * *\hfill\hfill\par\blank}
\starttext
\input tufte
\FancyBreak
\input tufte
\stoptext

I don't understand why I need the two consecutive \hfill's at the end 
for the marks to be centered, but the definition works well for me.


\unprotect

\def\fb{fb}

\getparameters
  [\fb]
  [\c!spacebefore=,
\c!spaceafter=]

\def\fancybreakparameter#1%
  
{\csname\fb\ifcsname\fb\currentfancybreak#1\endcsname\currentfancybreak\fi#1\endcsname}


\def\setupfancybreak
  {\dodoubleempty\dosetupfancybreak}

\def\dosetupfancybreak[#1][#2]%
  {\ifsecondargument
 \getparameters[\fb#1][#2]%
   \else
 \getparameters[\fb][#1]%
   \fi}

\def\definefancybreak
  {\dodoubleempty\dodefinefancybreak}

\def\dodefinefancybreak[#1][#2]%
  {\ifsecondargument
 \getparameters[\fb#1][#2]%
   \fi
   \setvalue{#1}{\dofancybreak{#1}}}

\def\dofancybreak#1%
  {\begingroup
   \edef\currentfancybreak{#1}%
   \everyvbox{\raggedcenter}%
   \dowithnextbox
 {\blank[\fancybreakparameter\c!spacebefore]%
  \flushnextbox
  \blank[\fancybreakparameter\c!spaceafter]%
  \endgroup}
 \normalvbox}

\definefancybreak[fancybreak]

\protect

\starttext
\input knuth
\fancybreak{$* * *$}
\input ward
\stoptext

Wolfgang

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] \section{\inmargin{}} doesn't work in MkIV

2010-06-02 Thread Rogutės Sparnuotos
I've quickly run a (MkII) document under MkIV after updating to
2010.05.27, but it didn't compile (perhaps this is related to the other
interaction bugs in MkIV):

\setupinteraction[state=start]
\starttext
\section{\inmargin{}}
\stoptext

-- 
--  Rogutės Sparnuotos
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Numbered bookmarks in PDF

2010-06-02 Thread Alan BRASLAU
 B. Tommy Jensen wrote: 
 I am struggling a bit with numbered bookmarks in generated PDF files. 

On Wednesday 27 August 2008 19:03 Hans Hagen wrote:
 since bookmarks do use lists the info is there but mkii bookmarks are 
 not going to be extended; you have to wait for the mkiv overhaul 

Would be a nice feature - is anything doing?

grep finds: Future version ... (rather trivial to implement)

Alan
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] \hyphenatedurl and the '%' character

2010-06-02 Thread Rogutės Sparnuotos
Hello,

I defined

  \def\url[#1]{\hyphenatedurl{#1}}

for URLs, because I find 

  \useURL[][]
  \from[]

inconvenient (there are ~30 URLs in my document and all of them unique).
But \hyphenatedurl doesn't work with '%' (and '\%' gets printed
literally). I'll just use \useURL as a workaround, but shouldn't
\hyphenatedurl work as well?

-- 
--  Rogutės Sparnuotos
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] first-setup.sh

2010-06-02 Thread Thomas A. Schmitz

On Jun 2, 2010, at 3:43 PM, Mojca Miklavec wrote:

 You may try again with --context=experimental as a temporary solution.

Mojca,

I just tried this (sorry, came home only now), and now I get a version of 
2010.06.02 which isn't even announced on the pragma site... So let's hope that 
Hans talks some sense into his servers and everything goes back to normal! 
Thanks for your swift reaction.

All best

Thomas
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] first-setup.sh

2010-06-02 Thread Hans Hagen

On 2-6-2010 11:35, Thomas A. Schmitz wrote:


On Jun 2, 2010, at 3:43 PM, Mojca Miklavec wrote:


You may try again with --context=experimental as a temporary solution.


Mojca,

I just tried this (sorry, came home only now), and now I get a version of 
2010.06.02 which isn't even announced on the pragma site... So let's hope that 
Hans talks some sense into his servers and everything goes back to normal! 
Thanks for your swift reaction.


ah .. that's interesting .. it's because mojca now syncs with an 
internal machine


i hope that this versions works ok as i'm in the middle of some changes 
in the luatools/mtxrun pair as wel as format generation (experimenting a 
bit with stubs as the existing code dates back from 2007 or so) ..


the code in this version is definitely not for texlive

so best treat it as a real beta (there will be another beta later this 
week)


Hans

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] first-setup.sh

2010-06-02 Thread luigi scarso
On Wed, Jun 2, 2010 at 11:45 PM, Hans Hagen pra...@wxs.nl wrote:
 On 2-6-2010 11:35, Thomas A. Schmitz wrote:

 On Jun 2, 2010, at 3:43 PM, Mojca Miklavec wrote:

 You may try again with --context=experimental as a temporary solution.

 Mojca,

 I just tried this (sorry, came home only now), and now I get a version of
 2010.06.02 which isn't even announced on the pragma site... So let's hope
 that Hans talks some sense into his servers and everything goes back to
 normal! Thanks for your swift reaction.

 ah .. that's interesting .. it's because mojca now syncs with an internal
 machine
Also beta download from
http://www.pragma-ade.nl/download-2.htm
works ok now

-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] list of figures (bug?)

2010-06-02 Thread Rogutės Sparnuotos
Hello,

What is the correct way to set 'alternative=c' for the
\completelistoffigures?

This works:

  \starttext
\completelistoffigures[alternative=c]
\placefigure[here]{x}{}
\placefigure[here]{y}{}
  \stoptext

But this doesn't:

  \setupcombinedlist[listoffigures][alternative=c]
  \starttext
\completelistoffigures
\placefigure[here]{x}{}
\placefigure[here]{y}{}
  \stoptext

Why? If I add \definecombinedlist[listoffigures][figure], it starts
working, but the list is printed without the title... This seems
inconsistent, so either I have something wrong or there is a bug, no?

-- 
--  Rogutės Sparnuotos
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___