Re: [NTG-context] Skew not working in latest beta

2011-01-13 Thread Hans Hagen
On 12-1-2011 4:26, Khaled Hosny wrote: On Wed, Jan 12, 2011 at 04:08:40PM +0100, Taco Hoekwater wrote: On 01/12/11 16:02, Mathieu Boespflug wrote: It seems this is a regression of either ConTeXt or LuaTeX. I have a PDF that I generated on December 9th that doesn't have this problem.

[NTG-context] Problem with \setuptyping-ed \typefile

2011-01-13 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, I encountered another problem with \typefile. This code crashes: --- \setuptyping[Model][bodyfont=6pt,style=\tt\setupinterlinespace] \starttext \typefile[Model]{t2.txt} %{t.u8} %\startluacode context.typefile({Model}, t.u8)\stopluacode \stoptext --- Although a .pdf is generated,

Re: [NTG-context] Problem typing file with diacritics by \typefile

2011-01-13 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, I just downloaded the last beta and it seems there is (again) a problem with \typefile a file with diacritics. Samples are attached. Best regards, Lukas On Tue, 12 Oct 2010 17:15:06 +0200, Hans Hagen pra...@wxs.nl wrote: this will work in the next beta (making zip now) -- Ing.

Re: [NTG-context] Problem with \setuptyping-ed \typefile

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 11:35 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: Hello, I encountered another problem with \typefile. This code crashes: --- \setuptyping[Model][bodyfont=6pt,style=\tt\setupinterlinespace] You need \definetyping[Model][...]. Wolfgang

Re: [NTG-context] mptopdf (broken again)

2011-01-13 Thread luigi scarso
On Wed, Jan 12, 2011 at 6:12 PM, Mojca Miklavec mojca.miklavec.li...@gmail.com wrote: 2011/1/12 Michal Kvasnička prgo...@gmail.com: Hallo. I tried mtxrun --script mptopdf chart08.1 but I've got the following error. This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)  \write18 enabled.

Re: [NTG-context] Problem typing file with diacritics by \typefile

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 11:36 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: Hello, I just downloaded the last beta and it seems there is (again) a problem with \typefile a file with diacritics. Samples are attached. Save your file in utf-8 encoding, my editor shows me your t.txt is

Re: [NTG-context] Problem with \setuptyping-ed \typefile

2011-01-13 Thread Procházka Lukáš Ing . - Pontex s . r . o .
... Thanks, it works now. (I've been using \setuptyping before and it used to work.) Lukas On Thu, 13 Jan 2011 11:58:28 +0100, Wolfgang Schuster schuster.wolfg...@googlemail.com wrote: Am 13.01.2011 um 11:35 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: You need

Re: [NTG-context] Problem typing file with diacritics by \typefile

2011-01-13 Thread Procházka Lukáš Ing . - Pontex s . r . o .
On Thu, 13 Jan 2011 12:03:06 +0100, Wolfgang Schuster schuster.wolfg...@googlemail.com wrote: Am 13.01.2011 um 11:36 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: Hello, I just downloaded the last beta and it seems there is (again) a problem with \typefile a file with diacritics.

Re: [NTG-context] Problem typing file with diacritics by \typefile

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 12:11 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: OSave your file in utf-8 encoding, my editor shows me your t.txt is currently encoded as “ISO 8859-7”. ... Yes, that's a possibility. But as I can remember, this was fixed and there was no requirement for the file to

Re: [NTG-context] Problem typing file with diacritics by \typefile

2011-01-13 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, sorry, my silly fault. The main problem was to use \setuptyping instead of \definetyping. When I was trying to create an as-small-as-possible example, I forgot to insert \enableregime[1250] to the header, so I encountered additional error messages. Sorry again for wasting your (and

[NTG-context] Bad interaction between new interpretation of underscore and modules

2011-01-13 Thread Mathieu Boespflug
Hi all, today's beta introduced a really strange problem. Consider two source files: definitions.tex: \startmodule[definitions] \def\lambdax{\lambda_x} \stopmodule[definitions] main.tex: \usemodule[definitions] \starttext blah $\lambdax$ blah. \stoptext This results in the following compile

Re: [NTG-context] Skew not working in latest beta

2011-01-13 Thread Mathieu Boespflug
Hi Hans, It's related to \Umathradicalrule* not being set. This has never been the case but at some point it worked ok and Taco/I are not going think too long about when and where something changed along the route. I'll make a new beta. that does fix the output of my document. Many thanks!

Re: [NTG-context] Finalizing a module

2011-01-13 Thread Willi Egger
Hallo Wolfgang, thank you for your reply. It looks already promising, however I get the following error and I do not know how to fix: Running context --ctx=s-mod t-pocketdiary.tex ! String contains an invalid utf-8 sequence. l.113 ? \dodotypeblockverbatim ..., nature = display, }}

Re: [NTG-context] Finalizing a module

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 20:55 schrieb Willi Egger: Hallo Wolfgang, thank you for your reply. It looks already promising, however I get the following error and I do not know how to fix: Running context --ctx=s-mod t-pocketdiary.tex ! String contains an invalid utf-8 sequence. l.113 ?

Re: [NTG-context] Bad interaction between new interpretation of underscore and modules

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 17:18 schrieb Mathieu Boespflug: Hi all, today's beta introduced a really strange problem. Consider two source files: definitions.tex: \startmodule[definitions] \def\lambdax{\lambda_x} \stopmodule[definitions] main.tex: \usemodule[definitions] \starttext blah

Re: [NTG-context] Bad interaction between new interpretation of underscore and modules

2011-01-13 Thread Aditya Mahajan
On Thu, 13 Jan 2011, Wolfgang Schuster wrote: Am 13.01.2011 um 17:18 schrieb Mathieu Boespflug: Hi all, today's beta introduced a really strange problem. Consider two source files: definitions.tex: \startmodule[definitions] \def\lambdax{\lambda_x} \stopmodule[definitions] main.tex:

Re: [NTG-context] Bad interaction between new interpretation of underscore and modules

2011-01-13 Thread Wolfgang Schuster
Am 13.01.2011 um 23:43 schrieb Aditya Mahajan: Untested: \def\lambdax{\math{\lambda_x}} should also work. Not, this won’t work in a module because _ has catcode 11 when you define the \lambdax command and it doesn’t matter whether you use \math, $ or \Ustartmath. What happens is that TeX

[NTG-context] TABLE in a flow chart

2011-01-13 Thread Aditya Mahajan
Hi, I want to include a TABLE in a flow chart, but the table is shifted by an offset. Any ideas on how to get rid of the offset \usemodule[chart] \setupFLOWcharts[nx=1,ny=1,width=3cm,height=2cm] \setupTABLE[each][each][height=1cm] \startFLOWchart[test] \startFLOWcell \name{test}

Re: [NTG-context] help with citation please (mkiv)

2011-01-13 Thread Steffen Wolfrum
Am 13.01.2011 um 07:42 schrieb Steffen Wolfrum: Am 12.01.2011 um 20:19 schrieb Aditya Mahajan: On Wed, 12 Jan 2011, Steffen Wolfrum wrote: Hi friends, I am a bit confused with the use of citation/bibliographies in MkIV. Maybe someone can help me? Say, I have a bib-file containing