Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Tue, Feb 11, 2020 at 03:57:27PM -0500, Aditya Mahajan wrote: > On Tue, 11 Feb 2020, Rudolf Bahr wrote: > > > > > On Tue, Feb 11, 2020 at 07:38:54PM +0100, Hans Hagen wrote: > > > On 2/11/2020 6:26 PM, Rudolf Bahr wrote: > > > > > > > "whereis mtxrun" gives: > > > >

Re: [NTG-context] mtxrun

2020-02-11 Thread Aditya Mahajan
On Wed, 12 Feb 2020, Rudolf Bahr wrote: On Tue, Feb 11, 2020 at 01:39:54PM -0500, Aditya Mahajan wrote: What is the output of ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun --generate (please paste the complete output; your previous message did not show if SELFAUTOPARENT was being set

Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Tue, Feb 11, 2020 at 01:39:54PM -0500, Aditya Mahajan wrote: > What is the output of > > ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun --generate > > (please paste the complete output; your previous message did not show if > SELFAUTOPARENT was being set correctly). Hi Aditya! Thank you for

[NTG-context] [Fwd: Re: upload]

2020-02-11 Thread Richard Mahoney | Indica et Buddhica
Actually, I've just seen that the file that seemed to be causing the issue: error loading file: util-tab.lua contains the following: 400 Bad Request Bad Request Your browser sent a request that this server could not understand. Apache Server at 87.195.107.53 Port 80

Re: [NTG-context] upload

2020-02-11 Thread Richard Mahoney | Indica et Buddhica
With the latest just uploaded I'm running into the following on Linux, after trying all these: mtxrun --script cache --erase --make mtxrun --generate context --make I've also tried manually deleting the cache but the result is the same. Does anyone know what might be wrong? I'm attaching

Re: [NTG-context] mtxrun

2020-02-11 Thread Aditya Mahajan
On Tue, 11 Feb 2020, Rudolf Bahr wrote: On Tue, Feb 11, 2020 at 07:38:54PM +0100, Hans Hagen wrote: On 2/11/2020 6:26 PM, Rudolf Bahr wrote: > "whereis mtxrun" gives: > ~/context-lmtx/bin/mtxrun.lua > ~/context-lmtx/bin/mtxrun > ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun.lua >

Re: [NTG-context] macro that does not work (Metapost)

2020-02-11 Thread Fabrice Couvreur
Hi Mikael, Thanks. Fabrice Le mar. 11 févr. 2020 à 14:01, Mikael P. Sundqvist a écrit : > On Tue, Feb 11, 2020 at 1:22 PM Fabrice Couvreur < > fabrice1.couvr...@gmail.com> wrote: > >> Hi Hans, >> I tried this but without success : >> >> \startMPcode >> suite{1,0}; >> suite{2,1}; >>

Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Tue, Feb 11, 2020 at 07:38:54PM +0100, Hans Hagen wrote: > On 2/11/2020 6:26 PM, Rudolf Bahr wrote: > > > "whereis mtxrun" gives: > > ~/context-lmtx/bin/mtxrun.lua > > ~/context-lmtx/bin/mtxrun > > ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun.lua > >

Re: [NTG-context] upload

2020-02-11 Thread Hans Hagen
On 2/11/2020 5:18 PM, Floris van Manen wrote: On 11-02-2020 17:00, Hans Hagen wrote: - support for ecmascript for those who think thayt javascript is better than lua (of course only to find out at some point that it's not true in the perspective of context but it migh tmake a transition

Re: [NTG-context] mtxrun

2020-02-11 Thread Aditya Mahajan
On Tue, 11 Feb 2020, Rudolf Bahr wrote: On Tue, Feb 11, 2020 at 04:57:15PM +0100, Pablo Rodriguez wrote: On 2/11/20 4:23 PM, Rudolf Bahr wrote: > > How should it be possible to mix mkiv and lmtx, when I install "LuaMetaTeX 2.03.15" > and "ConTeXt 2020.02.10 MKIV beta" in my linux directory

Re: [NTG-context] mtxrun

2020-02-11 Thread Hans Hagen
On 2/11/2020 6:26 PM, Rudolf Bahr wrote: "whereis mtxrun" gives: ~/context-lmtx/bin/mtxrun.lua ~/context-lmtx/bin/mtxrun ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun.lua ~/context-lmtx/tex/texmf-linux-64/bin/mtxrun i assume that you run the last one in this list, which is a copy

Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Tue, Feb 11, 2020 at 04:57:15PM +0100, Pablo Rodriguez wrote: > On 2/11/20 4:23 PM, Rudolf Bahr wrote: > > > > How should it be possible to mix mkiv and lmtx, when I install "LuaMetaTeX > > 2.03.15" > > and "ConTeXt 2020.02.10 MKIV beta" in my linux directory "~/context-lmtx", > > correct > >

Re: [NTG-context] upload

2020-02-11 Thread Floris van Manen
On 11-02-2020 17:00, Hans Hagen wrote: > > - support for ecmascript for those who think thayt javascript is better > than lua (of course only to find out at some point that it's not true in > the perspective of context but it migh tmake a transition easier). For > the impatient: > >

[NTG-context] upload

2020-02-11 Thread Hans Hagen
Hi, I uploaded a fresh lmtx. There is some new stuff in there: - upgraded mysql and sqlite support (more about that later as i need to check it some more) - upgraded support for barcodes using libzint (at some point we will provide this in the installation) - support for gnuplot as in:

Re: [NTG-context] mtxrun

2020-02-11 Thread Pablo Rodriguez
On 2/11/20 4:23 PM, Rudolf Bahr wrote: > > How should it be possible to mix mkiv and lmtx, when I install "LuaMetaTeX > 2.03.15" > and "ConTeXt 2020.02.10 MKIV beta" in my linux directory "~/context-lmtx", > correct > the PATH variable after installation, do not forget a "source" on ".bashrc" >

Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Tue, Feb 11, 2020 at 01:07:23PM +0100, Hans Hagen wrote: > On 2/11/2020 11:56 AM, Rudolf Bahr wrote: > > On Mon, Feb 10, 2020 at 01:03:38PM +0100, Bahr Rudolf wrote: > > > On Mon, Feb 10, 2020 at 11:54:49AM +0100, Bahr Rudolf wrote: > > > > > > > > Hello ConTeXters! > > > > > > > >

Re: [NTG-context] macro that does not work (Metapost)

2020-02-11 Thread Mikael P. Sundqvist
On Tue, Feb 11, 2020 at 1:22 PM Fabrice Couvreur < fabrice1.couvr...@gmail.com> wrote: > Hi Hans, > I tried this but without success : > > \startMPcode > suite{1,0}; > suite{2,1}; > \stopMPcode > > Fabrice > > Le mar. 11 févr. 2020 à 13:08, Hans Hagen a écrit : > >> On 2/11/2020

Re: [NTG-context] macro that does not work (Metapost)

2020-02-11 Thread Fabrice Couvreur
Hi Hans, I tried this but without success : \startMPcode suite{1,0}; suite{2,1}; \stopMPcode Fabrice Le mar. 11 févr. 2020 à 13:08, Hans Hagen a écrit : > On 2/11/2020 11:50 AM, Fabrice Couvreur wrote: > > Hi, > > I have some problems with the following macro : > > > > tex error

Re: [NTG-context] macro that does not work (Metapost)

2020-02-11 Thread Hans Hagen
On 2/11/2020 11:50 AM, Fabrice Couvreur wrote: Hi, I have some problems with the following macro : tex error       > mp error on line 23 in file /home/viserion/macro.tex: ! Missing argument to suite. { <*> suite{ 1,0}; suite(2,1); ; That macro has more parameters than you thought. I'll

Re: [NTG-context] mtxrun

2020-02-11 Thread Hans Hagen
On 2/11/2020 11:56 AM, Rudolf Bahr wrote: On Mon, Feb 10, 2020 at 01:03:38PM +0100, Bahr Rudolf wrote: On Mon, Feb 10, 2020 at 11:54:49AM +0100, Bahr Rudolf wrote: Hello ConTeXters! LuaMetaTeX, Version 2.03.15 ConTeXt ver: 2020.02.07 18:36 MKIV beta fmt: 2020.2.10 works well doing my usual

Re: [NTG-context] mtxrun

2020-02-11 Thread Rudolf Bahr
On Mon, Feb 10, 2020 at 01:03:38PM +0100, Bahr Rudolf wrote: > On Mon, Feb 10, 2020 at 11:54:49AM +0100, Bahr Rudolf wrote: > > > > Hello ConTeXters! > > > > LuaMetaTeX, Version 2.03.15 > > ConTeXt ver: 2020.02.07 18:36 MKIV beta fmt: 2020.2.10 > > works well doing my usual tasks. > > > >

[NTG-context] macro that does not work (Metapost)

2020-02-11 Thread Fabrice Couvreur
Hi, I have some problems with the following macro : tex error > mp error on line 23 in file /home/viserion/macro.tex: ! Missing argument to suite. { <*> suite{ 1,0}; suite(2,1); ; That macro has more parameters than you thought. I'll continue by pretending that each missing argument is