Re: [NTG-context] simpleslides with minimals

2009-05-07 Thread Amaël Broustet
Thank you for the advice.
I followed it but still run in some problems :
I used

~/context$ sh ./first-setup.sh --extras=t-simpleslides

then 

:~/context$ source ./tex/setuptex

Everythings look fine :

~/context$ luatools t-simpleslides.tex
/home/amael3/context/tex/texmf-context/tex/context/third/simple-slides/t-simpleslides.tex

~/context$ kpsewhich t-simpleslides.tex
/home/amael3/texmf/tex/context/third/simple-slides/t-simpleslides.tex

~/context$ type texexec
texexec est haché (/home/amael3/context/tex/texmf-linux/bin/texexec)

~/context$ type luatools
luatools est haché (/home/amael3/context/tex/texmf-linux/bin/luatools)

My essai.tex file is :

~/context$ cat essai.tex
\usemodule[simpleslides][style=BigNumber,font=Helvetica,size=24]

\setupTitle
[   title={Essai / Try SimpleSlides},
 author={Amaël Broustet},
date={6 mai 2009},
]

\starttext
\placeTitle
\SlideTitle{Le premier slide}
Essai 
\stoptext

but when I run mark IV :

~/context$ texexec --lua essai.tex
TeXExec | processing document 'essai.tex'
TeXExec | no ctx file found
TeXExec | tex processing method: context
TeXExec | TeX run 1
TeXExec | writing option file essai.top
TeXExec | using randomseed 1287
TeXExec | tex engine: luatex
TeXExec | tex format: cont-en
LuaTools | running command: luatex
--fmt=/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en
 
--lua=/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en.luc
 essai.tex 
This is LuaTeX, Version beta-0.40.0-200904 (Web2C 7.5.7)
 \write18 enabled.
(essai.tex

ConTeXt  ver: 2009.05.06 23:23 MKIV  fmt: 2009.5.7  int: english/english

system  : essai.top loaded
(essai.top)
fonts   : preloading latin modern fonts
bodyfont: 12pt rm is loaded
language: language en is active
system  : module simpleslides not found
! Undefined control sequence.
l.3 \setupTitle


and Mark II :

~/context$ texexec  essai.tex
TeXExec | processing document 'essai.tex'
TeXExec | no ctx file found
TeXExec | tex processing method: context
TeXExec | TeX run 1
TeXExec | writing option file essai.top
TeXExec | using randomseed 83
TeXExec | tex engine: pdftex
TeXExec | tex format: cont-en
This is pdfTeX, Version 3.1415926-1.40.10 (Web2C 7.5.7)
 \write18 enabled.
 (/home/amael3/context/tex/texmf-context/web2c/natural.tcx)
entering extended mode
(./essai.tex

ConTeXt  ver: 2009.05.06 23:23 MKII  fmt: 2009.5.7  int: english/english

system  : cont-new loaded
(/home/amael3/context/tex/texmf-context/tex/context/base/cont-new.tex
systems : beware: some patches loaded from cont-new.tex
(/home/amael3/context/tex/texmf-context/tex/context/base/cont-new.mkii)
(/home/amael3/context/tex/texmf-context/tex/context/base/cont-mtx.tex))
system  : cont-fil loaded
(/home/amael3/context/tex/texmf-context/tex/context/base/cont-fil.tex
loading : ConTeXt File Synonyms
)
system  : cont-sys.rme loaded
(/home/amael3/context/tex/texmf-context/tex/context/user/cont-sys.rme
(/home/amael3/context/tex/texmf-context/tex/context/base/type-tmf.tex)
(/home/amael3/context/tex/texmf-context/tex/context/base/type-siz.tex
(/home/amael3/context/tex/texmf-context/tex/context/base/type-siz.mkii))
(/home/amael3/context/tex/texmf-context/tex/context/base/type-one.tex)
(/home/amael3/context/tex/texmf-context/tex/context/base/type-akb.tex))
system  : essai.top loaded
(./essai.top)
bodyfont: 12pt rm is loaded
language: patterns nl-texnansi:texnansi-1-2:2
nl-ec:ec-2-2:2 us-
ec:ec-3-2:3 de-texnansi:texnansi-4-3:3 de-ec:ec-5-3:3
da-ec:ec-6-2:2
 sv-ec:ec-7-2:2 gb-ec:ec-8-2:2 fr-texnansi:texnansi-9-2:2
fr-ec:ec-1
0-2:2 es-ec:ec-11-2:2 ca-ec:ec-12-2:2
it-texnansi:texnansi-13-2:2 it-
ec:ec-14-2:2 la-ec:ec-15-2:2 pt-texnansi:texnansi-16-2:2
pt-ec:ec-17
-2:2 ro-ec:ec-18-2:2 pl-pl0:pl0-19-2:2 pl-ec:ec-20-2:2
pl-qx:qx-21-
2:2 cs-il2:il2-22-2:2 cs-ec:ec-23-2:2 sk-il2:il2-24-2:2
sk-ec:ec-25
-2:2 hr-ec:ec-26-2:2 sl-ec:ec-27-2:2 tr-ec:ec-28-2:2
agr-agr:agr-30
-2:2 fi-ec:ec-31-2:2 hu-ec:ec-32-2:2 ru-t2a:t2a-35-2:2
uk-t2a:t2a-3
6-3:3 loaded
specials: dvips loaded
systems : system commands are enabled
language: language en is active
specials: loading definition file tpd
(/home/amael3/context/tex/texmf-context/tex/context/base/spec-tpd.tex
specials: loading definition file fdf
(/home/amael3/context/tex/texmf-context/tex/context/base/spec-fdf.tex))
system  : module simpleslides loaded
(/home/amael3/texmf/tex/context/third/simple-slides/t-simpleslides.tex
loading : module simpleslides
system  : module default loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-s-default.tex
simpleslides: loading default style setup
color   : mpcmyk color space is supported
color   : mpspot color space is supported
color   : system rgb is global activated
)
system  : module

Re: [NTG-context] simpleslides with minimals

2009-05-07 Thread Amaël Broustet
Ok I thought i didn't need to do 
luatools --generate 
I run it and after that I got the same error with markIV that with
markII :
~/context$ texexec --lua essai.tex
TeXExec | processing document 'essai.tex'
TeXExec | no ctx file found
TeXExec | tex processing method: context
TeXExec | TeX run 1
TeXExec | writing option file essai.top
TeXExec | using randomseed 764
TeXExec | tex engine: luatex
TeXExec | tex format: cont-en
LuaTools | running command: luatex
--fmt=/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en
 
--lua=/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en.luc
 essai.tex 
This is LuaTeX, Version beta-0.40.0-200904 (Web2C 7.5.7)
 \write18 enabled.
(essai.tex

ConTeXt  ver: 2009.05.06 23:23 MKIV  fmt: 2009.5.7  int: english/english

system  : essai.top loaded
(essai.top)
fonts   : preloading latin modern fonts
bodyfont: 12pt rm is loaded
language: language en is active
system  : module simpleslides loaded
(/home/amael3/texmf/tex/context/third/simple-slides/t-simpleslides.tex
loading : module simpleslides
system  : module default loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-s-default.tex
simpleslides: loading default style setup
color   : mpcmyk color space is supported
color   : mpspot color space is supported
color   : system rgb is global activated
)
system  : module BigNumber loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-s-BigNumber.tex
simpleslides: loading Big Number style
system  : command NormalHeight is already defined
system  : command NormalWidth is already defined
system  : command PictureFrameHeight is already defined
system  : command PictureFrameWidth is already defined
)
system  : module default loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-f-default.tex
simpleslides: loading default font setup
! Illegal unit of measure (pt inserted).
to be read again 
   \relax 
l.31 ...\moduleparameter{simpleslides}{size}\relax
  
? 


If I press enter to continue, I get errors with fonts like this one :



  define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*24ptsstfss*

[...]
define font | unable to define unknown as \*30ptmmmr1ss*
fonts   : needs map file: original-base
mplib   : making 'metafun.mp' into
'/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
mplib   : problems with 'metafun.mp' from
'/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
][1.1]

[...]
mplib   : making 'metafun.mp' into
'/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
mplib   : problems with 'metafun.mp' from
'/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
[2.2]
systems : end file essai at line 13
 )
mkiv lua stats : used config path
- /home/amael3/context/tex/texmf/web2c/texmf.cnf
mkiv lua stats : used cache path
- /home/amael3/context/tex/texmf-cache
mkiv lua stats : input load time   - 0.034 seconds
mkiv lua stats : stored bytecode data  - 165 modules, 42 tables, 207
chunks
mkiv lua stats : cleaned up reserved nodes - 26 nodes, 9 lists of 1411
mkiv lua stats : node memory usage - 13 glue_spec, 2 dir
mkiv lua stats : loaded patterns   - en:us:pat:exc:2
mkiv lua stats : callbacks - direct: 202, indirect:
1349, total: 1551
mkiv lua stats : luatex banner - this is luatex, version
beta-0.40.0


Might it be related to the actual bugs in beta ?

best,
Amaël


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] simpleslides with minimals

2009-05-07 Thread Amaël Broustet
Ok I just put in my essai.tex size=24pt istead of  size=24 and there
were no more errors.
But the generated pdf file is blank (2 pages wihtout test or graphic).
Best,
Amaël

Le jeudi 07 mai 2009 à 13:07 +0200, Amaël Broustet a écrit :
 Ok I thought i didn't need to do 
 luatools --generate 
 I run it and after that I got the same error with markIV that with
 markII :
 ~/context$ texexec --lua essai.tex

 ! Illegal unit of measure (pt inserted).
 to be read again 
\relax 
 l.31 ...\moduleparameter{simpleslides}{size}\relax
   
 ? 
 

 


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] simpleslides with minimals

2009-05-07 Thread Amaël Broustet
Thank you !!
As I wrote, I have a blank pdf (size is only 1700 bytes). 
From the log (attached below), it's a problem with fonts :
there is a whole page of 

simpleslides: loading default font setup
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*24ptsstfss*

I'm reading messages about beta and font generation, maybe it's related.

Best
Amaël

Le jeudi 07 mai 2009 à 13:14 +0200, Taco Hoekwater a écrit :
 
 Amaël Broustet wrote:
  Ok I thought i didn't need to do 
  luatools --generate 
  I run it and after that I got the same error with markIV that with
  markII :
 
 After looking at your input, this is expected. The argument to
 'size' is a dimension, so it should be followed by 'pt':
 
   \usemodule[simpleslides][style=BigNumber,font=Helvetica,size=24pt]
 
 Best wishes,
 Taco
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___
This is LuaTeX, Version beta-0.40.0-200904 (Web2C 7.5.7) (format=cont-en 2009.5.7)  7 MAY 2009 13:12
 \write18 enabled.
**essai.tex
(essai.tex

ConTeXt  ver: 2009.05.07 12:10 MKIV  fmt: 2009.5.7  int: english/english

system  : essai.top loaded
%
%	begin of optionfile
%
%	% essai.top
%	\unprotect
%	\def\MPOSTformatswitch{-progname=metafun -mem=}
%	\setupsystem[\c!n=2,\c!m=3]
%	\setupsystem[\c!method=2]
%	\setupsystem[\c!type=linux]
%	\setupsystem[\c!random=734]
%	\setupsystem[inputfile=essai.tex]
%	\startsetups *runtime:options
%	\setupoutput[pdftex]
%	\stopsetups
%	\startsetups *runtime:modules
%	\stopsetups
%	\protect \endinput
%
%	end of optionfile
%
(essai.top)
fonts   : preloading latin modern fonts
bodyfont: 12pt rm is loaded
language: language en is active
system  : module simpleslides loaded
(/home/amael3/texmf/tex/context/third/simple-slides/t-simpleslides.tex
loading : module simpleslides
system  : module default loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-s-default.tex
simpleslides: loading default style setup
color   : mpcmyk color space is supported
color   : mpspot color space is supported
color   : system rgb is global activated
)
system  : module BigNumber loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-s-BigNumber.tex
simpleslides: loading Big Number style
system  : command NormalHeight is already defined
system  : command NormalWidth is already defined
system  : command PictureFrameHeight is already defined
system  : command PictureFrameWidth is already defined
)
system  : module default loaded
(/home/amael3/texmf/tex/context/third/simple-slides/simpleslides-f-default.tex
simpleslides: loading default font setup
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*24ptsstfss*
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*16.8ptmmmr2ss*
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*24ptmmmr1ss*))
systems : begin file essai at line 9
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*30ptsstfss*
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*15ptmmmr3ss*
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*21ptmmmr2ss*
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*30ptmmmr1ss*
fonts   : needs map file: original-base
mplib   : making 'metafun.mp' into '/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
mplib   : problems with 'metafun.mp' from '/home/amael3/context/tex/texmf-cache/luatex-cache/context/7280baf46d1f2412a3c85f3ce864846b/formats/cont-en-metafun.mem'
][1.1]
define font | font with name unknown is not found
define font | unknown font unknown, loading aborted
define font | unable to define unknown as \*30ptsstfss*
define font | font with name unknown

[NTG-context] lots of luatex process/instances (ps xa| grep lua / top -----sort by memory)

2009-05-10 Thread Amaël Broustet
Dear context users,
at first a lot of warm thanks for help and comments on using
t-simpleslides.

On a different matter, I now have the following problem :
I do a lot of testing trying compiling my slides (using the following
command : context essai.tex). Sometimes, I get errors and an
interactive prompt that I kill with either ctrl+C or ctrl+Z (at random).

I noticed that my computer was swapping (2Go RAM). 
With ps xa  | grep lua I get 34 process.

Using top and sorting by memory used the processes, I noticed 7
instances of luatex and 5 of texlua on the first page for a total of
800MB of resident memory.

Did I miss something using context (I do context essai.tex each time
that I want compile changes) ?

killall luatex and kill -15 PID does nothing.


Best,
Amaël  

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] lots of luatex process/instances (ps xa| grep lua / top -----sort by memory)

2009-05-10 Thread Amaël Broustet
Thank you !
it's ok now.

Le dimanche 10 mai 2009 à 20:14 +0200, Arthur Reutenauer a écrit :
  Sometimes, I get errors and an
  interactive prompt that I kill with either ctrl+C or ctrl+Z (at random).
 
   You shouldn't do that.  Type 'x' at the error prompt, it makes
 (Lua)TeX terminate.  Ctrl+C sometimes isn't enough to kill LuaTeX,
 though I have no idea why; as for Ctrl+Z, it never kills anything, it
 sends the suspend signal (you should see the process status with top).
 
  killall luatex and kill -15 PID does nothing.
 
   kill -1 is usually enough.
 
   Arthur
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] lots of luatex process/instances (ps xa| grep lua / top -----sort by memory)

2009-05-10 Thread Amaël Broustet
On a small example : ctrl+C works, ctrl+Z leaves unkillable (either -15
or -1) luatex and texlua process. kill -9 leaves zombies.
killing the parent shell clean everything. 


Le dimanche 10 mai 2009 à 19:25 +0100, Mohamed Bana a écrit :
 I've also noticed something along those lines.  I've also found that 
 CTRL+Z/C doesn't really exit the program --- there are stale processes 
 still lying around.
 
 What I described is general, it tends to happen across big documents.
 
 Is this a known problem?
 
 � Broustet wrote:
  Dear context users,
  at first a lot of warm thanks for help and comments on using
  t-simpleslides.
  
  On a different matter, I now have the following problem :
  I do a lot of testing trying compiling my slides (using the following
  command : context essai.tex). Sometimes, I get errors and an
  interactive prompt that I kill with either ctrl+C or ctrl+Z (at random).
  
  I noticed that my computer was swapping (2Go RAM). 
  With ps xa  | grep lua I get 34 process.
  
  Using top and sorting by memory used the processes, I noticed 7
  instances of luatex and 5 of texlua on the first page for a total of
  800MB of resident memory.
  
  Did I miss something using context (I do context essai.tex each time
  that I want compile changes) ?
  
  killall luatex and kill -15 PID does nothing.
  
  
  Best,
  Amaël  
  
  ___
  If your question is of interest to others as well, please add an entry to 
  the Wiki!
  
  maillist : ntg-context@ntg.nl / 
  http://www.ntg.nl/mailman/listinfo/ntg-context
  webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
  archive  : https://foundry.supelec.fr/projects/contextrev/
  wiki : http://contextgarden.net
  ___
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] subsection numbering

2009-05-23 Thread Amaël Broustet
Dear all,

I got a problem with the numbering of subsections :

they are numbered using the \currentheadnumber of the heading containing
the \subsection

attached an example and the output.

in the log, I get :

structure   : chapter @ level 2 : 0.1 - Chapter
structure   : section @ level 3 : 0.1.1 - Section
structure   : subsection @ level 4 : 0.1.1.1 - Subsection
structure   : subsection @ level 4 : 0.1.1.2 - Subsection
[2.2]
structure   : chapter @ level 2 : 0.2 - Chapter
structure   : subsection @ level 4 : 0.2.0.1 - Subection
structure   : subsection @ level 4 : 0.2.0.2 - Subsection
[3.3]


best,
Amaël



\starttext

\section{Section}
\char`\\{}currentheadnumber : \currentheadnumber

\subsection{Subsection}
\char`\\{}currentheadnumber : \currentheadnumber

\chapter{Chapter}


\char`\\{}currentheadnumber : \currentheadnumber


\section{Section}

\char`\\{}currentheadnumber : \currentheadnumber

\subsection{Subsection}

\char`\\{}currentheadnumber : \currentheadnumber
 

\subsection{Subsection}

\char`\\{}currentheadnumber : \currentheadnumber
\chapter{Chapter}
\char`\\{}currentheadnumber : \currentheadnumber

\subsection{Subection}
\char`\\{}currentheadnumber : \currentheadnumber
\subsection{Subsection}
\char`\\{}currentheadnumber : \currentheadnumber

\stoptext

essai.pdf
Description: Adobe PDF document
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] sections, subsections, indenting, startnarrower, alignment

2009-05-26 Thread Amaël Broustet
Wouldn't be easier to achieve this using section personalized section
numbering ?

Best,
Amaël  


Le vendredi 22 mai 2009 à 14:40 -0700, afsmith a écrit :
 Hi again ntg-context.
 
 I have been working on my own CV/Resume module. Up until now I've just
 been asking about specific bits of the implementation of this thing I
 want to do, but perhaps that was a mistake as it hasn't really helped
 progress much, so:
 What I am trying to achieve is to define some three-argument command
 to give a section/subject header and a date, and then a block of text.
 The header and date should be on the same line, but aligned in either
 direction (subject aligned left, date aligned right)
 This block of text underneath it should be indented and able to
 include an instance of the same command. Let me try to explain the
 desired output in a little monospaced text diagram..
 
 |(Subject)___(Date)|
 |__(Subsubject)__(Date)|
 |texttexttexttexttexttexttexttext__|
 |textmoretextmoretextmoretexttext__|
 |__(Subsubject)__(Date)|
 |texttexttexttexttexttextexttext___|
 |textmoretextmoretextmoretexttext__|
 
 The subject and subsubject parts don't need to literally use
 \subject , for example I also tried to use \start(description){...
 for this purpose as well but that failed equally. Just something that
 works reasonably as a section header.
 
 I promise I have looked in the archives before asking :) for example
 http://www.mail-archive.com/ntg-context@ntg.nl/msg2.html
 http://www.mail-archive.com/ntg-context@ntg.nl/msg37664.html
 http://www.mail-archive.com/ntg-context@ntg.nl/msg11337.html
 http://www.mail-archive.com/ntg-context@ntg.nl/msg17276.html
 
 And here is an example of something I was playing with...
 
 ---
 \definehead[mysubject][subject]
 
 \defineframed[lrframe][
 width=\localhsize,
 align=normal,
 rulethickness=1pt]
 
 \setuphead[mysubject][style={\bf}]
 \define[3]\CHRONSUBJ
 {\mysubject{\dontleavehmode\lrframe{#1\hfill#2}}
 \startnarrower[left]{#3}\stopnarrower}
 
 \showframe[text]
 \starttext
 \CHRONSUBJ
   {This happened from June 08 to June 09}
   {06/08--06/09}
   {\CHRONSUBJ
 {This happened from June 08 to December 08}
 {06/08--12/08}
 {\input tufte }
   \CHRONSUBJ
 {This happened from January 09 to June 09}
 {01/09--06/09}
 {\input zapf }}
 \stoptext
 ---
 
 -A
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] bug in MarkIV ? section numbering

2009-05-26 Thread Amaël Broustet
Dear all,

the following example :
...
\chapter{Blabla}
\subsection{bla}
...
 is  numbered 

1 Blabla
11 bla

The problem appears only if I skip the \section step.
In fact

\chapter{Blabla}
\section{Bla}
\subsection{bla}

gives

1 Blabla
1.1 Bla
1.1.1 bla


Is the first example the expected behavior ?
I would better have think to something like
1 Blabla
1.0.1 bla


Best,
Amaël

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] subsection numbering

2009-05-27 Thread Amaël Broustet
Thanks for the tip !

Le mercredi 27 mai 2009 à 16:38 +0200, Hans Hagen a écrit :
 Amaël Broustet wrote:
  Dear all,
  
  I got a problem with the numbering of subsections :
  
  they are numbered using the \currentheadnumber of the heading containing
  the \subsection
  
  attached an example and the output.
 
 whow ...
 
   \char`\\{}currentheadnumber
 
 easier ...
 
   \type{\currentheadnumber}
 
 
 -
Hans Hagen | PRAGMA ADE
Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
   | www.pragma-pod.nl
 -
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] bug in MarkIV ? section numbering

2009-05-27 Thread Amaël Broustet
I will test tonight,
thanks.
Amaël

Le mercredi 27 mai 2009 à 14:12 +0200, Hans Hagen a écrit :
 Amaël Broustet wrote:
  Dear all,
  
  the following example :
  ...
  \chapter{Blabla}
  \subsection{bla}
  ...
   is  numbered 
  
  1 Blabla
  11 bla
  
  The problem appears only if I skip the \section step.
  In fact
  
  \chapter{Blabla}
  \section{Bla}
  \subsection{bla}
 
 solved in upcoming beta
 
 -
Hans Hagen | PRAGMA ADE
Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
   | www.pragma-pod.nl
 -
 ___
 If your question is of interest to others as well, please add an entry to the 
 Wiki!
 
 maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___