Re: [NTG-context] XML/MathML namespace handling bug

2021-03-25 Thread Hugo Landau
> in x-math.mkiv search for
> 
>\startxmlsetups mml:apply
> 
> and replace this bit:
> 
> \edef\mmlapplyaction{\xmlfilter{#1}{/*/tag()}}
> \doifelsesetups {mml:apply:mml:\mmlapplyaction} {
> \xmlsetup{#1}{mml:apply:mml:\mmlapplyaction}
>  } {
> \xmlsetup{#1}{mml:\mmlapplyaction}
>  }
> 
> (btw, isn't content mathml more fun than presentation mathml?)
Works nicely. For  I also had to change this part from name() to
tag():

\startxmlsetups mml:relation
\edef\mmlapplyaction{\xmlfilter{#1}{/*/tag()}}
\MMLcreset 
\xmlsetup{#1}{mml:relation:\xmlattdef{#1}{align}{\MMLrelationalign}}
\stopxmlsetups
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


[NTG-context] XML/MathML namespace handling bug

2021-03-20 Thread Hugo Landau
Thanks for ConTeXt, it is an amazing system.

The following test case demonstrates the bug.

  \usemodule[mathml]
  \starttext
  \xmlprocessdata{}{
  
  http://www.example.com/ns/foo; 
xmlns:m="http://www.w3.org/1998/Math/MathML;>
  
ab
  
  
ab
  
  
  }{}
  \stoptext

No output is produced. This has been verified with live.contextgarden.net.

In order for output to be produced,  must be changed to  and
 must be changed to , but these are in the wrong
namespace in this context. In other words, this bug applies to the keyword
element in an apply element. 

Hugo Landau
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___