Re: [NTG-context] Strange expansion behavior in XML/luatex

2010-06-01 Thread Martin Kolařík
would use self unexpandable macros). Another way is problematic, as \edef inside \edef causes problems? Is it true or there is some other way? Thank you, Martin Dne 1.6.2010 0:10, Hans Hagen napsal(a): On 29-5-2010 12:01, Martin Kolařík wrote: I do not know, if it is a bug or a feature

Re: [NTG-context] Strange expansion behavior in XML/luatex

2010-06-01 Thread Martin Kolařík
:-), Thanks for now; I will ask you, if I do not succeed :-), Martin Dne 1.6.2010 9:51, Hans Hagen napsal(a): On 1-6-2010 9:03, Martin Kolařík wrote: I see, and for the single case it works. Also saving is fine, I am using it. Unfortunately, my example was too reduced :-). In fact, I have a problem

[NTG-context] Strange expansion behavior in XML/luatex

2010-05-29 Thread Martin Kolařík
:*} \stopxmlsetups I do not know, if it is a bug or a feature :-); but notwithstanding the fact, similar code I used in MkII worked very well. Thanks for hints, Martin -- Martin Kolařík martin.kola...@email.cz martin.kola...@jabber.cz +420603535593

[NTG-context] MkIV, XML and raw TeX input

2010-05-28 Thread Martin Kolařík
): \startxmlsetups doc:mathtex $\xmlflush{#1}$ \stopxmlsetups \xmlregistersetup{xml:doc} \startxmlsetups xml:doc \xmlsetsetup{\xmldocument}{mathtex}{doc:*} \stopxmlsetups Any hint? Thank you, mk -- Martin Kolařík martin.kola...@email.cz martin.kola...@jabber.cz +420603535593

Re: [NTG-context] MkIV, XML and raw TeX input

2010-05-28 Thread Martin Kolařík
Perfect! Thanks very much, mk Dne 28.5.2010 17:38, Wolfgang Schuster napsal(a): Am 28.05.10 15:38, schrieb Martin Kolařík: Hello, I have found a problem when switching from MkII to MkIV -- I am using a XML containing raw TeX (a temporary solution for math, which lasts for four years now

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-06 Thread Martin Kolařík
list for ConTeXt users Subject: Re: [NTG-context] Problem with encoding, XML and writetolist... Vit Zyka wrote: Martin Kolařík wrote: Hi Hans, I've analyzed the situation using different combinations of regimes and encodings, including switching off handling (\donothandleactivecharacter

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-05 Thread Martin Kolařík
... Martin Kolařík wrote: Aha, here maybe will be the solution :-) I'am using standalone Win32 distribution from Pragma and I'm running texexec with --translate=cp1252cs. Typescripts use il2, which corresponds to fonts, of course. If I run the code without XML (if I transcribe XML

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-05 Thread Martin Kolařík
... Martin Kolařík wrote: Aha, here maybe will be the solution :-) I'am using standalone Win32 distribution from Pragma and I'm running texexec with --translate=cp1252cs. Typescripts use il2, which corresponds to fonts, of course. If I run the code without XML (if I transcribe XML

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
, XML and writetolist... Martin Kolařík wrote: Hi Hans, isn't there some news with the stuff? small test file needed to refresh my memory Hans - Hans Hagen | PRAGMA ADE

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
and writetolist... Martin Kolařík wrote: Hi Hans, the test file is attached, what input encoding is used here? i get the same chapter title as toc entry is your tex configured for 8 bit (natural.ctx) Hans

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
- From: Hans Hagen [mailto:[EMAIL PROTECTED] Sent: Monday, April 03, 2006 11:57 AM To: [EMAIL PROTECTED]; mailing list for ConTeXt users Subject: Re: [NTG-context] Problem with encoding, XML and writetolist... Martin Kolařík wrote: Aha, here maybe will be the solution :-) I'am using standalone

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
users Subject: Re: [NTG-context] Problem with encoding, XML and writetolist... Hans Hagen wrote: Martin Kolařík wrote: Aha, here maybe will be the solution :-) I'am using standalone Win32 distribution from Pragma and I'm running texexec with --translate=cp1252cs. Typescripts use il2, which

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
Subject: Re: [NTG-context] Problem with encoding, XML and writetolist... On 4/3/06, Martin Kolařík wrote: which is not good. And I am not able, when not using cp1250.tcx, recode win1250 (default for win) to latin2. There I am able to write regime for myself (cp1250), but I suppose

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-04-03 Thread Martin Kolařík
, April 03, 2006 4:25 PM To: [EMAIL PROTECTED]; mailing list for ConTeXt users Subject: Re: [NTG-context] Problem with encoding, XML and writetolist... On 2/28/06, Martin Kolařík wrote: Hi all, I have problem with chars encoding now; I have updated ConTeXt sometimes in January; before the time

Re: [NTG-context] Problem with encoding, XML and writetolist...

2006-03-31 Thread Martin Kolařík
Hi Hans, isn't there some news with the stuff? Thank you and have a nice day, Martin -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Behalf Of Martin Kolařík Sent: Tuesday, February 28, 2006 10:33 AM To: mailing list for ConTeXt users Subject: Re: [NTG-context

[NTG-context] Problem with encoding, XML and writetolist...

2006-02-27 Thread Martin Kolařík
Hi all, I have problem with chars encoding now; I have updated ConTeXt sometimes in January; before the time I was using old (year) version. In this prehistorical version the problem was not present. What is the stuff? The following code generates content with titles without spaces -- accented

[NTG-context] Problem with encoding, XML and writetolist...

2006-02-27 Thread Martin Kolařík
Hi Hans, I have problem with chars encoding now; I have updated ConTeXt sometimes in January; before the time I was using old (year) version. In this prehistorical version the problem was not present. What is the stuff? The following code generates content with titles without spaces -- accented

[NTG-context] [force, here] floats and its bad placement -- LONG mail

2005-03-08 Thread Martin Kolařík
Hi Hans (and all), I have difficulties with [force,here] floats. Even if such floats are something a bit degraded, they occured in publication text and they should be handled correctly. I am sorry I do not send a minimal example, but the minimal example from me would be XML + XML mapping +

RE: [NTG-context] PDF bounding box problem?

2005-02-10 Thread Martin Kolařík
Hi all, I have problem with paragraph background in columnset environment: \definetextbackground [TXBG] [frame=no,offset=0.25em,location=paragraph] \definecolumnset[main][n=2] \startcolumnset[main] ... \starttextbackground[TXBG] \typebuffer[BUFFER] \stoptextbackground ... \stopcolumnset

[NTG-context] RE: \defaultinterface for cont-cz

2005-02-08 Thread Martin Kolařík
Hi all, I'm using english interface in cont-cz too... But, maybe, it could be useful to determine interface in the highest level -- during making the format like: texexec --make cz --commands en I know --interface cz cannot be used as --interface is used to select ConTeXt format (to rewrite