Re: [NTG-context] Strange pagebreaks in LMTX

2019-09-05 Thread Duncan Hothersall
>> Thanks for your answer. I tried Hans' suggestion to use \textbackground > instead of background: indeed it solves the problem of incorrect page > breaks, but it seems that \setuptextbackground « leftframe=on » is not > honoured, that is one cannot say for instance: > >> >

Re: [NTG-context] Strange pagebreaks in LMTX

2019-09-04 Thread Otared Kavian
solves the problem of incorrect page >> breaks, but it seems that \setuptextbackground « leftframe=on » is not >> honoured, that is one cannot say for instance: >> >> \setuptextbackground[frame=off,leftframe=on] >> >> while using \background this would be p

Re: [NTG-context] Strange pagebreaks in LMTX

2019-09-04 Thread Aditya Mahajan
On Thu, 5 Sep 2019, Otared Kavian wrote: Hi Wolfgang, Thanks for your answer. I tried Hans' suggestion to use \textbackground instead of background: indeed it solves the problem of incorrect page breaks, but it seems that \setuptextbackground « leftframe=on » is not honoured, that is one

Re: [NTG-context] Strange pagebreaks in LMTX

2019-09-04 Thread Otared Kavian
Hi Wolfgang, Thanks for your answer. I tried Hans' suggestion to use \textbackground instead of background: indeed it solves the problem of incorrect page breaks, but it seems that \setuptextbackground « leftframe=on » is not honoured, that is one cannot say for instance

Re: [NTG-context] Footnote in TABLE isn't rendered anywhere

2017-07-15 Thread Pablo Rodriguez
> >>\automigrateinserts >>\setuptextbackground[location=paragraph] >>\starttext >>\dorecurse{10}{\starttextbackground >>test\footnote{tufte}: \input knuth\hfill >>\stoptextbackground\blank} >>\stoptext > > What can be done that th

Re: [NTG-context] Footnote in TABLE isn't rendered anywhere

2017-07-15 Thread Mathias Schickel
ext page and footnotes had been at the first page of the theorem. So things worked fine. > > Just in case I got you wrong: is your issue that the background also > covers the footnotes, such as in the first and second pages from: > >\automigrateinserts >\setuptextb

Re: [NTG-context] Footnote in TABLE isn't rendered anywhere

2017-07-15 Thread Pablo Rodriguez
econd pages from: \automigrateinserts \setuptextbackground[location=paragraph] \starttext \dorecurse{10}{\starttextbackground test\footnote{tufte}: \input knuth\hfill \stoptextbackground\blank} \stoptext Just in ca

[NTG-context] educat can't work

2016-09-27 Thread Yi Qingliang
\scratchcounter \l... \donostartanswerlines ...ackgroundparameter \c!n ] \par \endgroup \grabuntil ... 26 test test test test test test test \startanswerlines 27 >> [n=3] What A Junk Answer \stopanswerlines 28 the doc content: \usemodule[educat] \setuptextbackground[answerarea][ framecolor

Re: [NTG-context] [beta] anch-pos.lua

2012-02-17 Thread Hans Hagen
On 17-2-2012 02:05, Philipp Gesang wrote: The new code is solid. Of course one can always stretch it to the limit: \setuptextbackground [mp=mpos:par:region, method=mpos:par:region] \setupbodyfont[dejavu,10pt] \showframe \definetextbackground[r] \definetextbackground[b] \starttext

[NTG-context] beta

2012-02-16 Thread Hans Hagen
is speed. The adventurous might want to try out \setuptextbackground [mp=mpos:par:region, method=mpos:par:region] or with some more visual tracing \setuptextbackground [mp=mpos:par:region:kind, method=mpos:par:region] A simple test with some 200 backgrounds brings down runtime with one

Re: [NTG-context] beta

2012-02-16 Thread Otared Kavian
impact is speed. The adventurous might want to try out \setuptextbackground [mp=mpos:par:region, method=mpos:par:region] or with some more visual tracing \setuptextbackground [mp=mpos:par:region:kind, method=mpos:par:region] A simple test with some 200 backgrounds brings down

Re: [NTG-context] beta

2012-02-16 Thread Otared Kavian
backgrounds (first stage cleanup). As I have no clue to what extend users mess around with background graphics themselves, it's hard to predict side effects, but the biggest impact is speed. The adventurous might want to try out \setuptextbackground [mp=mpos:par:region, method

Re: [NTG-context] [beta] anch-pos.lua

2012-02-16 Thread Philipp Gesang
bar \AR \stoptabulate% \stoptext · Regards Philipp \setuptextbackground [mp=mpos:par:region, method=mpos:par:region] or with some more visual tracing \setuptextbackground [mp=mpos:par:region:kind, method

Re: [NTG-context] [beta] anch-pos.lua

2012-02-16 Thread Hans Hagen
]}, ] add [location=paragraph] \starttext foo \starttyping bar \stoptyping baz \starttabulate[|r|l|] \NC foo \NC bar \AR \stoptabulate% ^^ missing \NC \stoptext · Regards Philipp \setuptextbackground [mp

Re: [NTG-context] [beta] anch-pos.lua

2012-02-16 Thread Philipp Gesang
Philipp \setuptextbackground [mp=mpos:par:region, method=mpos:par:region] or with some more visual tracing \setuptextbackground [mp=mpos:par:region:kind, method=mpos:par:region] A simple test with some 200 backgrounds brings down runtime with one second on my

[NTG-context] Text Background

2011-06-23 Thread H. Hodges
of the manuals that \setuptextbackground was only necessary in the case of multiple \definetextbackground statements, but I tried including it anyhow. Still, I'm getting no background whatsoever. ___ If your question

Re: [NTG-context] Text Background

2011-06-23 Thread Aditya Mahajan
things on my path, I assume that it isn't. Try adding background=color key as well to setuptextbackground Aditya ___ If your question is of interest to others as well, please add an entry to the Wiki! maillist : ntg

Re: [NTG-context] background, mkii vs. mkiv

2010-09-10 Thread Jörg Hagmann
been deprecated (?). And replaced with \definetextbackground ? ---Second minimal example- \setupcolors[state=start] \starttext \setuptextbackground[background=color,backgroundcolor=lightgray,corner=round,frame=on,framecorner=round,framecolor=red,rulethickness=2pt,topoffset

Re: [NTG-context] background, mkii vs. mkiv

2010-09-10 Thread Jörg Hagmann
Thank you, Wolfgang. I added the line \setnewconstant\backgroundsplit\zerocount to pack-rul.mkiv, AND IT WORKED! This leaves the (not vital for me) question why minimal example 2 (using setuptextbackground) produces that funny background with the same commands as in setupbackground. Thanks

Re: [NTG-context] background, mkii vs. mkiv

2010-09-10 Thread Wolfgang Schuster
Am 10.09.2010 um 16:52 schrieb Jörg Hagmann: Thank you, Wolfgang. I added the line \setnewconstant\backgroundsplit\zerocount to pack-rul.mkiv, AND IT WORKED! This leaves the (not vital for me) question why minimal example 2 (using setuptextbackground) produces that funny background

Re: [NTG-context] underbar to space

2009-05-18 Thread Wolfgang Schuster
underbars the spaces even? \usemodule[educat] \setupcolors[state=start] \setuptextbackground [answerarea] [framecolor=black, rulethickness=\linewidth, background=, alternative=1] \starttext text \answerspace [n=10] { } text text \answerspace [m=10] { } text \stoptext Wolfgang

Re: [NTG-context] underbar to space

2009-05-18 Thread Xan
} How can I get that \underbar underbars the spaces even? \usemodule[educat] \setupcolors[state=start] \setuptextbackground [answerarea] [framecolor=black, rulethickness=\linewidth, background=, alternative=1] \starttext text \answerspace [n=10] { } text text \answerspace [m=10

Re: [NTG-context] right/left only background offset?

2009-04-03 Thread Khaled Hosny
in textbackground, any ideas? \setupcolors[state=start] \setupbackground [background=color,backgroundcolor=lightgray, leftoffset=0cm,rightoffset=0cm, backgroundoffset=.5cm,topoffset=-.3cm, % the offset works here frame=on] \setuptextbackground [background=color,backgroundcolor=lightgray

Re: [NTG-context] ConTeXt-ifying Kile

2008-01-02 Thread Matija Šuklje
] # \setuptextbackground \setuptextposition[name][settings] \setuptextrules[options] \setuptexttexts[text|margin|edge][text|section|date|mark|pagenumber][text|section|date|mark|pagenumber] \setuptextvariable[name][options] \setupthinrules[options] \setuptolerance[options] \setuptop[text|margin|edge][options

[NTG-context] odd background color behavior

2007-09-02 Thread Alan Bowen
I am using ConTeXt ver: 2007.08.29 19:19 MKII fmt and the pdftex engine \definetextbackground[A][backgroundcolor=red] \setuptextbackground [backgroundoffset=0pt, offset=0pt, frame=off, location=text, background=color, backgroundcorner=round] gives a yellow background

Re: [NTG-context] odd background color behavior

2007-09-02 Thread Alan Bowen
[A][backgroundcolor=red] \setuptextbackground [backgroundoffset=0pt, offset=0pt, frame=off, location=text, background=color, backgroundcorner=round] gives a yellow background and \definetextbackground[A][backgroundcolor=yellow] gives a gray background. Any suggestions about to fix

Re: [NTG-context] non-interactive underlining

2007-06-06 Thread Alan Bowen
Thanks, Aditya, for making sense of my query and answering it. \setuptextbackground[framecolor=black] did the trick. All best, Alan On Jun 6, 2007, at 2:22 PM, Aditya Mahajan wrote: Quoting Alan Bowen [EMAIL PROTECTED]: How do I turn off interaction when using \startunderline

[NTG-context] textbackground inside framed

2006-10-03 Thread Peter Rolf
Hi, I need a textbackground inside a \framed macro, which uses it's own background (overlay). Sadly the textbackground appears behind the framed background and my attempts to change this order haven't succeeded. \setuptextbackground[foo] [level=+1] brings the textbackground to the top

Re: [NTG-context] minor console file queries

2006-07-12 Thread Alan Bowen
. disappeared. As for the error message check : missing or ungrouped '=' after 'location' in line 106 (@@td) , I found that I was missing a comma in my own \setuptextbackground after “location=text”. Many thanks for your help! Cheers, Alan

Re: [NTG-context] \page inside a block

2006-03-16 Thread Hans Hagen
] % \expanded{\definemeasure[SavedLeftSkip][\the\leftskip]} \Poem{#1} \starttextbackground[poem] \startlines} \def\StopPoem {\stoplines \stoptextbackground \stopnarrower} \showframe \StartPoem{xxx} line 1 line 2 \StopPoem \setuptextbackground [poem] [mp=mpos:par:poem

Re: [NTG-context] footnote disappeared when used in background text

2005-12-12 Thread Hans Hagen
). Is this a bug ? no, a side effect, (no inserts in boxes) best use textbackgrounds (or some wrapper like: \unprotect \definetextbackground [\??ag] [\c!location=\v!text, \c!corner=\v!round, \c!state=\v!stop, \c!framecolor=black] \def\setupbackground{\setuptextbackground[\??ag]} \def

Re: [NTG-context] footnote disappeared when used in background text

2005-12-12 Thread Xiao Jianfeng
{\setuptextbackground[\??ag]} \def\startbackground{\starttextbackground[\??ag]} \def\stopbackground {\stoptextbackground} \protect \setupbackground[state=start,background=color,cornor=round] ___ ntg-context mailing list ntg-context@ntg.nl http://www.ntg.nl/mailman