Re: [NTG-context] Stable broken, beta works

2009-03-26 Thread Hans Hagen
Mojca Miklavec wrote: On Wed, Mar 25, 2009 at 09:53, Thomas A. Schmitz wrote: On Mar 25, 2009, at 9:43 AM, Henning Hraban Ramm wrote: Sorry, I tested only on my Intel Mac at home this morning. texlua on OSX-PPC is still broken. It works with my self-compiled LuaTeX 0.36.0 Should I send my

Re: [NTG-context] Stable broken, beta works

2009-03-26 Thread Henning Hraban Ramm
Am 2009-03-25 um 20:04 schrieb Mojca Miklavec: On Wed, Mar 25, 2009 at 09:53, Thomas A. Schmitz wrote: Maybe we should use binaries compiled on 10.4, if they are upwards compatible with 10.5. Mojca, Arthur? Right, but we need to find someone on 10.4 that's willing to contribute. The

Re: [NTG-context] Stable broken, beta works

2009-03-26 Thread Henning Hraban Ramm
Am 2009-03-26 um 10:12 schrieb Henning Hraban Ramm: Right, but we need to find someone on 10.4 that's willing to contribute. The binaries used to be compiled on 10.4 until now, so obviously they are forward-compatible. I can offer to build these binaries at work on OSX PPC 10.4 For I'm

Re: [NTG-context] Stable broken, beta works

2009-03-26 Thread Arthur Reutenauer
Where should I send my binaries to? Can I check them in myself? Yes, you only need an SVN account on contextgarden.net. Just tell me by private mail what user name and password you would like, I'll create it. I'd like to automate the whole checkout-build-checkin process. Generally

[NTG-context] Stable broken, beta works

2009-03-25 Thread Henning Hraban Ramm
Thank you, Patrick, for bringing the garden (back) to live! Thank you, Mojca et.al., who fixed the latest LuaTeX issues! But I'm still not happy... With --context=current I get lots of warnings: Warning: support for multiple lua states has been dropped. Please stop using a number after

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Yue Wang
stable only works with luatex 0.30.x. On Wed, Mar 25, 2009 at 3:22 PM, Henning Hraban Ramm hra...@fiee.net wrote: Thank you, Patrick, for bringing the garden (back) to live! Thank you, Mojca et.al., who fixed the latest LuaTeX issues! But I'm still not happy... With --context=current I get

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread luigi scarso
On Wed, Mar 25, 2009 at 8:33 AM, Yue Wang yuleo...@gmail.com wrote: stable only works with luatex 0.30.x. I have just download last minimal x linux and ./luatex This is LuaTeX, Version snapshot-0.36.0-2009032321 (Web2C 7.5.7) ./context --version MtxRun | main context file:

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Henning Hraban Ramm
Sorry, I tested only on my Intel Mac at home this morning. texlua on OSX-PPC is still broken. It works with my self-compiled LuaTeX 0.36.0 Should I send my luatex/texlua binary to anyone? Greetlings, Hraban ___ If

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Thomas A. Schmitz
On Mar 25, 2009, at 9:43 AM, Henning Hraban Ramm wrote: Sorry, I tested only on my Intel Mac at home this morning. texlua on OSX-PPC is still broken. It works with my self-compiled LuaTeX 0.36.0 Should I send my luatex/texlua binary to anyone? Greetlings, Hraban Hmm, it's broken on your

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Henning Hraban Ramm
2009/3/25 Henning Hraban Ramm hra...@fiee.net: Sorry, I tested only on my Intel Mac at home this morning. texlua on OSX-PPC is still broken. It works with my self-compiled LuaTeX 0.36.0 Should I send my luatex/texlua binary to anyone? Sorry again, I should really test before I post :-(

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Thomas A. Schmitz
On Mar 25, 2009, at 10:03 AM, Henning Hraban Ramm wrote: Sorry again, I should really test before I post :-( Running mtx-update (--context=beta) I get: ./bin/mtx-update.lua:432: attempt to index global 'statistics' (a nil value) Have you tried mtxrun --selfupdate ? I know I got this

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Henning Hraban Ramm
2009/3/25 Thomas A. Schmitz thomas.schm...@uni-bonn.de: ./bin/mtx-update.lua:432: attempt to index global 'statistics' (a nil value) Have you tried mtxrun --selfupdate ? I know I got this error about a week or so ago, and I believe that solved it here. Yes dyld: Symbol not found:

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Mojca Miklavec
On Wed, Mar 25, 2009 at 09:53, Thomas A. Schmitz wrote: On Mar 25, 2009, at 9:43 AM, Henning Hraban Ramm wrote: Sorry, I tested only on my Intel Mac at home this morning. texlua on OSX-PPC is still broken. It works with my self-compiled LuaTeX 0.36.0 Should I send my luatex/texlua binary

Re: [NTG-context] Stable broken, beta works

2009-03-25 Thread Mojca Miklavec
On Wed, Mar 25, 2009 at 09:53, Thomas A. Schmitz wrote: Maybe we should use binaries compiled on 10.4, if they are upwards compatible with 10.5. Mojca, Arthur? Right, but we need to find someone on 10.4 that's willing to contribute. The binaries used to be compiled on 10.4 until now, so